open All Channels
seplocked Test Server Feedback
blankseplocked You call that interface "fixed"? _
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

Ulviirala Vauryndar
Gallente
Vauryndar Dalharil
Posted - 2008.06.12 10:34:00 - [1]
 

Having windows resetting themselves to positions you don't want them to be, you didn't even have them at last time, but instead of moving other windows out of the screen to resize them is not fixing the defects with the interface.

It's annoying and it's upsetting. Whoever did that, horribly failed at fixing the defect. I can't possibly imagine why it wasn't addressed properly since there was plenty of time before Empyrean Age was deployment.

Boo!



CCP Cascade

Posted - 2008.06.12 11:00:00 - [2]
 

Hi.

Please clear your cache and settings folder. If that doesn't work, please file a detailed bug report.

Ulviirala Vauryndar
Gallente
Vauryndar Dalharil
Posted - 2008.06.12 11:38:00 - [3]
 

Edited by: Ulviirala Vauryndar on 12/06/2008 11:49:27
So basically I'd have to reposition, resize and regroup all of the existing container and hangar windows which has been a lot of work, (edit)including overview settings with equally as much work,(/edit) right Razz

Anyways, Yay for my first Dev reply! So how about an ORE Command Ship, which is yet missing and is on no way comparable to that capital industrial platform which has been nerfed in terms of active mining ganglinks? Cool



CCP Cascade

Posted - 2008.06.12 13:01:00 - [4]
 

Originally by: Ulviirala Vauryndar

So basically I'd have to reposition, resize and regroup all of the existing container and hangar windows which has been a lot of work, (edit)including overview settings with equally as much work,(/edit) right Razz



A lot of UI issues are caused by people copying their cache from the older client to the newer one which corrupts it and then they start saying that there are still issues with the overview. I'm not saying that you are one of those, but usually the best way to determine if it is a cache problem or not is to clear your cache and settings and see if the problem is still there. If it is, then it is an issue and we welcome bug reports so that we can track it down and fix it. And your answer to your question: Yes, but only once ;)

Originally by: Ulviirala Vauryndar

Anyways, Yay for my first Dev reply! So how about an ORE Command Ship, which is yet missing and is on no way comparable to that capital industrial platform which has been nerfed in terms of active mining ganglinks? Cool



How about going to the Features and Ideas discussion forum?

Gor Kraon
Minmatar
Against ALL Authorities
Posted - 2008.06.13 01:38:00 - [5]
 

I cleared my cache and settings when i applied the patch, the UI is snapping all over the place at random. Frustrating at best. Let us turn this crap off until you can fix it. I had roughly the same setup before the patch and it was nowhere near as bad.

As an example, opening an info window with my current setup most of time works right, first one opens in the top left corner. Sometimes, (at random) it opens under my chat box, snapped to the bottom of the screen, forcing my chat, cargo, station windows up. Sometimes it opens on top of my chat box, snapped to my cargo and the bottom edge, pushing the cargo and station windows up. Sometimes it opens fine, but the second one snaps similar to what i just described on the first one (i have the option not to reuse info windows on).

Another example. My station windows are snapped to my cargo, which is snapped to the edge bar on the left. Undock, redock, they snap under my character sheet, which is not related to my cargo at all.. smushing both smaller than i wanted. This happens at random as well. Sometimes i can dock fine, sometimes i cant. Never know.

Had this one happen a few times too. I have my overview and drones like way back, snapped together, drones at the bottom. Undocking they appear fine most of the time, though occasionally (might have been in a carrier at the time) they reverse...

Give us the option to turn this 'feature' off until it works.

Ulviirala Vauryndar
Gallente
Vauryndar Dalharil
Posted - 2008.06.13 02:22:00 - [6]
 

Edited by: Ulviirala Vauryndar on 13/06/2008 02:23:45
Originally by: CCP Casqade
A lot of UI issues are caused by people copying their cache from the older client to the newer one which corrupts it and then they start saying that there are still issues with the overview. I'm not saying that you are one of those[...]

Apparently I am one of those people and admittedly you totally pwned me right there Rolling Eyes well, I didn't copy it but I sure left it in place. I mean, who am I telling? Everyone knows how much work it is to get everything back in place, reconfigure the overview and sort out bookmarks and everything ugh so I posted it in a rush, kind of. But I'll be reporting back if it doesn't work YARRRR!!

Originally by: CCP Casqade
How about going to the Features and Ideas discussion forum?

It ever felt being unnoticed and I probably speak for a majority of former attendees, that nobody actually replied officially with like... "No Wai!", "Thinking about it! ORLY? YARRLY!" very often. IDK about the current situation but I expect it not being changed. Since then I keep purring at people in #eve-chaos, stroking them, giving away hugs, supporting the move of creating 0-MNDY or just pwn the hell out of their eyes with screenshots of my purple interface color scheme! Laughing



Man'corr
Minmatar
Posted - 2008.06.13 09:39:00 - [7]
 

Basically i have the same problem.

everytime i open my cargohold, my Bookmarks window snaps off somewhere else.... GRRR

All i did was apply the patch.....

Par'Gellen
Gallente
Neon Cranium
Posted - 2008.06.14 00:57:00 - [8]
 

Edited by: Par''Gellen on 14/06/2008 00:57:30
Workaround with screenshot can be found here:
http://myeve.eve-online.com/ingameboard.asp?a=topic&threadID=794262&page=1#7

Ulviirala Vauryndar
Gallente
Vauryndar Dalharil
Posted - 2008.06.14 05:25:00 - [9]
 

Yea, I found that my ship's cargohold kept moving to the upper left area after docking, even if it wasn't snapped to a window anywhere close but in the lower left corner. Except for the left toolbar with all the fancy icons. Also the fleet windows kept appearing under the overview. The interface code does resize the other windows to not push them out of the screen but still, it's not where you snapped them at.

Also the targets move to the upper right corner every now and then when I hide the interface with CTRL + F9 to take some screenshots and then toggle the interface with CRTL + F9 again. If all targets are gone and you lock one again, it is in the right place after all. It can't be reproduced by just hitting CTRL+F9 and I don't do it quite often anyways :)

So I wasn't essentially wrong with what I said and I submitted it as Bug Report. It was attached to the associated defect and people will be looking into the issue again. Hopefully it gets fixed with the next patch as it ruins the Look&Feel. I just try to remember that people at CCP are playing the game, too and that they take it as annoying as anyone Razz
Last but not least, you need to know the game to get into things that are being developed so it's a good thing that they actually play their game Wink and be annoyed by its eventual defects, yarr! YARRRR!!



Volkier Neigh
Posted - 2008.06.14 11:51:00 - [10]
 

Aye, it seems that it works worse than before the patch. My inventory window now refuses to open on the top right corner of my screen 100% of the time (wheres before it was about 20% or so) unless I have my cargo window open too (which sits underneath) and any info window and whatnot would try to 'squash' under my main chat, forcing everything on top to resize and 'squash' upwards.

There is also still no way to change the transparency of a 'pinned' window either (unless you manually edit the config files, in which case who knows what bugs one would encounter) either - which has been a 'missing' case for quite a while now ::(

Leviathan9
Gallente
Royal Hiigaran Navy
South Pole Dancers
Posted - 2008.06.14 23:51:00 - [11]
 

Edited by: Leviathan9 on 14/06/2008 23:52:37
Well my UI problem isn't as bad. But if i decide to open my mail box while undocked, EVE seems to like to move my overview box's all over the screen for some reason, so i have to resize all other windows etc so my overview doesn't get moved and resized when i open the mail window or ship scanner. Didn't do it before.. Evil or Very Mad

Gor Kraon
Minmatar
Against ALL Authorities
Posted - 2008.06.15 01:04:00 - [12]
 

I too found that the workaround (did it before i read about it) is pretty much required. Very few of my windows are snapped together anymore, and none have given me issues since. Well, thats a lie, my drones window and overview did reverse positions yesterday for no apparent reason (not in a carrier this time). But i'm not putting a gap between those and losing that space on my screen...

Off feature would be great.

Volkier Neigh
Posted - 2008.06.15 08:22:00 - [13]
 

Edited by: Volkier Neigh on 15/06/2008 08:22:03
Aye - something like "Snap to -1 pixels" instead of 3 being the minimum? (which would actively turn off the snapping altogether)
That would really really tremendously help imho

Adunh Slavy
Ammatar Trade Syndicate
Posted - 2008.06.15 16:28:00 - [14]
 

Having the same issue with the new client. Did a clean install, hidden files/folders were all cleaned up prior to install, yes app data and personal too, still get the jump about business. Anoying.

Dontcheck Availability
GoonFleet
GoonSwarm
Posted - 2008.06.15 20:07:00 - [15]
 

Originally by: CCP Casqade

A lot of UI issues are caused by people copying their cache from the older client to the newer one which corrupts it and then they start saying that there are still issues with the overview.


You're actually blaming the users for this? All we did was install a patch to your damn game.

CCP Cascade

Posted - 2008.06.15 20:51:00 - [16]
 

I'm not blaming you or anyone specific, I'm just stating the facts. A lot of people asking for support with UI issues have corrupted their cache themselves by copying it from an older client to a newer one and those cases are solved by the user clearing their cache and settings. I am not saying that there are no more UI issues either, I was just trying to help out with the problems people are reporting. Basically it goes like this:

If you have UI issues -> Clear your cache and Settings
If you've done that and the issues are still around -> Please file a bug report with proper reproduction steps and we'll make sure to fix this issue.

We are aware of that there are some issues with saving the position of windows after relogging and/or session changing. We welcome you to help us track them down by filing a bug report.

Gor Kraon
Minmatar
Against ALL Authorities
Posted - 2008.06.16 00:13:00 - [17]
 

Main problem is the reproduction steps are entirely random it seems. Undock/redock 30 times and maybe 10 times my hangar/items in station will shift and 5 times my drones and overview will reverse positions. The rest are normal...

Wu Jiun
State War Academy
Posted - 2008.06.16 11:32:00 - [18]
 

Originally by: CCP Casqade
A lot of people asking for support with UI issues have corrupted their cache themselves by copying it from an older client to a newer one and those cases are solved by the user clearing their cache and settings.


Can you elaborate a little? What exactly do you mean by "copying it from an older client"? Personally i never copied my cache to anywhere i don't even know where its located. The only thing i have done is installing patches via the autopatcher without clearing the cache afterwards. Is this what you mean by "copying it from an older client"?

Because that would basically mean clearing cache files is more or less mandatory with each major patch. If this is the case maybe it would be good to let the patcher delete the cache on its own? That way much of confusion could be stopped.

Is it maybe possible to patch the cache once you've fixed errors? Tbh i don't think deleting your cache after a patch can be seen as intuitive or self-evident to most people. If its necessary ok but make people more aware of it or let the patcher do it automatically.

Imhothar Xarodit
Minmatar
Wolverine Solutions
Posted - 2008.06.16 14:50:00 - [19]
 

Edited by: Imhothar Xarodit on 16/06/2008 15:00:47
Edited by: Imhothar Xarodit on 16/06/2008 14:52:52
Exaclty the same here.
I reset to default window positions and cleared all cache file using the in-game options but it hasn't solved a thing.

The problem is you can't give proper reproduction steps as you can impossiblt foresee what window will snap somewhere it doesn't belong to. Sometimes my corp hangar window squeezes itself between two other windows, my freighter's cargo sometimes opens up on the bottom left overlapping the chat window... Only to name a few. Whoever has touched the UI code and called it "fixed" has never tested it, honestly.

And why in hell does EVERY SINGLE container window open up in a own window? Damnit, I positioned corp hangar to be on the top but stil every new container I open has its default position oin the bottom left. ANNOYING!

The whole EVE interface is starting to become more annoying than anything else. Windows aren't even saving their minimized status, which is also annoying when they all pop up on login.

The UI code need way more love, because right now it would win any "ugielst and most annoying game UI" contest by far.

Give us the option to disable window snapping in a quick patch and put all your UI coders on fixing it, nothing has driven me so mad for a long time in this game.

Oh and is it so damn difficult to let the patch "convert" the "older" cache to the format the new client uses? I mean, "copying from older client to newer client" is equall to patching! I remember times when interface and overview settings were killed by patching. This is really bad design, you know? All the MMO games out there have some form of caching files and data and stil they manage to keep it consistens along patching, preserving all settings as well. Think about it!

CCP Cascade

Posted - 2008.06.16 14:58:00 - [20]
 

Originally by: Wu Jiun
Can you elaborate a little? What exactly do you mean by "copying it from an older client"?


Some people do "backups" of their cache by copying it before the patch and the paste back in after the patch process has been completed.
Though let me point this out again that I do not mean that this is the only way to get a corrupted cache, but is an easy way to get it.

ElCoCo
KIA Corp
KIA Alliance
Posted - 2008.06.16 20:04:00 - [21]
 

Originally by: CCP Casqade
Some people do "backups" of their cache by copying it before the patch and the paste back in after the patch process has been completed.
I regularly do settings backups as redoing dronegroups (if you got a carrier) and putting BM's to folders is zomg tedious and whenever I need to do it (be it a patch or just a crash) I'm always on the verge of quitting the game Razz

Thommy
Posted - 2008.06.16 20:20:00 - [22]
 

Its badly needed specific parts of the UI get split into smaller files manageing different parts of the game.

Personally to keep it easy to migrate i would go for an XML approach and make each different part of the UI an seperate file (for example UIwin_charID.xml) or make the client create these and encrypt them into an file as one bigger file to prevent 3rd party tools from easely messing with these files if there could be problems with macro's and stuff.

This way there are only 2 validation steps to see if an file is an valid one namely:
- The inner tags matching an specific "must have" list, easy to understand for any developer even one which has not been budy on UI developing before
- XML generic validation (no missing end tags, proper header tags etc).

This would also make maintanance and patching alot easyer then it is at this time because right now GM's and developers need to spend time finding out if the cause is either old to new client copy corruption, unforseen effect of an more recent or older change and / or an effect of incompatability / erroring within files duo to bad hardware, bad os or just different handling of current OS / hardware / software.

It probably has been discussed often before but the cache & settings need an big overhaul because these are one of the top 3 issues always arrising with any patch day (settings nuke, cache problems / corruption).

Lord WarATron
Amarr
Shadow Warri0rs
Posted - 2008.06.16 21:06:00 - [23]
 

Originally by: Wu Jiun

Can you elaborate a little? What exactly do you mean by "copying it from an older client"? Personally i never copied my cache to anywhere i don't even know where its located. The only thing i have done is installing patches via the autopatcher without clearing the cache afterwards. Is this what you mean by "copying it from an older client"?


Historically, almost all patches effect overview in some way. a while back, pretty much every patch deleted your saved overview settings, which is pretty much suicide for a lot of people who live in hostile 0.0. so people just copy their settings/cache folders from a prior to a patch and paste it after the patch has done its thing. This is the reason why people do this.

Feilamya
Pain Elemental
Posted - 2008.06.16 23:23:00 - [24]
 

Originally by: CCP Casqade
I'm not blaming you or anyone specific, I'm just stating the facts. A lot of people asking for support with UI issues have corrupted their cache themselves by copying it from an older client to a newer one and those cases are solved by the user clearing their cache and settings.


I did not copy any cache or settings folders. However, I had to log in as super user (I am running Windows XP) to apply the patch. Is there a potential problem with that? I had to do this with every patch so far, and I always have problems with the UI.

If the answer is yes, then you should try to find a solution for it. Here is a hint: The settings should not be updated to a new version when applying a patch. They should be updated when logging in with the proper user account... Not everyone is willing to log in as super user so he can play EVE.

Papa Gwan
Tribal Liberation Force
Posted - 2008.06.17 11:57:00 - [25]
 

Well, I can confirm that clearing your Cache does not work =P I'll post a bug report as soon as I get not-lazy.

Also, a trick I learned: While you're docked, it seems you can open any window and not get anything moved around. Just wait until you are in a station to check on your Character sheet and all that. Doing it in the 'real' world just repositions/turns off/reloads/reactivates/repastes/overlays/turns around/defaults/inverts/or just plain SCREW 'ER UP!*

Meh, I predict that it'll be a pretty simple problem, so maybe we can score us a hotfix!

*Dramatization. Do not attempt at home.

Castelo Branco
Caldari
Forcas armadas
Moon Warriors
Posted - 2008.06.17 13:09:00 - [26]
 

Ok, I was out of town when big patch kicks in, and when I back I check foruns fist to prevent some damage (notinhg personal). So I see about windows moving and merging.

Knowing that I resolve to clear my cache before I install new patch. I make the clear as said here: http://kb.eve-online.com/Pages/KB/Article.aspx?id=371

Then I aply patch.. And than my windowns get totaly crazy with all problens said above. So, I clear it again. Not solve the problem.. Btw, the windows problem did not existe BEFORE EA patch.

Thal all for now, waiting some real solutions..

Feilamya
Pain Elemental
Posted - 2008.06.17 17:13:00 - [27]
 

Edited by: Feilamya on 17/06/2008 17:14:18
My Windows didn't go crazy. On the contrary. They have become smarter with the patch. In fact they have become so smart, it's giving me the creeps.

Before the patch, my overview was screwed up everytime I undocked. It always moved to the same position, and I got used to always moving it back to place where I wanted. No problem with that. Just a few clicks and drag & drop, nothing to get me annoyed. Okay, and my drone window disappeared everytime I launched drones teh first time after logging in. But it always came back after a few seconds in a different place, and I only had to move it back.

However, post-patch something nasty has infected my Windows. When I undock, the overview stays in place. The drone Window still disappears for a short time, then it reappears in the same place, just to remind me that the nightmare before the patch was real, and it isn't over yet. Then after some time, my windows begin to move. But they don't make big moves like my overview used to do after undocking. They move stealthy like ninjas when I don't notice. Sometimes they change size and merge with other windows, or they obscure some part of the screen, like the current system I'm in or the security status of the next waypoint system. Sometimes, when I move a window across the screen, it suddenly screws up all other windows so that it takes me half a minute or more to fix it.

By the way, did I mention that the watch list window still has no close button? This is just pathetic. I mean, if CCP did not notice, I wouldn't blame them - it's one window out of ... how many? But then again, *some* players must have noticed and reported a bug like this, don't you think? Don't blame me for not reporting it, I haven't used the watch list for months except once some days ago.

So what will happen after the next patch? Will we get windows in ninja costumes that silently sneak off the screen and suddenly stab us the backs while we are busy moving their friends back in place? This is getting out of hand. CCP do something!

EDIT: Please?

Imhothar Xarodit
Minmatar
Wolverine Solutions
Posted - 2008.06.18 05:13:00 - [28]
 

Edited by: Imhothar Xarodit on 18/06/2008 06:54:16
Edited by: Imhothar Xarodit on 18/06/2008 05:14:29
The problem seems to be session changes.

Now can a Dev answer the following question: Why do windows move during a session change? Except for hiding/showing windows which aren't visible inside station, of course.

A window should be a code object with its position saved in lokal variables. When drawing the window use those stored variables for positioning. I simply cannot see the reason for initiating some weird movement code by the system? Change positions only and I really mean only as a response to user interaction!

This is basic UI design, do not try to make the UI intelligent, as it doesn't work here, you have prooved that numerous times. Leave intelligence to the user as only he knows how he wants his windows positioned.

Regarding cache and settings, move to XML already, make seperate files for different settings categories. The proposal made earlier was good. Adapt to new technologies!
It is ridiculous that the first answer to many problems is "Clear your cache and settings folder". This is a horrible design.

Gor Kraon
Minmatar
Against ALL Authorities
Posted - 2008.06.18 05:50:00 - [29]
 

Session change has nothing to do with opening a new info and having it snap all over the screen. Before i took measures to stop snapping (separating everything) info windows would be hit or miss, same session, one after another even, to bug out or not. Open one, no biggie, open another, no issues. Close both, open a new one, bug. Open another is fine... Close both. Repeat, first one is fine, second is fine, third bugs out. And of course sometimes i could just keep on opening a whole pile of them with no issues.

Razin
The xDEATHx Squadron
Legion of xXDEATHXx
Posted - 2008.06.24 03:32:00 - [30]
 

So, can we expect a hotfix to take care of this some time soon?


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only