open All Channels
seplocked Issues, Workarounds & Localization
blankseplocked Bug: [API] shipTypeID=0 on all killmails
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Osiris Occido
The Nightshift
Posted - 2011.06.23 15:20:00 - [1]
 

Since Incarna released, the API is broken as it always reports the shipTypeID="0". Here is an edited example:

Originally by: API
<row killID="17251259" solarSystemID="30001360" killTime="2011-06-22 21:00:00" moonID="0">
<victim characterID="xxx" blah blah shipTypeID="0" />

AURUM
Posted - 2011.06.23 17:26:00 - [2]
 

Same problem with our killboard too.

Debbie DoesDallas
Posted - 2011.06.23 17:57:00 - [3]
 

Sounds like your kb's need to perform a code update. Our kb's are working ok.

CAPTAIN INSAINO
Black Lance
Posted - 2011.06.24 14:26:00 - [4]
 

Edited by: CAPTAIN INSAINO on 24/06/2011 14:31:40
Same problem with mine also, killmail malformed id=0 :(

Board API error ;
Error: Victim has no ship type.Killmail ID:18954524 is malformed.

API log ;
<victim characterID="1727855392" characterName="xxxxx" corporationID="740060715" corporationName="xxxxx" allianceID="1136157539" allianceName="C0VEN" factionID="0" factionName="" damageTaken="446" shipTypeID="0" />

Osiris Occido
The Nightshift
Posted - 2011.06.24 18:59:00 - [5]
 

Originally by: Debbie DoesDallas
Sounds like your kb's need to perform a code update. Our kb's are working ok.
manually posting killmails works fine, its just the API Feed from CCP that is broken.

Here is an actual example of a row killID:

- <row killID="18952786" solarSystemID="30005000" killTime="2011-06-24 07:23:00" moonID="0">
<victim characterID="1226917839" characterName="brokleg" corporationID="1537352304" corporationName="brotherhood of desman" allianceID="1530983307" allianceName="Desman Alliance" factionID="0" factionName="" damageTaken="2779" shipTypeID="0" />
- <rowset name="attackers" columns="characterID,characterName,corporationID,corporationName,allianceID,allianceName,factionID,factionName,
securityStatus,damageDone,finalBlow,weaponTypeID,shipTypeID">
<row characterID="2012448524" characterName="Jin Fae'Xao" corporationID="1092866550" corporationName="The Nightshift" allianceID="0" allianceName="" factionID="0" factionName="" securityStatus="-9.593057368885" damageDone="2779" finalBlow="1" weaponTypeID="0" shipTypeID="0" />
<row characterID="1374308933" characterName="Jifftoolabah" corporationID="1092866550" corporationName="The Nightshift" allianceID="0" allianceName="" factionID="0" factionName="" securityStatus="-6.8" damageDone="0" finalBlow="0" weaponTypeID="2575" shipTypeID="11957" />
</rowset>
- <rowset name="items" columns="typeID,flag,qtyDropped,qtyDestroyed">
<row typeID="28668" flag="5" qtyDropped="0" qtyDestroyed="26" />
<row typeID="31442" flag="0" qtyDropped="0" qtyDestroyed="1" />
<row typeID="3017" flag="0" qtyDropped="2" qtyDestroyed="2" />
<row typeID="31358" flag="0" qtyDropped="0" qtyDestroyed="1" />
<row typeID="11349" flag="0" qtyDropped="1" qtyDestroyed="0" />
<row typeID="5443" flag="0" qtyDropped="0" qtyDestroyed="1" />
<row typeID="1306" flag="0" qtyDropped="1" qtyDestroyed="0" />
<row typeID="5839" flag="0" qtyDropped="1" qtyDestroyed="0" />
<row typeID="12563" flag="5" qtyDropped="2" qtyDestroyed="2" />
<row typeID="5973" flag="0" qtyDropped="0" qtyDestroyed="1" />
<row typeID="2364" flag="0" qtyDropped="1" qtyDestroyed="0" />
<row typeID="23071" flag="0" qtyDropped="2" qtyDestroyed="2" />
<row typeID="17765" flag="5" qtyDropped="1" qtyDestroyed="0" />
</rowset>
</row>

system931
Posted - 2011.06.25 01:46:00 - [6]
 

exactly the same problem Sad

Free Shmak Datash
Posted - 2011.06.25 03:11:00 - [7]
 

Confirmed, this needs to be fixed, now. :(.

AURUM
Posted - 2011.06.25 14:59:00 - [8]
 

What about that bug??????


We have to post any km for our self ??????????



Free Shmak Datash
Posted - 2011.06.25 17:19:00 - [9]
 

yea, cause edk sees the mail as malformed cause the shiptypeid is always 0

CCP Explorer

Posted - 2011.06.25 20:13:00 - [10]
 

Sorry about this. We have fixed this internally and will deploy the fix Tuesday.

Twisted Gamer
Posted - 2011.06.26 01:41:00 - [11]
 

Originally by: CCP Explorer
Sorry about this. We have fixed this internally and will deploy the fix Tuesday.


Whats wrong with doing it on the next downtime? This patch Tuesday crap is just that crap. Don't make yourselves the next M$.

Osiris Occido
The Nightshift
Posted - 2011.06.26 05:10:00 - [12]
 

thank you for the quick turnaround! Looking forward to less clicks ugh

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.06.26 15:51:00 - [13]
 

Thanks Explorer, but 1 question, will the killmails that are already on the api get fixed so we will get 1 huge killmail add/verify cycle, or will they be stuck as shiptypeid=0 ?

Thanks again,

Demi

golem isnogood
Les chevaliers de l'ordre
Goonswarm Federation
Posted - 2011.06.26 15:56:00 - [14]
 

Merci tous plein Wink

oops , thanks alot

CCP Stillman

Posted - 2011.06.26 20:15:00 - [15]
 

Originally by: Demitrios
Thanks Explorer, but 1 question, will the killmails that are already on the api get fixed so we will get 1 huge killmail add/verify cycle, or will they be stuck as shiptypeid=0 ?

Thanks again,

Demi

"Broken" killmails will be fixed after DT on Tuesday. Just re-request all killmails that are broken, and you'll get the correct ones.

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.06.26 22:11:00 - [16]
 

Edited by: Demitrios on 26/06/2011 22:11:27
Originally by: CCP Stillman

"Broken" killmails will be fixed after DT on Tuesday. Just re-request all killmails that are broken, and you'll get the correct ones.


Great, that will please our alliance members, however, it wont make mysql happy :P.

MOAR SQL'S!

Thanks for replying.

Demi


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only