open All Channels
seplocked EVE Technology Lab
blankseplocked Carebearing Statistics for Corporation
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 2 [3]

Author Topic

Nutty trader
Posted - 2011.05.20 13:56:00 - [61]
 

Edited by: Nutty trader on 20/05/2011 13:56:09
And you have refreshed the page using ctrl+f5? It is the same error message? Sure you uploaded the new file and its got the correct name? If so then copy and paste the error message and the public DSN line here, just so it can all be double checked.

EDIT: Yer nutbolt here, silly forums.

Psyrelle
Caldari
Coalition Of Gentlemen.
Posted - 2011.05.20 14:55:00 - [62]
 

Edited by: Psyrelle on 20/05/2011 14:55:07
Originally by: Nutty trader
Edited by: Nutty trader on 20/05/2011 13:56:09
And you have refreshed the page using ctrl+f5? It is the same error message? Sure you uploaded the new file and its got the correct name? If so then copy and paste the error message and the public DSN line here, just so it can all be double checked.

EDIT: Yer nutbolt here, silly forums.


error:

<br />
<b>Warning</b>: mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Unknown MySQL server host 'saphyron' (1) in <b>/home/saphyron/public_html/test_carebear/adodb5/drivers/adodb-mysql.inc.php</b> on line <b>365</b><br />
Connection failed

dsn:

public $Dsn = 'mysql://saphyron_caerbea:826066@localhost/saphyron_caerbear2';

Nutbolt
Avalon Project
The Smurfs Alliance
Posted - 2011.05.20 15:25:00 - [63]
 

From what I can tell it still thinks the database host should be saphyron and not localhost. If you are sure you have uploaded the config file correctly etc... then only other thing I can think of is to start a new, delete the carebear_test folder off your server, upload it all again including the editted config file. If still no luck im out of ideas, sorry.

Psyrelle
Caldari
Coalition Of Gentlemen.
Posted - 2011.05.20 16:03:00 - [64]
 

Originally by: Nutbolt
From what I can tell it still thinks the database host should be saphyron and not localhost. If you are sure you have uploaded the config file correctly etc... then only other thing I can think of is to start a new, delete the carebear_test folder off your server, upload it all again including the editted config file. If still no luck im out of ideas, sorry.


well now it works sorta.

Error 200: Current security level not high enough.

this error comes... what does that mean?

Nutbolt
Avalon Project
The Smurfs Alliance
Posted - 2011.05.20 16:50:00 - [65]
 

Only thing I can think of is either the user doesn't have access to the database? or your api doesn't have access, are you a director or CEO of the corp your in and trying to pull the info from? Apart from that you need someone who actually understands the code to reply :p

Psyrelle
Caldari
Coalition Of Gentlemen.
Posted - 2011.05.20 17:30:00 - [66]
 

Edited by: Psyrelle on 20/05/2011 18:06:18
Edited by: Psyrelle on 20/05/2011 17:32:47
Originally by: Nutbolt
Only thing I can think of is either the user doesn't have access to the database? or your api doesn't have access, are you a director or CEO of the corp your in and trying to pull the info from? Apart from that you need someone who actually understands the code to reply :p


pulling it from the ceo. maybe i need to supply full api and not limited

though i would love to know how im gonna automatically pull every hour or so

EDIT: it now works thank you

Psyrelle
Caldari
Coalition Of Gentlemen.
Posted - 2011.05.20 20:18:00 - [67]
 

Edited by: Psyrelle on 20/05/2011 20:18:05
i was wondering is it possible to collect from multiple corps at the same time?

Nutbolt
Avalon Project
The Smurfs Alliance
Posted - 2011.05.20 23:53:00 - [68]
 

Originally by: Psyrelle
pulling it from the ceo. maybe i need to supply full api and not limited

though i would love to know how im gonna automatically pull every hour or so

EDIT: it now works thank you


No worries, glad I could help. To get it to pull automatically you will need to setup a cron job which uses the cron page. That's about as much as I can say lol, the way I have cron jobs set up on my server is a little weird, so I will let someone else explain now :)

MrDrugs IGotMoney
Posted - 2011.05.21 11:04:00 - [69]
 

Anychance you update it so it works with incursions ?

Kraken Greyoak
Posted - 2011.05.22 11:23:00 - [70]
 

Great code! Congrats.

On the main (sum) table, is it possible to add the number of kills made per member?

Ovidia Rhianon
Caldari
Mining and Industrial Services
The Irukandji
Posted - 2011.05.23 19:01:00 - [71]
 

First of all - this is a terrific tool, thanks for it =)

I am having a strange error though, I have set this up on three different websites with no problems at all and my most recent project is giving me the following error when I try to run cron.php:

Quote:
<br />
<b>Notice</b>: Undefined offset: 0 in <b>/home/lost/public_html/cb/cron.php</b> on line <b>178</b><br />


Any idea what the problem is?

Alexandr Soljenitin
ROMANIA Renegades
ROMANIAN-LEGION
Posted - 2011.05.26 16:34:00 - [72]
 

The script is registering and displaying only 2 days since it has been installed (5 days ago installed, only the first 2 days there is SOME data displayed).

I am saying SOME data because there are characters that have made NPC and they are not displayed in the script statistic results.

Any idea if this is normal or if there are maybe bugs in the implementation ? Or... some API limitation ?

apocryphat
Posted - 2011.05.27 06:04:00 - [73]
 

  • This tool doesn't work with incursions rats / rewards

Darth Imperius
Imperial Academy
Posted - 2011.05.30 23:32:00 - [74]
 

bump.

Venetian Tar
Wildly Inappropriate
Goonswarm Federation
Posted - 2011.05.31 15:27:00 - [75]
 

Nice tool, took a bit to get working but it's great.

Thanks.

Alexandr Soljenitin
ROMANIA Renegades
ROMANIAN-LEGION
Posted - 2011.05.31 15:32:00 - [76]
 

Originally by: Venetian Tar
Nice tool, took a bit to get working but it's great.

Thanks.


Are you experiencing any problems related with data not being pulled correctly from the API ?
I can't seem to understand why but in my installation I am only having access to reports for the past 1-2 days even if the script has been installed for more then 1 week.

Let me know. Thank you!

Nathan WAKE
Caldari
Osiris Entreprises
Posted - 2011.06.05 09:20:00 - [77]
 

Hello,

I installed it at the beginning of April, and it as been working since, pulling data with no problem at all for me.

I did not change anything in the database and it passed the different EvE updates without problem.

Nathan

Mikk36
Caldari
Posted - 2011.06.07 08:57:00 - [78]
 

Been away from EVE for a bit.

Updated the cron file: cron.php
to pull also the Incursion related data into the database, rest of the page doesn't need modifications since the data doesn't provide anything else other than the amount and sender (CONCORD in that case), no system or activity related information at all.

Alexandr Soljenitin, has the crontab been set up to execute cron.php every 30 minutes?

Arkon Hjallian
Wildly Inappropriate
Goonswarm Federation
Posted - 2011.06.10 10:36:00 - [79]
 

I'm also interested in multiple corp pulls, but with more info on the view screens to be able to filter / segregate by corps, and have a corp summary screen which shows totals by corp.

Also happy to pay a bounty for this. Evemail me :)

A.

netbotix
Posted - 2011.06.16 22:54:00 - [80]
 

Edited by: netbotix on 17/06/2011 01:05:34
I am having an issue with this where I dont think the chron is actually pulling any info. Is there a way I can debug the process? I ran chron.php and then go to the app and there is no data.

Also does

public $JournalTable = 'journal';

need to be the name of the master wallet or leave it as be?

thanks
cron.log

2011-06-16 22:56:21 Too soon
2011-06-16 22:57:56 Too soon
2011-06-16 23:05:24 Too soon
2011-06-16 23:09:39 Too soon
2011-06-16 23:12:56 Too soon
2011-06-16 23:17:33 Too soon
2011-06-16 23:40:38
4402301801
4402232098
4402189401
4402152558
4402133445
4402113028
4402071963
4402071961
4402071264
4402050531
4402027305
4401983618
4401937211
2011-06-16 23:41:17 Too soon
2011-06-17 01:03:42
4404549233
4404486061
4404471553
4404427859
4404413353
4404288495
4404288046
4404239581
4404239568
4404199995
4404199977
4404185886
4404157886
4404130745
4404076555
4404037659
4404037654
4404024842
4404012515
4403987316
4403987314
4403975072
4403961345
4403934371
4403934368
4403921489
4403908332
4403907990
4403895388
4403895376
4403857021
4403843669
4403843664
4403829807
4403829800
4403803330
4403753121
4403688737

Mikk36
Caldari
Posted - 2011.06.22 09:05:00 - [81]
 

Originally by: netbotix
Edited by: netbotix on 17/06/2011 01:05:34
I am having an issue with this where I dont think the chron is actually pulling any info. Is there a way I can debug the process? I ran chron.php and then go to the app and there is no data.

Also does

public $JournalTable = 'journal';

need to be the name of the master wallet or leave it as be?

thanks
JournalTable holds the default name for the journal table (if you imported the data from sql files, leave it be).
According to the cron.log, the cron script has pulled the data. You can check the "journal" table manually with phpmysql or similar that you have available to see when these entries occured.

netbotix
Posted - 2011.07.08 13:09:00 - [82]
 

Well I got it to import.. doesn't seem like a long history but I can deal with it. Now my only problem is the cron job when automatically running does not import anything. If I manually run it, it does fine, but with a cron job it seems nothing is being imported.

I have verified that the cron job is running yet nothing seems to happen. Any idea? Does the troubleshooter echo for cron need to be turned off? Although it seems doing this makes no difference.
Thanks

TheDoctorUK
Gallente
BSC LEGION
Split Infinity.
Posted - 2011.07.24 01:36:00 - [83]
 

Edited by: TheDoctorUK on 24/07/2011 02:55:15
Edited by: TheDoctorUK on 24/07/2011 01:50:32
Edited by: TheDoctorUK on 24/07/2011 01:49:28
Got it installed from the google code and updated the cron.php and added the table, but only the first tab works and the 2 tab with the graph works. The rest i see a circle for the ajax call, but does not display anything.

Got it installed on a ubuntu server (11.04) Apache/2.2.17, MySQL client version: 5.1.54 and PHP Version 5.3.5

I have even tried installing java6 to see if ajax needed it.

Is there some MySQL tables I'm missing like systems and rats as all I see in the tables are numbers referencing to rats but no names?

**edit**
Disregard my noob self was tired and seen there 3 mysql files there to import, now works a treat.

Micha W
Minmatar
Mining Industry Exile Foundation
Avaricious Cartel
Posted - 2011.08.28 14:36:00 - [84]
 

Edited by: Micha W on 30/08/2011 04:50:50
Edited by: Micha W on 29/08/2011 14:16:03
I have a error when i update the cron.php

Quote:
<b>Notice</b>: Undefined offset: 0 in <b>/home/miefevec/public_html/test/carebear/cron.php</b> on line <b>180</b><br />



Pages: 1 2 [3]

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only