open All Channels
seplocked Macintosh
blankseplocked Summary of Mac client issues
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

helixp0
Gallente
EVE University
Ivy League
Posted - 2011.01.20 13:40:00 - [1]
 

After last nights raft of issues I have decided two things -- 1) I am going to put together a full list of issues with the client here since I haven't seen all of the issues I've experienced in these threads and I want to make sure they're all out in the open. I suspect that, given the glaring ones, people never mention the little ones since they're happy they have a mac client at all. 2) I am installing bootcamp and windows7 since well... I can't take it anymore... ultimately I want to play eve with the little gaming time I have, not spend it rebooting, killing and restarting processes and praying the app won't exit with a locked screen. Going the boot camp route amounts to a huge disappointment for me but I am lucky since I have access to a legit Windows7 licence and can do this with no expense other than time. I am posting this with the hope that things will get fixed and I can go back to using the Mac version since I'd prefer spending all of my time in OS X.


System stats
============
Macbook Pro 15"
Mac OS X 10.6.6
2.4 ghz Intel Core Duo
4gb 667 mhx ddr2 sdram

I shut down *ALL* apps before trying to run Eve due to the last issue I outline below and to maximize memory.


Start Up Issues
===============

The client will start up about 1 in 10 times, roughly. There seems to be no rhyme or reason as to when it will start successfully.

One of three scenarios will occur:
Click on the icon and I get another icon on the Dock and then....nothing. Opening up Activity Monitor has "Eve Online (Not Responding)" in red and I kill the process and try again. Like I mentioned before, I have to do this over and over until I can get into the client. Eventually it will just work.

The other scenario is a bit more hopeful. I click the icon, the game icon appears in the Dock, I get the splash screen and it stays on-screen for about 10 seconds and then disappears. From there, I do the Activity Monitor song-and-dance.

The third, rarer circumstance is the success scenario. I get the splash screen, then 2 seconds later, a black screen and then the login screen.

I can find no sequence that will produce consistent results. Sometimes I can log in/start the app two or three times in a row; other times I have to try 10-15 times to get the app to start. When I get the "Not Responding" app, it is dead and will not start. I have waited while in this state up to 45 minutes just to see it if was some sort of time-out or latency issue but it isn't.


Client Crashes to Desktop
==========================

This is new with the latest Incursion release. It has happened no less than 5 times, all while warping or docking. There is no initiating event from what I can tell. Two of the most recent times were in the middle of a long warp. Suddenly I was at the desktop. After going through the frustrating sequences outlined above, I finally got back in to find myself floating in space. Scary business and makes me very reticent to go exploring given that I could be in an expensive ship and podded while going through the arduous task of trying to get back in game after a client crash.

What's frustrating is that this is new. I have been "back" in Eve for almost two months and never had a client crash to desktop until the latest releases. Hopefully that can be used to isolate the cause.


In-Game Browser Issues
======================

Sometimes it won't load pages. Like... at all. I get a black screen and nothing else. If I try to close the browser, the Eve client freezes for about 2 seconds and then it closes the window. If I keep trying, eventually it works (even using the same link). It seems like it is throwing some exception that is not being handled gracefully so it just shuts down. It's hard to say. If there's a way to find out, let me know and I'll cut and paste it here. It's frustrating but hardly a dealbreaker.

(to be continued)

helixp0
Gallente
EVE University
Ivy League
Posted - 2011.01.20 13:43:00 - [2]
 

(continued)


Shut Down Issues
=================

For the last month or so, the app often shuts down unsuccessfully. I think it started with the release before the last.

These fall into two categories:

One scenario is that I exit the program or log off and it dumps me to a white, blank window with an Eve title bar and a "unhandled exception" modal window, asking me if I want to debug it. This is the nicer of the two scenarios....

The other scenario is the reason I am moving to Windows 7 (other than the client crashes which may occur there too). When I select Log off or Exit, the screen locks upon clicking "Quit game". I still have a moveable mouse cursor but no keys seem to respond (even sending the Mac OS X shutdown hotkeys) and the display only will show the Log off screen. I have had this happen with the CTRL-Q hotkey, last night with the ALT-CTRL-Q hotkey and from selecting both buttons from the ESC menu.

When the latter scenario occurs, I have no choice but to hold down the power button and hard reset, obviously a scary venture and hardly a palatable solution.


SUMMARY
=======

I work in the software industry and would be happy to help the devs with any scenario testing, etc. I can send dumps and such as well, if it will help. Reproducing the issues above will not take long, trust me on that one. For now I will be installing Bootcamp, Win7 and seeing how it works out with VMWare since I use it for work. Let me know if I can be of assistance.

Damon Voidstrider
Posted - 2011.01.20 14:19:00 - [3]
 

After days of trying to get this update installed. Finally downloading the full client got me in succussfully no Hitches. I put a celebratory 3 day skill in, and attempted to quit to try and fix my character.. Quitting unsuccesfull. Locked up just the way you described, as I hit "Quit Game"
As hardbooting the system Once is too much for my liking (as I cant afford a new Mac right now). I now consider the game unplayable again.
I sincerely hope CCP fixes this soon, as well as fixing mac autopatching. I do not wish to download the full client again for 2 megs or w/e of fixes.

Katsuro Hikaru
Posted - 2011.01.20 16:10:00 - [4]
 

You can add to that list: missing images of items and ships in the station (all areas) and market.

Damon Voidstrider
Posted - 2011.01.20 16:14:00 - [5]
 

I was about to add missing Items to the list as well, I didnt realize how much I depended on the picture of my vessel, before getting into it.
I managed to circumvent the crash issue by playing in windowed mode... however that makes everything much smaller and hard to see.. Im hoping there is an obvious cause and fix for this quitting issue

helixp0
Gallente
EVE University
Ivy League
Posted - 2011.01.20 16:34:00 - [6]
 

There's another weird one that isn't as bad as the ones above:

Open Science and Industry > Open Planet 1of5 > Double-click the title bar to reduce the window to just a title bar > Launch Materials to Customs Office > Open Science and Industry window by double-clicking on the Title bar again > Look at the fact that there are no more planets...

The only fix is to close the Science and Industry window and re-open it.

Damon Voidstrider
Posted - 2011.01.20 17:02:00 - [7]
 

Edited by: Damon Voidstrider on 20/01/2011 17:04:48
I had disappearing planets from time to time myself pre-incursion. Quadrupleclicking the title bar seemed to remind the client I had planets

I was hooked on Eve before incursion release, now i cant even bring myself to play it with all the errors and bugs, and the funny lookin char i didnt know i was maken while maken it.

Lith Ragond
Posted - 2011.01.21 03:40:00 - [8]
 

I'm having similar issues. The start up and quit ones to be precise. I have barely been able to play.

Daff Punk
Death Incarnate INC
Important Internet Spaceship League
Posted - 2011.01.21 04:23:00 - [9]
 

Nothing I can say about the startup....sometimes it works and sometimes it doesnt...im sure CCP is working on it...

Random crashes happen to me from time to time for no reason --- im sure CCP is also working on this.

Logging off / quitting game i have found a work around -- before you go to log off / quit put the client into windowed mode [COMMAND + ENTER] -- this will allow you to access your apple bar at the top of the screen should it black screen you, you can still access the force quit. I have found that almost all the time after I quit the game, I have a buffer error or a debug message <--- maybe this will help CCP figure out part of the problem.

I know this sucks for the Mac users, but I've been playing the game for almost 5 years now....updates and patches take time to work out bugs so people please, take it from a seasoned EVE vet....keep posting problems and workarounds and for New Eden's sake -Exclamation DON'T FLAME CCP!! Exclamation I can guarentee they didn't build a new release with Mac bugs on purpose.

My iMac specs are (incase you were wondering):
Processor Name: Intel Core i7
Processor Speed: 2.93 GHz
Number Of Processors: 1
Total Number Of Cores: 4
L2 Cache (per core): 256 KB
L3 Cache: 8 MB
Memory: 8 GB

Chipset Model: ATI Radeon HD 5750
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB


//dp

Damon Voidstrider
Posted - 2011.01.21 07:51:00 - [10]
 

To add to the missing ships/items I've found a couple other minor itchs
1. loading up planet screen is a little choppy now.. could just be my own system. but it wasnt that choppy pre-incursion
2. The mouse wheel is extremely sluggish now, both for zooming in and out in space, and scrolling the chat bar. used to work fine.
3. i've also recieved an exception error on quit. and i had to force quit (cmd+option+esc)

these are the only glitches that have been a bother to me so far, I've had 0 client start up issues since redownloading the fullclient.

Lederstrumpf
Posted - 2011.01.21 14:03:00 - [11]
 

Edited by: Lederstrumpf on 10/04/2011 05:55:16
-

Bosdos
Posted - 2011.01.21 15:15:00 - [12]
 

My Eve online on Mac seem to run in the background. That's for the "starts but nothing happens" bug. Is there Developer's short cut to bring that thing to "not run in background, run in foreground"?


Bosdos
Posted - 2011.01.21 15:21:00 - [13]
 

Blue screen of death. This is common pc problem. Mac lets people see what app's running and show as all the screen to open and show that there are programs running like safari and eve. Safari shows the preview of what "eve website" I have and the preview of Eve Online game screen is "blue screen wide angle" which is the shape of the game on "27 inch imac"

If what I am thinking that mac version is bootcamp of Windows is running on Eve Online game on WIndows version.

What happens Windows (microsoft) deny letting eve run on background (technically it lets it run as background, but also doesn't let background services to display it on the foreground graphics. If it does, it would have to have special permission to access the foregreound graphics. And that permission is blocked or not "given".

Johnson 1044
Posted - 2011.01.21 18:04:00 - [14]
 

Any word on whether the latest update has resolved the Mac startup problems? I can't run the update because the client wont start so I have to download the entire client yet again. Don't want to bother if its not going to work.

Statis
Posted - 2011.01.21 18:23:00 - [15]
 

I just patched an hour ago and I start up to the black screen. Have to hard restart the computer to get back to the desktop.

Thoregosk
Posted - 2011.01.21 21:38:00 - [16]
 

When you get the black screen of death Press cmd alt esc. this is the mac equivalent of the windows 3 key salute ie ctrl alt delete

It works a treat then you can try again without risk of trashing ur mac os/hddWink

Charlonis
Posted - 2011.01.22 00:40:00 - [17]
 

When I get the black screen of death,I cant even force quit using command-opt-escape. Hard reset is the only way I've found to get out of it.

Taeyeon Elystra
Posted - 2011.01.22 11:22:00 - [18]
 

Edited by: Taeyeon Elystra on 22/01/2011 11:24:56
I can agree with a couple of your points. Perhaps with slight variation:

1. Startup of client is a random affair. I either get splash followed by perpetual black screen (requires cmd+opt+esc to get out) or normal startup. Can require two or three attempts before successful entry. Could be coincidence but I always seem to be successful after activating another window before clicking EVE icon on dock again.

2. Random crashing on session change via jump gate. Has happened several times.

3. Unhandled exception errors from Transgaming library upon exit. Random but regular. Buffer overflows that sort of thing.

now one of my own:

4. Character editor can develop lighting and texture issues when changing items. Everything from hair to shoes seems to have a chance of setting everything crazy. Worst case I have seen is a completely black face.

My system for reference:
Mac Pro 2009 2 x Quad Core 2.66 Nehalem, ATI Radeon 4870 512MB, 12GB Ram

I really hope CCP eventually creates a proper EVE client for Mac instead of this Wine wrapped crap Sad


Damon Voidstrider
Posted - 2011.01.22 17:37:00 - [19]
 

Edited by: Damon Voidstrider on 22/01/2011 17:37:36
I had to re-download client. If there was a successful way of patching, i couldn't find it. Since download completed I've been running eve without a hitch. They even seemed to resolve the no-quit issue on post-patch patch. (Cmd+Opt+Esc did work as a last-resort for me)
Only minor glitches as I stated earlier. (Missing Item/ship images, sluggish mousewheel scrolling)
Im using

Mac mini
OSX 10.5.8
2ghz Intel Core 2 Duo
2gig DDR3 ram
NVIDIA GeForce 9400


Bosdos
Posted - 2011.01.23 11:03:00 - [20]
 

I redownloaded the client with the latest patch built in. It crashes on startup and afterward never worked. Maybe it's corrupted like everyone said that it was. But no way of telling if that's even corrupted.

Apollo Gabriel
Mercatoris
Etherium Cartel
Posted - 2011.01.23 18:19:00 - [21]
 

I code, I get paid for it...

if I made code like CCP made code, I'd be out of work.

CCP I know you've had a hard time attracting new employees, but sometimes you have to fire the bad ones.

Bosdos
Posted - 2011.01.24 05:47:00 - [22]
 

I shortened the Eve Online to "EVE" and I can play the game. Everything works fine.

Choi Xao Evotori
Posted - 2011.01.24 11:05:00 - [23]
 

Sounds pathos but what botheres me most about the mac client is the freaking jukebox :/

Ronbo Prime
Posted - 2011.04.10 18:32:00 - [24]
 

I'm aware of the frailty of snow leopards startup structure and lack of backbone. Eve seems to be piggybacking these startup failures more so than anything else on my HD. Did anyone else come to this same conclusion? Also, not talkin eve startup, talking system startup. I love playing this fgame, but I'm not gonna install snow leopard weekly to do so.

Archa7ias
Posted - 2011.04.10 19:36:00 - [25]
 

Yes, same here. I have an open petition that I regularly update regarding the system freeze on my Mac.

iMac
10.6.7
3.06 GHz Intel Core 2 Duo
4GB 800 MHz DDR2 SDRAM

Startup-
1 out of 5 times client will not start, I get a black screen and nothing, sometimes I can force quit, sometimes I need to hard reboot. Once I froze on the character select screen.

CTD-
One gate crash to desktop where I dropped before jumping, one gate crash on the other side of the gate.

Overview Settings-
After my most recent clean install I had the overview open to adjust brackets, I froze while adjusting brackets, adding a new tab, and loading a saved profile.

Doing nothing while docked, in space-
Weird graphic glitches followed by a freeze, sometimes I can force quit, most of the time I need to hard reboot.

I have a multiweek skill training so I will wait until these problems are fixed. I have attempted the following--clean install, removed cache, removed OS X system cache, rebooted router, adjusted graphic settings to low on all options, unclicked multithread, cleared mail cache. A few weeks ago I upgraded to Snow Leopard.

Is there anything I can do to help with the debug effort? Does anyone know of any work arounds right now? Is there any other action I can take with my system that I have not already? (Besides buy a PC ugh)

Manssell
Posted - 2011.04.11 18:00:00 - [26]
 

Originally by: Choi Xao Evotori
Sounds pathos but what botheres me most about the mac client is the freaking jukebox :/


I know, it drives me nuts, especially since it seems like such a simple fix, and they've been claiming they are fixing it for the last year or so (i've only been in the game about a year so maybe longer than that?).

Deuce Syundai
Posted - 2011.04.11 20:37:00 - [27]
 

Originally by: Choi Xao Evotori
Sounds pathos but what botheres me most about the mac client is the freaking jukebox :/


Seconded. The Jukebox has been broken since friggen' DOMINION for crying out loud.

CCP, please fix existing issues before even beginning to work on new features. New features don't attract as many new players as broken features turn away existing players.

Ronbo Prime
Posted - 2011.04.13 09:54:00 - [28]
 

yeah who gives a **** about the jukebox? I'm talkin about real ****. OS corruption caused by a third party program... maybe it's just me, but that seems a bit less trivial than whether or not the ****in jukebox works.

Swearte Widfarend
Gallente
Aurora Security
Posted - 2011.04.13 19:37:00 - [29]
 

Edited by: Swearte Widfarend on 13/04/2011 19:37:29
Originally by: Ronbo Prime
yeah who gives a **** about the jukebox? I'm talkin about real ****. OS corruption caused by a third party program... maybe it's just me, but that seems a bit less trivial than whether or not the ****in jukebox works.


Easy to blame EVE. I've been playing the Mac client since Trinity release in 12/07. I have never, in 3.5 years of playing EVE on a Mac, had EVE corrupt my OS. I've played under 10.4, 10.5 and 10.6.

Most "stability" issues are related to the Transgaming engine, not EVE itself. I'd bet a lot of them are graphics or RAM issues. I have not seen any of these stability errors when running the current releases of Incursion. I have seen some of the redraw errors, and I've had issues with text-entry focus fields. I typically am running two clients simultaneously in windowed mode. The fact that I run EVE without sound at all is probably important though. Ever since Apocrypha when I've had the sound enabled EVE has been less stable.

Perhaps, step 1 in troubleshooting the stability of your Mac EVE client, you should go to the sound settings and disable sound. Now see if EVE is more stable for you.

System setup (current):
Mac Pro 2x2.66 GHz Xeon
12GB RAM
ATi Radeon 4870
2x23" Cinema Display with 2 EVE clients running 1600x1000 in Windowed mode.

axels2000
The Maverick Navy
Against ALL Authorities
Posted - 2011.04.14 04:03:00 - [30]
 

Black screen on start up. Computer frozen. iMac 27" OS X 10.6.6

After the patch, my windowed mode switches to full screen for a moment on start up. It switches back to windowed mode and the content inside of the window stays black. Mouse cursor still alive, but no actions can be taken. Attempts to Force Quit or even reboot computer are unsuccessful due to the fact that computer does not respond at all. I tried three times with identical result leading to hard reboot.

Tried Repair tool after work. It said "Repaired successfully". Behavior has not changed. Still black window and unresponsive computer. Anyone has any ideas what to do?


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only