open All Channels
seplocked Linux
blankseplocked Disabled audio, now I can't re-enable it without EVE crashing
This thread is older than 90 days and has been locked due to inactivity.

Author Topic

Posted - 2010.08.24 22:22:00 - [1]

Audio was working fine for me. I was watching youtube on another workspace and was tired of station sounds in the background so I flipped over to EVE and disabled audio. No sign of any problems. I came back a while later and tried to re-check the "enable audio" box and the client crashed. Ever since it's stayed disabled and the client just crashes out when I try to enable it. It doesn't freeze or show an error dialog or anything, it just immediately closes and I'm back to my desktop.

If I run if in a console I don't seem to give anything meaningful other than:
wine: Unhandled page fault on write access to 0x00000070 at address 0x7ef8ec2c (thread 0024), starting debugger...
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0x7ef8ec2c

Anybody have any ideas what could cause this?

Posted - 2010.08.25 14:40:00 - [2]

Arch Linux 64bit with Wine 1.3.1 by the way

Kaliba Mort
Executive Outcomes
Posted - 2010.08.26 06:29:00 - [3]

Most likely /dev/dsp got locked by flash and Eve/Wine exploded once they couldn't get sound device access.

Check in `winecfg` if you use Alsa or OSS. MAybe the other option will help.

Posted - 2010.08.27 13:12:00 - [4]

I think the fact that I was watching flash videos is just a coincidence. The problem has persisted through restarts even.

I tried changing my Wine audio driver. I had it set to ALSA before but it won't work with OSS or Jack. With OSS/Jack the client freezes when trying to enable audio instead of crashing, and in other games there's just simply no sound unless I select ALSA.

Reaver Glitterstim
Legio Geminatus
Posted - 2010.09.18 02:57:00 - [5]

I have the same problem. I turned my sound off to make the game run, and after getting the audio driver to work, I couldn't reactivate the sound cause it crashed the client. Sound is the least of my issues right now though.

Satori Yakamura
Archaeopteryx Werften
Free Allied Traders
Posted - 2010.09.20 01:40:00 - [6]

Edited by: Satori Yakamura on 20/09/2010 01:40:48
I have wine configured to use ALSA Sound.
After starting EVE the sound channel gets muted.
So it needs to unmuted by using alsamixer or , which works on my ubuntu desktop, hitting "volume up" on the keyboard a few times.

Everything else (JACK or OSS) don't work

Posted - 2010.09.25 01:00:00 - [7]

Edited by: Ka''Zar on 25/09/2010 01:01:37
My ALSA isn't being muted. I can still have other programs like TeamSpeak running just fine in the background but no matter what I do I can't seem to fix this crash on audio enabled.

Actually once since I made this topic the audio ended up enabled. I have no idea how it happened but being foolish I assumed the problem had fixed itself. Next time I wanted to turn it off I did so and ow it's back to doing what it was before Sad

Jory Miller
Posted - 2010.10.03 03:28:00 - [8]

Totally having this issue as well. Start up fine. No sounds. Hit Esc. Audio is already enabled but there is no sound. Clicking on the checkbox to disable sound freezes Eve.


Advanced Security And Asset Protection
Posted - 2010.10.03 05:01:00 - [9]

Sounds like a driver problem. What sound hardware do each of you have?

For example (I have no sound issue beyond the jukebox) mine is:

Sound processor: nVidia MCP55 HDA (part of the nForce 570 SLI MCP)
HDA/AC97 Codec: Analog Devices AD1988B (taken from motherboard manual)
Sound driver: HDA Intel (listed with lspci -k)

Jory Miller
Posted - 2010.10.03 15:53:00 - [10]

Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Jory Miller
Posted - 2010.10.05 14:47:00 - [11]

So..... I'm just screwed?

Infinitus Odium
Posted - 2010.10.08 21:59:00 - [12]

Edited by: Scorpyn on 08/10/2010 23:14:46
Similar error. Works fine until I click on a character and the station starts loading, at which point the client freezes.

Edit : It seems that the problem doesn't actually start until I click on a chat window or something. I can spin the ship, at which point I can hear some looping sound, but the client doesn't actually freeze until I click on something (like a chat channel).

It works if I disable sound.

Arch x86_64, Wine 1.3.4.

Edit2 : Solved it. I think.

I renamed .wine/drive_c/Program Files/CCP/EVE/res/audio/Jukebox to Jukebox-

Then I pressed pause in the jukebox ingame.

Haven't done any extensive testing, but at least it doesn't crash immediately Very Happy


This thread is older than 90 days and has been locked due to inactivity.


The new forums are live

Please adjust your bookmarks to

These forums are archived and read-only