open All Channels
seplocked Linux
blankseplocked Apocrypha 1.2 and Wine
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

CCP Hypnotic

Posted - 2009.05.14 14:26:00 - [1]
 

After the deployment of Apocrypha 1.2 there seems to be a problem for some users running EVE in Wine as well as some Windows users. The client will open to a black screen and crash if you try to interact with the escape menu. We at CCP are looking into the issue and will try to have a solution out as soon as possible. Unfortunately, with Apocrypha 1.0 back on March 10th we discontinued support of the linux client and we have never supported running EVE through Wine. What this means is that we can not guarantee that any solution we implement will correct this issue for anyone using EVE on a Linux machine.

If you are experiencing issues I encourage you to visit the Wine bug reporting site as they will be in a better position to correct the way EVE works with their program.

DrFro
Posted - 2009.05.14 14:51:00 - [2]
 

I am suffering from this issue, I checked on wineHQ and did not see any posts for this specific error. Anymore information on this would be great. Now I have to boot up my windows box for the first time in months and that makes me sad. :-(

Persephone 66
Gallente
Posted - 2009.05.14 15:13:00 - [3]
 

Edited by: Persephone 66 on 14/05/2009 15:14:15
Considering windows users are experiencing the same problem, this appears to be more an Eve issue than a Wine/Linux issue.

Percy Soars
Posted - 2009.05.14 15:21:00 - [4]
 

If you fix it on windows first, people may not have to report to Wine bug site. Dont try to pass the buck.

Ergomare
Posted - 2009.05.14 15:23:00 - [5]
 

Thank you verry much CCP.

This is a Problem from wine? I am not understand this!
Befor this Update comes, plays EvE with wine. After your Update never more work?

And you mean this is a wine Problem?

Thank you for this ...

I play EVE because it works under Linux. And now?
I stand in the rain ...

Beautiful ...

DrFro
Posted - 2009.05.14 15:36:00 - [6]
 

Edited by: DrFro on 14/05/2009 15:37:05
Hey guys I totally understand your anger here and my first thoughts where to be ****ed off also. Sure the game worked fine before the patch on Wine, but something has changed and there is a compatibility issue now. Sure something changed with Eve and not wine, but that does not mean it HAS to be eve's fault here. Eve could simply be using a new function or command that Wine does not support or understand, this would mean an issue with wine rather then with the Eve client.

Either way it does not matter who's issue it is, CCP Hypnotic says "We at CCP are looking into the issue and will try to have a solution out as soon as possible", sure after that he makes a disclaimer remark of "Unfortunately, with Apocrypha 1.0 back on March 10th we discontinued support of the linux client and we have never supported running EVE through Wine", but that does not mean they aren't looking into it.

What it all comes down to is, you catch more bees with honey, so lets try and be nice, give CCP any help that we can like the Distro we are running and possibly some info on what hardware/software we have and try and get this thing fixed.

My Specs (I am posting this from my Virus/Trojan/Adware/Malwar Magnet OS {A.K.A. Windows} so I don't have all my info, i can update later when I get home from work.)

Ubuntu 9.04
Nvidia 7600 GT
Latest Wine and took all the steps from the Eve Linux Wiki page.

Doublewhopper
Posted - 2009.05.14 15:38:00 - [7]
 

A fix for windows is as follows:

(copied from EggGirl)
Well I managed to get past the black screen and into the game.

Im running windows XP. Go into control panel / administrative tools / services.
Enable(if required) and start the "terminal service" service.

Start EVE.

Make sure you remember to disable the service in a few days when a patch is released.

Not sure about linux.

Meganoita
Posted - 2009.05.14 15:50:00 - [8]
 

Wine gives me the black screen, but Cedega works fine. I would rather use wine, but using Cedega is a good enough workaround for now.

Doublewhopper
Posted - 2009.05.14 15:55:00 - [9]
 

new patch and fix working for linux:

http://ccp.vo.llnwd.net/o2/evepremiumpatch88517-88737_m.exe

Friik9 Alt
Posted - 2009.05.14 16:00:00 - [10]
 

Absolutely great! Works like a charm!

Thank you CCP!

armas
Gallente
Black Thorne Corporation
Posted - 2009.05.14 16:00:00 - [11]
 

Above patch worked for me too.

Tizian Enel
Minmatar
Brutor Tribe
Posted - 2009.05.14 16:01:00 - [12]
 

confirming the new 1.2.1 patch got rid of blackscreen

Ergomare
Posted - 2009.05.14 16:08:00 - [13]
 

Ok, thank you. With this Patch works now eve under wine. *smile*


thetrel
Minmatar
Posted - 2009.05.14 16:33:00 - [14]
 

We love you.

Thank you.

Debeus
Amarr
Princeps Corp
Atlas Alliance
Posted - 2009.05.14 16:43:00 - [15]
 

Yeah, i also got the black screen of death with 88517, but 88737 fixes it.

Nefrin Maldoes
Minmatar
Outer Rim Survey and Salvage
Posted - 2009.05.14 18:40:00 - [16]
 

Edited by: Nefrin Maldoes on 14/05/2009 18:46:19
Confirming that the 88737 patch linked above is working with Wine 1.1.21 (dual client run).

Kadesh Priestess
Scalding Chill
Posted - 2009.05.14 19:26:00 - [17]
 

Thanks for quick fix, and (what's more important here from my perspective) for attention to the issue. At least it shows us that we're not abandoned completely (i never dared to imagine any further posts from CCP officials in linux section)

Persephone 66
Gallente
Posted - 2009.05.14 20:46:00 - [18]
 

Thanks for the patch, sorry I was so gripey in my last post.

Now I can get past the black screen and enjoy the game for about 5 minutes before it totally locks up on me :(

Jerera
Minmatar
Posted - 2009.05.14 21:12:00 - [19]
 

Originally by: Doublewhopper
new patch and fix working for linux:

http://ccp.vo.llnwd.net/o2/evepremiumpatch88517-88737_m.exe


Works for me. Thanks for the link, a lot !Very Happy

Birdman Ravo
Deep Core Mining Inc.
Posted - 2009.05.14 21:30:00 - [20]
 

I'd like to take a moment to thank CCP for all their effort. Dispite any real Linux support, today I saw a patch cripple EVE in Wine, and another patch not an afternoon later remedy the issue. Other games wouldn't see an update that quick if their patch crippled the game, period. So thanks CCP.

That said, I just tried the 88737 patch, and the black screen seems to have disappeared. Back to buzzkill. Yay.

CursedEagle79
Wrecking Shots
Wildly Inappropriate.
Posted - 2009.05.14 22:37:00 - [21]
 

Thank you for the attention & fix, CCP!!!!!!!!! Very HappyVery HappyVery HappyVery HappyVery Happy

deathlords
Posted - 2009.05.14 23:02:00 - [22]
 

Patch was NOT for Wine users. It was for Windows users. Many Windows accounts were crippled by the 1.2 update.


DrFro
Posted - 2009.05.14 23:06:00 - [23]
 

Awesome response time, Thanks Dev team!

And even if it is a windows patch it still working for me on Linux.

CursedEagle79
Wrecking Shots
Wildly Inappropriate.
Posted - 2009.05.15 00:35:00 - [24]
 

Originally by: deathlords
Patch was NOT for Wine users. It was for Windows users. Many Windows accounts were crippled by the 1.2 update.




Even so, the fact that they noticed that all of us linux users were having this problem, and to top that, addressed our concerns, is a good thing (and may have helped them diagnose?).

Gilbert T
Gallente
Gladiators of Rage
Posted - 2009.05.16 12:03:00 - [25]
 

They don't support running eve in wine officially. They are looking into the problem anyway. It's actually a little bit encouraging. Maybe they actually do care about keeping their linux customers after all.

The point is, they obviously are (unofficially) supporting running eve through wine, but just won't commit to "we will make it work", which is understandable.

So, anyway, thanks CCP for the unofficial support :)


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only