open All Channels
seplocked EVE Technology Lab
blankseplocked Out of Eve 1.6-AP - Character and Corporation info web app
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 2 3 4 5 [6] 7 8 9

Author Topic

ShadowandLight
Amarr
Cryptonym Sleepers
Test Alliance Please Ignore
Posted - 2009.03.09 18:25:00 - [151]
 

Originally by: ShadowandLight
i LOVE THIS WEBSITE

could we make the website smarter for POS stuff?

maybe incorporate "mypos" like qualities?

http://myeve.eve-online.com/ingameboard.asp?a=topic&threadID=585203


up!

Caelon Bissau
Posted - 2009.03.10 19:16:00 - [152]
 

Edited by: Caelon Bissau on 10/03/2009 22:18:50
Edited by: Caelon Bissau on 10/03/2009 21:23:32
Edited by: Caelon Bissau on 10/03/2009 19:42:26
Trying to install. I've edited config.php, loaded the db and the front page works ok. When I hit the register link, it takes me to a directory listing of the outofeve directory.

Apache
PHP 5.2.6

Any ideas?

EDIT: Simple .htaccess problem. Still trying to get it running but making progress.
EDIT 2: More fun, had to comment out the DirectoryIndex line in the config. Now on to an ooekeypass error which I know I saw earlier.
EDIT 3: Ok, getting API errors "Bad Request (Invalid Hostname)" but this is the day Apocrypha was released so would that have something to do with it. I get errors when I use other API apps so that's my guess for now.

Beor0d
Minmatar
Krupp-Stahl
Initiative Mercenaries
Posted - 2009.03.11 10:47:00 - [153]
 

I am not in a hurry but when will we see 1.6 Apocrypha ready? Laughing

Solo Drakban
GoonWaffe
Goonswarm Federation
Posted - 2009.03.17 18:07:00 - [154]
 

Does development on this application continue?

Wraas Mlnir
Arctic Flying Penguins
A.X.I.S
Posted - 2009.03.17 22:31:00 - [155]
 

Edited by: Wraas Mlnir on 17/03/2009 22:31:38
Originally by: Rilwar

Using the '/home/<cpanel login name>/ooekeypass'; is redundant, there's no point to it. The server is automagically looking for the file starting from the directory that index.php is in, telling it to go all the way down to /home then back up to your userdir is dumb.


Sorry thats not dumb, its smart and what I consider to be good security measure to help protect you. You are placing the very thing that is (not brilliantly) protecting your base64 encoded Full API key from snoopers. Putting it outside of the www or public_html dir protects it from being viewed by anyone who tries to read it direct.

Make PHP and the server read a couple of directories back if it makes it more secure, but don't think you should post advice like this without highlighting the potential security issues to others, as opposed to your analysis that its simply 'dumb'.

DrefsabZN
Caldari
Caldari Provisions
Posted - 2009.03.19 01:08:00 - [156]
 

I would love to see 1.6 with the tech 3 stuff in especially as I have only recently installed this and gave it ago and I love it :) BTW the point about installing the key file out of the www/public_html folder is so valid its not even funny, I work for an ISP and the amount of people whos sites get hacked because they left something important in a public accessible folder is not even funny. Its not hard to secure so do it properly or waive all rights to moan if someone gets your api and data because you didnt take the time to secure it :)

Tribalize
Posted - 2009.03.19 14:03:00 - [157]
 

i have been testing this with ach db dump. Works fine on local machine.

But on host i get this error

Fatal error: Call to a member function columnCount() on a non-object in /includes/database.php on line 47

Any suggestions

Lykash
Posted - 2009.03.19 15:56:00 - [158]
 

trib check my PM to you ;)

Lykash
Posted - 2009.03.20 16:29:00 - [159]
 

ok in ./include/database.php


Use this to actually let PDO give you the error details in regards to this problem

17c17,25
< $prep = $this->conn->prepare($sql);
---
> $prep = $this->conn->prepare($sql);
> if (!$prep){
> echo $dbh->errorCode() . "<br>";
> $info = $dbh->errorInfo();
> print_r(array('errorInfo' => $info, 'sql' => $sql));
> // $info[0] == $dbh->errorCode() unified error code
> // $info[1] is the driver specific error code
> // $info[2] is the driver specific error string
> }

Blue Sassley
Caldari
The Ankou
Raiden.
Posted - 2009.03.31 17:18:00 - [160]
 

Does anyone know if the wonderful creator is going to release updates for this?

Jaddar Kampton
The Scope
Posted - 2009.04.03 18:25:00 - [161]
 

Originally by: Sen Quenten
Originally by: Walkin' Dude
Quote:
OK I got everything running fine on my local test server and am now trying to install this on my host. I can register new members fine as I can see them in the database, however when I try to login nothing happens and I return to the main page.

Is this something to do with the encryption file?

I'm really sorry about this, but I've no idea what on earth could be preventing users logging in :(. I'm almost convinced it's a cookie problem, so I'll try some things in this area for the next update.

If it were a 'keypass' problem as others have had, you'd be getting big errors with the latest release informing you of a problem, and pages would refuse to load at all.

I know this sounds silly (desperation), but after 'logging in', have you tried a Ctrl+F5?


---

I have already asked twice in this thread what version of php people are using when they have problems logging in, since it seems php 5.2+ is required. I tried with php 5.1 and could not log in, php 5.2, it worked.




5.2.8 here. Still not able to log in. Both user[username] and user[password] cookies are in the browser. The user record is in the database. Nothing is in the Apache error log file. Any other thoughts?


1. Open includes/database.php
2. Go to line 34 (function QueryA)
3. Change the Function to this way:

function QueryA($sql, $params) {
$rs = $this->Query($sql, $params);
if ($rs) {
return $this->rsToArray($rs);
}
}

4. Enjoy it working.

nuroo
Posted - 2009.04.06 17:18:00 - [162]
 

I must agree, this is a wonderful idea/website. It really helps alot.

Feature request:
Is there anyway we could be emailed upon completion of a production/research job. As an option of course - some would prefer not be hassled. If it could be done easily, it would really help cut done on wasted slots. Plus email is already on file as part of the registration process.

S'if
Minmatar
Clan Destyne
Posted - 2009.04.07 00:10:00 - [163]
 

Edited by: S''if on 07/04/2009 00:11:37

Fatal error: Call to a member function execute() on a non-object in /usr/local/psa/home/vhosts/freelancerunion.co.uk/httpdocs/outofeve/includes/database.php on line 18

Made the change to includes/database.php and am now getting this error when trying to register a character's API details.

Croax Kra
Posted - 2009.04.07 11:18:00 - [164]
 

love this tool, but since a few days i get this error.

Please visit your user settings to re-enable images.

would be good if, the error would build up at the bottom of the page, so I could check the pref.

Zorath Kadram
Posted - 2009.04.07 22:18:00 - [165]
 

Sorry if this has been asked already. Is it possible to set this up to use the forum system phpBB's sessions and users?

Reel Maier
Posted - 2009.04.08 00:52:00 - [166]
 


Quantar Raalsken
Gallente
Posted - 2009.04.08 02:33:00 - [167]
 

Edited by: Quantar Raalsken on 08/04/2009 02:48:32
Edited by: Quantar Raalsken on 08/04/2009 02:35:08
OMG how did i miss this b4?Shocked

EXACTLY what i needExclamationExclamationIdeaExclamationExclamationIdea

tho can i ask? can u see if u can add it so that i can check production profitability of BPCs and BPOs that belong to the corp?

it would rly help seeing as we have a whole bunch in our corp hanger

EDIT: also it seems a few icons are broken but thats nothing compared to some of the other issues ive seen Shocked

also i think the new probe launchers are getting errors as they are an Apocrypha thing and i see that the site is made for QR

EDIT2: also i think it would be pretty easy to pull from my assets and be able to calculate mining yield directly w/o having to pick out what modules im using...especially if im using a mix of modules

Nisd
Amarr
Nasgul Collective
Cascade Probable
Posted - 2009.04.08 11:13:00 - [168]
 

I just installede this the other day and i am amazede. It is so good! And i actually got it working on IIS 7.0 with PHP :)

Tribalize
Posted - 2009.04.08 11:25:00 - [169]
 

Originally by: Croax Kra
love this tool, but since a few days i get this error.

Please visit your user settings to re-enable images.

would be good if, the error would build up at the bottom of the page, so I could check the pref.


If the api is down you will see this error

quote=Reel Maier]how to fix this:

Please visit your user settings to re-enable images.


I had the same prob on one of my hosts seems they didnt like capital letters on sql queries. Copy the errors in the background and fix manually.

Originally by: Quantar Raalsken
Edited by: Quantar Raalsken on 08/04/2009 02:48:32
Edited by: Quantar Raalsken on 08/04/2009 02:35:08
OMG how did i miss this b4?Shocked

EXACTLY what i needExclamationExclamationIdeaExclamationExclamationIdea

tho can i ask? can u see if u can add it so that i can check production profitability of BPCs and BPOs that belong to the corp?

it would rly help seeing as we have a whole bunch in our corp hanger

EDIT: also it seems a few icons are broken but thats nothing compared to some of the other issues ive seen Shocked

also i think the new probe launchers are getting errors as they are an Apocrypha thing and i see that the site is made for QR

EDIT2: also i think it would be pretty easy to pull from my assets and be able to calculate mining yield directly w/o having to pick out what modules im using...especially if im using a mix of modules


Update the database using the apoc database should fix some of your probs.

Tribalize
Posted - 2009.04.08 11:26:00 - [170]
 

What I would like to know is has anyone mad any new modules for this?

Croax Kra
Posted - 2009.04.08 14:04:00 - [171]
 

Originally by: Croax Kra
love this tool, but since a few days i get this error.

Please visit your user settings to re-enable images.

would be good if, the error would build up at the bottom of the page, so I could check the pref.


ok, got this one fixed - had an old api-key - i knew it but couldn't reach the menu to change it, since the error-warnings did covered it,
but - praise firefox ;) - there's a work around.
open the page, pick view from menu (firefox), website-style and change it to no-style, now you can make the necessary changes.

Zorath Kadram
Posted - 2009.04.08 23:03:00 - [172]
 

I get this error and it displays my username and password, which isn't exactly ideal... Any idea how I can fix this?

Quote:

Fatal error: Uncaught exception 'PDOException' with message 'invalid data source name' in .../outofeve/includes/database.php:12 Stack trace: #0 .../outofeve/includes/database.php(12): PDO->__construct('[my db]', '[my username]', '[my password]') #1 .../outofeve/includes/database.php(8): DBManager->Connect(Array) #2 .../outofeve/includes/site.php(18): DBManager->DBManager(Array) #3 .../outofeve/index.php(8): Site->Site() #4 {main} thrown in .../outofeve/includes/database.php on line 12

Quantar Raalsken
Gallente
Posted - 2009.04.09 03:08:00 - [173]
 

Originally by: Tribalize

Originally by: Quantar Raalsken
Edited by: Quantar Raalsken on 08/04/2009 02:48:32
Edited by: Quantar Raalsken on 08/04/2009 02:35:08
OMG how did i miss this b4?Shocked

EXACTLY what i needExclamationExclamationIdeaExclamationExclamationIdea

tho can i ask? can u see if u can add it so that i can check production profitability of BPCs and BPOs that belong to the corp?

it would rly help seeing as we have a whole bunch in our corp hanger

EDIT: also it seems a few icons are broken but thats nothing compared to some of the other issues ive seen Shocked

also i think the new probe launchers are getting errors as they are an Apocrypha thing and i see that the site is made for QR

EDIT2: also i think it would be pretty easy to pull from my assets and be able to calculate mining yield directly w/o having to pick out what modules im using...especially if im using a mix of modules


Update the database using the apoc database should fix some of your probs.


wait, me?

the API key is brand new since this is my first time using my full API key, should i make a new limited key then?

Maikar
Gallente
The Bloody Red
Posted - 2009.04.12 07:44:00 - [174]
 

I've got most of it running alright, but I'm getting errors still.

Warning: file_put_contents(---) [function.file-put-contents]: failed to open stream: No such file or directory in ---/httpdocs/includes/eve/apimarket.php on line 59

Warning: touch() [function.touch]: Unable to create file --- because No such file or directory in ---/httpdocs/includes/eve/apimarket.php on line 60

Any ideas? The cache folder has 777 permissions set to it, the path IS correct. I'm honestly at a loss.

Beor0d
Minmatar
Krupp-Stahl
Initiative Mercenaries
Posted - 2009.04.14 21:17:00 - [175]
 

Is this project still alive? No new version since 2008 is a bit disappointing

Adira Deimos
Posted - 2009.04.27 23:13:00 - [176]
 

Anyone know if development is continuing on this?

Also curious, has anyone written modules for this that they might be willing to release? (Re: "Included AJAX (using JSON) support for other developers to make use of. See the "ajaxtest" plugin for a very basic usage example.")

Athus
Open Designs
Posted - 2009.04.30 03:33:00 - [177]
 

I hope someone can tell me wth I am doing wrong. I have an ubuntu server running and it has the more recent releases of well basically everything LOL... now I got the login screen once and now I just get API key encryption file not found at "/includes/seckey" I have tried moving it into all kinds of different places, /var/tmp .. /var/tmp/ooe .. includes about 3 times.. and no matter where I put it it tells me that it is not found, is empty or I get another error or warning. so no matter what I have done it fails. I tried renaming and adding .txt to it.. it has something in the file for the key but I can't figure out why it fails no matter what I do. anyone got some idea's I am now finally at a lost and just about ready to quit trying. =(

Note88 I have had it working before but I don't understand why I cannot get it setup again, I had to reinstall my server from scratch.

Ratchman
Posted - 2009.04.30 10:36:00 - [178]
 

Edited by: Ratchman on 30/04/2009 10:52:26
Couldn't delete this post, so just had to change it. Images made the text box too wide.

Hitoshi Yamadori
Posted - 2009.05.05 11:56:00 - [179]
 

Is this nice project still active?
I would love to use it. But want to ensure active development first.

Takahashi Miyoko
Posted - 2009.05.05 18:26:00 - [180]
 

If this project is still active, Ive got a slight problem. Corp assets are quite large and I keep running into the same problem when tring to open them.

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 41 bytes) in /var/www/outofeve.com/includes/functions.php on line 16


Pages: 1 2 3 4 5 [6] 7 8 9

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only