open All Channels
seplocked EVE Technology Lab
blankseplocked Yapeal PHP API library (revision 1203 branches/keys/)
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 3 4 5 6 [7] 8 9 10 11 ... : last (24)

Author Topic

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.15 14:45:00 - [181]
 

From the first post.
Quote:
Available through subversion at new home.

I also now edited my first post to add some additional information and links that might be helpful.

So to put it simple there aren't any 'downloads' at this time and may not ever be you need to use a subversion client to get Yapeal. You can find out more about subversion and what you need to do to get it at http://code.google.com/p/yapeal/source/checkout there's also some instructions for installing Yapeal on Windows in the wiki.
http://code.google.com/p/yapeal/wiki/InsYapWinSer

This has also been asked/wrote about a couple times already in this thread as I remember so there's probably some more info back a couple pages if you look.

Just some notes for people that are on hosted server and don't have command-line access or no subversion access from it, you can get Yapeal on any computer and then upload it with ftp, etc just like you would any other web page or script. The preferred place to have Yapeal installed would be outside of any directory accessible by the web server but that isn't always possible I know and does make using the configurer very hard Smile If you use a local test server (You should be you know) you can even copy it's configuration to your live server so you don't even need to run the configurer on the remote server which should make it easier to instill it somewhere else for added security.

Marty Thompson
Posted - 2009.03.16 00:41:00 - [182]
 

Hey, just wanted to say thanks for the cool tool. I finally have it up and running on my computer and I'm working on creating useful output for myself.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.17 22:50:00 - [183]
 

Just thought I'd let everyone know I've added a page to the Eve online Wiki about Yapeal you can view it at http://wiki.eveonline.com/wiki/Yapeal

No new information in it since I basically took the wiki page from Eve-dev and dropped it into page but thought I'd let people know about it.

In other news I'm working on some issues that have come up while working on a new API and some errors that have been reported to me by some others as well. I expect to have some fixes ready in a few days.
Satis Iqulenax has also been work on some issues with the configurer that have been reported and hopes to have them fixed within a couple days also.

Wraas Mlnir
Arctic Flying Penguins
A.X.I.S
Posted - 2009.03.18 00:02:00 - [184]
 

Edited by: Wraas Mlnir on 18/03/2009 00:04:57
I did scan through to see if it had already been mentioned (apologies if this is a dupe, its been a long day).

Your Yapeal.sql file has a typo. The section that creates the TABLE utilConfig is referred to as utilconfig a couple of lines below causing the sqlscript to throw an error when it is run.

A quick search in vi for utilconfig will highlight only one instance and if you need a line count its on line: 742

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.18 00:54:00 - [185]
 

Your the first to report it but I had spotted that when I was doing something else with the SQL files. It'll be in one of the upcoming fixes. Thanks for the report.

For those interested or needing the fix before I merge it with the trunk change line 742 of install/Yapeal.sql to read:

INSERT INTO `utilConfig` VALUES('version', '$Revision: 621 $') ON DUPLICATE KEY UPDATE `Value`=VALUES(`Value`);


Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.18 23:21:00 - [186]
 

Ok Now that they've changed it to something easier to work with I've added the Skill Queue API to Yapeal.

I've also release some minor fixes the some of the SQL files, etc.

The backend/ directory with the old eve_api_pull.php file has been dropped also. It was replaced by the Yapeal.php a while ago but I left the old file in for a while to let people have time to switch over but I've decided it been long enough for everybody to make the switch Wink

Revision 690

Wraas Mlnir
Arctic Flying Penguins
A.X.I.S
Posted - 2009.03.19 23:01:00 - [187]
 

Is there any chance I can see an example of the three records I need to insert as part of the initial setup as per the Getting Started guide.

I think I am either missing something, or putting in too much into the utilRegistered* tables.

thanks

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.20 00:52:00 - [188]
 

Actual the instructions were missing a step that is needed now to have it work. I've added the step about activeAPI that was probably causing you the problem along with some addition notes that should be helpful.

Wraas Mlnir
Arctic Flying Penguins
A.X.I.S
Posted - 2009.03.20 13:01:00 - [189]
 

That did the trick, thanks for the update.

I have a question about how data is persisted in the database. With large datasets like journals, the API only allows you to go back a fixed amount (either time or number of records if I am not mistaken).

My question is does Yapeal accumulate the data, or does it write over the last dataset with the new data?

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.20 14:44:00 - [190]
 

Most APIs are deleted/truncated and then inserted but the Industry Jobs, Market Orders, Wallet Journal, and Wallet Transactions are not. They will keep the last values from the last update received from the API for each record and there for have a history that continues to grow.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.03.21 19:48:00 - [191]
 

Hi everyone it's me again I've just finished killing some bugs in the latest API to be added to Yapeal. With some help from Johnathan Roark on it Yapeal now has Kill Log (Kill mails). You can now get them for both characters and corporations.

Also in this revision Satis Iqulenax and I have been trying to fix all the problems that have crept into the SQL lately for both the main files and the ones used by the configurer. We're looking at making some changes to decrease the number of SQL files that need to be updated and kept in sync which should help some of the problems we are having now.

There was a small bug in the Skill Queue that I also fixed in this revision.

Work is still continuing on the problems with Wallet Journal and Wallet Transactions not walking back through API correctly but has been held up by a need to rewrite much of the code that Yapeal uses to connect to the API servers so has been slow going since it ends up effecting all the APIs to a degree and I'm trying not to break everything all at once for a change Wink

Revision 702

General Ordogg
Posted - 2009.03.26 04:49:00 - [192]
 

Dragonaire,
Your php to Mysql is awesome. Thank you for making this available to us all.

I have a question for anyone as I'm not a PHP programmer.

If someone could basicly rip out most of the code for the PHP files for the setup to change it to a free form user addtition to the database that would be awesome. it should be pretty simple for someone with some programming experiance. I just basiclly want to use the wizard or a new page to have a user enter their API and then tag all characetors for that API to get put into the database table utilregisteredcharacter.

I'm willing to pay isk for this.

Wraas Mlnir
Arctic Flying Penguins
A.X.I.S
Posted - 2009.04.03 11:13:00 - [193]
 

I'm working on just that at the moment General.

Its not being rushed at the moment, as I am still sorting out some crap with my host, but then I am moving on to some tool development, mostly its database admin, and some basic reports from the database to begin with, but the first step HAS to be user administration as its a ball ache doing it manually...

Selene D'Celeste
Caldari
The D'Celeste Trading Company
ISK Six
Posted - 2009.04.19 18:22:00 - [194]
 

Following the steps here: http://code.google.com/p/yapeal/wiki/InsYapWinSer

I get to "setup.php?install=step3" of the Yapeal setup and the apache server crashes.

Problem signature:
Problem Event Name: APPCRASH
Application Name: httpd.exe
Application Version: 2.2.11.0
Application Timestamp: 493f5d44
Fault Module Name: php5ts.dll
Fault Module Version: 5.2.9.9

I can't find any more information on what could be configured wrong to cause this. Ideas?

Satis Iqulenax
Amarr
Free Imperial Vikings
Posted - 2009.04.20 15:53:00 - [195]
 

Originally by: Selene D'Celeste
Following the steps here: http://code.google.com/p/yapeal/wiki/InsYapWinSer

I get to "setup.php?install=step3" of the Yapeal setup and the apache server crashes.

Problem signature:
Problem Event Name: APPCRASH
Application Name: httpd.exe
Application Version: 2.2.11.0
Application Timestamp: 493f5d44
Fault Module Name: php5ts.dll
Fault Module Version: 5.2.9.9

I can't find any more information on what could be configured wrong to cause this. Ideas?


In the cache/log folder where you have installed yapeal, you should have a setup log. with the date and time from where you started to use the setup.php.

Please check where it stops.

Kind Regards
Satis
install dev

Satis Iqulenax
Amarr
Free Imperial Vikings
Posted - 2009.04.20 19:10:00 - [196]
 

Okay NM my last post.

We have just released our new release.
There is nothing new in the API of Yapeal but the setup it totally rewritten.

It's the 2. generation of the yapeal setup and right now, there is no manual install, so you have to use the setup.php from the install folder.

The character selection is not needed anymore and will not be shown in the first time setup, but first after yapeal is setup and running from your web host.
The reason for this is that the character select and api registration is ONLY meant to be used as a test to test yapeal. When implementing into your system, do not use the test character section.

Another new thing that is added is that the setup now works together with yapeal error handler and there is now 3 new files in cache/log folder where all the new error/warning/notice logs will be added if there is one in the setup and it will be easier for us to find the error if you get one.

The backwards compatibility only goes back to last release so if you are using an older version than the last one, then you will need to start with a clean install.

Kind Regards
Satis

Ticnala
Posted - 2009.05.01 05:19:00 - [197]
 

Edited by: Ticnala on 01/05/2009 06:11:25
I was trying to use the setup.php today after grabbing the 755 revision. The page loads up blank in my browse and when I went to check on the code in funciton.php I noticed there were some for loops missing foreach ( from the beginning.
Dropping back to 754 will display the first page but I had to drop to 752 for it to pass the file write test.
In 753+ there was a log error saying that the YAPEAL_LOG_LEVEL varible was undefined.
752 doesn't have that problem though and has been working so far.

I'm running PHP 5.2.8, Apache 2.2.11, and mySQL 5.1.32 revision# 2761.

Thanks again for the awesome work :D

edit:

Ran into a few other errors

Message: mysqli error: [1364: Field 'lvl' doesn't have a default value] in EXECUTE("insert into `charAssetList` (`flag`,`itemID`,`lft`,`locationID`,`ownerID`,`quantity`,`rgt`,`singleton`,`typeID`) values

I changed the lvl field to have a default and it imported
and

Message: mysqli error: [1364: Field 'lastKillboard' doesn't have a default value] in EXECUTE("insert into `charKillLog` (`killID`,`killTime`,`moonID`,`solarSystemID`) values
I changed the lastKillboard, originalKillboard, and stratum fields to have defaults

This "fixed/suppressed" the warnings I was getting. It seems that the lvl field was added to the db table but not to the charAssetList class.

private $types = array('flag' => 'I', 'itemID' => 'I', 'lft' => 'I',
'locationID' => 'I', 'ownerID' => 'I', 'quantity' => 'I', 'rgt' => 'I',
'singleton' => 'L', 'typeID' => 'I'

Coryigon
Minmatar
Mom 'n' Pop Ammo Shoppe
Posted - 2009.05.01 17:16:00 - [198]
 

When accessing setup.php I get this

Parse error: syntax error, unexpected T_AS in /home/repoindu/public_html/Yapeal/install/inc/function.php on line 77

Satis Iqulenax
Amarr
Free Imperial Vikings
Posted - 2009.05.02 05:27:00 - [199]
 

Okay after having a look over in the code (and fixed some tiny bugs Dragonaire made :P) I found some small bugs that should be fixed now.

Try grab it from the trunk again and see if you still get the same errors

Kind Regards
Satis

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.05.02 06:43:00 - [200]
 

Hi guys I've fixed a few more things. The class/api/*AssetList.php files for char/corp have been updated to use the new lvl column. charSkillQueue should now update correctly also.

Revision 758

Coryigon
Minmatar
Mom 'n' Pop Ammo Shoppe
Posted - 2009.05.02 12:53:00 - [201]
 

Working good now thanks.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.05.02 19:48:00 - [202]
 

Some more fixes.

  • Fixed errors caused by merging a project member's killboard version of the *KillLog xml definitions from one of his other projects instead of one without the extra columns

  • Fixed minor missed edit to corpAssetList that caused warning messages when running yapeal.php


Revision 759

powers sellers
Posted - 2009.05.03 10:15:00 - [203]
 

i tried to use yapeal. All is ok but when i create cron i have this :

Quote:
nullPHP Warning: mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0 PHP Warning: mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0 PHP Warning: mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0 PHP Warning: mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0 PHP Warning: mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0 PHP Warning: mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0 PHP Warning: mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0 X-Powered-By: PHP/4.4.8_pre20070816-pl1-gentoo Content-type: text/html <br /> <b>Parse error</b>: syntax error, unexpected '{' in <b>/home/nthr/www/yap/yapeal.php</b> on line <b>101</b><br />


is it me or the code wich make problem ?

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.05.03 13:12:00 - [204]
 

Quote:
X-Powered-By: PHP/4.4.8_pre20070816-pl1-gentoo


Your trying to run it with PHP4 instead of PHP5 which won't work. Yapeal requires at least version 5.2.1. I'm also guessing from some of the rest of the message that you're trying to run it with the CGI version of PHP and not the CLI.

Just as a guess you're at a hosted site and you're using their so called 'cron' setup and not using the crontab command directly through a remote login like SSH to try setting it up which seems to cause all kind of problems for people. There is some help on the Yapeal website including some pointers in one of the issues on how to work around that.

Meissa Anunthiel
Redshift Industrial
Rooks and Kings
Posted - 2009.05.08 09:37:00 - [205]
 

Hi Dragonaire,

Your early comments refer to a yapeal.sql file that doesn't exist [anymore?].

Followed your InsYapWinserver documentation to install, everything is fine, works flawlessly until you reach the "Character Select and API Pull Select".

There's no such thing. :-)

Satis Iqulenax
Amarr
Free Imperial Vikings
Posted - 2009.05.08 10:51:00 - [206]
 

Originally by: Meissa Anunthiel
Hi Dragonaire,

Your early comments refer to a yapeal.sql file that doesn't exist [anymore?].

Followed your InsYapWinserver documentation to install, everything is fine, works flawlessly until you reach the "Character Select and API Pull Select".

There's no such thing. :-)


Okay first of :P
InsYapWinserver documentation is something I wrote and sorry for not updating it to the new version of yapeal that we have released.
I'll go fix that now.
The character select have been removed from the first time setup, since it's not really needed in a website where yapeal is implemented in.
However if you are still just trying Yapeal out, then just run the setup.php again and then there is 3 menu now, where you can change database info, change Yapeal api handler and test character witch is the one you were looking fore ;)

about the yapeal.sql file, then if you have read one of my previous posts, then we have removed all sql files and manual setup is not possible now, Dragonaire might make a CLI installer, but that's that.
We have changed from sql files over to use a axmls schema xml file to create the tables, since it's easier for us to maintain.

I'm guessing you found that info in a old dock :)

Kind Regards
Satis

Bonechewer
Posted - 2009.05.09 00:53:00 - [207]
 

Hey guys...

Ive got a bit of a problem with the SVN ive downloaded. The password field is not provided during the setup. So when i get to http://192.168.1.56/yapeal/install/setup.php?funk=configini ... no matter what i try, it doesnt work.

Any ideas ?

Satis Iqulenax
Amarr
Free Imperial Vikings
Posted - 2009.05.09 01:23:00 - [208]
 

Originally by: Bonechewer
Hey guys...

Ive got a bit of a problem with the SVN ive downloaded. The password field is not provided during the setup. So when i get to http://192.168.1.56/yapeal/install/setup.php?funk=configini ... no matter what i try, it doesnt work.

Any ideas ?


It should be on the yapeal.ini Setup page in the bottom.
it's the page right after the tables have been created.
Else check the cache/log folder and see if the setup_error.log, setup_notice.log or setup_warning.log have some info in it, since we need some more info on it.

Kind Regards
Satis

Matrix Lady
Posted - 2009.05.13 10:10:00 - [209]
 

i want to try the yapeal but where is the download links?
i try on google but nothing
any can help me with this?
thank you

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2009.05.13 14:07:00 - [210]
 

You have to use subversion to get it there's some instructions earlier in this thread and also in the wiki that should help you with getting it.


Pages: first : previous : ... 3 4 5 6 [7] 8 9 10 11 ... : last (24)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only