open All Channels
seplocked EVE Technology Lab
blankseplocked Yapeal PHP API library (revision 1203 branches/keys/)
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 16 17 18 19 20 21 [22] 23 24 : last (24)

Author Topic

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.02.06 21:48:00 - [631]
 

Hi All I've been working on getting something out for incursion and the code needs some more testing so decided to add incursion branch to downloads on SF so a few more people might try it out and let me know if everything seems to work.

I think I've also got issue 65 finally completely fixed for both old and newer version of PHP. I basically ended up doing feature detection like I was working in Javascript or something Mad

For those that want to give it a try there is a new branch where Johnathan Roark and I have been work been working on converting Yapeal to use HTTPS. You can find it in branches/https/. Be warned it's taken from trunk/ so will probably have some problems if you try any of the APIs that do walking like WalletJournal or WalletTransactions.

If you try out trunk/ or any of the new branches make sure you read their CHANGELOGs to see what has changed in each of them.

revision 1160

Malice Shecktily
Posted - 2011.02.12 10:59:00 - [632]
 

Originally by: Dragonaire
Ok thought I'd update everyone on Yapeal again. Had some bugs reported mainly with trunk/. Several typos were found in the SQL upgrade script file which have been fixed. Some of those same typos were also in the SQL XML file and they have also been fixed. One more bug that was showing up with Windows was files like class/Section*.php meaning Yapeal didn't do a lot other than throw lots of error Wink Seems to have been cause by some changes to inheritance and parenting changes of some classes in SPL and their defaults in newer versions of PHP. Yapeal now is setting some settings to know working values which has fix the issue.

revision 1134

Firstly, Thanks Dragonaire for all the time and effort you've obviously expended on Yapeal - I had started to build my own API classes to get data into mysql but have decided not to reinvent the wheel Smile
I'm getting the Yapeal error No Section classes where found when running yapeal.php.
I think I'm getting something related to the class inheritance issue as I've run through the code, although I'm a bit noob wrt OOP esp with SPL, seems to fall over in getStrippedFiles in class FilterFileFinder : $files gives me
<pre>FilterFileFinder Object
(
[path:protected] => D:/websites/yapeal/class/
[match:protected] => Section
[type:protected] => prefix
[piece:protected] => 8
)
</pre>
but doesn't loop though on the foreach (however is not empty)...like I say I'm noob on SPL so can't figure out what may be going wrong here or realistically how to debug any further... I just have a hunch that since this is a very new version of PHP 5.3 I'm running it may be related to some change in class inheritance that no-one else on here has hit yet. I've not been able to google anything up that seems to bear relevance (looked at http://www.php.net/~helly/php/ext/spl/) but can't be sure...

Db util* is populated, php version is PHP 5.3.5 (cli) (built: Jan 5 2011 20:29:28) running on apache2.2 on win xp. Yapeal version is 1160 from the SVN

Malice Shecktily
Posted - 2011.02.12 11:38:00 - [633]
 

Duh... please ignore last post - think I might have been using the alpha branch, just re-exported the latest trunk release and works fine Very Happy

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.02.12 16:42:00 - [634]
 

As you found alpha branch is currently broken. The trunk and the incursion branch are you're best bets with the incursion branch being preferred as it needs the testing and will soon be replacing the code currently in trunk.

Malice Shecktily
Posted - 2011.02.12 17:10:00 - [635]
 

Okey Doke, I'll check out incursion and work with that (my app is still under earlyish dev and needs significant refactoring now anyway so may as well grab as many bugs as poss in the early stages)

You prefer bug reports on this forum or http://code.google.com/p/yapeal/issues/list ?

Promise I'll try to remember which branch I was working on in future... Embarassed

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.02.13 11:56:00 - [636]
 

Either is ok I do like issues on site better in that they end up E-mailing me so I know there's something new to look at.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.02.18 10:20:00 - [637]
 

Hi all,
After a few delays I've finally reintegrated the incursion branch back into trunk/. Make sure to read through the CHANGELOG as there's a few things existing user should do like clear their exist XML cache but there are no database changes to deal with this time if your trunk/ was already up to date.

The changes have mostly to do with fixing walking for WalletJournal and WalletTransactions for characters and corporations. CCP seems to have some issues with how walking works in the APIs themselves but Yapeal should work with whatever it does get from them correctly.

Several bugs like issue 65,66,67 seem to be fixed.

Probably one of the biggest changes that will be noticed is Yapeal now uses HTTPS connections and unlike what I've heard about other API libraries Yapeal does actually check the certificates from the API servers so 'man-in-the-middle' attacks aren't possible now. I understand some other libraries have started using HTTPS connections but don't bother to check them which is kinda like using a new security door on your house and leaving the window wide open next to it Rolling Eyes

As always reports of any problems are welcome either here or as an issue on the main GoogleCode site.

revision 1164

Malice Shecktily
Posted - 2011.02.21 20:34:00 - [638]
 

Good Stuff - any db changes in there? or changes to the xsd's?

PS Better login to eve : Santa's been in town... Smile

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.02.22 06:07:00 - [639]
 

Since you brought it up yes there is a new update to XSDs since it seems AccountStatus.xsd wasn't allowing offer rowset to work correctly. There were of course a few other improvements made to all the XSDs while I was working on it in incursion branch as stated in the CHANGELOG.

BTW Santa was very nice to me and it isn't even December thank you Very Happy

Arnakoz
Posted - 2011.02.27 03:19:00 - [640]
 

Hi there, I'm running this on a Mac 10.6.6 with XAMPP.

i got into phpMyAdmin and created a db called yapeal and a user for it. but on running

php -f install/testForMySQLDatabasePrivs.php localhost <user> <pw> yapeal

i get

Connection error (2002) No such file or directory


i tried adding mysql.default_socket = /Applications/XAMPP/xamppfiles/var/mysql/mysql.sock" to /Applications/XAMPP/xamppfiles/etc/php.ini and restarting apache/mySQL ... but no go...

any ideas?

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2011.02.27 04:48:00 - [641]
 

Originally by: Arnakoz
Hi there, I'm running this on a Mac 10.6.6 with XAMPP.

i got into phpMyAdmin and created a db called yapeal and a user for it. but on running

php -f install/testForMySQLDatabasePrivs.php localhost <user> <pw> yapeal

i get

Connection error (2002) No such file or directory


i tried adding mysql.default_socket = /Applications/XAMPP/xamppfiles/var/mysql/mysql.sock" to /Applications/XAMPP/xamppfiles/etc/php.ini and restarting apache/mySQL ... but no go...

any ideas?


Does creatMysqlTables.php work? if so, I wouldn't worry about it.

Arnakoz
Posted - 2011.02.27 22:23:00 - [642]
 

so i figured out my problem.

XAMPP sucks.

no really, XAMPP had chosen to ignore the password for the new user that i created, and simply used no-password.

so running the xampp security util fixed the problem (though it added the problem that the log-in to phpMyAdmin only works every 10 times or so)

but the next problem was that when creating the tables with the yapeal php script it complained about the mysql socket, even though i had change it to the crazy location that xampp uses in php.ini. so i just created a symbolic link to make mysql think everything was where it was supposed to be:
sudo ln -s /Applications/XAMPP/xamppfiles/var/mysql/ /var/mysql


Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.02.28 07:29:00 - [643]
 

You might also try http://bitnami.org/stack/mampstack as I've had good luck using their WAMP stack and would expect the Mac one to be good too.

Arnakoz
Posted - 2011.02.28 13:28:00 - [644]
 

yup, i was considering it. if i hadn't been able to get XAMPP to work that was my next step...

Mad Maxipad
Posted - 2011.03.07 14:17:00 - [645]
 

I'm still having problems getting this to work. I filled out my fullapi/limitedapi/userid and set isactive to 1 under utilRegisteredUser. I filled out characterid,isactive,name,userid for RegisteredCharacter and put in AccountBalance under activeAPI.

When I php -f yapeal.php, it updates the count of users on the server in the DB, but no other DB tables get filled in. Is there something I am missing?

Ruziel
Minmatar
Twilight Military Industrial Complex
Posted - 2011.03.07 17:53:00 - [646]
 

Originally by: Mad Maxipad
I'm still having problems getting this to work. I filled out my fullapi/limitedapi/userid and set isactive to 1 under utilRegisteredUser. I filled out characterid,isactive,name,userid for RegisteredCharacter and put in AccountBalance under activeAPI.

When I php -f yapeal.php, it updates the count of users on the server in the DB, but no other DB tables get filled in. Is there something I am missing?


Did you also set utilSections.isActive = 1 where utilSections.sectionName = char?

Yo have to activate the sections in utilSections and have the API page in the activeAPI field of the registeredCharacter or resisteredCorporation for yapeal to pull the data.

Steven Trux
State War Academy
Posted - 2011.03.11 08:59:00 - [647]
 

Hi guys, I'm having some problem trying to setup yapeal....

Everything should be ok, but I receive this error:

Quote:
[2011-03-11 08:10:33.487]
NOTICE: None of the allowed APIs are currently active for *******
File: .../class/SectionAccount.php(110)
[2011-03-11 08:10:34.545]
NOTICE: Undefined variable: char
File: .../class/util/RegisteredCorporation.php(275)
[2011-03-11 08:10:34.545]
NOTICE: Trying to get property of non-object
File: .../class/util/RegisteredCorporation.php(275)
[2011-03-11 08:10:34.552]
WARNING: Parent record(s) missing from utilRegisteredCharacter for 1 making corporationID ******** in utilRegisteredCorporation incomplete.
File: .../class/util/RegisteredCorporation.php(212)
[2011-03-11 08:10:35.603]
NOTICE: None of the allowed APIs are currently active for *******
File: .../class/SectionChar.php(118)


Only "general" tables as "eveMemberCorporations" or "mapSovereignty" are populated, none of the character specific is.
I've modified the "utilSection" table and the other "util" one.
Thanks for any help Wink (and sorry for my english YARRRR!!)

Steven Trux
State War Academy
Posted - 2011.03.15 08:03:00 - [648]
 

Nobody can help me? Crying or Very sad

Ramov Tinoga
Tinoga Enterprises
Posted - 2011.03.15 13:05:00 - [649]
 

Do your utilRegistered* tables contain entries with the activeAPI column being non-empty and isActive = 1?

Without that, yapeal will only fetch non-character related data from the API.

Steven Trux
State War Academy
Posted - 2011.03.15 13:17:00 - [650]
 

Edited by: Steven Trux on 15/03/2011 19:52:42
Yes they do.
activeApi = myFullApiKey
isActive = 1

Sohlstyss Mahm
Posted - 2011.03.15 19:55:00 - [651]
 

ActiveAPI must contain a list of APIs separated by spaces.

Example: WalletJournal IndustryJobs

Steven Trux
State War Academy
Posted - 2011.03.15 20:15:00 - [652]
 

Thank you so much Exclamation
Now works like a charm Wink

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.03.16 04:17:00 - [653]
 

If you are writing an application you might also look at using class/util/Registered*.php and the other classes there to manage the tables you'll need to make things work. In the README file you'll find some links to the wiki where you'll find more information on how everything works together.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.04.07 15:01:00 - [654]
 

Probably the last post on the old forums I've started a new thread on the new forums for Yapeal which you can find at https://forums.eveonline.com/default.aspx?g=posts&t=4266&find=unread

Mikokoel
Posted - 2011.04.17 09:48:00 - [655]
 

new forums Very Happy

I have recently seen this project and I'm very amazed at all the work you and others? put into this project.

Last year you blogged about Memory Problems when used with lots of API-Keys and large API-Calls like AssetList and so on.

I plan using your library for an industrial planning tool. There will be around 40 Full API-Keys involved and API-Calls like AssetList will be used often.

Do you recommend using your library for this type of project or would you advise me something else?

Keep up your great work!

Mikokoel

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.04.18 04:59:00 - [656]
 

The memory problem have already been solved by going to XMLReader soon after those blogs. Yapeal has been used in applications with 100s to 1000s of characters and/or corporations and memory isn't a problem. At least it's not for Yapeal but sometimes the DB has problems keeping up because of memory or I/O bandwidth problems Wink

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2011.06.06 08:13:00 - [657]
 

Hi all know it's been a little quiet for development lately but I've been having multiple computer issues and been working on another project related to Yapeal.

Seems I missed any Dev Blogs about NPC corps now returning data for CorporationSheet so when someone brought it to my attention in issue 73 I made a change that now will let it work with them. Let me know if there are any other APIs that need to be updated because NPC data is now available for them as well. Fix is in SVN on GoogleCode and I'll try to get it pushed over to SourceForge soon.

Now for a little background on the other project I've been working on. You can find it at https://sourceforge.net/projects/xmlschema/

As most of you know ADOdb is use in Yapeal and during the install it uses the ADOdb Data Dictionary Library from ADOdb to build the SQL needed to make the database tables from the XML files in install/. It has worked well generally but has a few quarks and 'features' to it that make doing some things like updates more difficult than it should be. It also lacked some features that would make it vastly more useful IMHO. To make a long story shorter a friend (Johnathan Roark) and I in the end ended up branch the old unmaintained project on SF and started a new one. Johnathan took on the job of rewriting the table extract code so it used DOM instead of the hand coded strings it had before so it could be more easily maintained. I took on the task of rewriting the rest of the code used to make the SQL from the XML.

While we were at it I thought it would be a 'Good Idea' to also make a
<schema version="0.4"/>
with some of the new features that we had come up with.

The first thing needed was to convert everything away from XML Parser which is based on James Clark's expat to something more programmer friendly like XML Reader which is used in Yapeal but to do so someone (Dragonaire) had to learn how XML Parser worked. For anyone else trying to do the same thing make it easier on yourself and just make your own code that takes your input XML and gives the right result as trying to do it like I did is NOT the best way but was needed for backwards compatibility.

Okay to sum it up and not bore everyone anymore, do to backward compatibility and feature creep in the project what should have been at most a 1-2 month project has turned into a 6 month and counting one Razz In the end I know it'll be worth it for how it will let Yapeal be more forgiving during installs and upgrades but does mean Yapeal will mostly be in bug fix only mode for a while longer.

revision 1170

CTapocTAevp
Posted - 2011.07.02 14:22:00 - [658]
 

Pls show me any project site for use Pheal =)

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2011.07.03 02:53:00 - [659]
 

Originally by: CTapocTAevp
Pls show me any project site for use Pheal =)


I'm guessing your in the wrong thread?

Fredrick Engly
RaVal Thyokill Industies Inc.
Intergalactic Exports Group
Posted - 2011.07.09 16:33:00 - [660]
 

Edited by: Fredrick Engly on 09/07/2011 16:33:42
Now getting
WARNING: Caching invalid API XML for char/WalletTransactions
File: /blah/class/YapealApiCache.php(177)

and
WARNING: Caching invalid API XML for corp/WalletTransactions
File: /blah/class/YapealApiCache.php(177)

Can send files if needed


Pages: first : previous : ... 16 17 18 19 20 21 [22] 23 24 : last (24)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only