open All Channels
seplocked EVE Technology Lab
blankseplocked Yapeal PHP API library (revision 1203 branches/keys/)
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 14 15 16 17 [18] 19 20 21 22 ... : last (24)

Author Topic

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.15 03:50:00 - [511]
 

I'm surprised those lines caused you problems but they aren't really important they are just checking if the file is being ran directly or being included from another PHP file. My only concern is the same lines are used in many of the other files in Yapeal as well. Will probably need to figure out which line is causing the problem. If it's the 'if' there maybe ways to work around it but if it's the 'fwrite' it'll cause problems with all the logging and maybe some other places. Once you get it fully installed we'll see if you continue to have any problems Wink

Qoi
Exert Force
Posted - 2010.05.15 13:34:00 - [512]
 

Edited by: Qoi on 15/05/2010 13:34:35
Just wanted it to throw in here as i think most yapeal users are annoyed by it:
Originally by: Tyrannis Release Candidate Patch Notes
Corporation & Alliance
API - journal walking now works for the corporate wallet journal


Keep up the good work o/

Eduardo'o
Posted - 2010.05.15 19:46:00 - [513]
 

I want to try and install yapeal manually ..... but i cannot find where to start. I understand tehre is no real documentation, but is there any place indicating where to start?

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.15 22:13:00 - [514]
 

Eduardo'o - You can do it all manually but it's not easier or quick for sure. I'll go over some of the high points of what you'd need to do.

  1. Download one of the archives (*.zip, *.tar.bz)

  2. Make directory where you plan on instilling it and un-zip archive into it

  3. Update any/all paths from inc/common_paths.php for where you put Yapeal

  4. Copy config/yapeal-example.ini to config/yapeal.ini

  5. Edit config/yapeal.ini and add your settings using the comments from the file for reference

  6. Create MySQL database that matches your settings from config/yapeal.ini (This could be done before last step but this order is usually less error prone IMHO)

  7. Open up each of the install/*.xml files and decipher it manually and create all 70-80 database tables making sure to get the types, lengths, indexes, etc correct for each table Shocked

  8. Add any test users, characters, and/or corporations you need into the utilRegistered* database tables

  9. Hope you got everything right because if something is wrong on many of the steps above you might not even be lucky enough to get useful error message and it just fails silently

  10. Try it

  11. Figure out what steps I forgot to add to this list that keeps it from working or what typo etc you madeRazz

  12. Repeat the last two steps as many times as needed until it: Runs without errors and correctly gets all the data from the API servers for all APIs


If you can get it to work without doing the last step more than twice I'll turn the project over to you because I'm sure the project would be in much better hands with a 'guru' instead of me since if I tried it I probably wouldn't be successful Evil or Very MadVery Happy If you can get it to work within 5 tries I'd like to invite you to become a developer and help me out Very Happy If you think do the above is a great way to spend a day, week, or month of your time you probably should get some mental help but if you're interested I'm looking for some victims, uh I mean test subjects for some pre-Alpha code Twisted Evil

Personally I'd start by contact my host tech support for help fixing whatever is keeping you from running the installer. IMHO if they can't help you with any issues or you can't figure it out yourself I'd find a new host because Yapeal doesn't have any requirements that they shouldn't be able to supply. You can also try use a local test server and install Yapeal there then copy stuff over to the remote one with all the database exports etc that will be needed. I've covered how to do that already in this thread several times so I wouldn't repeat it here but feel free to ask any questions you have if you run anything new or just can't figure something out and either I or someone else on the thread will be glad to help.

Eduardo'o
Posted - 2010.05.16 06:30:00 - [515]
 

Edited by: Eduardo''o on 16/05/2010 06:42:33
Nuf said, the installer it will be then Wink

Is there anyway to run the installer but by making the database manually?
I do not mean filling up the database with the table. Just the create database command should be done manually

Ed

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.16 12:48:00 - [516]
 

You can create the database without problems just make sure to give the name to the installer and the user you use for DB has all the privileges needed for creating the tables, etc.

BanditFly9
Posted - 2010.05.18 14:35:00 - [517]
 

Thank you for all of the information. I will be attempting to implement this once I setup my server box.

Loki L'Odin
Gallente
Aliastra
Posted - 2010.05.22 13:52:00 - [518]
 

Edited by: Loki L''Odin on 22/05/2010 16:46:34
EDIT: ok...installer has loaded...now im being a nub...Where can I find my CLI version of PHP?! lol

Gouverneur
Posted - 2010.05.22 14:49:00 - [519]
 

My Problem was fwrite(STDOUT/STDERR after all.
CGI PHP doesnt open SDTOUT/STDERR Handles automatically.
So something like
Quote:
$stdout = fopen('php://stdout', 'w'); $stderr = fopen('php://stderr', 'w');
must be added at the Beginning of the File and fwrite-Lines must be updated accordingly to make it work on cgi-php.
Well at least testForPHPVersion.php works for me, after updating it that way.

Am I the only one having these Problems installing with cgi-php or did nobody ever tried it yet?

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.22 20:30:00 - [520]
 

Ok I've been looking into the problems with PHP-CGI some more and seem to have a fix. I was 'ass-u-ming' that the switches I was passing and the ini overrides where changing more than they do about how it works Embarassed I've now added lines to set the constants for STDIN, STDOUT, and STDERR if they aren't already set. I've updated trunk/ with the fixes and you can get the update installer from downloads now. Give it a try and see if it fixes the problems you've been having.

I'd like to get some feedback about the new APIs from everyone to see which ones they would like to see added to Yapeal first. You can read about what's being added in this dev blog post:
http://www.eveonline.com/devblog.asp?a=blog&bid=757
I'm also trying to decide if I will add them to the existing trunk code or just work on them in the new XMLReader code and wait until moving it to trunk/ before really making them available. Doing the latter would probably give some time for CCP to work out any bugs in them first and may work better but does mean they wouldn't be available from Yapeal for a couple weeks or more for everyone to work on their applications with. I wouldn't be as concerned with that if I'd seen more people had tried the Alpha builds I uploaded and had some feedback on any bugs with them.

revision 1072

Gouverneur
Posted - 2010.05.22 22:16:00 - [521]
 

Edited by: Gouverneur on 22/05/2010 23:08:46
Thanks for the Update.
I've just tried the fresh Installer.
fwrite-Lines seem to work, getting another error now:
Quote:
Warning: Error running /usr/local/bin/php.5 -f '/tmp/Yapeal/install/testForPHPVersion.php' : Including of /tmp/Yapeal/install/testForPHPVersion.php is not allowed

It's kinda my fault, had the same error while trying to 'fix' the fwrite-lines, but commented the code-block out and totally forgot about it.

Edit: the Filename-Check fails because PHP_SELF is empty :/

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.23 00:28:00 - [522]
 

Really beginning to dislike PHP_CGI Mad

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.23 22:54:00 - [523]
 

Ok I've been digging into the changes needed to make Yapeal work with PHP_CGI and I am sorry to say at least in the case of the installer it's not possible Crying or Very sad You can have a look at this page to get a little more detail:
http://www.php.net/manual/en/features.commandline.differences.php

Why it wouldn't work is found in the first note. To sum it up by the time you can turn register_argc_argv on PHP has already processed the command line and put anything you've passed it into $_GET and $_REQUEST and wouldn't populate $argc or $argv with the values Mad The good news is once it's installed Yapeal doesn't normal use any parameters and PHP-CGI works without any problems. I'll continue to look for workarounds but since Yapeal was made for the command-line it doesn't make sense to spend a lot of development time on it right now.

Tonto Auri
Vhero' Multipurpose Corp
Posted - 2010.05.23 23:37:00 - [524]
 

It's a nonissue, in fact, you should not attempt to run PHP scripts intended for console (php-cli) through php-cgi SAPI.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.24 00:21:00 - [525]
 

Only reason I try to support it where I can is some host services don't allow access to CLI version and I do want to make it possible to use it everywhere when I can figure out how. Right now Yapeal itself seems to work fine it's just some of the scripts used during install that cause issues. The normal work around for installer issues has always been to install Yapeal on a local test server then copy the configuration over to remote production server. Many times this can even work with different OSes on each system with a little care.

Something I've been try out is VMWare player and stuff from BitNami. For anyone that only have a Windows machine locally it looks like it may be an option when you have a Linux/Unix host and stuff from Windows doesn't seem to work. I've also been looking at some cloud computing stuff to see if Yapeal is going to be compatible for anyone that is outgrowing what a single server can handle. So far I haven't found any show stoppers but I wouldn't know until I actually take some time and spend some RL money to try it Smile

Gouverneur
Posted - 2010.05.24 01:59:00 - [526]
 

Originally by: Tonto Auri
It's a nonissue, in fact, you should not attempt to run PHP scripts intended for console (php-cli) through php-cgi SAPI.

Well, I guess the Requirements-List should be updated then.
There is no Hint about the Project being intended for CLI yet.

@Dragonaire: Thanks for trying.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.24 03:43:00 - [527]
 

Actually the project website use to say something about Yapeal being for CLI only but was removed after some changes where made and it seemed to work without problems. I think once you actual get it installed it'll run without problems but the installer highlights where the CLI and CGI versions are made to be use for different applications. If they weren't they wouldn't need to have two different versions after all Wink

Mi'Rini Nemo
Posted - 2010.05.27 08:46:00 - [528]
 

Edited by: Mi''Rini Nemo on 27/05/2010 09:43:35
Edited by: Mi''Rini Nemo on 27/05/2010 09:43:12
Edited by: Mi''Rini Nemo on 27/05/2010 09:17:20
Hi

First of all congratulations for your tool! But....

I am having a problem with the windows installer. I cannot get past the database Setup section... As soon as I click on the next button to install the database I get an error. A new window appears with the message "The following Error occured:" and... that's it! Nothing after that. Any ideas?

I really want to start using it so pls help!

*EDIT* Also tried the web installer but there is no setup file (http://code.google.com/p/yapeal/wiki/InsYapWinSer)

*LAST EDIT* OK... Fixed the first problem the installer had ' "" ' in the fields so I removed them. Now it says that the user I put in the field does not have the required privileges to use it. I granted full privilleges on all of the databases but still the installer pops-up this error.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.27 14:05:00 - [529]
 

Mi'Rini Nemo - I'd suggest looking back a couple pages in this thread where the last person was asking the same questions or in some of the issues on the project site ( You may need to look at all issues including closed ones) if you still are having problems then I'll try to help but right now with all the new API changes I'm going to be busy updating Yapeal for next few days.

For those wondering yes they made a few changes to some of the older APIs that have broke them so I'll be working on them and hope to have a fix out this weekend or soon if I can but been busy at work doing some certifications so a bit worn out by end of day and just haven't been feeling like working on Yapeal as much in the evenings lately Sad

Gouverneur
Posted - 2010.05.27 20:55:00 - [530]
 

Yeah, finally got it up and running(didnt check everything, but looks good so far) with my picky CGI-PHP-Binary :D
Installed on local vmware lamp machine, edited a few Paths and copied over to the 'real' server.

However, one thing was kinda strange: I had to create the (empty) Database manually after the Mysql Privileges check had passed in Installer. I've tried to install into empty DB first, but got the Privileges-Error although I've had root logged in(with all Privileges activated of course).
Deleted the DB and Installer failed to create the DB-Tables at the end, because the DB itself wasn't created at that point.

I suspect testForMySQLDatabasePrivs.php was somehow responsible, here is its log-entry:
Quote:
Script exit code: 0

Script output:
false

Script stderr:
root lacks the needed privileges: alter, create, delete, drop, index, insert, select, update on the db49430_1 database

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.28 07:22:00 - [531]
 

Ok to update the charMailMessages table all current users will need to use the following SQL before updating Yapeal with the installer. CCP renamed "toListIDs" to "toListID" and changed it from being a list to a single ID which is a type of change the SQL updater in the installer doesn't handle well on it's own Sad use the follow SQL:
alter table `charMailMessages` change column `toListIDs` `toListID` decimal(20,0) unsigned DEFAULT 0

You may need to add the database name if you don't have it selected already by prefixing the table name with it i.e. : ... table `MyDBName`.`charMailMessages` change ...

You may notice some additional tables being added for some of the new APIs that were included in Tyrannis but the classes aren't done so none of them will be active until later.

revision 1073

Mi'Rini Nemo
Posted - 2010.05.28 08:12:00 - [532]
 

Edited by: Mi''Rini Nemo on 28/05/2010 09:04:09
Originally by: Dragonaire
Mi'Rini Nemo - I'd suggest looking back a couple pages in this thread where the last person was asking the same questions or in some of the issues on the project site ( You may need to look at all issues including closed ones) if you still are having problems then I'll try to help but right now with all the new API changes I'm going to be busy updating Yapeal for next few days.

For those wondering yes they made a few changes to some of the older APIs that have broke them so I'll be working on them and hope to have a fix out this weekend or soon if I can but been busy at work doing some certifications so a bit worn out by end of day and just haven't been feeling like working on Yapeal as much in the evenings lately Sad


Prepare for some feedback...!

My os : Windows 7 64-bit
local : WAMP server
PHP VERSION : 5.3.0

Downloaded and tried both the beta and alpha installers from your download list.
NOTE: There are three files in the PHP folder in wamp ( php.exe, php-win.exe & php-cgi.exe )

BETA Installer VERSION:
Run it as admin.

CLI selection: php.exe
What happened: Passed the CLI selection. Put the required database info. Triple-checked they are right and tha my user has the minimum required privileges (and/or more privileges than required). Click "Next". Pops-up error message "User doesn't have the required privileges".


CLI selection: php-win.exe
What happened: Passed the CLI selection. Put the required database info. Triple-checked they are right and tha my user has the minimum required privileges (and/or more privileges than required). Click "Next". Pops-up error message "User doesn't have the required privileges". [/left]

CLI selection: php-cgi.exe
What happened: Did not pass the cli selection. Error message "Error running C:\wamp\bin\php\php5.3.0\php-cgi.exe -f "P:/users/programmer/AppData/Local/Temp/Yapeal/install/testForPHPVersion.php": Including of is not allowed ".


ALPHA Installer VERSION:
Run it as admin.

CLI selection: php.exe
What happened: Did not pass the CLI selection. Error "The following required PHP extensions are not active: hash"

CLI selection: php-win.exe
What happened: Did not pass the CLI selection. Error "The following required PHP extensions are not active: hash"

CLI selection: php-cgi.exe
What happened: Passed the cli selection. Passed the Database check. Installed properly with default options selected. After the installation checked the database to check the new tables and their structure but the database was empty. Uninstalled yapeal and installed again with same database info but yet again the tables weren't there".

Is available a web installer at least?

[/left]

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.28 13:58:00 - [533]
 

Quote:
Is available a web installer at least?
No and no current plans to add one since Yapeal is a command line library that isn't really made to be ran with web server it doesn't make sense to have one. Yapeal use to use one but since the person that wrote it has moved on from Eve and it was start to show its limitations I converted to the current installer. I have been thinking about a remote installer which would use a web-base front end system but it's not something I've had time to figure out yet.
Quote:
What happened: Did not pass the CLI selection. Error "The following required PHP extensions are not active: hash"
How about activating the required extension? It is probably there just not turned on in php.ini even though it's include be default since 5.1.something Don't ask me why they always seem to have all the extensions turned off by default in Windows builds Razz

Quote:
"User doesn't have the required privileges"
Make sure the user you are using has select for `information_schema`.`SCHEMA_PRIVILEGES` and what privileges are listed there for the user you are using. Often if you are using "root" user it's not listed because it is granted access in a different way during MySQL startup so try creating one just for Yapeal to use. For the example user used in Yapeal with default database setting it would look like this:

[code]
+--------------------------+---------------+--------------+----------------+--------------+
| GRANTEE | TABLE_CATALOG | TABLE_SCHEMA | PRIVILEGE_TYPE | IS_GRANTABLE |
+--------------------------+---------------+--------------+----------------+--------------+
| 'YapealUser'@'localhost' | NULL | yapeal | SELECT | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | INSERT | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | UPDATE | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | DELETE | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | CREATE | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | DROP | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | INDEX | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | ALTER | NO |
+--------------------------+---------------+--------------+----------------+--------------+
[\code]
If yours doesn't look something like that you'll need to change the privileges until it does.

Quote:
*LAST EDIT* OK... Fixed the first problem the installer had ' "" ' in the fields so I removed them.
They are probably required where you removed them and are causing you some of your other problems but since it isn't clear which ones you remove I can't tell. I've had some escaping problems in the past so if you could clarify which ones you were having problems with I can maybe look into it and see if something got missed. Also try looking for a bitrock*.log file in your temp directory as it may have some additional detail on why stuff is failing.

Rottw Adleweh
Posted - 2010.05.28 14:37:00 - [534]
 

@Dragonaire

I was wondering how hard it would be for me to switch my database backend to postgre. I know yapeal has been developed with mysql as the backend and I haven't really looked into the code to figure out how tied it is to mysql. Some tools you just need to configure to use another 'driver' to access another type of sql backend, I'm not sure how easy it would be with yapeal though.

Could you give me a guestimate on how much I have to change to port it to a postgre backend? (as in 'a hell of a lot' or 'just a few lines')

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.29 01:36:00 - [535]
 

Rottw Adleweh - I would say converting the installer would be hard because of how it detects MySQL and the existing DB etc. but Yapeal itself could be converted with some work. Generally I've tried to use standard SQL and where I didn't I've try to isolate the MySQL only SQL into PHP methods/functions so they could be changed for other DBs. One reason for using ADOdb was to make converting it easier if I ever decided to do so. Contact me via my GMail from the project and I can discuss with you some details I don't want to bore everyone with in a forum post Wink

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.29 20:23:00 - [536]
 

Hi all I've been working on adding some of the new APIs to Yapeal and need a little help. Since my alliance/corp doesn't have our own Outpost (yet Wink) I need some help from someone that does. If someone would be kind enough to send me a copy of their /corp/OutpostList.xml.aspx and /corp/OutpostServiceDetail.xml.aspx with one or more outposts in it that would be extremely helpful. I will only be using it as a reference for typing and sizing columns for the database tables in Yapeal and I would not be sharing it with anyone (Not even corpmates) and if you want to obscure the ownerID, stationID, and/or standingOwnerID that is okay as I mostly have questions about some of the other stuff. If you can help out please E-Mail them to me at my G-Mail address from the project home page (project owner). I'm also be looking for someone that would have some time to do some alpha testing for the same APIs but that wouldn't require sending me the XML like above just a server where you can instill Yapeal and have command line access to look at log files and report any error to me via IM (preferred) or E-Mail.

Thanks for everyone's time and hopefully I'll get a response today and be done with test by tomorrow and at least have out an alpha build with the new APIs for people to do their own testing with.

Mi'Rini Nemo
Posted - 2010.05.30 17:38:00 - [537]
 

Edited by: Mi''Rini Nemo on 30/05/2010 17:40:53
Originally by: Dragonaire


Quote:
*LAST EDIT* OK... Fixed the first problem the installer had ' "" ' in the fields so I removed them.


They are probably required where you removed them and are causing you some of your other problems but since it isn't clear which ones you remove I can't tell. I've had some escaping problems in the past so if you could clarify which ones you were having problems with I can maybe look into it and see if something got missed. Also try looking for a bitrock*.log file in your temp directory as it may have some additional detail on why stuff is failing.




I finally managed to install Yapeal, on another PC YAYYYYYYYYY!!!!!!!

Now about your question... I removed the ' " " ' from all the database configuration fields. They were interfering with the normal installation, clicking next a pop up window appeared with the message " The following error occured: ". Removing those I managed to finish the installation. Probably an escaping error?

Note: I want to add that the ' "" ' were the only problem, nothing else happened, a fact tha leads to the conclusion that there was some sort of problem with my previous systemYARRRR!!.

Now how can I retrieve the data from the database, is there something ready or through custom code?
The xml files can be/are stored to a folder?
How can I change my char's credential, add new or edit them?
Which file should be set for a cron job?

Sorry about my questions!

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.05.30 18:55:00 - [538]
 

Quote:
Now how can I retrieve the data from the database, is there something ready or through custom code?
That would be called your application Wink The More detailed explanation section of the main project page details what it does for you everything else is up to you. You can just forget where the data is coming from and make your application knowing the tables will always have the most up to date data available. The idea behind the design of Yapeal was to let anyone that knows how to make a LAMP web application do so. It has been expanded to include WAMP as well or anything else that can work with a MySQL database.

Quote:
How can I change my char's credential, add new or edit them?
Have a look through the project wiki where the http://code.google.com/p/yapeal/wiki/UsingClassUtilClasses and the http://code.google.com/p/yapeal/wiki/UtilDatabaseTableDependences pages will probably but the most useful in understanding how to add additional chars/corps, etc.

Quote:
Which file should be set for a cron job?
Have a look at the http://code.google.com/p/yapeal/wiki/CrontabSetup for help with setting up crontab.

While you're at it you'll probably want to look through some of the other wiki pages and maybe some of the issues include closed ones as they have some information that you may find help during any troubleshooting you may need to do.

BTW the problem you may have been having with it not finding 'hash' extension was probably do to a typo on my part. I include a space in front of it inside the quotes that didn't get caught until I was testing the installer locally yesterday. Embarassed I'll be releasing an updated alpha build once I've smashed a few other bugs I've found that are mostly in the new APIs I've been trying to add from Tyrannis.

Bai Guang
Caldari
Perkone
Posted - 2010.06.01 07:52:00 - [539]
 

Installer is failing for me. Im running in a hosted linux environment where I have SSH access to a jailed account. The spot that it is failing is the part where it checks permissions for the database user. It says the user does not have the proper permissions but a SHOW GRANTS FOR CURRENT_USER(); reports back that the user has all privileges on the database.

I've triple checked to make sure that Im using the proper database, database user, and password, so other than that, I don't know why its failing.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.06.01 08:50:00 - [540]
 

Bai Guang - Try looking at the second half of post 533 and check your access that way. I.E.
select * from `information_schema`.`SCHEMA_PRIVILEGES` where GRANTEE like "%YapealUser%" and
TABLE_SCHEMA="yapeal";

That gives me this on a test server:
[code]
+--------------------------+---------------+--------------+----------------+--------------+
| GRANTEE | TABLE_CATALOG | TABLE_SCHEMA | PRIVILEGE_TYPE | IS_GRANTABLE |
+--------------------------+---------------+--------------+----------------+--------------+
| 'YapealUser'@'localhost' | NULL | yapeal | SELECT | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | INSERT | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | UPDATE | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | DELETE | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | CREATE | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | DROP | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | INDEX | NO |
| 'YapealUser'@'localhost' | NULL | yapeal | ALTER | NO |
+--------------------------+---------------+--------------+----------------+--------------+
8 rows in set (0.00 sec)
[\code]


Pages: first : previous : ... 14 15 16 17 [18] 19 20 21 22 ... : last (24)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only