open All Channels
seplocked Linux
blankseplocked Get lockups when switching workspace
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

Baghtar
Dreddit
Test Alliance Please Ignore
Posted - 2008.09.30 17:50:00 - [1]
 

Edited by: Baghtar on 30/09/2008 17:50:31
This problem started after todays patch. I have never had any problems with eve locking up when I switch workspace before but now its doing it every time I do it. Anyone else experiencing this and have any workaround.

Running Wine 1.1.5 in Ubuntu 8.04.

Keyser Wilhelm
Posted - 2008.09.30 18:07:00 - [2]
 

Can confirm this. As soon as i switch to another whatever, the client/wine freezes.

Running wine 1.1.5 with Gentoo GNU/Linux.

Have been running with wine and gentoo for at least a year without much trouble. The patch does seem to screw things up a bit.

Elegbara
Posted - 2008.09.30 18:18:00 - [3]
 

If you alt-tab from Eve into another application, Eve keeps running. Once you return focus back to Eve, it freezes.

Wine 1.1.5, Ubuntu 8.04 here.

Baghtar
Dreddit
Test Alliance Please Ignore
Posted - 2008.09.30 18:25:00 - [4]
 

Seems like its not only me then, now when we have confirmed that 100% of all Linux users got this error(3of3) all that is left is someone being a wine wizard to come in and tell us what to do.

Gonna loose a ship soon due to my tabing reflex.

Einheriar Glad
Purple Reign Entertainment
Posted - 2008.09.30 18:27:00 - [5]
 

Same here Sad.... wine 1.1.5, Ubuntu 8.04

- Glad

Keyn Thror
Minmatar
N.S.
Posted - 2008.09.30 18:27:00 - [6]
 

Confirming this, started after today's patch.

Never had this problem before.

I start the client, load to whatever stage (login screen, char select screen, the game - anything), then click out of the game window, click in the game window - then client freezes 100%.

Running Wine 1.1.1 on Debian 2.6.24-etchnhalf.1-686


Baghtar
Dreddit
Test Alliance Please Ignore
Posted - 2008.09.30 18:29:00 - [7]
 

Edited by: Baghtar on 30/09/2008 18:36:39
I have now also tested on the last 'stable' wine version 1.0.0 and its the same in that version.

From the "Eve under Linux /w wine":

Originally by: Kadesh Priestess
Filled in issue 15485, vote for it :)

Keyser Wilhelm
Posted - 2008.09.30 18:42:00 - [8]
 

Edited by: Keyser Wilhelm on 30/09/2008 18:46:12
Edited by: Keyser Wilhelm on 30/09/2008 18:42:32
Well, i suggest that someone post a bug report at WineHQ. I couldn't find any report of this issue as of yet.

EVE Online entry here:

http://appdb.winehq.org/objectManager.php?sClass=version&iId=9971

Tried to register an account but have not received any mail from WineHQ yet.

---edit----
someone got to file bug before me, ignore me... :)

BTW : Register an account at bugzilla at WineHQ in order to vote the bug up here: http://bugs.winehq.org/createaccount.cgi

Tola
Arta Amicitia
Ships of the Line
Posted - 2008.09.30 18:44:00 - [9]
 

Edited by: Tola on 30/09/2008 18:54:41
Edited by: Tola on 30/09/2008 18:47:11
Edited by: Tola on 30/09/2008 18:45:35
Same here.
Wine 1.1.5, running with kubuntu 8.04

-> Classic Client is also affected.

Ancy Denaries
Posted - 2008.09.30 19:02:00 - [10]
 

Confirmed. Same effect here. Ubuntu 8.04 64bit, Wine 1.1.5.

This completely screws up any chance of running two clients or any other side program.

Crimson Calis
Deep Core Mining Inc.
Posted - 2008.09.30 19:56:00 - [11]
 

Can confirm it also, Debian unstable, wine-1.0

Aurix Lexico
Slacker Industries
The Boat Violencing Initiative
Posted - 2008.09.30 19:56:00 - [12]
 

Dear CCP,

Can you hire a part-time wine dev so things like this don't happen?

Or something along those lines?

Please?

Sincerely,
Adam

Kadesh Priestess
Scalding Chill
Posted - 2008.09.30 20:13:00 - [13]
 

Originally by: Tola
Edited by: Tola on 30/09/2008 18:54:41
Edited by: Tola on 30/09/2008 18:47:11
Edited by: Tola on 30/09/2008 18:45:35
Same here.
Wine 1.1.5, running with kubuntu 8.04

-> Classic Client is also affected.
Classic client or premium with classic graphics?

CCP Atropos

Posted - 2008.09.30 20:18:00 - [14]
 

As CCP Casqade stated here, we do not officially support EVE under Wine. As such I can't make any promises as to this particular problem being resolved, unless it presents itself under Cedega.

Tola
Arta Amicitia
Ships of the Line
Posted - 2008.09.30 20:22:00 - [15]
 

Originally by: Kadesh Priestess
Originally by: Tola
Edited by: Tola on 30/09/2008 18:54:41
Edited by: Tola on 30/09/2008 18:47:11
Edited by: Tola on 30/09/2008 18:45:35
Same here.
Wine 1.1.5, running with kubuntu 8.04

-> Classic Client is also affected.
Classic client or premium with classic graphics?

Premium client with classic graphics, didn't knew that there is a difference between classic and classic with premium clien.

Kadesh Priestess
Scalding Chill
Posted - 2008.09.30 20:23:00 - [16]
 

But it is there, lots of old bugs reproduced on one and didn't on another.

Could smb check classic client (not premium with classic graphics)?

Tola
Arta Amicitia
Ships of the Line
Posted - 2008.09.30 20:33:00 - [17]
 

Edited by: Tola on 30/09/2008 20:48:49
I'm allready downloading the classic client and will test it.

Edit
Same bug with the classic client.

Baghtar
Dreddit
Test Alliance Please Ignore
Posted - 2008.09.30 20:58:00 - [18]
 

Edited by: Baghtar on 30/09/2008 20:58:35
I tested with the official client and didn't encounter this bug. Unfortunate for us since we are on our own then. =/

Aurix Lexico
Slacker Industries
The Boat Violencing Initiative
Posted - 2008.09.30 20:59:00 - [19]
 

Confirming the bug persists with the classic only client.

There is going to be a decent sized fleet battle between amarr/minmatar FW. I wish I could join, but not going to risk it with this whole "eve loses focus and your carrier dies lol" bug.

Fennicus
Amarr
United Trade Coalition
Posted - 2008.09.30 21:01:00 - [20]
 

Edited by: Fennicus on 30/09/2008 21:02:13
This even happens on the login screen, so it seems to rule out some of the UI changes (listed in the patch notes) causing it. :/

Quote:
wine: Unhandled page fault on read access to 0x0000006c at address 0x10045e45 (thread 001a), starting debugger...

This is on a laptop with a GeForce Go 7400.

Lithia Tsanov
Posted - 2008.09.30 21:25:00 - [21]
 

Problem confirmed on Intrepid

Linux H2SO4 2.6.27-4-generic #1 SMP Wed Sep 24 01:29:06 UTC 2008 x86_64 GNU/Linux
wine-1.1.5

@As CCP Casqade stated here, we do not officially support EVE under Wine. As such I can't make any promises as to this particular problem being resolved, unless it presents itself under Cedega.

Please, we beg you to start. Wine provides a far superior customer experience.

Frank

Alaki Kant
Selective Pressure
Posted - 2008.09.30 22:31:00 - [22]
 

Running eve in a 2nd X server does work, so that's a decent workaround for now.

Ryas Nia
Minmatar
Veto.
Posted - 2008.09.30 23:00:00 - [23]
 

dont forget to vote for this bug on wineHQ lets hope they can get this fixed because i cant live with the CCP client, i require Premium Scythe/Scimitar models, windowed mode, and multiple clients!

http://bugs.winehq.org/show_bug.cgi?id=15485

Aurix Lexico
Slacker Industries
The Boat Violencing Initiative
Posted - 2008.09.30 23:17:00 - [24]
 

Edited by: Aurix Lexico on 30/09/2008 23:17:23
Second X server works, but it's going to be annoying having to setup teamspeak, then launching eve. And switching between X servers is not nearly as pretty as a rotating compiz cube.

Ugh.

AleRiperKilt
Posted - 2008.09.30 23:17:00 - [25]
 

running it in windowed mode seems to work. Full screen locked up but windowed through explorer has not crashed so far:

taskset 0x1 env WINEPREFIX="/home/spectro/.wine" wine explorer /desktop=,1550x1050 "C:\Program Files\CCP\EVE\eve.exe" /end /LUA:OFF

I am in Ubuntu 8.04, wine 1.1.5

Beseiged
Minmatar
Rim Collection RC
Kraftwerk.
Posted - 2008.10.01 00:47:00 - [26]
 

Same problem here. This patch officially sucks.

Tianhou
Posted - 2008.10.01 01:30:00 - [27]
 

Edited by: Tianhou on 01/10/2008 01:41:15
Edited by: Tianhou on 01/10/2008 01:35:32
N3o (Wine app Maintainer - Eve Premium) explain with details the fix to run 2 clients with Wine + ALT-TAB, Classic mode works too ^^ details at : http://bugs.winehq.org/show_bug.cgi?id=15485#c17

Debeus
Amarr
Princeps Corp
Atlas Alliance
Posted - 2008.10.01 02:12:00 - [28]
 


Keyn Thror
Minmatar
N.S.
Posted - 2008.10.01 03:47:00 - [29]
 

Edited by: Keyn Thror on 01/10/2008 04:08:30
Edited by: Keyn Thror on 01/10/2008 04:08:00
Some update on mentioned workaround:

You can create separate independent Wine Virtual Desktops to keep two EVE clients on different displays, for example:
Quote:

wine explorer /desktop=0,1024x768 "C:\Program Files\CCP\EVE\eve.exe"

wine explorer /desktop=1,1024x768 "C:\Program Files\CCP\EVE\eve.exe"


Of course, you can use any screen resolution you like, not only 1024x768.

UPD: I experience a minor drop in FPS when running two Virtual desktops like this, comparing to usual Wine-way client launch.

Probably not too good idea to go into some massive fight with two virtual desktops running.
Otherwise - it works fine, at least for me.

Fennicus
Amarr
United Trade Coalition
Posted - 2008.10.01 13:24:00 - [30]
 

This is almost a nice solution for people who just require the one client running, and who have Gnome toolbars and Wine window titles taking up screen real-estate.

I've found that one can solve the former problem through gconf-editor: navigate to apps/panel/toplevels, choose one of the named subcategories (e.g. "top_panel_screen0"). Tick "auto hide", change "auto_hide_size" to 1*, and you'll probably want to play with the show/hide delay times too since the default values seem to be optimised for old grannies.

*This leaves 1-pixel wide bars at the top & bottom of your screen. You typically can't hide these, and there's a 5-year old Gnome "bug" asking for the developers to totally hide it or make it transparent.

Now to get rid of the "Wine 1280x12024" screen title...


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only