open All Channels
seplocked Science and Industry
blankseplocked POS-Tracker 3.0.0 RC 5 [updated January, 12 2010]
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2 3 4 5 6 7 8 9 ... : last (25)

Author Topic

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.03 22:54:00 - [1]
 

Edited by: Johnathan Roark on 12/01/2010 00:47:32
Download:
Full Download:
POS-Tracker 3.0.0 RC 5
Patch from previous version:
POS-Tracker 3.0.0 RC 5 Patch

Installation/upgrade instructions are at Install Instructions

Features:
* POS Fuel Tracking with Uptime Calculations
* Outpost Fuel Tracking with Uptime Calculations
* AutoSov© Sovereignty tracking with automatic fuel usage updates (CRON)
* Absolute Location System
* Moon Mining and Reaction Tracking as well as Silo Tracking -Improved
* Fully templated - Theme based.
* Modular - You can extend the Manager by creating a module without touching the main code.
* Fuel Bill page
* Easier module additions
* Production page
* Black Rise
Requirements
* PHP 5.1.2
* PHP Hash Extension (installed by default on most php installs)
* PHP Curl Extention (installed by default on most php installs)
* MySQL 5

If you find any bugs, either post them in the issue thracker or in this thread. I would also like hear about any features, fixes, mods, templates, etc. Please contact me if you have any of those.

An FYI for everyone:
I made a google group for POS-Tracker Announcements. I will use it to send an alert about updates. Join at http://groups.google.com/group/announce-pos-tracker

Old Thread:
POS-Tracker 2.x Thread

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.03 22:58:00 - [2]
 

Installation Instructions are in the readme.txt file.

Ai Sakura
Caldari
Posted - 2008.08.03 23:31:00 - [3]
 

Edited by: Ai Sakura on 03/08/2008 23:40:10
Edited by: Ai Sakura on 03/08/2008 23:39:49
Bug report:

Sov still shows hostile even when logged in as my own corp/alliance (Level 4 admin)
Production page is empty.. (? Possible because I have no structures setup)

Adding A Silo results in that wont work - duplicate key message

ShadowMaster
Gallente
Posted - 2008.08.04 01:56:00 - [4]
 

How do you use the fitexporter.xml.php file? Will it work if I have my old POS-Tracker on a different database? It currently requires the use of the recent POS-Tracker, so i can not just drop it in with the old one and run it.

ShadowMaster
Gallente
Posted - 2008.08.04 02:03:00 - [5]
 

Ok, so I decided to just put my old database into the new tracker and see how it goes. It shows my pos and everything, and when I click view I see the button for export but is there a way to export all of my POS at once instead of one at a time? Also when i press the export button what do I do with the page it gives me?

ShadowMaster
Gallente
Posted - 2008.08.04 02:29:00 - [6]
 

Every time I try and add structures or import them I get this error;
"That doesnt work; Duplicate entry '28' for key 1"

The entry number has been going up every time I try.

Halada
Caldari
Lone Star Joint Venture
Posted - 2008.08.04 04:45:00 - [7]
 

Importing towers with API now works

Cannot add structure, I get same error as above poster

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.04 06:17:00 - [8]
 

Originally by: ShadowMaster
Every time I try and add structures or import them I get this error;
"That doesnt work; Duplicate entry '28' for key 1"

The entry number has been going up every time I try.


This is a bug with Adodb, I've updated the download with this fixed. I've also provided a fix in a little bug fix download.

Originally by: ShadowMaster
Ok, so I decided to just put my old database into the new tracker and see how it goes. It shows my pos and everything, and when I click view I see the button for export but is there a way to export all of my POS at once instead of one at a time? Also when i press the export button what do I do with the page it gives me?


It was planned, but never happened and I dont see it ever happening for 2.1.x. Maybe for 3+.
Originally by: ShadowMaster
How do you use the fitexporter.xml.php file? Will it work if I have my old POS-Tracker on a different database? It currently requires the use of the recent POS-Tracker, so i can not just drop it in with the old one and run it.

The version for 2.1.0 is in the bugfix patch as well. You should be able to just drop it into your old installation, view pos, and export the fitting. Save the xml it generates to you local computer. Then Click the import button on your new installation.

Originally by: Halada
Importing towers with API now works

Cannot add structure, I get same error as above poster


Thanks for confirming.

ShadowMaster
Gallente
Posted - 2008.08.04 06:26:00 - [9]
 

Thank you very much for the update. I shall go and try it out.

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.04 06:30:00 - [10]
 

Originally by: Ai Sakura
Edited by: Ai Sakura on 03/08/2008 23:40:10
Edited by: Ai Sakura on 03/08/2008 23:39:49
Bug report:

Sov still shows hostile even when logged in as my own corp/alliance (Level 4 admin)
Production page is empty.. (? Possible because I have no structures setup)

Adding A Silo results in that wont work - duplicate key message


For the Sov showing hostile, I need more information. Evemail me ingame and ill respond with how to get what I need.

The Production page shows what silos, reactors, and harvesters are producing. If you have none setup, they wont be producing anything

For the Adding structures bug, see above post for fix.

ShadowMaster
Gallente
Posted - 2008.08.04 06:41:00 - [11]
 

I have applied the bug fix and am still having the same issue when adding structures.

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.04 06:52:00 - [12]
 

Originally by: ShadowMaster
I have applied the bug fix and am still having the same issue when adding structures.


Did you put the replaced file in the correct directory? It should be in includes/adodb/drivers/

ShadowMaster
Gallente
Posted - 2008.08.04 06:56:00 - [13]
 

yes, and I am 100% sure because it asked me to overwrite.

ShadowMaster
Gallente
Posted - 2008.08.04 06:57:00 - [14]
 

I do not have to re-install the entire DB do I? This was just a patch to add to my current 3b2 instillation?

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.04 08:19:00 - [15]
 

Originally by: ShadowMaster
yes, and I am 100% sure because it asked me to overwrite.


That is odd, it fixed it on mine, I will look around some more tomorrow and see if anything else could be causing issues. If you want, you can try the older adodb in the beta 1 download.

Originally by: ShadowMaster
I do not have to re-install the entire DB do I? This was just a patch to add to my current 3b2 instillation?


No, you shouldn't have to re-install the database. Although if thats something you want to try, go for it. I'd suggest trying the adodb files from beta 1 first to see if that works for you.

ShadowMaster
Gallente
Posted - 2008.08.04 19:59:00 - [16]
 

I completly deleted my DB and my install. I re-uploaded the new POS tracker, the updated one with the bug fix. I then reinstalled the tracker and proceeded to add a tower. That was all fine until I tried to import structures. After uploading the file and such the gave me this error:
"Column count doesn't match value count at row 1INSERT INTO pos2_silo_info VALUES ('14','1','14343','0','0','0','0','0')"

When I went and looked at the tower, it had added a complex reactor and corp hanger array but nothing else. When I tried to add another structure it gave the same error as before:
"That doesnt work; Duplicate entry '19' for key 1"

DeTox MinRohim
Madhatters Inc.
The Initiative.
Posted - 2008.08.04 20:28:00 - [17]
 

Edited by: DeTox MinRohim on 04/08/2008 20:29:04
The "Duplicate entry..." thing is an old bug of adodb that was fixed in my test svn but it got wiped by updating to the latest adodb class.

John, see line 31 and 206 for the GenID fix here

Also for John, please contact me at eve [] onewayweb.com I don't have your email on this laptop but I have a few days of connection in front of me. The sound of the see is deafening though Smile

John Xei
Posted - 2008.08.04 22:15:00 - [18]
 

Tried to import a MyPOS setup but got this


/tmp/phpwDks1X
mypos
8

Array
(
[0] => SimpleXMLElement Object
(
[0] => 24658
)

[1] => SimpleXMLElement Object
(
[0] => 17184
)

[2] => SimpleXMLElement Object
(
[0] => 24660
)

[3] => SimpleXMLElement Object
(
[0] => 17621
)

[4] => SimpleXMLElement Object
(
[0] => 27576
)

[5] => SimpleXMLElement Object
(
[0] => 27576
)

[6] => SimpleXMLElement Object
(
[0] => 27576
)

[7] => SimpleXMLElement Object
(
[0] => 27579
)

[8] => SimpleXMLElement Object
(
[0] => 27579
)

[9] => SimpleXMLElement Object
(
[0] => 27582
)

[10] => SimpleXMLElement Object
(
[0] => 27582
)

[11] => SimpleXMLElement Object
(
[0] => 27582
)

[12] => SimpleXMLElement Object
(
[0] => 27585
)

[13] => SimpleXMLElement Object
(
[0] => 27585
)

[14] => SimpleXMLElement Object
(
[0] => 27585
)

[15] => SimpleXMLElement Object
(
[0] => 24659
)

[16] => SimpleXMLElement Object
(
[0] => 13780
)

[17] => SimpleXMLElement Object
(
[0] => 13780
)

[18] => SimpleXMLElement Object
(
[0] => 13780
)

[19] => SimpleXMLElement Object
(
[0] => 13780
)

[20] => SimpleXMLElement Object
(
[0] => 13780
)

[21] => SimpleXMLElement Object
(
[0] => 17185
)

[22] => SimpleXMLElement Object
(
[0] => 24656
)

[23] => SimpleXMLElement Object
(
[0] => 24656
)

[24] => SimpleXMLElement Object
(
[0] => 24654
)

[25] => SimpleXMLElement Object
(
[0] => 24654
)

[26] => SimpleXMLElement Object
(
[0] => 17187
)

[27] => SimpleXMLElement Object
(
[0] => 12237
)

)


Any idea?

Halada
Caldari
Lone Star Joint Venture
Posted - 2008.08.04 22:19:00 - [19]
 

I applied the bugfix but still no joy...

cannot add structures!

ShadowMaster
Gallente
Posted - 2008.08.04 22:28:00 - [20]
 

I think John is at work or at least away. He has been very responsive so far in this thread, so just give him a bit to fix the bug. By the sounds of it there was just a slight communication error between him and one of the other developers. Should be fixed soon, both are aware of the issue.

DeTox MinRohim
Madhatters Inc.
The Initiative.
Posted - 2008.08.05 01:59:00 - [21]
 

Edited by: DeTox MinRohim on 05/08/2008 02:03:12
Like I said, the fix for the "duplicate thing" is here

You can probably grab the file and replace the one in your includes/adodb/drivers folder without any other fuss, the original file you had is more recent since John updated adodb. But the new version lacks that fix.

Line 31 and 206 of that file are the ones to change/add if you don't want to replace the file completly.

Although being on vacation, I have a good connection for a few days so I'll keep an eye on my part of what I wrote. Can't help yet on the MyPOS thing yet as John added that after I was done and didn't have the time to look at all this.

EDIT: John did the second part of the fix in his SVN, his fix doesn't work because the first part is not there yet. Stay tuned Wink

ShadowMaster
Gallente
Posted - 2008.08.05 05:55:00 - [22]
 

I edited both of the lines you suggested. Copied from the document you linked and edited into the appropriate file, works perfectly now. Thank you very much.

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.05 07:11:00 - [23]
 

Originally by: John Xei
Tried to import a MyPOS setup but got this


Any idea?


Thats normal, if you have the fix for the genID() applied, it should import your structures. I'll make it look better, but MyPOS just stores the itemIDs and not the names so I have to do a look up on each one to make it look the same way the POS-Tracker fitting import, which currently gives you some output thats really for testing.

Originally by: DeTox MinRohim
Edited by: DeTox MinRohim on 04/08/2008 20:29:04
The "Duplicate entry..." thing is an old bug of adodb that was fixed in my test svn but it got wiped by updating to the latest adodb class.

John, see line 31 and 206 for the GenID fix here

Also for John, please contact me at eve [] onewayweb.com I don't have your email on this laptop but I have a few days of connection in front of me. The sound of the see is deafening though Smile


Ah, thats why, I didn't check the first part to see if that was causing issues. I'll send you an email.

Originally by: ShadowMaster
I edited both of the lines you suggested. Copied from the document you linked and edited into the appropriate file, works perfectly now. Thank you very much.


Uploading fixed downloads, should be available soon. I am planning on switching most of the images from png to gif to cut down on size. Thanks to Sylithr for switching them.

XFranc
Caldari
Interstellar eXodus
BricK sQuAD.
Posted - 2008.08.06 09:33:00 - [24]
 

One thing I noticed the other night, was that the fuel calculations fail to take into consideration starbase charters when the pos is in empire space. Is this something that can be added ?

Thanks,

Sly Chick
Shining Horses
Posted - 2008.08.07 10:24:00 - [25]
 

Edited by: Sly Chick on 07/08/2008 10:30:56
I've tested the tracker locally on my pc and it seems to run fine. I've now uploaded it to my hosting isp and I now get the following error when trying to run install.php :

Fatal error: Smarty error: unable to write to $compile_dir '/zzzzzzzz/zzzzzzzz/public_html/postracker/cache/templates_c'. Be sure $compile_dir is writable by the web server user. in /zzzzzzzz/zzzzzzzz/public_html/postracker/includes/Smarty/Smarty.class.php on line 1088

Any suggestions on where to look for the problem is welcome.

Thanks
Sly Chick

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2008.08.07 17:35:00 - [26]
 

Originally by: Sly Chick
Edited by: Sly Chick on 07/08/2008 10:30:56
I've tested the tracker locally on my pc and it seems to run fine. I've now uploaded it to my hosting isp and I now get the following error when trying to run install.php :

Fatal error: Smarty error: unable to write to $compile_dir '/zzzzzzzz/zzzzzzzz/public_html/postracker/cache/templates_c'. Be sure $compile_dir is writable by the web server user. in /zzzzzzzz/zzzzzzzz/public_html/postracker/includes/Smarty/Smarty.class.php on line 1088

Any suggestions on where to look for the problem is welcome.

Thanks
Sly Chick


As it says, check to make sure /zzzzzzzz/zzzzzzzz/public_html/postracker/cache/templates_c is writable by the web server. CHMOD 775 should work.

Sly Chick
Shining Horses
Posted - 2008.08.08 11:23:00 - [27]
 

Originally by: Johnathan Roark
Originally by: Sly Chick
Edited by: Sly Chick on 07/08/2008 10:30:56
I've tested the tracker locally on my pc and it seems to run fine. I've now uploaded it to my hosting isp and I now get the following error when trying to run install.php :

Fatal error: Smarty error: unable to write to $compile_dir '/zzzzzzzz/zzzzzzzz/public_html/postracker/cache/templates_c'. Be sure $compile_dir is writable by the web server user. in /zzzzzzzz/zzzzzzzz/public_html/postracker/includes/Smarty/Smarty.class.php on line 1088

Any suggestions on where to look for the problem is welcome.

Thanks
Sly Chick


As it says, check to make sure /zzzzzzzz/zzzzzzzz/public_html/postracker/cache/templates_c is writable by the web server. CHMOD 775 should work.


Yes, that did the trick, I'm a noob when it comes to linux hosting Embarassed. I have now got it installed up and running. I can add a tower, fittings, etc with no problems. I have run into a problem now on the admin page. When clicking on the 'Update Now' buttons for alliance, sovereignty or Pos and also the add API key, the page eventually times out and gives the error 'Error: String could not be parsed as XML' .

Yorick Downe
Caldari
Agony Unleashed
Agony Empire
Posted - 2008.08.08 11:35:00 - [28]
 

Sly,

Which version of PHP? The installer claims the code needs PHP 5.1.3 or greater, but I think that's actually incorrect - if memory serves, POS Tracker uses xpath, which means it needs PHP 5.2.1 (possibly 5.2.0) or greater.

Sly Chick
Shining Horses
Posted - 2008.08.08 12:03:00 - [29]
 

Originally by: Yorick Downe
Sly,

Which version of PHP? The installer claims the code needs PHP 5.1.3 or greater, but I think that's actually incorrect - if memory serves, POS Tracker uses xpath, which means it needs PHP 5.2.1 (possibly 5.2.0) or greater.



according to my phpinfo, I'm running 5.2.5 , the details can be found here phpinfo

Yorick Downe
Caldari
Agony Unleashed
Agony Empire
Posted - 2008.08.08 13:22:00 - [30]
 

Here's a couple bugs / feature requests that came up while installing a fresh copy of 3.0beta2b.

Possible bugs:

1) The duplicate ID bug is still present in 3.0beta2b. Fixing it like indicated in this thread worked
2) Tower import from API does not add structures, even once 1) is resolved. Is that a bug or a missing feature?
3) Spelling error on "about" page. "Managment Website. Combattible" should be "Management Website. Compatible"

Request For Enhancement:

1) No indication in IGB that "View" etc. buttons aren't functional - this confused some of our users. Display some language to the effect of "you need to use an out-of-game browser to get full functionality"
2) Documentation - if I missed it, please point me towards it. I'm puzzling over basic things like "What do the permission levels do, exactly? What does "highly trusted" mean? What is the Absolute Location System? What cron features exist - auto-api updates? What does the Moon Database do for me?"
3) Default the DB prefix to pos3_ instead of pos2_ ? Minor detail, to be sure.
4) Back buttons in some of the screens, like the View and Edit screens, would be nice. Moving the structure buttons up instead of having them at the bottom of the screen would be nice. Workflow improvement, really.

Take all this as constructive feedback, please. I am aware I could contribute code, but I'm busy with other projects. I'm tickled pink to have this tool - so take this list not as criticism, but my way of giving back.


Pages: [1] 2 3 4 5 6 7 8 9 ... : last (25)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only