open All Channels
seplocked Test Server Feedback
blankseplocked Ingame Web Browser Bug Thread
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 11 12 13 14 [15] 16 17 18 19 ... : last (25)

Author Topic

TornSoul
BIG
Gentlemen's Agreement
Posted - 2006.01.25 01:08:00 - [421]
 

Originally by: Knossos
Something else thats been bugging me.

When using PHP Header redirect, the browser keeps the same URL in the address bar, but it still redirects to the other page.

This is a problem, because PHP thinks that the webpage is in one place, when the browser thinks its somewhere else. This makes relational URLs mis-function.


I've been bugging that particular one for over 2 years... (Been quite a while since last time though - aka. I've given up that it will ever get fixed)


And yes it does indeed raise all kinds of hell for a web-developer...

And makes for sites needing more clicking from the users, as you cant rely on the redirect feature.
One of the most basic things of making sits user-friendly... (aka. less clicking etc)

Can you sense I'm utterly frustrated with the lack of will to fix this one?


Ray McCormack
Nordar Innovations.
Posted - 2006.01.25 11:08:00 - [422]
 

Originally by: NewDisease
Warp drive active = No missile damage what so ever.

What's the cure?

Fredrik Gnaust
Posted - 2006.01.25 12:25:00 - [423]
 

Edited by: Fredrik Gnaust on 25/01/2006 15:16:55
damn.. i feel like a fool.. how can i use the corprole value in ASP to figure out what roles a user has?


Originally by: Traveler
Actually, i don't know the exact meaning of each of the newer bits. The IGB only forwards the value to the webserver.
The only list i have looks like this:
'corpRoleDirector',1L
'corpRolePersonnelManager',128L
'corpRoleAccountant',256L
'corpRoleSecurityOfficer',512L
'corpRoleFactoryManager',1024L
[...]



EDIT: Found a solution.. but i cant find a variable that is large enough.. when using the mod method..

EDIT: Worked around MOD and used x-( fix( x / 2 ) * 2 ) in stead. Will post function here when i have cleaned it.

EDIT: This function will return an array filled with 0's and 1's. Each field defining, in this case, the corp roles. Feel free to send me an IGM if you have any questions.

<%
'x = Doublevalue
'size = The bit array size

Private Function dbl2bin(x, size)

Dim binArr()
dim y

redim binArr(size)

y = 0

Do
If x-( fix( x / 2 ) * 2 ) Then
binArr(y) = "1"
Else
binArr(y) = "0"
End If

x = fix(x / 2)

y = y +1
If x < 1 Then Exit Do
Loop

for y=y to size
binArr(y) = "0"
next

dbl2bin = binArr

End Function
%>

Knossos
Gallente
GrueTech
Posted - 2006.01.25 18:26:00 - [424]
 

Originally by: TornSoul
I've been bugging that particular one for over 2 years... (Been quite a while since last time though - aka. I've given up that it will ever get fixed)


Ahhh, I'm getting around it by using a static URL instead of relational urls. Which is a shame, because it is now completely non-portable.

Examples:

$baseURL = "http://".$_SERVER['HTTP_HOST']."/cwra/igb/";

<a href="<?PHP echo $baseURL; ?>index.php?p=index">Main</a>

As long as the website is in that set of sub-directories.

TornSoul
BIG
Gentlemen's Agreement
Posted - 2006.01.25 22:34:00 - [425]
 

Hmm - intersting.
Never thought of that as a 'work-around'.
And dont quite get why it should help either. (I'll have to do some testing)

For portability - Well, you've already kinda showed the workaround for that.

Simply have an include file for all pages, with the base (URL) constant in it.
Only need to change it one place then (if/when you port to a diff server)


It still remains... Why this thing hasnt ever been fixed...


elFarto
Deep Core Mining Inc.
Posted - 2006.02.05 18:52:00 - [426]
 

Edited by: elFarto on 05/02/2006 18:52:47
Originally by: TornSoul
Originally by: Knossos
Something else thats been bugging me.

When using PHP Header redirect, the browser keeps the same URL in the address bar, but it still redirects to the other page.

This is a problem, because PHP thinks that the webpage is in one place, when the browser thinks its somewhere else. This makes relational URLs mis-function.


I've been bugging that particular one for over 2 years... (Been quite a while since last time though - aka. I've given up that it will ever get fixed)


Wow, that's taking me back. I assume your talking about sending a "Location" field back in the header? IIRC I was the one who raised it to get changed to what it is. Also, IIRC, this is exactly how normal web browsers work (hence why I wanted it changed).

It was causing me problems with submitting data to pages, then having the user press back and it would resubmit the page.

To work around it, use absolute paths, relative paths are a pain in the arse.

Regards
elFarto

Cybu
Caldari
Big Guns Inc.
Atlas Alliance
Posted - 2006.02.05 18:57:00 - [427]
 

Originally by: elFarto
Edited by: elFarto on 05/02/2006 18:52:47
Originally by: TornSoul
Originally by: Knossos
Something else thats been bugging me.

When using PHP Header redirect, the browser keeps the same URL in the address bar, but it still redirects to the other page.

This is a problem, because PHP thinks that the webpage is in one place, when the browser thinks its somewhere else. This makes relational URLs mis-function.


I've been bugging that particular one for over 2 years... (Been quite a while since last time though - aka. I've given up that it will ever get fixed)


Wow, that's taking me back. I assume your talking about sending a "Location" field back in the header? IIRC I was the one who raised it to get changed to what it is. Also, IIRC, this is exactly how normal web browsers work (hence why I wanted it changed).

It was causing me problems with submitting data to pages, then having the user press back and it would resubmit the page.

To work around it, use absolute paths, relative paths are a pain in the arse.

Regards
elFarto


I can only speak for Firefox, but that's not how it works. And I don't think for IE either. However, FF gives a warning that you are resubmitting data and the option to cancel.

Sirilonwe
Caldari
Posted - 2006.02.06 13:51:00 - [428]
 

Traveler, I think you should really look at the beta of the game "Dungeon & dragons online". I didn't know how they did this, but they had integrated a fully fonctionning internet explorer within their game (found in the help). All is working. Javascript, Flash.

This is quite impressive, may I say. I don't know if you can take a look at it (I can fraps some demo to you if you want), but it could help you, maybe, with your ingame browser (cleaning the code, making only one call to IE, for example).

Kijana
Posted - 2006.02.06 14:02:00 - [429]
 

Hey all. I've just started playing with the IGB so this won't be anything new to you guys, however I thought I would save some other coder types out there some trouble in case they run into the same misinterpretation I did. :)

When constructing the 'eve.trustme' header, the code examples are a bit misleading in that newer versions of PHP as well as perl modules like CGI.pm will automatically assume that if you pass something with the 'header' object you are trying to set Content-type, and not make a new header with a new name. So, I'll print here GRAPHICALLY EXACTLY what the header should look like, and a simple print statement that creates it in perl:

eve.trustme: http://my.web.site/::Please allow me trusted access

eve.trustme is the header NAME, not the content, which is not terribly clear from the code since I haven't coded in php much, nor have I played with HTML::Mason :-)

print "eve.trustme: http://www.ennui.net/::Please allow me trusted access.\n\n";

...creates the correct header you need for the IGB to initiate trust negotiation.


Traveler

Posted - 2006.02.07 09:51:00 - [430]
 

The EVE IGB was not implementat to act as a full web browser. It provides ingame functionality to player webpages. It is simply not possible to use these functionality in 3rd party products. It would already be very hard if not impossible to implement the IE or Mozilla rendering engine into the EVE rendering engine. It works in a completely different way.
I will continue to fix bugs in the IGB and implement more useful features. But you will for sure never see Flash support in the IGB.

Raaki
The Arrow Project
Morsus Mihi
Posted - 2006.02.07 23:17:00 - [431]
 

Hi,

Is it possible to send out eve-mails automaticaly to a Character. Without using a link <a></a>

I would like my script to automaticaly send out an eve-mail to people who have registered on my site.




Traveler

Posted - 2006.02.08 07:56:00 - [432]
 

Automatic eve mail sending is currently not possible. This function could also be abused for spaming. I will set it one on my feature request list.

Raaki
The Arrow Project
Morsus Mihi
Posted - 2006.02.08 15:07:00 - [433]
 


Spamming could be a problem yes. Hmm.
Think you can already kinda spam with the current functionality. You can just pull big list of charnames from a DB and create a link like
<A HREF=”evemailto:charname1,charname2,...,charname100
and then spam with just a few clicks. Or is this limited someway.

Anyway, I hope it will be possible to get a reasonably abuse-free automail feature in.

Tnx for your response traveler.




Raze R
Posted - 2006.02.09 00:28:00 - [434]
 

Edited by: Raze R on 09/02/2006 01:02:14
Just a quickie....

The sessionchange event. While I can see code on how to perform this within PHP with the Header() function, I'm wondering if I can do the same with a HTTP-Equiv, tested the following but no joy... (I suspect, not suprisingly)

<meta http-equiv="refresh" content="sessionchange;URL=MyTestURLand.asp">

Any help would be great.

Many Thanks,

Raze

Edit> Err... soz I know this is a bug thread.. Embarassed can't delete it now so... uhmm... any ideas?

Sirilonwe
Caldari
Posted - 2006.02.09 10:43:00 - [435]
 

Traveler, after some tests on DDO, I finally found that they were overlaying IE over the game. It means that every element from the game was behind the IE window. Bad thing, I prefer largely the IGB :).

Luarvique Luarvique
Caldari Provisions
Posted - 2006.02.10 00:35:00 - [436]
 

I currently have a very simple page with a form on it, which refuses to submit :( I can mouseover the submit button, it highlights and I can press it, but it never submits; here's the document source as copied from IGB (note I have even disabled CSS to make sure it doesn't interfere with something); all < and > have been replaced with [ and ]:


[html]
[head]
[title]Killboard Login[/title]
<!-- [link rel="stylesheet" href="style/igb.css"] -->
[/head]

[body]

[table width="250"]
[tr]
[td width="70"]
[img src="portrait:xxxxxx"]
[/td]
[td width="180" valign="middle"]
Test Character
Hedion University [/td]
[/tr]
[/table]

[form name="login" method="post" action="/kb/index.php"]
[table]
[tr]
[td]Password:[/td]
[td][input type="password" name="password"][/td]
[/tr]
[tr]
[td][/td]
[td][input type="submit" name="submit" value="Submit"][/td]
[/tr]
[tr]
[td colspan="2"]Forgot your password?
Contact the
killboard admin to have it reset[/td]
[/tr]
[/table]
[/form]

[/body]
[/html]

Guy Gallente
Posted - 2006.02.10 03:02:00 - [437]
 

Is it possible, once a site is trusted and the charid retrieved, to access character sheet-type information (attributes, skills, standings, etc.) the way character images can be fetched and displayed? The XML is there for download on myeve.eve-online and I know that ECM can get this data, so I wonder if it's available for capture via IGB?

Thanks!

Traveler

Posted - 2006.02.10 08:40:00 - [438]
 

I have recently fixed forms in tables. Please test on Sisi if this is still happening there.

There is currently no way to fetch the complete char info using trusted page headers. However, you can still display the character portrait by using the charID in and <img src="portrait:charID" size="64"> tag.

xena zena
The Money Shot Inc.
Posted - 2006.02.10 18:16:00 - [439]
 

Edited by: xena zena on 10/02/2006 18:16:29
I can't for the life of me get the CORPROLE to work. The headers for me has the value "13194142703616" which is absoutely not correct... I'm useing the following php code to test each:

if ($_SERVER["HTTP_EVE_CORPROLE"] & 1) {
$out .= "corpRoleDirector = true<br>";
}
if ($_SERVER["HTTP_EVE_CORPROLE"] & 128) {
$out .= "corpRolePersonnelManager = true<br>";
}
if ($_SERVER["HTTP_EVE_CORPROLE"] & 256) {
$out .= "corpRoleAccountant = true<br>";
}
...

is this wrong for testing these bitmasks? I'm at a loss. Is it broken?

The website I have it testing on is: http://fun.blkadder.com/

Gunther Hoosler
Caldari Provisions
Posted - 2006.02.10 23:40:00 - [440]
 

Edited by: Gunther Hoosler on 10/02/2006 23:43:21
Originally by: Raze R
Edited by: Raze R on 09/02/2006 01:02:14
Just a quickie....

The sessionchange event. While I can see code on how to perform this within PHP with the Header() function, I'm wondering if I can do the same with a HTTP-Equiv, tested the following but no joy... (I suspect, not suprisingly)

<meta http-equiv="refresh" content="sessionchange;URL=MyTestURLand.asp">

Any help would be great.

Many Thanks,

Raze

Edit> Err... soz I know this is a bug thread.. Embarassed can't delete it now so... uhmm... any ideas?


I use this to get the trust.me header into my aspx pages

Response.AddHeader("eve.trustme","http://vckillboard.servebeer.com/::VC KillBoard")

so try

Response.AddHeader("refresh","sessionchange;URL=MyTestURLand.asp")
or maybe
Response.AddHeader("refresh","sessionchange::URL=MyTestURLand.asp")

Raze R
Posted - 2006.02.11 15:50:00 - [441]
 

Thanks Gunther, I'll go play...

Raze

Luarvique Luarvique
Caldari Provisions
Posted - 2006.02.11 20:15:00 - [442]
 

Originally by: Traveler
I have recently fixed forms in tables. Please test on Sisi if this is still happening there.



I just tested, and it works correctly on SiSi. Great stuff, thanks a lot! Any idea when this particular fix might propagate to Tranquility?

Strikeman
Gallente
Inter Corp Ops
Posted - 2006.02.12 01:07:00 - [443]
 

omg Traveler is back in the topic ?! Shocked

i just want to raise one major issue again here, which i started reporting since RMR was released; the carriage return character (\n etc) still doesn't get recognized in mails composed in a <a href=evemail(to)> link.

this has been a major setback for any corporation who uses an IGB site to send mails to 3rd parties.

In our particular case, we require more then 100 mails to be sent on a daily basis. The implementation of the IGB site literally saved us several hours per day. since this bug rose, we feel like we've been set back about a year.

the bug has existed for 3 months now, i've bugreported it, i believe it was marked as fixed but i know it still is not, i tested it yesterday for the last time.

please traveler, pleaaaase ? Crying or Very sad

Ray McCormack
Nordar Innovations.
Posted - 2006.02.12 05:00:00 - [444]
 

Originally by: Strikeman
i just want to raise one major issue again here, which i started reporting since RMR was released; the carriage return character (\n etc) still doesn't get recognized in mails composed in a <a href=evemail(to)> link.


Traveler posted it was fixed back here on January 15. There's not been a new patch on TQ yet, so it would only show as fixed on SiSi (not checked this myself). All the fixes should hit TQ when Blood comes.

Takigama
Black Eclipse Corp
Band of Brothers
Posted - 2006.02.13 09:58:00 - [445]
 

Hi all,

im getting an odd problem that im having a truckload of difficulty trying to solve. For some reason im randomally getting "domain innaccessible" errors... at first i thought it was connection resets/connection refused, but its not that, then dns failures, but not that either. What exactly is the "domain inaccessible" error meant to mean? its got me quite confused...

Takigama
Black Eclipse Corp
Band of Brothers
Posted - 2006.02.13 10:20:00 - [446]
 

Edited by: Takigama on 13/02/2006 10:49:22
I just figured this error out... unfortunate the igb is not always sending a host header along with the request...

Which is kinda painfull..

Edit:
Actually, after doing a bit of packet dumping it appears the request is being malformed now and then. occasionaly the request comes thru as unicode, sometimes plain old ascii..

From what i can tell tho, occasionally, the request (GET/POST/etc) comes thru as unicode, then the host header comes thru as ascii, which is whats causing the real issue (i think)

Traveler

Posted - 2006.02.13 12:06:00 - [447]
 

Thx for the report Takigama. I will look into the problem.

Takigama
Black Eclipse Corp
Band of Brothers
Posted - 2006.02.13 16:46:00 - [448]
 

Edited by: Takigama on 13/02/2006 17:45:29
Originally by: Traveler
Thx for the report Takigama. I will look into the problem.



I do actually have an ethereal packet dump of it doing this if its of any use to you?

Edit:
Ok, after some "messing around" i finally understand why and whats actually happening. the currect "test" (sisi) code breaks everytime with this. But, basically when a Location: header is thrown out with a relative path, the igb send the following request completely in unicode.

I thought i had actually pulled out all the relative redirects from my code cause of a post earlier about something along these lines. But, the reason its happening rather randomally is due to me using php session id's passing thru the url request header (cause of no-cookies) and the code eventually calls itself with a blank variable due to a session revalidation problem...

anyways, my mistake. But, i assume this is a bug, so i will bug report it.

Regards, Taki

Takigama
Black Eclipse Corp
Band of Brothers
Posted - 2006.02.14 13:42:00 - [449]
 

Anothing thing worth noting as well, if a url comes thru as http://host.com//dir/file.html, it sets the host header to "dir":)

Nlle Kaani
Posted - 2006.02.18 10:56:00 - [450]
 

Originally by: Traveler

EVE supports chinese text in the IGB. Unfortunately, it is not possible to change the default charset yet. You can always use &#xxxx; style characters. I will add a charset parsing in Kali.



What about Cyrillic characters? I've tried utf8,utf16,utf32,cp1251,koi8-r,cp866 and nothing seems to work. Cyrillic can't be displayed at all or there is some trick?


Pages: first : previous : ... 11 12 13 14 [15] 16 17 18 19 ... : last (25)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only