open All Channels
seplocked Linux
blankseplocked Ubuntu 7.10: Splash and black screen afterwards fix....
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Beowolf Sagan
Caldari
Lucian Alliance
Arcane Alliance
Posted - 2007.12.26 20:03:00 - [1]
 

If you tried the OSS fix and it still hangs then try this. AFAIK this is only due to KDE, haven't tried it with Gnome but it might be similar.

KDE takes exclusive control of the sound system to play its system sounds. There is a feature to suspend the sound system after a few seconds of the KDE subsystems playback. If you set the amount of time to 2 seconds or less my game finally loaded :).

To change the settings in KDE click the following:
KDE Menu button -> Settings -> Sound & Multimedia -> Sound System

On the very bottom of the screen that pops up is the delay slider. Change it to 2 seconds or so and the game should work fine after that.

I don't know if this is true for the Gnome Desktop Manager. Im not sure how its sound subsystem works. But when i get a chance, ill install gnome on my box and test it.

Greg.

NightKhaos
Gallente
Relative Quantum Limited
Posted - 2007.12.26 20:58:00 - [2]
 

Edited by: NightKhaos on 26/12/2007 20:58:12
Gnome does not have an aRts evq. And tbh, I believe it would be more beneficial for your to artswrap EVE.

Ideally speaking, I would recommend the complete removal of aRts, but I do not believe that is possible under Ubuntu just yet.

Ereman Sarat
Posted - 2007.12.27 10:54:00 - [3]
 

My first caveat. I don't use Kubuntu, I use Ubuntu.. err, you get the idea.

My second caveat. I've been going at it a few weeks, but I'm still a neophyte where it comes to linux. the following is true, as much as I have observed it, but it's based on limited experience.

For better or worse, it appears that ALSA is becoming the sound standard for linux, or at least replacing OSS, for all intents and purposes. At least from what I'm seeing. Heck, OSS on Ubuntu these days itself is, if I understand it correctly, really just ALSA, in a wrapper to make it look/operate like OSS. The problem is, OSS doesn't like to share sound resources.

In any case, with the cedega options for eve, you can flip it to use alsa, and replace 'hw' in the fields, with 'default', and it should work at that point, unless there's a real issue somewhere else. Sevarus James sticky up above about optimizing contains more stuff you can do, in addition to that.

The good thing is, running it through ALSA like that, will make it behave nicely with your other sound apps... aka, sharing the resources properly.

I used to have to make sure no other apps were using sound resources before I could fire up EVE, amongst other irritations, til I read the nice sticky on how to optimize things. Since then, everything has been tons better.

ES

Oh yeah, for Ubuntu at least, one thing I did was to go to the sound preferences, and change everything to use ALSA as the default where possible, instead of 'auto'. Between that, and the changes to the cedega options, my sound issues are long gone.

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.27 12:21:00 - [4]
 

The only issue I'm seeing with 'alsa' vs. oss is that if you use eve-voice (and I do)...alsa as the choice will allow you to listen....but the mic is s.o.l. (on some systems, one of which, is mine.) Using eve +oss resolves the mic issue and I'm able to listen and talk via the in game client. external comms using alsa-oss wrapper still work regardless.

Another poster indicated the exact opposite was true on his system, where alsa worked fine and oss didn't.

Of course, talking about sound, this is the area of greatest pain and angst occurs in linux. Its a mess to be honest from distro to distro and sometimes just one distro but differrent sound cards causes much weeping and lamentation.
Shrugs. Anyway, good info. Very Happy


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only