open All Channels
seplocked Linux
blankseplocked Russian encoding in Eve under Archlinux
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Mepharius Khan
Posted - 2007.12.06 09:05:00 - [1]
 

Hi, all!

Recently i moved to Archlinux from Kubuntu. In Kubuntu everything worked after following steps:
1) Adding 2 strings to /var/lib/locales/supported.d/local :
ru_RU.KOI8-R koi8-r
ru_RU.CP1251 microsoft-cp1251
2) Running sudo dpkg-reconfigure --force locales
3) Running Eve with "LC_ALL=ru_RU.KOI8-R LANG=ru_RU.UTF-8 LANGUAGE=ru_RU:ru '/usr/bin/cedega'" (now it would be not '/usr/bin/cedega' but 'eve')

In Archlinux (+KDEmod) I have
ru_RU.KOI8-R KOI8-R
ru_RU.UTF-8 UTF-8
ru_RU CP1251
in /etc/locales.gen, run locale-gen, start Eve with "LC_ALL=ru_RU.KOI8-R LANG=ru_RU.UTF-8 LANGUAGE=ru_RU:ru eve" - and get rectangles instead of cyrillic symbols when entering text or viewing cyrillic text typed by others. The same happens after running Eve with
"LC_ALL=ru_RU.KOI8-R LANG=ru_RU.UTF-8 eve" (suppose that LANGUAGE is purely Ubuntu feature).
Omitting LC_ALL prevents me from typing cyrillic text, also I tried combinations
"LC_ALL=ru_RU.KOI8-R LANG=ru_RU.CP1251 eve"
"LC_ALL=ru_RU.CP1251 LANG=ru_RU.UTF-8 eve", none of them helps.

Can anybody advice me something?


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only