open All Channels
seplocked Linux
blankseplocked Random Crashing
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 2 [3] 4

Author Topic

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.12 12:06:00 - [61]
 

As this is the 'random crash' thread, I thought I'd point out that there is a decent sized thread in the windows section with the same issues that we (mac/linux users) are seeing. Is it possible that it might NOT be TG, and rather the CCP side that has a bug problem to fix?

--I remember not so long ago when we were here in the tech section SCREAMING about cedega being all messed up after a patch only to find out it was the game code that was borked and it took playing via cedega for it to show up fully.

Before folks jump off the deep end when things go wrong, please keep in mind that its not always one thing causing the other.

(not that anyone IS jumping off the deep end, but there have been some really hot comments about TG in here, and well, until we're patched, we don't know for sure its specifically TG or something else causing the issues.)

Lastly, before pointing at wine git+ elf patch + this that and the other thing, keep in mind that there is no sound/eve voice and such when its running and its dealing with the windows premium client rather than the wrapped client. (apples vs. oranges.)

UberL0rd
Minmatar
Comply Or Die
G00DFELLAS
Posted - 2007.12.12 12:10:00 - [62]
 

Originally by: Sevarus James
Lastly, before pointing at wine git+ elf patch + this that and the other thing, keep in mind that there is no sound/eve voice and such when its running and its dealing with the windows premium client rather than the wrapped client. (apples vs. oranges.)



I have sound fully working with wine git + elf patch + ani cursor patchset for classic and premium clints. I don't use EVE voice though.

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.12 12:18:00 - [63]
 

Originally by: UberL0rd
Originally by: Sevarus James
Lastly, before pointing at wine git+ elf patch + this that and the other thing, keep in mind that there is no sound/eve voice and such when its running and its dealing with the windows premium client rather than the wrapped client. (apples vs. oranges.)



I have sound fully working with wine git + elf patch + ani cursor patchset for classic and premium clints. I don't use EVE voice though.


Is this the WRAPPED client, or the windows downloaded client? As I said different fruits/animals/veggies/ pick yer metaphor.

The wine client isn't officially supported, and as such no bug report or official support would be forthcoming. I'm referring here to the WRAPPED CCP official linux/mac client which is being supported by both CCP and Transgaming.

UberL0rd
Minmatar
Comply Or Die
G00DFELLAS
Posted - 2007.12.12 13:15:00 - [64]
 

Sorry, I should have been more specific. Sound also works fine with the cedega wrapped client. All 3 crash randomly though - wine classic/premium requiring a three finger salute to restart X whereas the cedega client just does a CTD.

Niron Werls
Ceptacemia
-Mostly Harmless-
Posted - 2007.12.12 14:02:00 - [65]
 

Originally by: CCP Lingorm
We are going to set up a group for linux and Mac testing, we are just working out the details on how to do it effectively.

Will be a dedicated section of the Bug Hunters most likely.



Now that is excellent news. I am sure the Linux client is going to have its share of fairly unique issues, especially after content updates of any type, but we are used to it, and there are a fair number of talented players that can dig into problems pretty good available.


Postlatta Mouseanon
Caldari
State War Academy
Posted - 2007.12.12 16:24:00 - [66]
 

Originally by: Sevarus James
As this is the 'random crash' thread, I thought I'd point out that there is a decent sized thread in the windows section with the same issues that we (mac/linux users) are seeing. Is it possible that it might NOT be TG, and rather the CCP side that has a bug problem to fix?



Just as an aside, the "random crash" bug under Windows was solved by updated ATI drivers on my ATI machine (radeon x550). My nVidia machine (2*7600gt oc) hasn't had the problem under Windows.

The Linux machine (Ubuntu), is an Athlon 64 3200 with an nVidia 5950 Ultra. The "crashiness" of this system is profound when running EVE. However, it is known good hardware and the EVE client is running under a fresh install.

I don't know who this helps... but I felt like typing.

Mamede
Posted - 2007.12.12 18:14:00 - [67]
 

Edited by: Mamede on 12/12/2007 18:22:30
The no sound was not the thing.Just had a crash. But it seems more stable

Snowcrash Winterheart2
Gallente
Concordia Discors
Posted - 2007.12.12 19:06:00 - [68]
 

Edited by: Snowcrash Winterheart2 on 12/12/2007 19:21:49
Edited by: Snowcrash Winterheart2 on 12/12/2007 19:06:27
Seems highly unstable regardless of sound, windowed or fullscreen settings. So far it seems nothing is causing the crashes they just happen... as I've had it crash and burn just as the login screen opened.

Interestingly enough, double clicking (or selecting and pressing return) on the icon can spawn multiple clients... the current record is three all with attendant black screen's in windows behind them. This random spawning might or might not be related to a) me being a `tard and b) the crashing.

ETA: I am talking about the Cegeda client and not wine here :)

Edit2: Look, this is getting silly. I know it's just a game, but it's a game I'm paying to play and thus... highly irked by the lacklustre, unstable and unreliablility of the cegeda system. Someone go forth and kick their asses please; especially if you have a contingent in the CCP offices.

Mamede
Posted - 2007.12.12 19:47:00 - [69]
 

Edited by: Mamede on 12/12/2007 19:48:21
Quote:

Edit2: Look, this is getting silly. I know it's just a game, but it's a game I'm paying to play and thus... highly irked by the lacklustre, unstable and unreliablility of the cegeda system. Someone go forth and kick their asses please; especially if you have a contingent in the CCP offices.


Agreed
it amazing how wine folks could get premium to work and transgaming pps didn't yet.

Gilbert T
Gallente
Gladiators of Rage
Posted - 2007.12.12 22:43:00 - [70]
 

Yeah I tried disabling sound completely on 2 different machines and it still crashes just as much. On the first one I tried it on it actually went for almost an hour without crashing and then went back to its original crash every 1-10 minutes behavior. On my best machine I'm going to update everything and install lsb-release and then reinstall the client to see if possibly an outdated library had something to do with it. I kind of doubt it since none of my libraries were more than a month old anyway but what the hell. I think I might try a few things and post back only if I find some kind of workaround that improves the stability.

Dalseta Volitare
Posted - 2007.12.12 22:51:00 - [71]
 

I get random crashes whenever i use the Premium Graphics. Some random bugs like ships not rendering properly, but the second i try and undock, or fly anywhere my wine client just 'dies' the window stays open, but no CPU resources are being used. If i switch the premium content off pretty much no issues. (aside from the empire jump slow downs)

Mystica Shadowheart
Amarr
Posted - 2007.12.13 12:01:00 - [72]
 

Originally by: Dalseta Volitare
I get random crashes whenever i use the Premium Graphics. Some random bugs like ships not rendering properly, but the second i try and undock, or fly anywhere my wine client just 'dies' the window stays open, but no CPU resources are being used. If i switch the premium content off pretty much no issues. (aside from the empire jump slow downs)


This thread is actually intended for the ones who use the wrapped (aka supported) client.

Mamede
Posted - 2007.12.13 18:40:00 - [73]
 

Originally by: Gilbert T
Yeah I tried disabling sound completely on 2 different machines and it still crashes just as much. On the first one I tried it on it actually went for almost an hour without crashing and then went back to its original crash every 1-10 minutes behavior. On my best machine I'm going to update everything and install lsb-release and then reinstall the client to see if possibly an outdated library had something to do with it. I kind of doubt it since none of my libraries were more than a month old anyway but what the hell. I think I might try a few things and post back only if I find some kind of workaround that improves the stability.


Exactly after the first hour or so after sound disabling everything was ok. After that crash crash. Did you check reboot?

Gilbert T
Gallente
Gladiators of Rage
Posted - 2007.12.13 18:54:00 - [74]
 

Originally by: Mamede
Exactly after the first hour or so after sound disabling everything was ok. After that crash crash. Did you check reboot?


There has been the occasional extended period where the game runs for close to an hour without crashing all along, but this was the first time it ran for that period of time under these conditions. I must have warped/jumped about 20 times and docked/undocked 10 during that period of time, and normally it seems to crash about 3 times minimum on that kind of a run.

I haven't rebooted my system since 51 days ago when my power went out, so no to the reboot thing. I have checked to be sure that all wine and wineserver processes are dead and restarted dbus though which should be just about the same. My laptop has been rebooted a few times, though, and it always has the same problem with eve.

On my desktop I recently updated all of my software and installed the lsb-release package. The software updated included glibc, mesa, and several xproto* packages, and I think dbus might have been in there as well. I only played the game for a few minutes on that machine since the update but it did not crash. If I have found the recipe for stability I will try to post my current versions of all of these libraries and programs to see if it helps anyone else.

Gilbert T
Gallente
Gladiators of Rage
Posted - 2007.12.13 19:20:00 - [75]
 

I wanted to post about an experience I had which caused the game to crash consistently after the trinity patch. I was creating a new character, a minmitar female, and when flipping through the costumes ever time I reached a particular costume the game would crash. I tried about 10 times just to see if it would keep doing it and it did.

Is it possible that someone forgot to include certain textures in the patch, and that every time we approach something that uses these textures it tries to pre-load them causing our crashes? It seems possible to me, but my experience with opengl is very limited so I am only guessing. I just thought it might be something worth checking into.

CCP Lingorm


C C P
Posted - 2007.12.14 10:14:00 - [76]
 

We do have a patch coming soon with a number of fixes for stability issues.

But please, we need as much information on the different crashes.

If you are experiencing regular crashes could you please please file a bug report with any replication steps, your configuration. If you can get a debug/error log that would be good.

How to get an debug log in the Linux client is as follows.

Open the Eve Configuration
type +debugstr into the 'Debug Channels to use'
check 'Output to logfile'
put error.log in the file name space
uncheck 'Debug Output to Console'

(It will remember these settings)

this will record the stuff in the background. When it crashes, gzip the file and attach it to a bug report. We can then send it to TransGaming and they can use it to fix the issue.

We do except reports from unsupported distributions and hardware configurations (ATi etc) and will try to fix them but support configurations have a higher priority.

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.14 11:18:00 - [77]
 

Thanks for that info. Will give it a try with that particular string selected. (any other choice/more seemed to cause the client to slow to a complete crawl which made it impossible to do any real testing.)

Suki Kamir
Posted - 2007.12.15 14:11:00 - [78]
 

Latest Crash took out my entire desktop environment, forcing me back to the GDM login window. This was after the client had already crashed about 5 times in the previous 30 minutes.

We really need this sorting out sooner rather than later. Personally I can see myself dumping cedega (even though I have been paying them for over 2 years now) and installing wine. Seems the latest patch for wine allows you to play with premium content and does not have the crash problems cedega has.

Transgaming have totally dropped the ball here and WineHQ have picked it up, run the length of the field and scored a touchdown whilst TG have been sleeping in the dugout.

Suki

rig0r
The Gravedigger Company
Posted - 2007.12.15 14:22:00 - [79]
 

Edited by: rig0r on 15/12/2007 14:22:14
Originally by: Suki Kamir
Latest Crash took out my entire desktop environment, forcing me back to the GDM login window. This was after the client had already crashed about 5 times in the previous 30 minutes.

We really need this sorting out sooner rather than later. Personally I can see myself dumping cedega (even though I have been paying them for over 2 years now) and installing wine. Seems the latest patch for wine allows you to play with premium content and does not have the crash problems cedega has.

Transgaming have totally dropped the ball here and WineHQ have picked it up, run the length of the field and scored a touchdown whilst TG have been sleeping in the dugout.

Suki


While Wine do works better at the moment it has other issues. Framerate drops, missing gfx with premium content, freezes. For me eve on linux just isn't reliable enough to PvP so I stick to carebearing for now ugh

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.15 15:19:00 - [80]
 

The debug string works. The game plays at normal fps until it crashes, which enables at least normal use while attempting to get that log for submission. (which I have done.) I still see no rhyme nor reason for it (the crashing) at this point. I'm using the client + eve voice and all works perfectly up until ze *poof* back to my desktop.

As for wine, hitting a home run for someone familiar with git+patching+font copying and such is not my definition of a home run. When are you folks going to chill out on this "us vs. them" mentality?? You don't see TG in here dissing winehq when wine broke and TG worked after patch day. (of course we're not seeing much of them either way, but I'll take that as "hunched over desks hacking".) Laughing

We're here TO PLAY EVE FOLKS. CCP has an officialy supported client and bug reporting mechanism in place. Wine is a GREAT tool and is getting closer and closer to a 1.0 release, but if you think that the entire wine project is trying to get EVE running, you'd better think again. Its focus is on a broader pallete. This, imho, is a very good thing. Sniping about TG vs. Wine doesn't get us any closer to resolution either way.

---off soap box.



Snowcrash Winterheart2
Gallente
Concordia Discors
Posted - 2007.12.15 16:51:00 - [81]
 

I have to agree with the above. Wine is not a stick to beat Transgaming with. But its worth noting that neither winehq or transgaming's whole focus is on getting a single... low population MMO working. Wine's stated goals are 1:1 compatibility with the various win32 API's and we're just tagging along for the ride, Transgaming have far bigger customers for their Cider line than CCP (Electronic Arts springs to mind).

The fact that wine is supporting all it currently does is brilliant, a wonderful testament to OSS development practices and such. The fact that Transgaming have been able to do what they've done with an infinitely smaller team of programmers and using an exceptionally old wine (and very broken compared to 9.51) source as their starting point, is equally brilliant.

farfrael
FP Enterprise
Posted - 2007.12.15 17:42:00 - [82]
 

Bug report submitted with error log attached

fixme:imm:ImmGetConversionStatus (0x00000000, 0x68c22c, 0x68c210): stub
warn:debugstr:OutputDebugStringA "LOAD: 0.00001 sec 'res:/UI/Texture/LogoLib05.dds'\n"
warn:debugstr:OutputDebugStringA "PREP: 0.01710 sec 'res:/UI/Texture/LogoLib05.dds'\n"
warn:debugstr:OutputDebugStringA "LOAD: 0.00001 sec 'res:/Texture/Face/deco/deco/deco03.dds'\n"
warn:debugstr:OutputDebugStringA "LOAD: 0.00000 sec 'res:/Texture/Face/Backdrop/window.dds'\n"
warn:debugstr:OutputDebugStringA "PREP: 0.01445 sec 'res:/Texture/Face/deco/deco/deco03.dds'\n"
warn:debugstr:OutputDebugStringA "PREP: 0.01834 sec 'res:/Texture/Face/Backdrop/window.dds'\n"
warn:debugstr:OutputDebugStringA "LOAD: 0.00001 sec 'res:/UI/Texture/Corps/corps45.dds'\n"
warn:debugstr:OutputDebugStringA "LOAD: 0.00000 sec 'res:/UI/Texture/Corps/corps44.dds'\n"
warn:debugstr:OutputDebugStringA "PREP: 0.01680 sec 'res:/UI/Texture/Corps/corps45.dds'\n"
warn:debugstr:OutputDebugStringA "PREP: 0.01483 sec 'res:/UI/Texture/Corps/corps44.dds'\n"
warn:debugstr:OutputDebugStringA "LOAD: 0.00018 sec 'cache:/Pictures/Portraits/612396809_256.png'\n"
warn:debugstr:OutputDebugStringA "LOAD: 0.00018 sec 'cache:/Pictures/Portraits/612396809_256.png'\n"
warn:debugstr:OutputDebugStringA "PREP: 0.00949 sec 'cache:/Pictures/Portraits/612396809_256.png'\n"
err:seh:EXC_DefaultHandling Unhandled exception code c0000026 flags 1 addr 0x68cb58

Asif BADKARMA
Mentally Unstable Enterprises
Posted - 2007.12.15 18:59:00 - [83]
 

I was getting repeated crashes on portriat loading, I cleared the cache, now cant get past character selection screen Evil or Very Mad

farfrael
FP Enterprise
Posted - 2007.12.15 21:55:00 - [84]
 

Just crashed (again) during a fight
This game is just NOT playable as it is

CCP, could you please make sure this gets addressed as a top issue?

Slightly frustrating as you might imagine, not being able to help your corpmates during a fight

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.16 02:11:00 - [85]
 

Originally by: farfrael
Just crashed (again) during a fight
This game is just NOT playable as it is

CCP, could you please make sure this gets addressed as a top issue?

Slightly frustrating as you might imagine, not being able to help your corpmates during a fight



Farfrael did you bug report it? I NEVER run the official client without running the debug at this point as the crashing is KNOWN. Because of that running with the debug string that Lingorm posted above and filling out a bug report is imperative to getting this thing fixed.

Every crash at this point should get an addon bug report to give as much information as possible. (prolly preaching to the choir here), but in case others are reading with similar problems... BUG REPORTS ARE YER FRIENDS!!!!!


Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.16 02:13:00 - [86]
 

Edited by: Sevarus James on 16/12/2007 02:15:36
Edited by: Sevarus James on 16/12/2007 02:14:16
Originally by: Sevarus James
Originally by: farfrael
Just crashed (again) during a fight
This game is just NOT playable as it is

CCP, could you please make sure this gets addressed as a top issue?

Slightly frustrating as you might imagine, not being able to help your corpmates during a fight



Farfrael did you bug report it? I NEVER run the official client without running the debug at this point as the crashing is KNOWN. Because of that running with the debug string that Lingorm posted above and filling out a bug report is imperative to getting this thing fixed.

Every crash at this point should get an addon bug report to give as much information as possible. (prolly preaching to the choir here), but in case others are reading with similar problems... BUG REPORTS ARE YER FRIENDS!!!!!

Farfrael did you bug report it? I NEVER run the official client without running the debug at this point as the crashing is KNOWN. Because of that running with the debug string that Lingorm posted above and filling out a bug report is imperative to getting this thing fixed.

Every crash at this point should get an addon bug report to give as much information as possible. (prolly preaching to the choir here), but in case others are reading with similar problems... BUG REPORTS ARE YER FRIENDS!!!!!

--EDIT---I see you said you did. Just a further FYI to those reading: you can ADD to existing reports. Just open "my bugreports" pick the one you've done for crashing and add the logfile (tar.gz'd) to it. Saves a lotta time. Smile


farfrael
FP Enterprise
Posted - 2007.12.16 10:48:00 - [87]
 

Unfortunately, for technical reasons i forgot to log using the debug that time so the combat crash was not reported.
Will follow your suggestion and have debug on 100% of the time going forward. It does seem to catch a lot of small crap during "normal" gameplay anyway

The debug crew seems to be off during the weekend though

As for CCP, after reading the below thread the only thing i can say is WTF?
Bug? What bug? There are NO bugs in Trinity!
I guess this might explain why CCP is so self-satisfied with Trinity while most players consider it a complete disaster on par with Castor: the head honcho doesn't seem 100% up to date Rolling Eyes



Sevarus James
Minmatar
Meridian Dynamics
Posted - 2007.12.16 11:10:00 - [88]
 

Originally by: farfrael
Unfortunately, for technical reasons i forgot to log using the debug that time so the combat crash was not reported.
Will follow your suggestion and have debug on 100% of the time going forward. It does seem to catch a lot of small crap during "normal" gameplay anyway

The debug crew seems to be off during the weekend though

As for CCP, after reading the below thread the only thing i can say is WTF?
Bug? What bug? There are NO bugs in Trinity!
I guess this might explain why CCP is so self-satisfied with Trinity while most players consider it a complete disaster on par with Castor: the head honcho doesn't seem 100% up to date Rolling Eyes





ShockedShockedShocked to that other thread. k. that officially bothers me.Evil or Very Mad

Gilbert T
Gallente
Gladiators of Rage
Posted - 2007.12.17 12:27:00 - [89]
 

Originally by: CCP Lingorm
We do have a patch coming soon with a number of fixes for stability issues.

But please, we need as much information on the different crashes.

If you are experiencing regular crashes could you please please file a bug report with any replication steps, your configuration. If you can get a debug/error log that would be good.

How to get an debug log in the Linux client is as follows.

Open the Eve Configuration
type +debugstr into the 'Debug Channels to use'
check 'Output to logfile'
put error.log in the file name space
uncheck 'Debug Output to Console'

(It will remember these settings)

this will record the stuff in the background. When it crashes, gzip the file and attach it to a bug report. We can then send it to TransGaming and they can use it to fix the issue.

We do except reports from unsupported distributions and hardware configurations (ATi etc) and will try to fix them but support configurations have a higher priority.



from command line:
eve -debugmsg +debugstr 2>&1 >> ~/eve-online.log

Everyone use this and send them the logs every day.
Maybe if we flood them with log files they can find the common factor.

KtoJest
Minmatar
Silkroad Partners
Posted - 2007.12.17 17:37:00 - [90]
 

logged over 8 hours playtime today without a crash. :)


Pages: 1 2 [3] 4

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only