open All Channels
seplocked Linux
blankseplocked Wine vs. Official Client
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Schroni
PPN United
Posted - 2007.11.27 20:43:00 - [1]
 

ahoi! i'm running into some problems both with the Official Cedega Wrapped Client and Wine.

The official client installs and starts fine, but the frame rates i'm getting are very low, like 5 to 10 frames in space. also the game "feels" to be very laggy, like a second delay for the right-click menu in space for example.

wine instead seems to be much more responsive, and i'm also getting between 20-30 fps in space. but, the fonts are corrupt, so you can't really read anything. i tried putting the arial.ttf fonts in the wine folder, but that didn't fix the problem.

so, what should i do... Laughing

is there any fix for wine? or should i just go with another version maybe?

here's my spec, should it matter (i know it's crap ;) ):

cpu: AMD Athlon(tm) XP 2500+
cpu_ghz: 1.84
memory: 1011
videocard_manufacturer: NVIDIA Corporation
videocard_type: GeForce FX 5600/AGP/SSE/3DNOW!
videocard_ram: 256
agp_aperture_size: 188
videocard_driver_version: 2.1.1 NVIDIA 100.14.19
soundcard: NVidia nForce2 with CMI9739 at irq 1
soundcard_driver: ALSA Version 1.0.14
machine_bitness: 32
kernel: 2.6.22-14-generic
x_version: Xorg Version 1.3.0
distro: Debian lenny/sid
GUI version: eve-000066

Distro is Ubuntu 7.10
wine-0.9.46 (the one supplied by Ubuntu)

so, any suggestions?

Schroni

Kadesh Priestess
Scalding Chill
Posted - 2007.11.27 21:02:00 - [2]
 

Corrupted fonts will be fixed in .50 release, just wait it, or compile current git yourself.
If you use OS that uses .deb package manager, you may try to find thread about 0.9.49 wine and dl package linked there which should fix fonts too.

Schroni
PPN United
Posted - 2007.11.27 21:09:00 - [3]
 

another very annoying thing about the official client, whenever it has to load a non-cached image like a character portrait or a ship image, the client hangs for a couple of seconds. this doesn't happen with wine.

ugh

Schroni
PPN United
Posted - 2007.11.27 21:32:00 - [4]
 

Originally by: Kadesh Priestess
If you use OS that uses .deb package manager, you may try to find thread about 0.9.49 wine and dl package linked there which should fix fonts too.


well, i just installed the 0.9.49 deb from winehq, and i still have broken fonts. i tried copying over the fonts from msttcorefonts, but that didn't solve the problem either. so i guess my only hope is compiling the latest source myself?

Schroni
PPN United
Posted - 2007.11.27 21:58:00 - [5]
 

another update Surprised

just downgraded to version 0.9.44 from winehq, and the game seems to run fine. much better then the official client anyways.

only one problem remains, even the eve client claims to be full screen, my Gnome Taskbars/Menubars are still shown on top of it, which is kinda annoying.

still kinda funny that there is such a big performance difference between wine and the official client. Confused

Kadesh Priestess
Scalding Chill
Posted - 2007.11.27 22:21:00 - [6]
 

Edited by: Kadesh Priestess on 27/11/2007 22:20:59
wine 0.9.49.
Read this thread through :P

Schroni
PPN United
Posted - 2007.11.27 22:31:00 - [7]
 

Originally by: Kadesh Priestess
Edited by: Kadesh Priestess on 27/11/2007 22:20:59
wine 0.9.49.
Read this thread through :P


yeah, just did. the copying of the 0.9.44 dll actually fixed the fonts. \o/

now i need to figure out why my gnome task and menubars are still shown in fullscreen mode...

Schroni
PPN United
Posted - 2007.11.27 23:54:00 - [8]
 

found it Very Happy

i had to "disallow" my wm to manage the wine windows, now it works perfect \o/

Rusty Hinge
Minmatar
Posted - 2007.11.28 22:32:00 - [9]
 

My story. I had the CCP EVE client running fine on ubuntu 7.10. Then I upgraded my vid from a nvidia 6200 to an 8500GT and I could not get it going again. Re-installed EVERYTHING and still no go. So I went to Wine .49 did the font install and all is good now. Before my frames were 10-15 with the supported client and now they are in the 30's.

It is odd how the supported version seems to suck in comparison. Sad. Granted I suck too and am very new to Linux. Oh and my 4Gb of ram should be here in a couple days... that will be fun.

Good luck to all you others,

Rusty

Tiny Carlos
Posted - 2007.11.28 23:12:00 - [10]
 

Quote:
It is odd how the supported version seems to suck in comparison.


Cedega is not good compared to Wine, but I guess CCP wanted to work with a company rather than with a comunity.

Employing some Wine hackers might have got a better result, but it wasn't the way they wanted to go.


ANSJ0VIS
Posted - 2007.11.29 11:22:00 - [11]
 

Originally by: Schroni
i had to "disallow" my wm to manage the wine windows, now it works perfect \o/


Thanks, that works for me as well now (with wine 0.49-2 mentioned above for the fonts). However, eve does not get focus of my keyboard. Everything I type ends up in the terminal I started eve from. I can copy/paste my password to log in (with the mouse), but after that, I cannot type any more. (Perhaps I should look in the extremely large Eve-on-Wine thread..)

In the meantime, does anyone know how to quit eve w/o the keyboard? I'm an eve noob, but it seems you can do most things with only the mouse. BTW, how do you see your fps?

Kadesh Priestess
Scalding Chill
Posted - 2007.11.29 20:20:00 - [12]
 

Edited by: Kadesh Priestess on 29/11/2007 20:20:30
Originally by: ANSJ0VIS
However, eve does not get focus of my keyboard. Everything I type ends up in the terminal I started eve from. I can copy/paste my password to log in (with the mouse), but after that, I cannot type any more. (Perhaps I should look in the extremely large Eve-on-Wine thread..)

I've heard of the same prolem on our rus community forums. Unfortunately, we hadn't found any solution except for ugly one...
Originally by: xzv
Btw, i've solved problem concerning input using following way: i launch another program thru wine that has input field (e.g. notepad), trying to input some text there for a while... once it succeeds, i switch to EVE and input anything i want...


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only