open All Channels
seplocked Linux
blankseplocked Debian Lenny (Testing)
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Abraxius Mitrilum
Posted - 2007.11.13 22:32:00 - [1]
 

I am running Debian Lenny (testing) on an Amd 64 single core

whenever I try to start eve I get following message which doesnt make any sense to me....
I can see the "boot up picture" of eve. but thats it

Quote:
Traceback (most recent call last):
File "/usr/bin/lsb_release", line 305, in ?
main()
File "/usr/bin/lsb_release", line 269, in main
distinfo = get_distro_information()
File "/usr/bin/lsb_release", line 232, in get_distro_information
distinfo = guess_debian_release()
File "/usr/bin/lsb_release", line 186, in guess_debian_release
rinfo = guess_release_from_apt()
File "/usr/bin/lsb_release", line 131, in guess_release_from_apt
releases = parse_apt_policy()
File "/usr/bin/lsb_release", line 116, in parse_apt_policy
policy = commands.getoutput('apt-cache policy 2>/dev/null')
File "/usr/lib/python2.4/commands.py", line 44, in getoutput
return getstatusoutput(cmd)[1]
File "/usr/lib/python2.4/commands.py", line 55, in getstatusoutput
sts = pipe.close()
IOError: [Errno 10] No child processes


wheres the problem?

thanks

Last Wolf
Umbra Wing
Posted - 2007.11.13 22:43:00 - [2]
 

Edited by: Last Wolf on 13/11/2007 22:44:35
Edited by: Last Wolf on 13/11/2007 22:44:24
edit, nevermind. I have no idea.

Kadesh Priestess
Scalding Chill
Posted - 2007.11.13 22:58:00 - [3]
 

I'm using debian lenny to and have no probs.
At least tell us which way you're using (officially wrapped client, cedega, wine)?

Kain Bodom
Gallente
Garoun Investment Bank
Posted - 2007.11.13 23:01:00 - [4]
 

Edited by: Kain Bodom on 13/11/2007 23:01:05
there are so many problems with this linux installer. I would love to see a count of ppl that are successfully using it and those that gave up like me... :(

my bu page. :)
http://ubuntubyhand.blogspot.com/

Zevrik
Posted - 2007.11.14 15:09:00 - [5]
 


The problem appears to be with the lsb-release command which doesn't appear to be part of a base Debian install which is why most Debian people aren't having issues.

You can try removing it with:
apt-get remove lsb-release

Abraxius Mitrilum
Posted - 2007.11.19 18:28:00 - [6]
 

Well... lsb_release is needed by the ia32-libs package whis is needed to run eve.

Anyway. I reintalled Debian Testing. Guess after some years there went something wrong with my system. Now it works but I do get the same error message anyway.

Ularra Gi
Posted - 2007.11.29 06:03:00 - [7]
 

I'm seeing a almost the same error message:

Quote:
Traceback (most recent call last):
File "/bin/lsb_release", line 244, in ?
main()
File "/bin/lsb_release", line 208, in main
distinfo = get_distro_information()
File "/bin/lsb_release", line 158, in get_distro_information
distinfo = guess_debian_release()
File "/bin/lsb_release", line 141, in guess_debian_release
release = guess_release_from_apt()
File "/bin/lsb_release", line 96, in guess_release_from_apt
policy = commands.getoutput('apt-cache policy 2>/dev/null')
File "/usr/lib/python2.4/commands.py", line 44, in getoutput
return getstatusoutput(cmd)[1]
File "/usr/lib/python2.4/commands.py", line 55, in getstatusoutput
sts = pipe.close()
IOError: [Errno 10] No child processes



I have a brand new installation of Ubuntu (6.06 LTS), Intel processor. I think I'm using the "officially wrapped" version of the client, but I have Cedega around and might be using that since it starts with

Quote:

Single-user install...
This is the update checker...
Running /home/karl/.cedega/.updater/cedega_updater.py



BTW, I installed cedega, then I installed the Eve linux client. I don't know if that order causes problems or not.

James Ashwood
Posted - 2007.11.30 15:01:00 - [8]
 

Trust me, these messages are nothing to worry about.

Instead, check with the help of the Eve Online's configuration utility that you can run the open GL test about the direct rendering thing.

If your system fails at that test, it's maybe that either the NVidia (I don't know for ATI things) "non-free" Xorg driver/module is not set up (nvidia-kernel-common nvidia-kernel-source module-assistant nvidia-glx packages) or that you don't have the NVidia compatibility driver/module for 32-bits systems (nvidia-glx-ia32 package) or that the 32-bits compatibility libs are missing (ia32-libs package).

Even if the glxinfo | grep direct (mesa-utils package) command tells you that Direct Rendering is active, that may not give the same result with the 32-bits one used by the Eve Online's package.

Debian Lenny (testing) is able to run in 64-bits mode under the amd64 architecture's name (since Intel catched up with the X86-64/amd64 instruction set in their core2 chips). Check if that's the case of your system with the uname -m command.

--
James

Ularra Gi
Posted - 2007.12.01 02:27:00 - [9]
 

Edited by: Ularra Gi on 01/12/2007 02:38:30
Originally by: James Ashwood
Trust me, these messages are nothing to worry about.

Instead, check with the help of the Eve Online's configuration utility that you can run the open GL test about the direct rendering thing.

If your system fails at that test, it's maybe that either the NVidia (I don't know for ATI things) "non-free" Xorg driver/module is not set up (nvidia-kernel-common nvidia-kernel-source module-assistant nvidia-glx packages) or that you don't have the NVidia compatibility driver/module for 32-bits systems (nvidia-glx-ia32 package) or that the 32-bits compatibility libs are missing (ia32-libs package).


I see Open GL and 3d Accelerator tests failed. I'll see what packages need installing. Added: I have an GeForce 6200 LE which is low end but supported.

Ularra Gi
Posted - 2007.12.03 16:42:00 - [10]
 

Edited by: Ularra Gi on 03/12/2007 16:43:19
Ok, to get nvidia to work on Ubuntu Dapper (which is getting off topic), I had to install the nvidia drivers using these instructions. I did it on top of a clean install. A gotcha was that somehow my OS had snuck 3 patches ahead of the header libraries I needed for the nvidia installation. But now, it works. Passes the six tests including OpenGL and 3D accelerator.

Then I needed to add group write permissions to the Eve Online directory because it wanted to modify tg_config_version in that directory and was throwing an error. Also a linking error which I manually fixed. I'm not getting past the splash page, but I'll look around first and open a new thread, if I can't figure it out.

Thanks a lot for the help.


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only