open All Channels
seplocked Out of Pod Experience
blankseplocked You can have my stuff
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 2 3 4 [5] 6 7

Author Topic

TylerJames
Appetite 4 Destruction
Posted - 2006.09.23 17:20:00 - [121]
 

disregard...got it thanks Laughing

Krhe Khar
Amarr
20th Legion
Sodalitas XX
Posted - 2006.09.24 08:35:00 - [122]
 

Didnt know u in game rig0r, but its always sad when people leave.
Thanks a lot for releasing your code. Just set it up and it seems to work like a charm.Very Happy

Grez
Neo Spartans
Laconian Syndicate
Posted - 2006.09.24 20:11:00 - [123]
 

If anyone has the requirements for this killboard, I don't mind setting them up on a webserver for you (I setup RISE's killboard earlier). Just give me a shout ingame, and I'll do what I can to help.

liquidism
Rainer Luxus
Posted - 2006.09.25 22:18:00 - [124]
 

reqs are: php 4, mysql db, some webspace Rolling Eyes

Keldire
Posted - 2006.09.26 06:03:00 - [125]
 

Originally by: Loyal Servant
Since we have all the gurus watching this thread.......
I put this killboard up for our corp and got it all working no prob, EXCEPT.....
The maps.

There are 3 maps, region, constellation and the last one that shows the system in question as well as the surrounding areas.

2 of the maps draw, the region does not draw...
It draws an empty image basically.

Our board is at: http://www.cornholeinc.com

If anyone has an idea, I would appreciate it.



Has anyone found a fix for this yet?

Ghen
Black Omega Security
Pandemic Legion
Posted - 2006.09.26 11:35:00 - [126]
 

Originally by: Keldire
Originally by: Loyal Servant
Since we have all the gurus watching this thread.......
I put this killboard up for our corp and got it all working no prob, EXCEPT.....
The maps.

There are 3 maps, region, constellation and the last one that shows the system in question as well as the surrounding areas.

2 of the maps draw, the region does not draw...
It draws an empty image basically.

Our board is at: http://www.cornholeinc.com

If anyone has an idea, I would appreciate it.



Has anyone found a fix for this yet?


I assume the cache/map/ directory is writable, do the region images appear blank there? Try removing them and see if they get displayed properly afterwards.

You could also try commenting out lines 111 and 112 in common/class.map.php which fixes a warning and might help:
Quote:

111: Header( "Content-type: image/gif" );
112: imagegif( $img );


liquidism
Rainer Luxus
Posted - 2006.09.26 12:37:00 - [127]
 

the one with the world_map not rendering drove me nearly insane. i fixed it tho :)

it worked on one of my servers w/o any problems but did not work on the other one.

i can really pinpoint why but it seemed that the dots were not drawn on the first map if the picture was too small.

just take the picture and manually play around with the size parameter.. (eg: /?a=mapview&sys_id=100&mode=map&size=1500)
and you will notice the dots stop rendering when going below a certain size. i think it was about 213px with my server but can be diff. with yours.

so here's the solution:
open class.map.php and screw around with the ly_ value ( $this->ly_ = 0.4 / 1000000000000000; , line 13) till the dots get rendered with the default 145px big picture. in my case it was this 0.4 (think the orig. value was 0.75 but not sure) the smaller you make this value, the bigger the dots get. so play around till you have a compromise between dots being there and dots being not too big to blob the whole map. also the ($ed = $xscale * 0.75;) thing in line 283 was of some importance, so go and play with the values till you got it. Wink


//liq

liquidism
Rainer Luxus
Posted - 2006.09.26 12:40:00 - [128]
 

to demonstrate what i meant above compare those two links by yourself:

1. http://killboard.eve-d2.com/?a=mapview&sys_id=1932&mode=map&size=122

2. http://killboard.eve-d2.com/?a=mapview&sys_id=1932&mode=map&size=121

only one px difference but the whole map dont gets rendered...

//liq

TigCobra
Battlestars
S E D I T I O N
Posted - 2006.09.27 00:04:00 - [129]
 

my images arent showing up any suggestions?


http://eve-battlestars.net

Vito Parabellum
Fivrelde Corp
Posted - 2006.09.27 02:10:00 - [130]
 

Edited by: Vito Parabellum on 28/09/2006 01:20:47
Edited by: Vito Parabellum on 27/09/2006 02:27:52
found another bug me thinks

When a killmail contains a container (giant sec etc), the container variable is set to 1 and never resets, so everything after it ends up in the "cargo".

fix is to set

$container = false;

below or around
$location = "";
in class.parser.php (~line 250)

Did you fix that truncated bug liquidism?

Thanks rig0r for an excellent board and I hope you come back to the game someday! Actually I know you will :P

Edit:
I had problems with my images until I uncommented the extension=php_gd2.dll line in all my php.ini's

Grez
Neo Spartans
Laconian Syndicate
Posted - 2006.09.27 16:04:00 - [131]
 

Originally by: TigCobra
my images arent showing up any suggestions?


http://eve-battlestars.net


Get rid of .htaccess in the main folder, for some reason it borks up on some machines.

Also, anyone else know how to make the class.toplist.php file display ONLY the corps in the alliance in the top corps list? I've been looking at the SQL query in there, and it's beyond my level of PHP. Liquid, perhaps you might know?

liquidism
Rainer Luxus
Posted - 2006.09.28 00:16:00 - [132]
 

Edited by: liquidism on 28/09/2006 00:21:14
Edited by: liquidism on 28/09/2006 00:17:14
Originally by: Vito Parabellum

Did you fix that truncated bug liquidism?


uhm, kinda.. i edited the parser.php so it gives an errormsg like "there is no final blow, please fake one"

Ranko
Fusion Enterprises Ltd
Morsus Mihi
Posted - 2006.09.28 00:21:00 - [133]
 

I was wondering if anyone can help me, I would like the killboard to not display in weekly, but monthly...

I tried to look at and edit the source code, but to be honest I have no idea what I should be changing and where.

So if anyone can help me out, I would be greatful.

HyperBeanie
Phantom Squad
En Garde
Posted - 2006.09.29 06:27:00 - [134]
 

Edited by: HyperBeanie on 29/09/2006 06:27:37
The portrait and map is due to cache/* (portraits/maps) not being chmod 777

Just do that form your favorite ftp browser.

If you have a killboard.co.uk system and want to move, i have made a little system to do that:
http://ipod.nsbit.dk/tools/

Have fun

/HyperBeanie

Idaeus
Posted - 2006.09.29 18:51:00 - [135]
 

Someone wouldn't happen to have a clean sql dump, with no record of everything except the basics? My webserver keeps choking on the import. :/

Admentus Cor'vion
Sharks With Frickin' Laser Beams
Mercenary Coalition
Posted - 2006.09.30 05:36:00 - [136]
 

I think it's great, Rig0r leaves a gift, and they all wanna call him back for tech support. :)

GL.

Ranko
Fusion Enterprises Ltd
Morsus Mihi
Posted - 2006.09.30 12:06:00 - [137]
 

Edited by: Ranko on 30/09/2006 12:11:06
Originally by: Idaeus
Someone wouldn't happen to have a clean sql dump, with no record of everything except the basics? My webserver keeps choking on the import. :/


How are you trying to do a server import? via a ssh screen? or via the phpmyadmin system?

If your doing it via SSH, it should work just fine just type in:

mysql -uUSERNAME -p NEWDBNAME < /PATH/TO/INSTALL.SQL

If you are using phpmyadmin, it has a limit if 2meg file import, so give this file a try, its just the normal install.sql file thats been 'bzipped' so it should work just fine.

http://www.sanjiyan.com/files/install.sql.bz

Say if it works or not.

Grez
Neo Spartans
Laconian Syndicate
Posted - 2006.09.30 20:48:00 - [138]
 

Originally by: Ranko
Edited by: Ranko on 30/09/2006 12:11:06
Originally by: Idaeus
Someone wouldn't happen to have a clean sql dump, with no record of everything except the basics? My webserver keeps choking on the import. :/


How are you trying to do a server import? via a ssh screen? or via the phpmyadmin system?

If your doing it via SSH, it should work just fine just type in:

mysql -uUSERNAME -p NEWDBNAME < /PATH/TO/INSTALL.SQL

If you are using phpmyadmin, it has a limit if 2meg file import, so give this file a try, its just the normal install.sql file thats been 'bzipped' so it should work just fine.

http://www.sanjiyan.com/files/install.sql.bz

Say if it works or not.


It depends on your server host. Mine has a 51MB limit to SQL database imports.

Cacia Source
Gallente
Doomheim
Posted - 2006.10.01 03:02:00 - [139]
 

First of all thank you for this parting gift. Sad to see veteran players leave eve, though the reasons are understandable. Secondly, and to the point, how do I change the code to make the board public, so that anyone can post given that they have the correct password. My understanding of it, this code is designed to limit posts by either an alliance or a corporation. I want to be able to host this wonderful board for the general public, who may not have the isk to pay for a nice board and/or those who just dont have sites to host the board.

Anyone can help me out with this? Thanks.

Pepperami
Rionnag Alba
Northern Coalition.
Posted - 2006.10.01 03:41:00 - [140]
 

Sad to leave about you leaving rig0r. Takecare and many very generous of you to provide your excellent killboard for download.

Packet Loss
Minmatar
TEKNO
Posted - 2006.10.01 12:26:00 - [141]
 

Originally by: Vito Parabellum
Originally by: liquidism
Edited by: liquidism on 17/09/2006 06:25:21
i found a really serious bug.

if you add a killmail without someone having the final blow, because the final blower got truncated (lots of involved players), corrupted information gets into the database (a kill with several NULL fields that cant be read afterwards).


How did you fix this?


I discovered the affects of this bug yesterday (thank you for the delete function in the killmail class Smile)

I've also had killmails which aren't truncated yet still lack the 'laid the final blow' statement in them and thus broke the parser.

I've made some quick modifications that should resolve the issue for others too:

Edit: common/class.parser.php

Add lines in bold to your "Parser" function:

if ( strpos( $this->killmail_, "**** Truncated - mail is too large ****" ) > 0 ) {
$this->killmail_ = str_replace( "**** Truncated - mail is too large ****", "", $this->killmail_ );
}

if ( strpos( $this->killmail_, "laid the final blow") < 1 ) {
$this->needs_final_blow_ = 1;
}

Then add the following bold lines to the "parser" function:

preg_match( "/(.*) \(laid the final blow\)/", $ipname, $matches );
if ( $matches[1] ) {
$ipname = $matches[1];
$finalblow = 1;
} else $finalblow = 0;

if ( $this->needs_final_blow_ ) {
$finalblow = 1;
$this->needs_final_blow_ = 0;
}

I detect if the killmail contains the required phrase when the class is initialized and set a flag for the instance of the class. Then when running through the involved parties while loop it simply picks the first party (i.e. the highest damage do'er) and assigns them the honor of the final blow :)

I hope its useful :)

Vito Parabellum
Fivrelde Corp
Posted - 2006.10.01 19:00:00 - [142]
 

Originally by: Cacia Source
... My understanding of it, this code is designed to limit posts by either an alliance or a corporation. I want to be able to host this wonderful board for the general public, who may not have the isk to pay for a nice board and/or those who just dont have sites to host the board.

Anyone can help me out with this? Thanks.

Board is not made for that purpose so you will have to modify stuff anyway, but to allow everyone to post you can just comment the auth check in class.parser.php at around line 65 and make sure that $authorized always is true.
Then in config.php you put alliance and corp ids to 0, this will show all killmails. Everywhere, as kills and losses have lost it's meaning on a public killboard.


Originally by: Packet Loss
code

Nice solution, I'll try that, thx :)

Mirida
Meltd0wn
Posted - 2006.10.02 00:54:00 - [143]
 

First, a big thanks to rig0r for letting the code go and giving the EVE-Community such a great killboard.

Originally by: liquidism
Originally by: cRaNbErRy MuFfInMaN
liquid can you post the code for the ability to post comments and make it so they need a password to also?


sorry, but no.



Too bad that you didn't put it under the GPL rig0r... anyway, i'm currently playing with the it.
Some things are wonderful other pretty ugly, currently i'm preparing it for beeing encapsuled by joomla (thats really hard stuff, i don't like it at all) and many other things (config system, portrait handling, security stuff, stuff posted here etc).
Once ready i want to release all modifications within the terms of the GPL and set up a svn server for interested people.
Current working adress: http://exi.ath.cx/eve/?a=kill_detail&kll_id=2
Stil collecting suggestions so there isn't much done yet.

BTW liquidism, i tracked down your bug with the regionmap (had that one, too hehe):
I'ts an issue with GDLIB. Looks like imagefilledellipse() doesnt paint anything if the ellipse is too small on some systems (1px = nothing).
Line is 292 on class.map.php but i reordered the whole code so it might be some lines off, just replace the imagefilledellipse() line with that stuff:
Quote:

// bug compat: imagefilledellipse doesnt draw ellipses with 1px size
// on some installations
if ($ed < 1)
{
imagesetpixel($img, $px, $py, $color);
}
else
{
imagefilledellipse($img, $px, $py, $ed, $ed, $color);
}


Culmen
Caldari
Culmenation
Posted - 2006.10.02 03:57:00 - [144]
 

Edited by: Culmen on 02/10/2006 03:57:18
Crying or Very sad

Packet Loss
Minmatar
TEKNO
Posted - 2006.10.02 05:52:00 - [145]
 

Edited by: Packet Loss on 02/10/2006 05:58:14
Originally by: Mirida
First, a big thanks to rig0r for letting the code go and giving the EVE-Community such a great killboard.

Originally by: liquidism
Originally by: cRaNbErRy MuFfInMaN
liquid can you post the code for the ability to post comments and make it so they need a password to also?


sorry, but no.



Too bad that you didn't put it under the GPL rig0r... anyway, i'm currently playing with the it.
Some things are wonderful other pretty ugly, currently i'm preparing it for beeing encapsuled by joomla (thats really hard stuff, i don't like it at all) and many other things (config system, portrait handling, security stuff, stuff posted here etc).
Once ready i want to release all modifications within the terms of the GPL and set up a svn server for interested people.
Current working adress: http://exi.ath.cx/eve/?a=kill_detail&kll_id=2
Stil collecting suggestions so there isn't much done yet.

BTW liquidism, i tracked down your bug with the regionmap (had that one, too hehe):
I'ts an issue with GDLIB. Looks like imagefilledellipse() doesnt paint anything if the ellipse is too small on some systems (1px = nothing).
Line is 292 on class.map.php but i reordered the whole code so it might be some lines off, just replace the imagefilledellipse() line with that stuff:
Quote:

// bug compat: imagefilledellipse doesnt draw ellipses with 1px size
// on some installations
if ($ed < 1)
{
imagesetpixel($img, $px, $py, $color);
}
else
{
imagefilledellipse($img, $px, $py, $ed, $ed, $color);
}




Tbh I've already started working on such a project, although I had intended to try and get hold of Rig0r first to make sure he was going to be happy with it before doing anything public.

If Rig0r and/or the community supports another project that my own, I would be happy to assist on such a project.

HyperBeanie
Phantom Squad
En Garde
Posted - 2006.10.02 08:01:00 - [146]
 

Would be very nice to have a common killboard project going.
Get all the nice features implemented ;)

I'm ready to help as much as i can :D

M3ta
Amarr
Giants in the Playground
Privateer Alliance
Posted - 2006.10.03 12:18:00 - [147]
 

It's not gonna happen.
Some will implement their own features and use them for themselves while gloating about it (*1), thinking (wrongly) that it will embarass other programmers (yeah right), some others will just rent the KBs for isk.


*1 - forgetting they got the source code for free

Earthan
Gallente
GREY COUNCIL
Nulli Secunda
Posted - 2006.10.04 12:08:00 - [148]
 

Hello everybody,

Im a programmer but not really into internet stuff and php, so plz dont lauph if its stupid mistake:)

Have set it up , eveyrthing works but "stats" tab

the error i get after clicking it
"
Database error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '?a=alliance_detail' at line 3
SQL: select * from kb3_corps where crp_id = 903?a=alliance_detail"

Anyone bumped into it?

Earthan
Gallente
GREY COUNCIL
Nulli Secunda
Posted - 2006.10.04 12:20:00 - [149]
 

hmm something with alliance identicfication line, commented it left only corp and it works...

still must know whats worng with this alliance line:)

Earthan
Gallente
GREY COUNCIL
Nulli Secunda
Posted - 2006.10.04 12:58:00 - [150]
 

solved:)


Pages: 1 2 3 4 [5] 6 7

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only