open All Channels
seplocked Issues, Workarounds & Localization
blankseplocked The Log Server
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2 3

Author Topic

CCP Pann

Posted - 2003.06.01 18:07:00 - [1]
 

How to use the LogServer.exe

LogServer is a program that is in your install directory and when you run it, it will log everything the client does. If you run into problems with the game and need help from customer support, these logs are very likely to help and even make it possible to completely solve the problem.

For the program to work, you need to start it before you start the game.
So:

1. Start LogServer.exe
2. File > New Workspace
3. Play the game
4. File > Save Workspace (once you get the error)

The .lbw file can then be zipped and sent as a attachment with your support request (or when submitting a bug report).

Just a reminder though, running this program can lag your client so don't run it unless you need to. Plus if you run if for a long time the log can be quite big and will take up a fair bit of memory.

- Kwai
Ebil, very ebil

Rooo
Posted - 2003.06.03 00:11:00 - [2]
 

Thanks Pann useful info

Sajuuk Cor
Minmatar
Brutor Tribe
Posted - 2003.06.23 17:31:00 - [3]
 

I have the same problem. Any suggestions on what's wrong? More importantly....how can I fix it?

I got booted back to desktop with my Rifter floating around in space...help.

Rymar Vortox
Minmatar
Mix Master
Posted - 2003.07.04 06:12:00 - [4]
 

Quote:
Just a reminder though, running this program can lag your client so don't run it unless you need to. Plus if you run if for a long time the log can be quite big and will take up a fair bit of memory.


If the logserver program lags the client and gradually eats up memory the longer the client is online how is the client supposed to even be used when myself and other players I'm sure are normally on for hours on end playing the game?

I don't know why but when the game runs on my comp it creates a huge 600+MB pagefile anyway and after a while the game starts lagging really bad and takes a while for my windows xp to repaint the desktop.

Like I said the lag eventually gets pretty bad after a while of playing but goes away after I close the client and reopen it.

So I don't know how I'm supposed to use the program without having problems if I can't be on for long.

Why does the program have to eat up memory?

Saurian
Gallente
Aliastra
Posted - 2003.07.04 21:21:00 - [5]
 

File is to big to submit on the website!!
users upload ur logs and wrkspaces!

ftp://gto.dynu.com
user: eve
pw: eve

Devs! FIX THIS!
http://gto.dynu.com/eve


Aegis Osiris
Gallente
Peanut Factory
Posted - 2003.07.05 03:09:00 - [6]
 

Guys, I've had this same problem crop up twice. Just found the fix, instead of reinstalling the game. Go in and delete the cache folder entirely. You will then get the proper login screen. Slightly annoying, yes, but livable.

Rase
Posted - 2003.07.14 17:14:00 - [7]
 

I thought I was the only 1!. Im running a P4 3Ghz, Asus P4C800-e Deluxe, 1 gig of corsair cms, and an ATI9700 pro.

Just a black box with nice music when I start the game. Error file grows MASSIVE as long as this black box is allowed to run...until I end task it

The Hydra


Polaris Bug Hunters
Posted - 2003.08.10 03:12:00 - [8]
 

Pressing CTRL/DELETE will clean up the logserver, so once you have pinpointed a bug, you can aproache the point of no return, and press these before reproducing the bug.

And yu will find yourself with a log file that is much smaller and easyer to uploadWink

Technical
Brutor Tribe
Posted - 2003.09.09 20:37:00 - [9]
 

i double click the game and it just brings up a white box were the login screen shud be ... any ideas on how 2 help -

Cant beleive pple release games when they dont work properly. and i cant return it because its a multi player only game !!!


Athan
Amarr
Viziam
Posted - 2003.11.24 20:40:00 - [10]
 

Edited by: Athan on 27/11/2003 04:00:53
Edited by: Athan on 27/11/2003 04:00:29
A BH came across some fresh info about the log server that might encourage people to use it more on TQ (the live server).

Basically you can put it in a special mode where every X lines it will save the current contents and then reset them to empty. This keeps the size of the logserver process down and avoids the crash some people (i.e. ME :P) experience if letting it run too long.

  1. Run logserver.exe
  2. Create a new workspace
  3. Now go to 'Tools' Menu and make sure 'Server mode (100,000)' has a tick to the left. You might need to click i and 'change' the number of lines to get the tick. You only need do this once, the preference is saved.
  4. Now on Tools menu select the next option 'Server Mode Save'
  5. Now run eve.exe as normal, and when you get a crash save the logfile as normal.


The upshot of this is that you'll get a log file per 100K lines in it without having to manually save and clear the workspace. If the disk chugs a bit too much at 100K lines try lowering it, but obviously not so low that it doesn't have a useful amount of information in it.

I'm running this now to see if I can catch any info about the 1246 CTDs I've been experiencing.

-Ath

StealthNet
Gallente
Posted - 2003.12.01 00:45:00 - [11]
 

Quote:
Pressing CTRL/DELETE will clean up the logserver, so once you have pinpointed a bug, you can aproache the point of no return, and press these before reproducing the bug.

And yu will find yourself with a log file that is much smaller and easyer to uploadWink


WOW! If I had this info back in beta... Laughing

Moonracer
Posted - 2004.02.07 15:11:00 - [12]
 

LOL, EVE has broken my comp. Haven't been able to play the last week or so. can't even start the program. tried everything, and now XP is in bad enough shape that I'm backing up important files and reinstalling XP.

Just a thought, if this logging program slows down your system won't it in fact increase chances of crashing and therefore possibly alter the types of arrors?

Also, the errors I got for the past week (until I could no longer run EVE) were that it completely reset my computer and rarely just crashed to desktop, so would a logging file even be able to save in this instance?

Moonracer
Posted - 2004.02.08 05:51:00 - [13]
 

BTW,
Is this an official acknowlegment of the recent increases in player side crashes and an active attempt to fix/study the situation?

If CCP is taking any action, just saying that would make myself, and I'm sure a lot of other people considerably less agravated.

When I see a lot of crash reports in the forums and no official remark on the situation, it doesn't look good.

Moonracer
Posted - 2004.02.25 17:00:00 - [14]
 

okay, just to point out; the logserver program only works if you CTD. So if you're more like me, and the game reboots your system more frequently, it can't help.

What's going on with this? nothing has been said in a while. Is it fixed for everyone?

I had 2 weeks of not being able to play around the end of january. then I could play for a few weeks. Now it's the end of February and I can't play again.

endless frustration.

Sin Ist
Posted - 2004.03.03 12:04:00 - [15]
 

Question:

When I goto my logs folder I have like 5 or 10 Crash Dump files. And I also have about 40 or so Error logs. WHat should I do with these? Send them all in? Put each one as a bug report?

I was just attempting to start running the logserver and try and catch these CTD and bugs. Do I even have to are they already being saved?

An answer tot his would be appreciated and if I would appreciate being unbanned from the eve-chaos IRC channel. Since I was making fun of Karen_Sjet I got banned but it was not in eve-chaos channel how can she ban me from a CCP channel? Abuse of pwoer?

Anyways can I get answers to my questions and be unbanned please.

Also how can I get my character mirrored? I would like to get on there as soon as possible. Chaos Server that is.

Thanks

The Chef
Caldari
Posted - 2004.03.04 21:37:00 - [16]
 

Question: I have a bug on my version of eve that crashes the whole computer... This means that the log server doesn't actually save anything because i can't do it! Is there anyway to get it to constantly write to file so that i can get a fixed on the crash causing code?

Ynaig
Posted - 2004.03.25 21:44:00 - [17]
 

What i want to know if the developers can add also remote logging to the logserver, that will allow me to save the logs remotely when the computer I'm using to play the game totally freezes with no way to alt-tab or quit the game at all. That feature should be totally mandatory cause it also helps with the random reboots of the computer, since the log file isn't lost at all remotely on another computer. I don't understand why you (devs) didn't think of it.

My 2isks.
Ynaig

Just4u
Caldari
Posted - 2004.04.20 18:48:00 - [18]
 

I have a problem and would like to know if the logserver.exe would actually work with it. When I play EVE my systems just resets no warning no error message before it happens, I'm playing and wam black screen and my system is rebooting? Can anyone help with his issue??



typhoon ray
Posted - 2004.05.19 09:34:00 - [19]
 

Rose i have the samr problem m8 black box tryed everything what is above and still there can anyone help

Roshan longshot
Gallente
Ordos Humanitas
Posted - 2004.06.12 12:40:00 - [20]
 

Ok I have tried it all. deleated the cache file, reinstalled the game. CANT LOG ON!!! Seems the hardware change CCP did was not up to snuff. Come on CCP, did you change the requirments to log on and not tell us?

Roshan longshot
Gallente
Ordos Humanitas
Posted - 2004.06.12 12:42:00 - [21]
 

P.S Now i cant even patch the game after last reinstall.....

Ulthar
Caldari
Rock Tronics
Posted - 2004.07.04 02:39:00 - [22]
 

OK, this is in response to all the people who posted about their system rebooting randomly, a bit off topic I know, but they started it Razz

I had this problem for about 3 months. The problem was with the drivers of my video card; for some reason even uninstalling the drivers did not get rid of them all the way. I resorted to reinstalling WinXP (and everything else) and then downloading the proper drivers for my video card (I have an ATI Radeon 7500). The proper drivers are labled Catalyst 4.1, my understanding is if you are running EVE this is the proper driver set for all Radeon series cards. So for all of you reading the above posts wondering if ANYTHING has been done about this, understand that it is how EVE was developed, it DOES NOT WORK WELL WITH RADEON CARDS. If you have a Radeon card try the drivers labled Catalyst 4.1. I had to sift through 250+ pages of posts to realize that every Radeon card needs those specific drivers. Since I have reinstalled WinXP and installed those drivers, I have not had a single reboot playing EVE and only a few CTDs, which I capture on my Log Server.
Please, for all our sakes, run the Log Server if you encounter problems, it is the only way the devs have of really tracking down these issues. It records everything on your system. And as to why they do not run it and store it remotetly, they did during Beta. Game speed increased about three times over when that was done away with at release (I was on dial-up at a time). Believe me, coming out of warp in a pod due to lag is no fun Sad

Omega Zargax
Gallente
Aliastra
Posted - 2004.07.04 23:19:00 - [23]
 

Man this is really bad. I was in the game and stuck in a jumpgate loop lag. So I logged out and now after 2 hours I have still not been able to log back in. Why? What gives with Eve?

Dentali
Gallente
Posted - 2004.07.12 12:40:00 - [24]
 

Friends, peasents, lovers...

Welcome to EVE!

The game where lag is abundant and the GMs use the nerfbat instead of fixing simple problems!

SpeedoMan
Caldari
Posted - 2004.07.26 03:29:00 - [25]
 

Here's a little bit I got back from logserver while trying to start EVE. It locks up while displaying the splash screen, then just quits, all hard drive activity stops, and processor seems inactive as well:

-All hope lost while loading 'script:/ui/deco/datepicker.py'
-EXCEPTION #1 logged at 7/25/2004 10:15:51 PM
-Traceback (most recent call last):
-File "E:/EVE/script/sys/nasty.py", line 564, in Run
-File "E:/EVE/script/sys/nasty.py", line 865, in BrowseClassFile
-File "c:/builds/files/client/script/ui/deco/datepicker.py", line 11, in ?
-File "E:/EVE/script/sys/nasty.py", line 322, in ImportBackwards
-ImportError: No module named calendar
-This function was called with arguments:
-self :<__main__.Nasty instance at 0x0090E8C8>
-name :'calendar'
-glob :{'blue': <module 'blue' (built-in)>, 'util': <module 'util' (built-in)>, 'uthread': <module 'uthread' (built-in)>, 'xtriui': <module 'xtriui' (built-in)>, '__builtins__': {'StackTrace': <function StackTrace at 0x0090B6F8>, 'Using': <bound method

....if i need to post more, I will. Hopefully this is more simple than complex, hopefully someone else might have seen it before. Clearing cache doesn't seem to have any effect.

Atma Darkwolf
Gallente
Posted - 2004.08.31 23:43:00 - [26]
 

This log server is a great idea, problem is it will NOT help us who have random reboots.

I can not explain it.. I played eve fine about 1 month ago, never had a problem(please read on and become as confused as me)

First thing I did when problems started was to swap ram. This didn't work(exact same problem) then I went and bought a new vid card(radion 9800 pro 128 meg) and the problem presists. So then I went to get some new ram, dual chan 1 gb 2x512.. problem still there, then I replaced the sound card, and insalled all new drivers, problem stil here, then I reinstalled win xp home.. problem still there, then I tried win xp pro. Same problem. the ONLY freaking thing that I have not changed is the mobo, and if I change that(then it's a new computer) I lose my warrenty.

The problem happens MOST often with eve(restarts ONLY when in battle and weapons are going off, never any other time in eve, but ALWAYS when in battle I will restart.. it can be 20 sec or 1 min, but I WILL restart.) The problem DOES happen very infrequently with other programs such as dvd copying, or web surfing, but the chance of it happening is so low..but I cna log onto eve, get into a fight, and bang..confirm that the problem still exists.

Other games are fine(never any crashes, RYL, CS, RO, Etc) but eve ALWAYS crashes.


Explain this.. about me saying that I replaced everything I am NOT being sarcastic.. I have. Vid card went from geforce 4 64 meg MMX to a radion 9800 pro, 128 meg, sound went from onboard(disabled) to creative sound blaster PCI, HD went from a WD 80 gig to a seagate 160 gig, ram went from (duno..stock crap) to 1 gig of dual channal 512x2 Kingston hyber X. I also rent from win xp HOME(total reinstall..problem presists, so I went and bought pro, not the upgrade, but the full version) and installed that too.

This makes NO sense, and all because of my lack of being able to play eve, I have lost a LOT of important and very personally valuable pictures and movies of our family. I can NEVER get my neices 8th b-day movies again now.. Just an example of what this has caused me(yes, it was my fault that I forgot to totaly back up everything, but thats besides the point.. the game worked wonderfully a month ago, but since I have been UNABLE TO PLAY, and it is NOT on this end.. I proved that by basicaly rehauling this comp and dumping a LOT of money into stuff that could have waited.)

Eve - devs. please track this problem.. provide us with some way to actualy keep track of what is going on.. give us a program that uses some of the systems resources to write constantly to a file that we can recover after a total crash.. then and ONLY then can u actualy help us.

Aronis Contar
Caldari
Independent Manufacturers
Posted - 2004.09.05 04:54:00 - [27]
 

Edited by: Aronis Contar on 05/09/2004 04:57:34
Just to let me get this straight:

Your computer randomly reboots. Not only in EVE, but also while you are doing other stuff. And you want CCP to fix that.

Cool.

Also, I don't get why your rebooting computer has caused your b-day pictures to vanish.

Ciao, Aronis!

Tel'Karas
Caldari
Deep Core Mining Inc.
Posted - 2004.09.15 01:09:00 - [28]
 

Edited by: Tel'Karas on 15/09/2004 01:13:43
Originally by: Atma Darkwolf

The problem happens MOST often with eve(restarts ONLY when in battle and weapons are going off, never any other time in eve, but ALWAYS when in battle I will restart.. it can be 20 sec or 1 min, but I WILL restart.) The problem DOES happen very infrequently with other programs such as dvd copying, or web surfing, but the chance of it happening is so low..but I cna log onto eve, get into a fight, and bang..confirm that the problem still exists.


Your not just having issues with EVE so its not the game causing the problems. Maybe heat inside your case, might be your power supply, might be a lot of other things, but i can tell you this...

If the game isnt running, and your having crashes then its not the game, and the game administrators will not, and can not, help you with that.

That said...

Quote:
The problem DOES happen very infrequently with other programs such as dvd copying, or web surfing


You get a random reboot while web surfing so i'm guessing one of 2 things, your mainboard is crap (also by changing everything on the board you've prolly already voided your warrenty) or you most definately not got enough fans or a good heatsink on that processer of yours.

I've never seen a machine have major issues with web browsing (reboots are major issues) unless its got bad airflow, a virus, hard drive crash, or its powersupply is very under wattaged. As you've replaced the HDD before then its prolly not that.

OAN (On another note):

Originally by: Aronis Contar

Also, I don't get why your rebooting computer has caused your b-day pictures to vanish.



usually cause people forget to backup when they reformat as he's already admitted to, helps if you read the whole message.

Ankanos
Caldari
Posted - 2004.10.18 14:54:00 - [29]
 

Originally by: Atma Darkwolf
This log server is a great idea, problem is it will NOT help us who have random reboots.

The problem happens MOST often with eve(restarts ONLY when in battle and weapons are going off, never any other time in eve, but ALWAYS when in battle I will restart.. it can be 20 sec or 1 min, but I WILL restart.) The problem DOES happen very infrequently with other programs such as dvd copying, or web surfing, but the chance of it happening is so low..but I cna log onto eve, get into a fight, and bang..confirm that the problem still exists.




sounds like a heat or power supply issue.. or possible a corrupt driver.. Tel'Karas is spot on with his suggestions..

-especially since battles in eve will tax your cpu/power the most..

try this: right click my computer, select properties, go to advanced tab and click Startup and Recovery/settings. in this panel, uncheck automatically restart, and check administrative alert. this will cause XP
to halt to a Blue Screen instead of just rebooting. at the bottom of the blue screen will be the offending issue or driver thats causing the reboot
(i forget exactly how its titled, havent seen a bluescreen in almost a year..)

if the file ends in .sys or .dll most likely belongs to a driver set of some sort..

either post it here, and/or search the error on microsoft's knowledge base, google or googgle groups..

in the future, ALWAYS check for heat and power supply issues 1st... they the cheapest and easiest to troubleshoot for(hardware wise)

.. also, in one case, i had spyware causing random reboot/bluescreen...



good luck,
-ank

Ruah Piskonit
Amarr
PIE Inc.
Posted - 2004.11.24 04:55:00 - [30]
 

So I am not alone,
I downloaded the eve patch - or should I say, I stored away the old eve and BitTorrented the new version - and now when I try to log on it tells me: "C:/Program Files/CCP/EVE/logs/#crash b . . . . . ..dmp" What does this mean? How do I fix it? Can it be fixed?
Praying


Pages: [1] 2 3

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only