open All Channels
seplocked EVE Technology Lab
blankseplocked TriExporter
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : 1 2 [3] 4 5 6 7 8 9 ... : last (38)

Author Topic

Ominus Decre
Imperial Shipment
Posted - 2006.04.14 17:37:00 - [61]
 

Originally by: TheKiller8
Sweet


Cool! You have anymore animations??? Wink

SirSpectre
Gallente
Harbingers Of Destruction
Posted - 2006.04.14 21:08:00 - [62]
 

I cant seem to figure out how to put on or view the textures at all. I have deepexplorer and everything else I need, all i see are DDS files. When i got to add the texture to the model in the triexporter client it adds, but nothing happens. Could someone give me a step by step tutorial?

elFarto
Deep Core Mining Inc.
Posted - 2006.04.16 11:22:00 - [63]
 

Edited by: elFarto on 16/04/2006 11:39:30
Originally by: TheKiller8
Sweet


As I just posted this in another post, I thought I'd post it here too.

Impoc

Btw that's rendered in OpenGL in realtime Very Happy

Regards
elFarto

keepiru
Omega Fleet Enterprises
Executive Outcomes
Posted - 2006.04.28 17:42:00 - [64]
 

Mmmm... think there's a way to get the character creation backgrounds with this? Or am I missing something really simple?

elFarto
Deep Core Mining Inc.
Posted - 2006.04.29 18:02:00 - [65]
 

Originally by: keepiru
Mmmm... think there's a way to get the character creation backgrounds with this? Or am I missing something really simple?


resFaceTextures.stuff

res/Texture/Face/Backdrop

Regards
elFarto

keepiru
Omega Fleet Enterprises
Executive Outcomes
Posted - 2006.04.30 04:20:00 - [66]
 

Edited by: keepiru on 30/04/2006 14:57:56
Nvm, no sleep = no reading comprehension. :)

Gar Ku
Posted - 2006.05.02 19:57:00 - [67]
 

Anyone able to help with exporting the Machariel ship model with the image map applied correctly? The ship is at Model/Ship/pirate/pirb1/AngB1Shape.tri, while the texture at /Texture/Merc/Alien3a.dds does not seem to map fully correctly.

Ather Ialeas
Amarr
Viziam
Posted - 2006.05.02 22:01:00 - [68]
 

Edited by: Ather Ialeas on 02/05/2006 22:01:30
I was directed to here from another thread and decided to give the whole thing a whirl. After a few mishaps I managed to do this:

Firstly, a picture as a proof-of-concept: Linkage!
And secondly a short video of the same: Linkage!

There was a lot of guesswork involved in making of this but hey, it works!

Maxit0
Posted - 2006.05.03 07:19:00 - [69]
 

Hello guys...

I export the model ship apoc to 3d studio max 7 (format *.obj) i can see the model of apoc ShockedShockedvery nicePlease visit your user settings to re-enable images.

Nice.. how i can put the textures???? Rolling EyesRolling Eyes

Harukakanata
Posted - 2006.05.07 15:23:00 - [70]
 

can someone please explain what im doing wrong, i cant get the textures to correctly work on the model, although they work fine in the triexporter.

I first exported the model from triexporter to a .obj file, then i unstuff the texture to the same location. since blender doesnt like .dds files i converted the.dds to a .tga then applied that as a texture to the model and tried to render it. i tried using the different settings to put the texture on the model but it always appears either in the wrong positions, or stretched.

so can someone tell me, how do i correctly apply the texture. is it because i converted the .dds into a .tga? or is it because im using blender (cant afford 3dsm)

Ather Ialeas
Amarr
Viziam
Posted - 2006.05.07 17:38:00 - [71]
 

Originally by: Harukakanata
can someone please explain what im doing wrong, i cant get the textures to correctly work on the model, although they work fine in the triexporter.


In short, the UV:s vertical vector is flipped so you need to either flip the UV:s or flip the texture. I recommend the latter.

Doppleganger
Minmatar
Band of Builders Inc.
Sodalitas XX
Posted - 2006.05.07 23:20:00 - [72]
 

Originally by: Gar Ku
Anyone able to help with exporting the Machariel ship model with the image map applied correctly? The ship is at Model/Ship/pirate/pirb1/AngB1Shape.tri, while the texture at /Texture/Merc/Alien3a.dds does not seem to map fully correctly.


Yeah I have the same prob with the Mach myself... I havent had probs with any other ships but that one.

Think I need to just try to remap it myself =(

Ryushe
Tengo Kagegetsu
Posted - 2006.05.08 10:08:00 - [73]
 

I've been somewhat successfull exporting the models from TriExporter in .obj format, and 'converting' them in Deep Explorer (great little tool there, find a 30 day full functional trial at http://www.righthemisphere.com/products/dexp/index.htm).
The basic steps I took in order:

1) Select model, apply texture in TriExporter, export as .obj
2) Open the .dds file for the texture, which TriExporter exports as well, in Photoshop (using the nVidia .dds stuff) and flip horizontal.
3) Open the .obj file in Deep Explorer, changing all the texture properties to rotate them 180 degrees (so they line up correctly), and then save the same .obj file again.
4) Import the .obj file in 3DMax (for instance), rotate the model -90 over x, and 180 over y, mirror horizontal.
5) Do a basic render, and your model should look ok.

There are however a few exceptions of course.
- First off I can't get the cpaint.dds (which makes the red painted bars on caldari ships) to correctly display in 3DMax.
- I can't get the glass parts for stations and jumpgates to become translucent as far as I can see.
- There are some models that come in parts, such as the Heron and the Tempest, aligning the various parts can be a bit difficult.
- I can't find the textures for the tech2 versions of ships, for instance stuff like the Deimos texture or Cerberus texture.
- Creating (and placing) the blue blinker lights on (again) Caldari ships can be a pain.
- Information about the materials seems to get lost in the translation. From what I can tell, simply having the .dds files (texture) and the models isn't enough. Most of the parameters for how the texture is displayed is contained in the .blue file for the model. For instance there are items which only have a .blue file entry in that directory in the stuff files, which simply use some other model + special texture settings to look different.

Overall, very nice toy to play with :)
Two examples of pics I made with this during the first 2 hours of playing with it:
Image 1 (Carrier + Fighters)
Woot, shiny surfaces rule!

If there's anyone who can help me out a bit with the issues I mentioned above, I'd be very gratefull :)

Maxit0
Posted - 2006.05.08 22:12:00 - [74]
 

Ryushe nice post! very nice infor

i can make this APOC
No have the correct position texture how u can make the correct position texture? EmbarassedEmbarassedEmbarassed

Ather Ialeas
Amarr
Viziam
Posted - 2006.05.12 07:13:00 - [75]
 

Made this during last DT: http://www.eve-files.com/media/0605/yarrmageddon_shoots.avi

Brother Benthor
FinFleet
Raiden.
Posted - 2006.05.13 18:33:00 - [76]
 

After a few minutes playing with the texturing i was very satisfied with the results on my gallente ships texturing :) Very nice aplication!

Brutix (3DsMax 8)
Megathron (3DsMax 8)
Dominix (3DsMax 8)

Torin
Minmatar
Red Bone Corsairs
Posted - 2006.05.19 18:53:00 - [77]
 

Does anyone have converted lightwave versions of the ship models? I'm interested in playing around with them.

Banni Vinda
Posted - 2006.05.20 23:41:00 - [78]
 

Firstly I gotta say thanks to Selvin for TriExporter :)
I've been trying to get some models imported into Blender, but having no luck so far. When I try to import a .obj file, I get the following error:

Using Python version 2.4
'import site' failed; use -v for traceback

Importing OBJ file: "f:\eve\exported\cyclone1\cyclone.obj"
file length: 23749
found 0 smoothing groups.
Attempting to load "mbc1.png"
Image Not Found in any of the dirs, doing a recusrive search
Image Not Found "mbc1.png"
Attempting to load "mbc1.png"
Image Not Found in any of the dirs, doing a recusrive search
Image Not Found "mbc1.png"
Using MTL: "cyclone.mtl"
Traceback (most recent call last):
File "<string>", line 877, in load_obj
File "<string>", line 435, in getUniqueName
ValueError: object "shape" not found


I converted the .dds files to .png, because I don't Blender supports them. The error was the same if I tried to use the dds files. I'll post this on the Blender forums too, and see if I get any luck there, but I thought one of you might have Blender experience that could help.
Cheers

Banni Vinda
Posted - 2006.05.21 01:05:00 - [79]
 

Originally by: Banni Vinda
Firstly I gotta say thanks to Selvin for TriExporter :)
I've been trying to get some models imported into Blender, but having no luck so far. When I try to import a .obj file, I get the following error:
<snip>


I've managed to track it down. It was due to a bug in the 2.41 python scripts. Anyone else using Blender, let me know and I'll post an edited version of the script.
And so, I now present... Linkage for your pleasure. Getting the textures working was a little tricky. I converted them to png before importing to Blender, tho I suspect it may actually support dds. The trick is that each texture layer appear as a separate material, but only the first one is assigned to the actual texture file. The others must be pointed to the file by hand. The texture must also be flipped vertically as someone else pointed out.


Aceanuu
Posted - 2006.05.25 00:26:00 - [80]
 

Does anyone know how to extract the space maps? Like the aaaawesome environment-map-like image that you see when you look into "space." I'm trying to make a movie, and I can't leave the background black, and I can't use a static image of EVE space because it looks horrible and induces a wierd vertigo. Anyway, anyone know how to get the space spheremap or whatever into Lightwave 3D?

elFarto
Deep Core Mining Inc.
Posted - 2006.05.25 11:42:00 - [81]
 

Originally by: Aceanuu
Does anyone know how to extract the space maps? Like the aaaawesome environment-map-like image that you see when you look into "space." I'm trying to make a movie, and I can't leave the background black, and I can't use a static image of EVE space because it looks horrible and induces a wierd vertigo. Anyway, anyone know how to get the space spheremap or whatever into Lightwave 3D?


The cube-maps used for the backgrounds are in resCelestialTextures.stuff, you'll need to poke around for them in there.

As for getting them into Lightwave, I never figured out a way todo it easily.

Regards
elFarto

Kaya Ironwood
Suddenly Ninjas
Tear Extraction And Reclamation Service
Posted - 2006.06.01 14:43:00 - [82]
 

Originally by: Banni Vinda
I've managed to track it down. It was due to a bug in the 2.41 python scripts. Anyone else using Blender, let me know and I'll post an edited version of the script.


I am using the latest version of Blender 2.41 and am also having issues importing the models from TriEx. Could you provide instructions on getting it to work? I appreciate the help!

Seidr
Noir.
Posted - 2006.06.02 11:54:00 - [83]
 

First off, thanks for the program. It's exactly what I was looking for :). I had some time during d/t, and decided to play around a bit, and here's what I came up with. The skybox is pretty sketchy, but I got the comparison I wanted :)

Avatar vs Caldari station

Banni Vinda
Posted - 2006.06.03 16:51:00 - [84]
 

Originally by: Kaya Ironwood
Originally by: Banni Vinda
I've managed to track it down. It was due to a bug in the 2.41 python scripts. Anyone else using Blender, let me know and I'll post an edited version of the script.


I am using the latest version of Blender 2.41 and am also having issues importing the models from TriEx. Could you provide instructions on getting it to work? I appreciate the help!


I'm away from my main computer atm so I can't remember the exact fix, but I know I started here.
You need to edit the python script file for importing the lightwave objects. I seem to recall that 2 different files needed to be edited in the same way. I'll be back home next week, so if you're still stuck, post back here or contact me and I'll check which files I had to edit.

Gar Ku
Posted - 2006.06.08 10:40:00 - [85]
 

Originally by: Doppleganger
Originally by: Gar Ku
Anyone able to help with exporting the Machariel ship model with the image map applied correctly? The ship is at Model/Ship/pirate/pirb1/AngB1Shape.tri, while the texture at /Texture/Merc/Alien3a.dds does not seem to map fully correctly.


Yeah I have the same prob with the Mach myself... I havent had probs with any other ships but that one.

Think I need to just try to remap it myself =(


Finally figured out how to adjust the UV map by scaling and moving UVs around to get the Machariel textured as desired:

http://dl.eve-files.com/media/0606/Machariel.jpg

Gar Ku
Posted - 2006.06.08 23:01:00 - [86]
 

Also managed to approximate a T2 ship after looking at the .blue file.

http://dl1.eve-files.com/media/0606/Harpy.jpg

For the T2 125m rails, I looked up the entry in the evegraphics files that was posted earlier on in this thread. It had csh531 which I intepreted as the sh as small hybrid, the numbers as barrel shape 5, small housing 3 shape, etc...

Torin
Minmatar
Red Bone Corsairs
Posted - 2006.06.09 02:25:00 - [87]
 

What 3D program are you using?

DJ P
Posted - 2006.06.09 12:42:00 - [88]
 

Edited by: DJ P on 09/06/2006 12:45:04
Originally by: Ryushe

3) Open the .obj file in Deep Explorer, changing all the texture properties to rotate them 180 degrees (so they line up correctly), and then save the same .obj file again.



Cheers for the nice explanation but I have a small problem.
I never used Deep Explorer, so could you please tell me how to rotate the Texture properties?

Regarding Blender 2.41 one solution is to use Blender 2.40 for import. Save it as blend project and then work on 2.41

Thank you
P


Banni Vinda
Posted - 2006.06.09 22:28:00 - [89]
 

Here's what you need to do if you're using Blender 2.41
I'll use the cyclone as an example

1) Edit the Blender\.blender\scripts\obj_import.py as follows:
Line 439:
except AttributeError:
needs changing to:
except ValueError:

2) In triexporter, go to res/model/ship/minmatar/mbc1 and doubleclick mbc1shape.tri to load the model.

3) Go to res/texture/minmatar and doubleclick mbc1.dds TWICE (important!). This should now show the model properly textured.

4) In TriExporter, go to File, Export... Set the export type to 'Obj files'. Create a directory somewhere, and export the model as 'cyclone.obj'.

5) You should now have 3 files in the directory: 'cyclone.mtl', 'cyclone.obj' and 'mbc1.dds'

6) You now need to edit the mbc1.dds file in photoshop or similar. Use the DDS plugin mentioned above in this thread. You need to flip the image vertically, and then save it out as 'mbc1.png'

7) Fire up Blender, and delete the default cube.

8) Go to File, Import, Wavefront (Obj). In the next dialog, select the 'cyclone.obj' file you exported earlier.

9) In the Blender console window, you should see something similar to this:
| Importing OBJ file: "f:\eve\exported\cyclone\cyclone.obj"
| file length: 23749
| found 0 smoothing groups.
| Attempting to load "mbc1.dds"
| Image Not Found in any of the dirs, doing a recusrive search
| Image Not Found "mbc1.dds"
| Attempting to load "mbc1.dds"
| Image Not Found in any of the dirs, doing a recusrive search
| Image Not Found "mbc1.dds"
| Using MTL: "cyclone.mtl"
| obj import time: 1.40385495922

10) Nearly there now. You should have the model in Blender, but it will be plain grey. Here's the tricky bit, so pay attention...
Select the ship model, and press F9 (Editing). In the 'Link and materials' panel, it will say either "2 mat 1" or "2 mat 2". The model is split into two parts. Thats why you had to doubleclick the texture twice in TriExporter, since each part uses the same texture. On other models, there may be more parts, and each part may use a different image. Click the arrows to make sure you have "2 mat 1" displayed if it isn't already.

11) Press F6 (Textures). In the 'Texture' tab, the second texture should be called 'Kd'. Select this texture, and then in the 'Image' tab, click 'Load image' and load the mbc1.png file you created earlier.

12) Now repeat steps 10 and 11, but this time using "2 mat 2".

13) Set up you camera and some lights, then render your image. Hopefully you have something that looks right, if a little flat and dull.

14) Now you need to tweak the material settings to get it looking pretty. As a hint, try creating a normal map, and add it to the two parts of the model in a similar way. Also try creating an emit map to make the glowing lights. Both these maps can be made in photoshop by tweaking the original mbc1.png texture map.


Well thats it. I think that should make sense, but if I've made any mistakes, please let me know. And if you've found this useful, feel free to throw a few ISK my way ingame :)
Have fun!

Kw4h
Dragon's Rage
Intrepid Crossing
Posted - 2006.06.10 08:54:00 - [90]
 

Thanks Ryushe,
your post works as a charm :)


Pages: first : previous : 1 2 [3] 4 5 6 7 8 9 ... : last (38)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only