open All Channels
seplocked EVE Technology Lab
blankseplocked TriExporter
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 22 23 24 25 [26] 27 28 29 30 ... : last (38)

Author Topic

Kolatha
Posted - 2009.12.21 02:30:00 - [751]
 

Originally by: Aurer
Edited by: Aurer on 19/12/2009 16:42:08
I just started to work with eve models and have found something weird. My main texture files appear to be the _ngs.dds files. The problem is that the files are colored wrong, like this. After tweaking with turning off channels, I found the plain texture here, but there is no color to them. I've been trying to change the order of the channels, with no luck.

Any help is appreciated.

Edit: Found the answer to my problem. I use gimp, so I decomposed the _d.dds file in RGBA mode and composed it with just RGB layers, made the texture with perfect colors.


There are 2 texture maps for use with the models. The first one, the _d.dds, is the main diffuse colour map.
The second one, the _ngs.dds, is used for normal, glow and specular.
The ngs file needs to be decomposed. The blue channel is the specular map while the green and alpha channels make the normal map.
See here.

Aurer
Minmatar
Posted - 2009.12.21 20:49:00 - [752]
 

Thanks Kolatha, I found that out after my post and before my edit. The sets of DDS files just seem weird to me in default state after they are extracted. The _d.dds file has some transparent and glass effects as the primary image with the texture data in the RGB channels as well, with the texture being hidden from normal view. This made the decompose/compose necessary, at least on my system.

Mullethead
Mercurialis Inc.
RAZOR Alliance
Posted - 2009.12.26 11:59:00 - [753]
 

If anyone has a bunch of models done in 3ds Max format all skinned and ready to drop into a scene Im willing to pay decent isk for them.

Please mail or convo in game.

Cheers
Mullet

Sierra X117
Posted - 2010.01.08 02:40:00 - [754]
 

hey, iv got several and can get anyothers u want
contact me if ur still interested (done in 3DS 2010 btw)

Line IO
Posted - 2010.01.15 16:01:00 - [755]
 

It's great to have the source code but I can't compile it with visual c++ express. Did someone try ? Or do you know how to process ?

Phi Au
Gallente
Center for Advanced Studies
Posted - 2010.01.19 07:32:00 - [756]
 

Edited by: Phi Au on 25/01/2010 02:27:48
Originally by: Therow
Originally by: Therow
Originally by: TwitchOfEVE
1)they have color codes like this 0.2392157, 0.2392157, 0.2392157 i cant figure out what color format that is.

2) you need to get the normal map. its made from 3 channels of that greeny texture. its explained in here how to do it.


1) If i open them in note pad, how can i turn around and use them? I mean they need to have in the client, the affects such as lasers, and sun animations, right?
(I was reading about how to extract the green map, and i must admit, at fist i just glanced over it. Though now it makes a little bit of sense =x )

I also would like to know if using 3ds would be better than Maya for these models, since Maya often times handles bump, and diffuse differently than 3ds.



Could someone please clarify ^


The .red file is the ship's lights and effects definition file.
The values are in RGBA (red green blue alpha)
The numbers are normalised to be between 0 and 1. multiply each number by 255 to get the standard values. (values over 1 in colours are overbright so a 3 is 300% indicating a light that gets bloom effects, you can simulate this in 3DS Max by setting the colour bump percentage to match... a blue bump value of 3 will glow bright blue even with no light source as it becomes self-illuminated)
eg. Taking an entry from the Gal Myrm...
- type: Tr2Vector4Parameter
name: "MaterialDiffuseColor"
value: [0.3254902, 0.3254902, 0.3254902, 1]

255 * 0.3254902 = 83.000001 (round to 83)
so the colour becomes 83, 83, 83 (alpha is 1 so colour is solid/opaque)
83 in Hexadecimal is 53 so the hex colour value is #535353 which is a dark gray

Also in the .red is the Myrm's glow colour: 1.9294, 3, 2.6824
As you can see the values go over 1. Use these values directly in the colour bump settings and enable self-illumination on the texture using the alpha channel. That means that white values in the texture's alpha channel will glow with the colour set. If you want a non-overbright equivalent value, divide all values by the highest value (3) to normalise them, then apply the above method:
so: 1.9294, 3, 2.6824 becomes 0.64313, 1, 0.89413
and the relative decimal of 0.64313, 1, 0.89413 is 164, 255, 228 when rounded to the nearest integer
the hex of which is: #A4FFE4 (the familiar light tourquise of Gallente ship lights)

If you're wondering why your ship still doesn't look right, then the _p.dds file is for you. The alpha channel in there indicates the tintable areas on the main diffuse skin for faction colouring etc.

mchief117
Posted - 2010.01.19 17:17:00 - [757]
 

Edited by: mchief117 on 19/01/2010 17:32:44
Edited by: mchief117 on 19/01/2010 17:23:32
Pretty new here as i just found this exporter tool today but have encoutered a problem. i set its location to the eve folder and it brings up a lot of texture files and such but no actual models to speak of. is this a lack of doing something in game or do i have to do something out of game for this to work ?

As an update i found that som one said that to look in the DX9 folder but all i can find are dds files , i am apperantly lacking the models themselfs

edit #2 found a fix here http://www.eveonline.com/ingameboard.asp?a=topic&threadID=269677&page=23#664

Arcturus Io
Resilience.
Northern Coalition.
Posted - 2010.01.30 07:12:00 - [758]
 

Hey, Ive used TriExporter in the past but when i tried to run it on this machine it just crashes on startup instantly, no window or interface popups or anything.
Ive just started using Windows 7 64bit and wondering if that might be an issue, anyone else running it on this os? and yes ive tried compatibility mode.

Error report if this helps.

Problem signature:
Problem Event Name: BEX
Application Name: TriExporter 2009.exe
Application Version: 0.4.1.5
Application Timestamp: 47821992
Fault Module Name: TriExporter 2009.exe
Fault Module Version: 0.4.1.5
Fault Module Timestamp: 47821992
Exception Offset: 00029bad
Exception Code: c000000d
Exception Data: 00000000
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057
Additional Information 1: 6510
Additional Information 2: 6510a9a34cd121a2714c9d65ed21b9dd
Additional Information 3: 3f0b
Additional Information 4: 3f0b26f69222af2e21c9eea5847869a9

Arous Drephius
Posted - 2010.01.30 19:00:00 - [759]
 

Originally by: Arcturus Io
Hey, Ive used TriExporter in the past but when i tried to run it on this machine it just crashes on startup instantly, no window or interface popups or anything.
Ive just started using Windows 7 64bit and wondering if that might be an issue, anyone else running it on this os? and yes ive tried compatibility mode.

Error report if this helps.

Problem signature:
Problem Event Name: BEX
Application Name: TriExporter 2009.exe
Application Version: 0.4.1.5
Application Timestamp: 47821992
Fault Module Name: TriExporter 2009.exe
Fault Module Version: 0.4.1.5
Fault Module Timestamp: 47821992
Exception Offset: 00029bad
Exception Code: c000000d
Exception Data: 00000000
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057
Additional Information 1: 6510
Additional Information 2: 6510a9a34cd121a2714c9d65ed21b9dd
Additional Information 3: 3f0b
Additional Information 4: 3f0b26f69222af2e21c9eea5847869a9



I had a problem like this before. IIRC I just searched the registry for "TriExporter" and removed everything that came up.

chadsshop
Posted - 2010.02.18 13:37:00 - [760]
 

Instead of reading 750+ posts..

Is there a updated version of this app?

or an definetive guide/method on the process of exporting it to 3ds max and applying the textures?

Chabniest
Posted - 2010.02.19 03:37:00 - [761]
 

Hi,

does anybody know which model files are from the Hulk und the Retriever. I don't found the files in TriExporter under dx9/Ships.


Kolatha
Posted - 2010.02.19 09:35:00 - [762]
 

Hulk, Retriever etc is found under dx9/model/ship/ore
you are looking for ore_l and ore_m

The T1/T2 version is simply defined by which .red file you use.

I don't know if it is just my system or not but I haven't been able to actually extract the mining barge models, Triexporter just exits. No error messages, no crash logs, nothing, just stops.

Flight Line
Posted - 2010.02.24 09:21:00 - [763]
 

Originally by: Arous Drephius
Originally by: Arcturus Io
Hey, Ive used TriExporter in the past but when i tried to run it on this machine it just crashes on startup instantly, no window or interface popups or anything.
Ive just started using Windows 7 64bit and wondering if that might be an issue, anyone else running it on this os? and yes ive tried compatibility mode.

Error report if this helps.

Problem signature:
Problem Event Name: BEX
Application Name: TriExporter 2009.exe
Application Version: 0.4.1.5
Application Timestamp: 47821992
Fault Module Name: TriExporter 2009.exe
Fault Module Version: 0.4.1.5
Fault Module Timestamp: 47821992
Exception Offset: 00029bad
Exception Code: c000000d
Exception Data: 00000000
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057
Additional Information 1: 6510
Additional Information 2: 6510a9a34cd121a2714c9d65ed21b9dd
Additional Information 3: 3f0b
Additional Information 4: 3f0b26f69222af2e21c9eea5847869a9



I had a problem like this before. IIRC I just searched the registry for "TriExporter" and removed everything that came up.


Same error. New computer. No registry entries for TriExporter.
Any suggestions for other fixes?

Windows Vista Home Basic

Phi Au
Gallente
Center for Advanced Studies
Posted - 2010.02.25 00:07:00 - [764]
 

Edited by: Phi Au on 25/02/2010 00:12:47
Edited by: Phi Au on 25/02/2010 00:10:40
For everyone that just can't seem to get their head around the texture file format... it's going to change soon anyway (beginning with the Summer 2010 update)
Here is the official image from CCP's art dept. about the file structure (image is linked to larger version):
http://ccp.vo.llnwd.net/o2/community/devblog/2010/TexturePack_large.jpgPlease visit your user settings to enable images.

All of this info comes straight from the new dev blog: art blog improvement of textures, and a new scorpion model

So currently the texture file ending in "_d" is the difuse map with Glow/Transparency, the "_ngs" file is the Normal, SubMask & Specular map, and the "_p" file is the Paint map (factional coloring mask)

MAALaR
Gallente
Morior Invictus.
Velocitas Eradico
Posted - 2010.02.28 10:27:00 - [765]
 

I've tried using this tool, it "kind of" worked before maybe five months ago, but now anytime I attempt to open any of the files it either gives me an error "WTF?" or an error "Model Not Loaded", and if i try to open any dds files with triexporter it simply does nothing and outputs no error. So....is there an actual download that WORKS or am i just wasting my time here?

Gad'ui
Posted - 2010.03.02 23:52:00 - [766]
 

I'm having alot of trouble setting up the materials for the station in 3ds max 2010.

What materials do you guys use to get it rendering correctly? Blinn, Anisotropic, Metal, phong etc.

Not sure what images are used on what maps, and what the settings I should use for those is.

Do I need to do anything with the textures before dropping them into 3ds materials (other then flipping them cause i can do that in max)

Mograph
Caldari
SwEaTy ArMpIT RaIDeRs
Posted - 2010.03.12 00:51:00 - [767]
 

can somebody uplaodtheir latest version of tri exporter somwhere for download pleas, coz the lin aint working now more.

Kolatha
Posted - 2010.03.12 05:16:00 - [768]
 

Originally by: Mograph
can somebody uplaodtheir latest version of tri exporter somwhere for download pleas, coz the lin aint working now more.

Lazy or what? You only have to go back 3 pages to find a working link.

ColdBlood Exile
Minmatar
CTPAHHUKU
Posted - 2010.03.20 23:49:00 - [769]
 

Where are Self-Illumination textures in *.STUFF?

JS LiamElms
Gallente
Zor Industries
Pandemic Legion
Posted - 2010.03.23 03:46:00 - [770]
 

Edited by: JS LiamElms on 23/03/2010 03:46:55
Yeah.. so first prob... i lost my link in triexporter to load up the models and for the life of deleting it and reloading it, i can't seem to get it back.... so it forever crashes on me :(

2nd issue... getting the specular levels right on 3ds :-/ i just added 7% raytrace on the reflect map... which really dosn't do it at all :-/ WHen loading up the ingame preview i been really wanting to get the level of shine they are getting using the material map. Yeah, i guessed the lighting is changing the general color output, but to get the shine seems a little over my head :((

However.... as a test model, i used the dramiel and had a little fun animating a short sequance.

http://www.youtube.com/watch?v=k5HkxvoWlm0


Davik Rendar
Gallente
Posted - 2010.03.23 23:18:00 - [771]
 

Originally by: JS LiamElms
i lost my link in triexporter to load up the models and for the life of deleting it and reloading it, i can't seem to get it back.... so it forever crashes on me :(

It's a broken registry entry.

Here's how to fix it:
Open the Registry Editor (regedit.exe)
browse to this directory: HKEY_CURRENT_USER\Software\TriExporter
open the EVE entry
change the value data to: "C:\Program Files(x86)\CCP\EVE" (64bit OS)
or: "C:\Program Files\CCP\EVE" (32bit OS)

Originally by: JS LiamElms
2nd issue... getting the specular levels right on 3ds :-/ i just added 7% raytrace on the reflect map... which really dosn't do it at all :-/ WHen loading up the ingame preview i been really wanting to get the level of shine they are getting using the material map. Yeah, i guessed the lighting is changing the general color output, but to get the shine seems a little over my head :((

Depends what 3D app your using, I can only help if its Cinema 4D, but from the sounds of it it's probably 3ds max, or maya.

Also, nice test render Wink


I got the new scorp model with new PGS texture system exported: Scorpion

Arous Drephius
Posted - 2010.03.31 09:13:00 - [772]
 

Is it possible to extract the Sleeper icons from the client? If so, where are they?

Davik Rendar
Gallente
Posted - 2010.04.01 04:36:00 - [773]
 

Originally by: Arous Drephius
Is it possible to extract the Sleeper icons from the client? If so, where are they?


I'm not sure how to actually generate them on demand, however if you load the npc info in game it will generate an icon in your cache.
Generally it's in the following directory: AppData\Local\CCP\EVE\c_program_files_(x86)_ccp_eve_tranquility\cache\Pictures\Gids - (Windows 7 64bit, cant remember the exact directory for any other OS)

They are stored as .DSS files, so you will need to get the nvidia photoshop dds plugin, or another dds viewer. Then you'll just have to browser through until you find them.

Hopefully that will put you on the right track Wink

Kolatha
Posted - 2010.04.01 14:06:00 - [774]
 

Originally by: Arous Drephius
Is it possible to extract the Sleeper icons from the client? If so, where are they?

If you mean the icons for the sleeper salvage then you might try looking under

res>ui>texture>icons

there are a whole host of icons in there and I'm pretty sure I saw some sleeper stuff when I was poking about in there.

Arous Drephius
Posted - 2010.04.01 14:44:00 - [775]
 

Originally by: Kolatha
Originally by: Arous Drephius
Is it possible to extract the Sleeper icons from the client? If so, where are they?

If you mean the icons for the sleeper salvage then you might try looking under

res>ui>texture>icons

there are a whole host of icons in there and I'm pretty sure I saw some sleeper stuff when I was poking about in there.


No, I meant the images for the actual Sleeper NPCs.

Davik Rendar: Thanks for that. I was hoping there'd be a better way though :(

Accla89
Posted - 2010.04.12 22:01:00 - [776]
 

Hy@all i have @ Problem whit the TriExporter_2009, TriExporter0.4.1.0beta2 etc.

it does not show all ships

Please visit your user settings to re-enable images.

what can that be ?

Kolatha
Posted - 2010.04.14 13:04:00 - [777]
 

Originally by: Accla89
Hy@all i have @ Problem whit the TriExporter_2009, TriExporter0.4.1.0beta2 etc.

it does not show all ships

what can that be ?


Here

Tip for people new to this thread.
Start at the last page and then work backwards to get the info you need. You only have to look 3 or 4 pages back to find all the instructions and information on how to use the latest version of this great little tool. You will also find nice tips and tricks on how to work with the textures, info on what all the stuff in the .blue files mean and even some starters on how to get the correct location for mount points, running lights and other effects.

Oh, and ignore the posts that say to flip the textures. The textures are fine. It is the ship models and UV co-ords that need to be flipped along the y axis. If you don't flip the model it will be the mirror image of what is in the game.

Have fun.

Danni Arkada
Minmatar
Posted - 2010.04.16 14:03:00 - [778]
 

Edited by: Danni Arkada on 16/04/2010 14:12:32
Not sure on that flipping, because I used almost different techniques (I don't mean to muddy the waters, here), and got good results with 3ds Max Design 2010 (just got my demo copy), and rendered these two beauties last night, tho I need to work on the animation parts now:

http://www.dreadnet.org/rendered/brutix_04.15.2010-01.png
http://www.dreadnet.org/rendered/brutix_04.15.2010-02.png

Kolatha
Posted - 2010.04.17 03:04:00 - [779]
 

Originally by: Danni Arkada
Edited by: Danni Arkada on 16/04/2010 14:12:32
Not sure on that flipping, because I used almost different techniques (I don't mean to muddy the waters, here), and got good results with 3ds Max Design 2010 (just got my demo copy), and rendered these two beauties last night, tho I need to work on the animation parts now:



For the most part you won't notice on a symmetrical model like the brutix.
For asymmetrical models like the incursus you will notice.

See this post and note which side the incursus's lance is on. Now go to the game and view the Incursus there, you will notice the lance is on the other side.

You will also find that if you take the models straight from TriExporter that the co-ordinates in the .blue file for things like running lights, mount points and thruster locations and other effects appear back to front (if you haven't scaled your model the co-ordinates given in the .blue file are 1 for 1 with the mesh). That's where I figured out you need to flip the UV co-ords and the model along the y axis rather than the more immediately apparent x axis.

If you've found a method the results in a correctly oriented mesh and UV co-ords then please share.

Danni Arkada
Minmatar
Posted - 2010.04.18 01:20:00 - [780]
 

Edited by: Danni Arkada on 18/04/2010 15:24:31
Edited by: Danni Arkada on 18/04/2010 01:22:03
Originally by: Kolatha

For the most part you won't notice on a symmetrical model like the brutix.
For asymmetrical models like the incursus you will notice.

See this post and note which side the incursus's lance is on. Now go to the game and view the Incursus there, you will notice the lance is on the other side.

You will also find that if you take the models straight from TriExporter that the co-ordinates in the .blue file for things like running lights, mount points and thruster locations and other effects appear back to front (if you haven't scaled your model the co-ordinates given in the .blue file are 1 for 1 with the mesh). That's where I figured out you need to flip the UV co-ords and the model along the y axis rather than the more immediately apparent x axis.

If you've found a method the results in a correctly oriented mesh and UV co-ords then please share.


Ahh, that might be why I got away with it on the Brutix. I'm in the process of confirming the details and putting together a "how to" kind of page, that has diagrams and steps, and will give you to review to see if it makes sense.

One thing to note, the above two links were for the model and to represent a detailed rendering around that, not for any accuracy on the painting.. which is what I am trying to figure out now. I managed to get some of it (the blue section in my next link - tho I need to darken the blue more), but can't figure out the reflective aspect for the silvery regions yet, nor how to integrate the brown at the top of the Brutix.

Here's the new link:

http://www.dreadnet.org/rendered/brutix-04.16.2010-01.png

I changed three things: The lightmap is much brighter now, as well as the opacity is correct (was using the wrong map), and finally the paint (_p.dds) file is being correctly loaded for the blue, but need to figure out how to tag the tail grill (that's whitish grey atm) before that part works completely.

The black scaring in the blue sections are in fact part of the paint texture, but are quite blurred out in game vs in a detailed rendering like that.

Also, I've not been able to open any of the blue files, but the red files are completely readable in a text editor, tho I'm still working my way through understanding those.

Edit: I've made progress again, the only thing I have left to do now is the white section on the tail, thus far it's looking nice I think:

http://www.dreadnet.org/rendered/brutix-04.17.2010-01.png


Pages: first : previous : ... 22 23 24 25 [26] 27 28 29 30 ... : last (38)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only