open All Channels
seplocked Linux
blankseplocked Wine 1.3.27 breaks my EVE (ArchLinux 64)
This thread is older than 90 days and has been locked due to inactivity.

Author Topic

Jarex Kang
Posted - 2011.08.31 20:43:00 - [1]

Before my routine pacman -Syu eve worked perfectly.
after updating wine, it crashes on startup.

Is anyone else experiencing this?

Kahlan MordSith
Posted - 2011.08.31 21:16:00 - [2]


OpenSuse 11.4 X64
Running Wine 1.3.12 works okay.
After upgrading to wine 1.3.27 i've had eve crash on startup.
Downgrading back to 1.3.12 kept eve craching. I needed to reinstall eve.

Bummer Crying or Very sad

Jarex Kang
Posted - 2011.08.31 21:32:00 - [3]

I'm going to wait 24 hours for any solutions/fixes before uninstalling wine and compling 1.3.26 from source.

Posted - 2011.09.01 01:45:00 - [4]

It's weird. Even with a fresh install I get the same d3d errors both before and after installing d3d.

It's amusing watching pastebin go up in a flurry of eve related error logs. :)

Posted - 2011.09.01 03:56:00 - [5]

Just sort of reinstalled everything using wine 1.3.27

  • moved "Program Files/CCP" directory aside

  • removed .wine/

  • WINEARCH=win32 && winecfg

    • disabled wm decor and control, enabled virtual desktop

    • auto detect drives

    • enable audio

    • WinXP mode

  • winetricks corefonts

  • winetricks vcrun2005

  • winetricks d3dx9_36 (might not be necessary?)

  • winetricks vcrun2008 (for installers)

  • moved "Program Files/CCP" directory back to .wine/drive_c/

I get different errors than I used to, but it runs. Had to redo my hud, hotkeys, overview, chat channels, bookmark directories, and brackets -- standard linux pain.

Jarex Kang
Posted - 2011.09.01 05:16:00 - [6]

ugg I did not want to do that :/

ill do it tommorow, its sleepytimes for me.

(if anyone else has any suggestions, please)

Posted - 2011.09.01 19:33:00 - [7]

Edited by: Jhary-a-Conel on 01/09/2011 19:33:39
I have the same system like topicstarter. My solution to the problem: rollback wine to 1.3.25, reinstall vcrun2005 manually from winetricks cache directory (vcredist_x86.exe) without using winetricks, becouse it skips installing with error "already installed". After that EVE should work.
Maybe rollback isn't necessary, but i did it at once.

Jarex Kang
Posted - 2011.09.02 04:10:00 - [8]

did what velusip did, just reinstalled basically.

works now. wonder what the problem was...

DaQuark Mortiferus
Posted - 2011.09.02 06:55:00 - [9]

Latest git wine-1.3.27-177-gff0cea3 seems to fix it issue.

Works now after fresh install and winetricks corefonts vcrun2005.
d3dx9_43 is not needed for me and even AA works !

Fly Safe

Yakiv Petrov
Posted - 2011.09.03 21:01:00 - [10]

yes, installing the git version was the only thing that worked for me, too. (installed git through yaourt)

Posted - 2011.09.04 16:46:00 - [11]

No problems here with Slackware 13.37 and wine 1.3.27, except those that the windows users are having as well.

Douglas WildOak
The Executioners
Posted - 2011.09.05 06:16:00 - [12]

Same problem here on ubuntu 11.04 amd64. velusip's rebuilding of ~/.wine doesn't work for me, nor does rolling back to an earlier version of wine. I'm about to rebuild from git source.

LaaLaa LeeLoo
Imperial Shipment
Posted - 2011.09.06 14:28:00 - [13]

Edited by: LaaLaa LeeLoo on 06/09/2011 15:04:36
Edited by: LaaLaa LeeLoo on 06/09/2011 14:36:31
I'm running Arch linux x86_64 and I had same issues with 1.3.27--->
got the wine-git from AUR using yaourt and EVE works fine now:
Remove wine/winetrics (pacman -R wine_gecko winetricks wine)

Get the latest winetricks:

"/path/to/prefix" I use ~/.wine32 --> "WINEARCH=win32 WINEPREFIX=~/.wine32 winecfg"

WINEARCH=win32 WINEPREFIX=/path/to/prefix winecfg
WINEARCH=win32 WINEPREFIX=/path/to/prefix winetricks corefonts
WINEARCH=win32 WINEPREFIX=/path/to/prefix winetricks vcrun2005
WINEARCH=win32 WINEPREFIX=/path/to/prefix wine explorer /desktop=1,1200x1024 EVE_Premium_Setup_288329.exe
WINEARCH=win32 WINEPREFIX=/path/to/prefix wine explorer /desktop=1,1200x1024 "C:\\Program Files\\CCP\\EVE\\eve.exe"

Reyk Mcharlich
Posted - 2011.09.06 21:24:00 - [14]

Posted - 2011.09.07 05:57:00 - [15]

Same problem for me on Ubuntu 11.04.


This thread is older than 90 days and has been locked due to inactivity.


The new forums are live

Please adjust your bookmarks to

These forums are archived and read-only