open All Channels
seplocked Macintosh
blankseplocked Incarna SM3 Mac probs - solutions
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

Wakkachu
Posted - 2011.06.22 18:06:00 - [1]
 

Edited by: Wakkachu on 22/06/2011 18:24:11
oi oi Chaps

its been a bad day for us mac users. I think its safe to say we are all cross. Ok I have had a look into it, this is what i have found.
I am running a Mac Pro quad core with a NVIDIA GeForce 7300 GT.
I have checked with Nvidia and the "Chipset" does support SM3 http://www.nvidia.com/page/geforce_7300.html
But!
As Apple make the drivers for there own GC. They have not inculed the SM3 bit https://discussions.apple.com/message/15431566#15431566
This guy had these probs before it went live on Tranquility (that ****es me off as CCP knew there would be issues with Mac and SM3).
I would be interested to know how many mac users are playing eve now and how they are doing it ( on the Macos side of course, not a windows partion)
So any thoughts?

Toovhon
Posted - 2011.06.22 18:29:00 - [2]
 

Hey, at least you have an upgradable Mac :-)

Personally I think it would have been nice for an earlier patch to have detected your GPU driver's capabilities, and informed the user that the next expansion would not work for them on their current setup. Surely that would not have been hard to do.

Saltash
Posted - 2011.06.22 18:33:00 - [3]
 

Edited by: Saltash on 22/06/2011 18:33:09
oi oi
yeah i do.
But i think this might be a mac wide problem (regarding Apple GC updates).
I could be wrong. But I have a work mac book pro one year old and thats not having it either.

Mechazer Zotron
Posted - 2011.06.23 12:24:00 - [4]
 

I Uninstalled My Client! I redownloaded the 5GB Full Client! I skipped Verification! i installed EVE! I downloaded and installed the Fixfontpatch! I opened the Client and it auto-updated the final patch! I went into Graphical Settings! I disabled CQ, I diasbled HDR, I disabled Depth Effects! i then optimizied graphics for Performance! it set all the settings to LOW! I logged in and i worked! However the one flaw is I can't see my Items in my ITEMS TAB! I tried Clearing All Chaces! Still Can't See my Items! It says i have X number of Items but there are no Icons!

I Hope This Helps People! Razz

ariana ailith
FreakyTech
Posted - 2011.06.23 13:54:00 - [5]
 

@Mechazer Zotron: Stop spamming your "solution", tool!

Wakkachu
Posted - 2011.06.23 17:35:00 - [6]
 

The way I understand the implications of SM3 is:
Turning off CQ wont matter as SM3 is all so needed for space flight.
So you still need the SM3 to play, fight and do all the normal eve stuff.

Serpents smile
Posted - 2011.06.23 17:49:00 - [7]
 


Oh, my god. Where is Casqade when you need him? -.-

Running EVE Incarna under 10.6.7 with an ATI Radeon HD 4870 just fine.
Ok its a MacPro but its also old, the 1.1 version. Rolling Eyes

If you have trouble it may be because CCP shifted where things are stored and the old stuff is still in your preferences folder AND in the new directory. Clear that first (EVE in pref folder) then try again. It may help.



siredmond
Posted - 2011.06.23 18:02:00 - [8]
 

Edited by: siredmond on 23/06/2011 18:04:34
Edited by: siredmond on 23/06/2011 18:04:14
Edited by: siredmond on 23/06/2011 18:02:47
Actually im off to a fishing expedition, but I need someone who currently cant run their game under os x to try this. And general disclaimer about you following my instructions at your own peril.

requires navigating inside EVE.app
to
/Applications/Eve Online/Contents/Resources/Preferences/

files names config
open in textexit

find these lines they start at line 167.

[d3dgl]
"AnisotropicTextureFiltering" = "Y"
"VertexShaders" = "Y"
"PixelShaders" = "Y"
"PixelShadersLevel" = "3.0"
"ClipSpaceFix" = "Y"
"FragmentOffset" = "Auto"
"FFoVS" = "Y"
"RectangleTextures" = "Auto"
"DynamicVBO" = "Y"
"IndexVBO" = "Y"
"FBO" = "Y"
"FBOBackBuffer" = "Y"
"GLSL" = "M"
"VertexShadersLevel" = "3.0"
"FloatTextures" = "Y"
"ForceTextureRG" = "Y"
"OcclusionQueries" = "Y"
"ForceMOVACompliance"="N"
"ATIINTZ" = "N"
"ShowFPS" = "N"
"ShowMem" = "N"
"ShowGraphicsStats" = "N"

[d3d9]
"EvictMaxTextureAge" = "1000"
"EvictFrequency" = "600"
"EvictWhenVRAMLessThan" = "2048"
"EvictVAThreshold" = "300"
"CustomFullscreenResolution" = "Y"

[d3dx9]
"NativeEffects" = "N"

[opengl]
"FixedGLExtensionBuffer" = "N"
"GLExtensionBuffer" = ""

If they don't read like that,
you could change them to those values, and essentially lie about your system. Will probably cause harm in some way, or in the off chance fix eve.... Do so at your own risk, and backup the files first if you are going to try this:P It however may not render correctly.

But if your not sure about it and dont know what you are doing, reply back with this section and what it reads.

To my knowledge, in Incarna
"VertexShaders" = "Y"
"PixelShaders" = "Y"
"PixelShadersLevel" = "3.0"
"GLSL" = "M"
"VertexShadersLevel" = "3.0"

these must be the value that is listed, or it will tell you that SM3 is not supported.

Erytnicmcire
Posted - 2011.06.23 20:11:00 - [9]
 

ATI Radeon X1900 XT:

Chipset Model: ATY,RadeonX1900
Type: GPU
Bus: PCIe
Slot: Slot-2
PCIe Lane Width: x1
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x7249
Revision ID: 0x0000
ROM Revision: 113-A52027-140
EFI Driver Version: 01.00.140
Displays:
Cinema HD:
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Display Connector:
Status: No Display Connected

From AMD site:
ATI Radeon™ X1900 Specifications

Ultra-Threaded Shader Engine
Support for Microsoft® DirectX® 9.0 Shader Model 3.0 programmable vertex and pixel shaders in hardware


What am I missing here?

Viceroy Kalong
Posted - 2011.06.23 20:13:00 - [10]
 

siredmond:

I checked the file as you suggested.
It has the values as you outlined.
EVE runs but tells me I have an outdated video card.

siredmond
Posted - 2011.06.23 20:24:00 - [11]
 

Originally by: Viceroy Kalong
siredmond:

I checked the file as you suggested.
It has the values as you outlined.
EVE runs but tells me I have an outdated video card.


There goes my hunch.

Tug McLub
Posted - 2011.06.23 20:42:00 - [12]
 

well...
I have the new Mac Pro 12-core with 8 gigs ram and the HD 5870 ATI Radeon graphics Card. I can run Maya, After effects, photoshop, Finalcut Pro and a bunch of audio programs all at once with no problems at all....

I can run ONE eve client ok...TWO only at the lowest settings possible, and it doesn't work all the time... THREE, I get black screen and it freezes my comp.....

FIX YOUR **** CCP, i know its not my setup.

Wakkachu
Posted - 2011.06.23 21:09:00 - [13]
 

oi oi chaps,
right
i backed up my eve prefs by copying them to my desk top.
eve prefs are located HD/Users/<eg><wakkachu>/Library/Preferences/EVE Online Preferences
Once I did that, I removed my eve app useing appzapper.
I D/L the full mac client, installed it. - eve-premium_006453_271273-mac.dmg -
ran it and it still failed the SM3 test.

Mac Pro quad core 3ghz
ram 2gb
NVIDIA GeForce 7300 GT
MacosX 10.6.7

Regarding what Tug McLub said I agree.
Our systems are fast enough yet software is lacking. We should not have to do complicated software fixes.




Wakkachu
Posted - 2011.06.23 21:18:00 - [14]
 

BTW I reconmend you back up your prefs before you install the new client. Because you are likely to loose your fits and settings. At least with backing up your prefs you can inport the .xml files again.........Thats if we ever get to login again larfs

makanesi
Minmatar
Solar Storm
The Forsaken.
Posted - 2011.06.23 21:55:00 - [15]
 

@CCP
Is anyone listening?
Is there a response to what is happening? If there is, don't hide it in the forum. Put it on the main page. I suggest an apology for starters, and then some sort of compensation.

Wakkachu
Posted - 2011.06.24 16:51:00 - [16]
 

Oi oi chaps
Apple has an OS update 10.6.8
I have seen on some forums that the update did the job and Incarna works for some mac pilots.
It didn't work for me

Nirani Fell
Posted - 2011.06.24 18:23:00 - [17]
 

Incarna is working for me on a MacBook Pro with no problem, other than everything is so dark I can barely see a thing. In space it's difficult but in CQ it's just impossible. I've got the brightness up full on the screen, but it doesn't seem to make a difference to the brightness in game.

Plus my MAcBook is getting hot enough to fry eggs in the top left corner. Definitely couldn't play this with the laptop on my lap as I'd end up with a burnt leg...

Wakkachu
Posted - 2011.06.24 18:32:00 - [18]
 

@Nirani
Cool at least some of us are on:)
I got a mac book pro. One year old its still not working
Nirani just dont wear shades when your flying :)

Unit562
Posted - 2011.06.24 18:37:00 - [19]
 

So what about us users that don't have SM3 support, and can't afford a new computer? im assuming CCP is just going to say "**** you!" and leave us in the dark?

Wakkachu
Posted - 2011.06.24 18:39:00 - [20]
 

whats your spec Unit562?

Siobhan en Cedoulain
Posted - 2011.06.24 18:40:00 - [21]
 

Edited by: Siobhan en Cedoulain on 24/06/2011 18:41:01
@Wakkachu
LOL... so that's where I've been going wrong. I'm just updating to 10.6.8 now to see if that makes any difference. I'm getting backache sitting with my nose pressed against the screen to see what's going on Very Happy

Oops... posted as wrong Avatar - oh bugger!

Wakkachu
Posted - 2011.06.24 18:48:00 - [22]
 

Larfs np I think a lot of mac pilots are spending there time on the forums and not flying becuase of this prob

Wakkachu
Posted - 2011.06.24 18:51:00 - [23]
 

Edited by: Wakkachu on 24/06/2011 18:54:01
BTW I did have a "throwing toys out pram moment today". and I made this image
http://cakesanddrakes.co.uk/cms/index.php?option=com_content&view=article&id=54:one-universe-one-war&catid=35:propaganda&Itemid=64

Nirani Fell
Posted - 2011.06.24 19:07:00 - [24]
 

Well, I've updated to 10.6.8, client still works and still no light switch in CQ... It looks like I've not been paying my bills Laughing

Wakkachu
Posted - 2011.06.24 19:11:00 - [25]
 

At least your on mate.
can you post your spec?

Unit562
Posted - 2011.06.24 19:25:00 - [26]
 

Originally by: Wakkachu
whats your spec Unit562?


Model Name: iMac
Model Identifier: iMac4,2
Processor Name: Intel Core Duo
Processor Speed: 1.83 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 2 MB
Memory: 1 GB
Bus Speed: 667 MHz


Chipset Model: GMA 950
Type: GPU
Bus: Built-In

yes, its fairly weak, but before Incarna it ran eve fine at 20fps

Wakkachu
Posted - 2011.06.24 19:30:00 - [27]
 

@Unit562
whats your graphics card on you mac?

Unit562
Posted - 2011.06.24 19:33:00 - [28]
 

Originally by: Wakkachu
@Unit562
whats your graphics card on you mac?


the Intel GMA 950

Wakkachu
Posted - 2011.06.24 19:53:00 - [29]
 

@Unit562
OK mate ive had a quick look.
this is what i have found out about your GC.
http://support.apple.com/kb/HT3246
http://www.intel.com/products/chipsets/gma950/index.htm

From my quick look. It dont look like you can run SM3. But from a quick look at the specs ies 70% certian.
So I could be wrong:)

Buzz Terbludvessel
Posted - 2011.06.24 23:37:00 - [30]
 

*sigh* Yes confirmed my both my fairly reasonably zippy Dual core Macs are SOL with Eve Incarna - no SM3 support. I have a 20 inch 2.16 iMac and a 2.33 Macbook Pro I just juiced up with more RAM and 500G Hybrid drive ... all toast as far as Eve is concerned :P My Wife's older PC runs Eve OK (wonder if she'll trade).


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only