open All Channels
seplocked Macintosh
blankseplocked ATI Radeon X1600 GPU not working after incarna
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

makanesi
Minmatar
Solar Storm
The Forsaken.
Posted - 2011.06.21 23:11:00 - [1]
 

Howdy. Opening the client causes a warning "Shader Model 3.0 Required." After which the game closes.

I have a MBP 2.16 Core Duo with 2gb ram and ATI Radeon X1600 256MB running OS 10.6.7.

From what I can tell my GPU supports SM3, so what gives? The same is true on the iMac. Help!

S7E
The Priesthood
The 0rphanage
Posted - 2011.06.21 23:27:00 - [2]
 

Edited by: S7E on 21/06/2011 23:28:21
Originally by: makanesi
Howdy. Opening the client causes a warning "Shader Model 3.0 Required." After which the game closes.

I have a MBP 2.16 Core Duo with 2gb ram and ATI Radeon X1600 256MB running OS 10.6.7.

From what I can tell my GPU supports SM3, so what gives? The same is true on the iMac. Help!


The card supports it, but for some reason it doesnt use sm3 just sm2 with macs, just windows based machines.

I downloaded eve for my iMac and get the same warning, it's a shame that it can't run eve when my macbook pro can cause it has an NVIDIA card.

I have the best spec 2010 Macbook Pro which i am considering using for eve although i bought it for work and uni only really, but it has the NVIDIA card, but CCP kind of forcing my hand here, resulting in me spending money in repairing my pc which runs a 1gb nvidia card with sm3, but got overheated and screwed the hardrive and motherboard.

It's pretty **** that they couldnt somehow find an alternative way to get around this issue, even to allow most mac users the chance to atleast log in and turn ofd station environement in order to atleast play, but times are changing and software requirements are going through the roof.

Verite Rendition
Caldari
F.R.E.E. Explorer
EVE Animal Control
Posted - 2011.06.21 23:35:00 - [3]
 

The GPU supports SM3 alright. The drivers do not, however...

makanesi
Minmatar
Solar Storm
The Forsaken.
Posted - 2011.06.21 23:38:00 - [4]
 

Is there any buzz of a work-around?

S7E
The Priesthood
The 0rphanage
Posted - 2011.06.21 23:41:00 - [5]
 

Don't know but i'm keeping my eyes open.

Would be good if CCP would post more in the mac forums.

Verite Rendition
Caldari
F.R.E.E. Explorer
EVE Animal Control
Posted - 2011.06.21 23:54:00 - [6]
 

Originally by: makanesi
Is there any buzz of a work-around?
Nope. The client requires certain features that simply are not available on the Mac.

makanesi
Minmatar
Solar Storm
The Forsaken.
Posted - 2011.06.22 00:02:00 - [7]
 

Well, this is a tricky situation. I've got 2 computers, both of which now cannot run EVE. I've been playing since late 2006 and really love this game, but I'm not sure I can afford to invest in a new machine right now. Sad

S7E
The Priesthood
The 0rphanage
Posted - 2011.06.22 00:07:00 - [8]
 

Originally by: makanesi
Well, this is a tricky situation. I've got 2 computers, both of which now cannot run EVE. I've been playing since late 2006 and really love this game, but I'm not sure I can afford to invest in a new machine right now. Sad


Sorry to hear dude.

I think most of the mac eve community is in the same position to be fair.

As much as everyone is ****ed off at CCP it really isnt their fault, however they should have tried to produce a work around.

You may be able to get another gcard for the mac and try to fit that, or take it to a mac store, they may be able to upgrade the gcard...although i am unsure about that

Verite Rendition
Caldari
F.R.E.E. Explorer
EVE Animal Control
Posted - 2011.06.22 00:22:00 - [9]
 

Originally by: S7E
Originally by: makanesi
Well, this is a tricky situation. I've got 2 computers, both of which now cannot run EVE. I've been playing since late 2006 and really love this game, but I'm not sure I can afford to invest in a new machine right now. Sad


Sorry to hear dude.

I think most of the mac eve community is in the same position to be fair.

As much as everyone is ****ed off at CCP it really isnt their fault, however they should have tried to produce a work around.

You may be able to get another gcard for the mac and try to fit that, or take it to a mac store, they may be able to upgrade the gcard...although i am unsure about that
The GPU is integrated in everything except the Mac Pro. So there's no chance of replacing it on the iMac (or MacBooks, or Minis).

Toronto Mohican
Posted - 2011.06.22 00:42:00 - [10]
 

Unfotunately because Apple has to be different you cant update your card drivers like other computers.

in order to update your drivers you need to do it through software update.

To compound this(and ive looked) you cant manually install drivers from AMD's website because of this, or I just cant find them.

Bottom line is unless Apple releases some sort of driver update that allows the ATI radeon 1600's on mac to start using shader model three any one using mac book pros has been cut off from eve with this expansion.

CCP cant fix it at this point. All of their development into Carbon is based off of SM 3 meaning they'd have to go back to the drawing board and its too late for that.

Im more dissapointed in Macintosh right now then CCP. I jumped from a buggy PC to mac thinking all my problems were solved. Clearly mac is more interested in pimping mobile devices like the I phone 16 and 1/2 or the I pad 5. Clearly if I want a machine I can keep updated over the long term it will have to be a desktop and most certainly a PC.

lesson learned. If you want to desktop game dont muck around, buy a PC. If you want to do creative stuff like art video etc buy a mac. Oh wait. PC's are stable enough to do that now too...


Gunther Gabel
Caldari
Posted - 2011.06.22 01:10:00 - [11]
 

Originally by: Toronto Mohican
Unfotunately because Apple has to be different you cant update your card drivers like other computers.

in order to update your drivers you need to do it through software update.

To compound this(and ive looked) you cant manually install drivers from AMD's website because of this, or I just cant find them.

Bottom line is unless Apple releases some sort of driver update that allows the ATI radeon 1600's on mac to start using shader model three any one using mac book pros has been cut off from eve with this expansion.

CCP cant fix it at this point. All of their development into Carbon is based off of SM 3 meaning they'd have to go back to the drawing board and its too late for that.

Im more dissapointed in Macintosh right now then CCP. I jumped from a buggy PC to mac thinking all my problems were solved. Clearly mac is more interested in pimping mobile devices like the I phone 16 and 1/2 or the I pad 5. Clearly if I want a machine I can keep updated over the long term it will have to be a desktop and most certainly a PC.

lesson learned. If you want to desktop game dont muck around, buy a PC. If you want to do creative stuff like art video etc buy a mac. Oh wait. PC's are stable enough to do that now too...




If you buy a windows laptop, you can't upgrade the processor or the GPU, same for macs

If you would have bought a Mac pro, you can upgrade anything, and keep it updated with no problem

llhloiug
Posted - 2011.06.22 16:28:00 - [12]
 

Edited by: llhloiug on 22/06/2011 16:30:14
I guess it's time to pull out the old xp disks and give it a try with bootcamp. I wish ati drivers on the Mac supported sm3. Too bad by creating boot camp apple essentially ensured that companies like ccp wouldn't give pause when screwing over a whole group of users. After all, developers can always say "you don't need a native client; you can use bootcamp.". Well ccp, my account is cancelled. Too bad I payed with a credit card and now you have my subscription until 17 July... Sigh.

Tako Lordman
Posted - 2011.06.22 16:33:00 - [13]
 

You guys see the recent posts over here yet?

http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1533832

Mara Rinn
Posted - 2011.06.23 08:43:00 - [14]
 

Edited by: Mara Rinn on 23/06/2011 08:52:03
Originally by: Toronto Mohican
Bottom line is unless Apple releases some sort of driver update that allows the ATI radeon 1600's on mac to start using shader model three any one using mac book pros has been cut off from eve with this expansion.


The X1600 is only in Macs that have been obsolete for three years. You knew you'd have to upgrade one day.

I'm in the same boat, don't worry you're not alone.

I have a 17" iMac 2GHz Core 2 Duo, Radeon X1600, and I only get the notification about SM3.0 not being supported. No mention of any option to turn off CQ.



 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only