open All Channels
seplocked Macintosh
blankseplocked ATI Radeon X1600 rejected as too old post Incarna?
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Aiko Intaki
Lodizal Shield Tek
Lodizal Conglomerate
Posted - 2011.06.21 13:27:00 - [1]
 

I downloaded the expansion this morning and launched the client, expecting to see the server still down but wondering if I could get the hotfix patch or not. I was surprised to have the client throw me back to the desktop with a message that my card is too old and does not support SM3. Web lookups suggest that my card does, but I could be wrong:

ATI Radeon X1600:

Chipset Model: ATY,RadeonX1600
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 256 MB
Vendor: ATI (0x1002)
Device ID: 0x71c5
Revision ID: 0x0000
ROM Revision: 113-xxxxxx-158
EFI Driver Version: 01.00.158

I was able to create an avatar prior to Incarna, but did receive dialogs that some of the visual candy would be turned off while doing so. Is this functioning as expected? I'm not completely angry if so, as I'll soon be saving just shy of 90$/month in subscription fees... It all seems rather sudden, however.

Toronto Mohican
Posted - 2011.06.21 14:50:00 - [2]
 

I tried to log into singularity. I have the same set up as you and i get the same message.

According to AMD's website though this card supports direct x 9.0 and SM 3 so not entirely sure whats going on here.

Elesentra
Gallente
Pawnstars INC
Posted - 2011.06.21 14:50:00 - [3]
 

Maybe OS X doesn't have the latest drivers?

da go
Posted - 2011.06.21 15:09:00 - [4]
 

Are you using Snow Leopard version 10.6.7 ?
If so, did you file a bug report?

Aiko Intaki
Lodizal Shield Tek
Lodizal Conglomerate
Posted - 2011.06.21 15:30:00 - [5]
 

My MacBook Pro is patched to current and running Snow Leopard.

I did not file a bug report this morning because I grabbed the patch off a link in the Incarna release thread and not off CCP's patch download page (where it was not yet present). Once the official Incarna client is advertised by CCP, I'll reinstall the full client from download and file a bug report if the issue persists.

Jez Amatin
Posted - 2011.06.21 16:14:00 - [6]
 

EVE system requirements

This would suggest it's just in the minimum spec... so it should work. At least i hope so cos i got same gfx card ugh.
FYI SM3 is to do with shader models used on the GPU side, and Direct X is windows so not applicable to mac platform.

Aiko Intaki
Lodizal Shield Tek
Lodizal Conglomerate
Posted - 2011.06.21 16:33:00 - [7]
 

Yeah, I was pretty sure the card was still within the minimum spec, which is why I was surprised to see the SM3 notice. I wasn't really planning on an upgrade for another year or so yet.

If this is a real change on CCPs part it's sudden enough that I won't have had time to get things properly in order before suspending the accounts. Asset loss from surprise inability to log in due to CCP suddenly dropping support makes one significantly less likely to return post future upgrade.

Hopefully this is just a bug.

Aiko Intaki
Lodizal Shield Tek
Lodizal Conglomerate
Posted - 2011.06.21 16:36:00 - [8]
 

Although...

Quote:
Please note: Macs with the ATI X1600 or ATI X1900 graphics chipset are not supported, but may be able to still run the game by disabling the "Load Station Environment" option.


It would be nice if they at least let us log into the game rather than searching on ATI x1600 and immediately killing the client to desktop.

Toronto Mohican
Posted - 2011.06.21 17:27:00 - [9]
 

In their own words:
Minimum system requirements
Video: ATI X1600 or NVIDIA GeForce 7300 GT or higher with 128 MB of Video RAM
RAM: 1024 MB or more
HD space: 20 Gb
Network: Broadband Internet connection"

If their not supporting this video card any longer they had better say so and make that info easy to find and readily available. I shouldnt have to dig for it or worse have the website say yes it will work and no it wont at the same time.


Aiko Intaki
Lodizal Shield Tek
Lodizal Conglomerate
Posted - 2011.06.21 17:51:00 - [10]
 

Agreed. It is both confusing and seemingly arbitrary.

The 128M ATI Radeon X1600 is supported on Windows, but the 256M ATI Radeon X1600 is not supported on MacBook Pros (officially). Even if they do seem to be picking this specific card out and disallowing it on the Mac for whatever reason, it does appear I can at least get a bootcamp setup configured and install the window EvE client long enough to get things packed up properly before suspending the accounts.

Well, at least I *hope* it works out like that.

Levarr Burton
B0rthole
Test Alliance Please Ignore
Posted - 2011.06.21 18:06:00 - [11]
 

This is actually not CCP's fault. For some reason, the X1600's Mac drivers have only ever supported SM2, even though the Windows XP drivers for it (and the card itself) are capable of supporting SM3.

My understanding is that it will still function, you just won't be able to use the fancy mirror thing, or see tattoos. Might be shut out from Captain's Quarters completely, but you can still load the normal station environment, iirc. I guess we'll see in a few hours.

Gunther Gabel
Caldari
Posted - 2011.06.21 18:17:00 - [12]
 

A few hours, well, is it magically not going to say you aren't supported and not close the game client?

Right now, I can't even get into the login screen to disable all this Incrapa bull****

Aiko Intaki
Lodizal Shield Tek
Lodizal Conglomerate
Posted - 2011.06.21 18:52:00 - [13]
 

Originally by: Levarr Burton
This is actually not CCP's fault. For some reason, the X1600's Mac drivers have only ever supported SM2, even though the Windows XP drivers for it (and the card itself) are capable of supporting SM3.

My understanding is that it will still function, you just won't be able to use the fancy mirror thing, or see tattoos. Might be shut out from Captain's Quarters completely, but you can still load the normal station environment, iirc. I guess we'll see in a few hours.

I guess that would explain the inconsistency.

I think CCP still gets the heat on this one for the client working last night - including through avatar creation, and then explicitly forbidding even a log in attempt after patching this morning. They should at least allow us to log in with the recently added 'disable Incarna' button selected.

Walking in stations may well be nice, but Incarna broke my Internet Spaceships.

S7E
The Priesthood
The 0rphanage
Posted - 2011.06.22 00:03:00 - [14]
 

Originally by: Levarr Burton
This is actually not CCP's fault. For some reason, the X1600's Mac drivers have only ever supported SM2, even though the Windows XP drivers for it (and the card itself) are capable of supporting SM3.

My understanding is that it will still function, you just won't be able to use the fancy mirror thing, or see tattoos. Might be shut out from Captain's Quarters completely, but you can still load the normal station environment, iirc. I guess we'll see in a few hours.


Nope, if you run the X1600 it won't allow you to launch eve.

Thankfully i got my macbookpro and fathers pc to run eve until either upgrade my imacs gcard or i get around to fixing my pc


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only