open All Channels
seplocked Linux
blankseplocked No UI elements so I'm unable to login
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Nebu Retski
Posted - 2011.06.01 19:37:00 - [1]
 

Since the last patch I am unable to login because I can't see any UI elements. The only thing I see it the login background. Before I could play just fine, no issues whatsoever. On my Win7 partition I am able to login, but I would love to get a fix for my linux. So if someone would have an idea, that would be great.

I have found a bug report on WineHQ with an identical problem and error log.
http://bugs.winehq.org/show_bug.cgi?id=27350

System information (laptop):
Linux 2.6.38-ARCH #1 SMP PREEMPT Mon May 23 22:02:08 CEST 2011 x86_64
Intel GMA 4500MHD
wine-1.3.21

The main errors from the log are:
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #7:

fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #4:
fixme:d3d_shader:print_glsl_info_log linking with uncompiled shader
err:d3d_shader:set_glsl_shader_program >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from Find glsl program uniform locations @ ../../../wine/dlls/wined3d/glsl_shader.c / 4449
err:d3d_shader:set_glsl_shader_program >>>>>>>>>>>>>>>>> GL_INVALID_OPERATION (0x502) from glUseProgramObjectARB(programId) @ ../../../wine/dlls/wined3d/glsl_shader.c / 4462



Jinx Xi
Posted - 2011.06.01 21:36:00 - [2]
 

Edited by: Jinx Xi on 01/06/2011 21:41:15
Having the same problems here. I'm going to give the advice in the bug report a shot and try compiling my own mesa drivers with the patch. I've had nothing but bad luck with these Intel GMA drivers, and knew it was only a matter of time that Eve Online started having issues with them too (with Incarna approaching us).

I'm spending most of my time studying for the next couple of weeks, but if I have time I'll report back if the new mesa drivers fix the problems.
Hopefully there will be an update to mesa/wine so we won't have to use a patch though.

EDIT:
One piece of information I forgot to mention; A while back when I first got my Core i5, I ended up fscking around trying to get the mesa drivers to work. If the kernel was too old, it didn't support the drivers, but if the kernel was too new it would render things...well... weird. I believe I had good luck with 2.6.32 - 2.6.34. If I have some spare time, I'll test this out too. Right now I'm on Slackware 13.37 running on the testing kernel 2.6.38.4.

Mr M
Posted - 2011.06.03 02:12:00 - [3]
 

The user interface goes away now and then here but it comes back if I switch between predefined optimised settings. Still a bug though.

Phoeniix
Posted - 2011.06.04 18:21:00 - [4]
 

Someone tried this WWine patch ? http://bugs2.winehq.org/attachment.cgi?id=34998

Wine compiling on my side but it's supposed to fix it.

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.06.05 04:04:00 - [5]
 

Work great on Radeon r600g... But still no go for Intel.

Stoned Wish
Minmatar
Queens of the Stone Age
Posted - 2011.06.06 17:46:00 - [6]
 

Edited by: Stoned Wish on 07/06/2011 01:41:46
Compiling wine with the patch posted in here. Will report back how it works.

Well nothing changed for me when I used the new wine version... Might've done something wrong as I half-arsed the whole thing. Will try more thouroughly when I got time

Arionos
Posted - 2011.06.07 04:11:00 - [7]
 

Just signing in with the exact same problem, and unfortunately not even the slightest idea how to apply the suggested patch.

Stoned Wish
Minmatar
Queens of the Stone Age
Posted - 2011.06.09 02:22:00 - [8]
 

Originally by: Mr M
The user interface goes away now and then here but it comes back if I switch between predefined optimised settings. Still a bug though.


Quoting to bring more attention to it. This did work for me I usually switch between "Performance" and "Memory" and it fixes the problem.

BlackSparrowHawk
Posted - 2011.06.09 11:05:00 - [9]
 

Edited by: BlackSparrowHawk on 09/06/2011 11:05:18
It seems one of the posters on WineHQ may have solved the problem. Although I'm quite noob when it comes to Ubuntu in general.

this is the patch that supposedly fixes it:
Quote:
diff --git a/dlls/wined3d/glsl_shader.c b/dlls/wined3d/glsl_shader.c
index 1cf7f22..0d775a6 100644
--- a/dlls/wined3d/glsl_shader.c
+++ b/dlls/wined3d/glsl_shader.c
@@ -4942,10 +4942,7 @@ static void shader_glsl_get_caps(const struct wined3d_gl_info *gl_info, struct s
* make this a hard requirement, but the extension is still somewhat new,
* and relatively few SM3 shaders actually depend on it. For the moment
* just use it to enable SM3 (20110423). */
- if ((gl_info->supported[NV_VERTEX_PROGRAM3] && gl_info->supported[NV_FRAGMENT_PROGRAM2])
- || gl_info->limits.arb_ps_instructions > 512
- || gl_info->supported[ARB_SHADER_TEXTURE_LOD]
- || gl_info->supported[EXT_GPU_SHADER4])
+ if (gl_info->supported[ARB_SHADER_TEXTURE_LOD] || gl_info->supported[EXT_GPU_SHADER4])
{
caps->VertexShaderVersion = WINED3DVS_VERSION(3,0);
caps->PixelShaderVersion = WINED3DPS_VERSION(3,0);



But could someone explain to me In quick steps how I apply the patch to wine git master HEAD, as it says in the post?

Would appreciate the help and would like to get back playing EVE :)

cargo2000
Minmatar
Nepenthe Inc.
Posted - 2011.06.10 05:55:00 - [10]
 

Edited by: cargo2000 on 10/06/2011 05:55:53
patching is archaicly simple (something like that) looking at that patch do your git check out, via wine's instructions.
Then cd to the root of the source tree say you told it to download to /usr/src/ it should be something like /usr/src/wine-version/
now apply the patch using: patch </path/to/saved/plaintext/patch

notice the '<' before the path

if something does not seem happy
reverse the patch by: patch -R </path/to/saved/plaintext/patch
then read man page for patch: man patch

if the patch worked build wine according to their distructions

Etheoma
Posted - 2011.06.16 12:14:00 - [11]
 

Edited by: Etheoma on 16/06/2011 12:28:41
They changed the program that draws the UI its IDirect3D9Device which is part of the directx package there are some problems though according to wine HQ

correctly manage NULLS as input and output
Generate 'c' style log files that can be compiled and executed with wine and winegcc for implementing test cases.

I don't know if this would stop it working but it sounds like it may do im not a pro at coding or linux so yeah i can only point you to what the problem might be giving that your having a problem with the new UI and they changed from D3D7 to D3D9 to draw the UI because there are less draw orders needed in the new Direct3D.


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only