open All Channels
seplocked EVE Technology Lab
blankseplocked [Question] - Overview Settings XML Editing
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Evannar
Posted - 2011.05.06 16:48:00 - [1]
 

I have been playing around with various overview settings objects in the overview xml that can be exported. I have found that I can make custom labels for player ships, including things like ship name/distance in various colors and in various sizes.

Has anyone figured out how to manipulate the labels for non-player objects? For instance there is a set of tags for "shipLabels". This affects the labeling for player ships/cans/wrecks/etc. A similar set of tags for manipulating the display of NPC-based objects would allow me to see the information I need the way I'd like to see it.

The main reason for this is that I am an older player, and the text in space is quite small and sometimes (actually quite often) difficult for me to read without getting really close to the screen.

Thanks in advance.

Evannar
Posted - 2011.05.06 19:37:00 - [2]
 

So far, this is what I have for the xml layout:


<eveOverview>
-- <globalSettings>
-- -- <useSmallColorTags />
-- -- <applyOnlyToShips />
-- -- <hideCorpTicker />
-- -- <overviewBroadcastsToTop />
-- -- <columns>
-- -- -- <column />
-- -- </columns>
-- -- <shipLabels>
-- -- -- <label></label>
-- -- </shipLabels>
-- </globalSettings>
</eveOverview>


The xml tags are pretty self explanatory. The shipLabels label tags allow you to add custom label data (to a point).

Does anyone know what other global settings tags are available? I can't seem to find any information online anywhere relating to the xml tag layout for the overview settings. It would be really nice if this information was detailed somewhere in order to help make things easier for those of us who have a desire to make custom overviews.

Evannar
Posted - 2011.05.06 22:54:00 - [3]
 

For those who don't know what it is I am trying to do, I have made some screenshots:


This is the current celestial tag when something is selected:
Please visit your user settings to re-enable images.

When I have a pilot selected, this is what I currently see:
Please visit your user settings to re-enable images.


I have made the text size significantly larger (and thus easier for me to read), as well as coloring the tags somewhat in order for me to easily differentiate different portions of the data.


Mike Lone
Posted - 2011.05.07 17:57:00 - [4]
 

Linkage

Try this link see if that's what your after if not maybe ask the guy who wrote it

Evannar
Posted - 2011.05.07 22:58:00 - [5]
 

I have been there as well. It doesn't do exactly what I need it to do. I will try to contact the writer there, but it would really be nice to see if the dev team could add more information about the tags that are available in the overview xml files to the wiki, or even to this post.

Tonto Auri
Vhero' Multipurpose Corp
Posted - 2011.05.09 23:42:00 - [6]
 

All object in space are labeled using the same pattern, which you've defined in settings.
Your problem is likely coming from the fact that many NPC ships don't have usual attributes at all (like, corp/ally ticker).
If you want anything else, please be more precise in your wishes, than "if you could..."
they definitely could. Would they? Likely no.

Annasys
Goonswarm Federation
Posted - 2011.05.10 12:00:00 - [7]
 

I have come across yet another issue that I can't seem to figure out the cause of. With the latest overview setup, It correctly displays in-space tags for ships that have a corporation or alliance, however it defaults to the regular size text for players who aren't part of a player-owned corporation. It is a little annoying. Here is the xml I have for the latest changes I have been playing with:

Quote:

<shipLabels>
<label>
<part name="pre" value="<fontsize=16><b>"/>
<part name="state" value="1"/>
<part name="type" value="None"/>
<part name="post" value=""/>
</label>

<label>
<part name="pre" value=""/>
<part name="state" value="1"/>
<part name="type" value="pilot name"/>
<part name="post" value=" "/>
</label>
<label>
<part name="pre" value="<color=0xFFFF3300>"/>
<part name="state" value="1"/>
<part name="type" value="ship type"/>
<part name="post" value="</color> "/>
</label>
<label>
<part name="pre" value="<color=0xFF0033FF>["/>
<part name="state" value="1"/>
<part name="type" value="corporation"/>
<part name="post" value="]</color>"/>
</label>
<label>
<part name="pre" value="<color=0xFF0033FF>["/>
<part name="state" value="1"/>
<part name="type" value="alliance"/>
<part name="post" value="]</color>"/>
</label>
<label>
<part name="pre" value="There is a cr/lf character here."/>
<part name="state" value="1"/>
<part name="type" value="None"/>
<part name="post" value=""/>
</label>
<label>
<part name="pre" value="Distance: "/>
<part name="state" value="1"/>
<part name="type" value="None"/>
<part name="post" value=""/>
</label>
</shipLabels>



Please note, the brackets that display as < have been written in the xml as their html-encoded counterparts, lt and gt, including & and ;. One other thing to note here is that if I include the fontsize/bold style in the pilot name label, everything works as intended.

I would love to see a complete documentation on the tags used in the overview settings xml file. This would include available tags and nesting order, allowable values, and other attributes that may not normally be seen during an export.

Tonto Auri
Vhero' Multipurpose Corp
Posted - 2011.05.10 12:35:00 - [8]
 

Make each tag separate from other.
Right now you have only one tag with defined font size, worse - you've never closed the tag.

Annasys
Goonswarm Federation
Posted - 2011.05.10 15:41:00 - [9]
 

Originally by: Tonto Auri
Make each tag separate from other.
Right now you have only one tag with defined font size, worse - you've never closed the tag.


Umm...

Each tag is separate from each other.

As to the fontsize tag, closing it is done automatically by the eve client. If you try to close it before another label tagset, it will just act as if you hadn't closed it.

As I stated, if I put the fontsize portion into the player name label instead of it's own separate label, then everything works fine. This is not an issue.

The main issue still sits with the fact that npc objects are not affected by the shipLabels tag. I still would like to know what tags are available for other things, as well as what types of things we can put in labels. Obviously things like ship name, ship type, and pilot name would be there by default. I am sure there are other things that you could also put in the tags, although I don't know why you would. I will tinker with possible "types" later today and see what I come up with.

Evannar
Posted - 2011.05.12 19:35:00 - [10]
 

Bumping for interest.

zoolkhan
Minmatar
Mirkur Draug'Tyr
Ushra'Khan
Posted - 2011.06.20 11:27:00 - [11]
 

bumping as well

ID54321
Posted - 2011.08.01 10:38:00 - [12]
 

the exact same question bothers me...

but also I like to know why there is no space between my type entries.
It looks like:
Example'sRifter[ExampleCorp][ExampleAlliance]'Example's Rifter' 200m
Instead of:
Example's Rifter [ExampleCorp] [ExampleAlliance] 'Example's Rifter' 200m


I use this xml:
Quote:
<shipLabels> <label>
<part name="pre" value="<fontsize=14><b>"/>
<part name="state" value="1"/>
<part name="type" value="pilot name"/> <part name="post" value="'s"/>
</label><label>
<part name="pre" value="<color=0xFFc94c0a>"/>
<part name="state" value="1"/>
<part name="type" value="ship type"/> <part name="post" value="</color>"/>
</label>
<label>
<part name="pre" value="<color=0xFF1d7c1d>["/>
<part name="state" value="1"/>
<part name="type" value="corporation"/>
<part name="post" value="]</color>"/>
</label>
<label>
<part name="pre" value="<color=0xFF2f69c8>["/>
<part name="state" value="1"/>
<part name="type" value="alliance"/> <part name="post" value="]</color>"/> </label>
</shipLabels>

This was created by the Overview Creator Website.

Also I'd like to change the players name to yellow, if possible.
Any ideas?


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only