open All Channels
seplocked Linux
blankseplocked EVE-Online on Ubuntu 10.04 Need Assistance Please
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 02:35:00 - [1]
 

I have a fairly fresh install of Ubuntu here. I am pretty new to Linux and the whole Terminal thing. I don't have a copy of Windows to play on so I am opted for using Ubuntu.

Ok, so here's whats going on. I have Wine installed, I installed all the gits and libraries, that what you call it? Anyway I got EVE-Online installed via the full offline install, not the download manager. When I attempt to open the EVE client, I get the splash screen and then a black screen a few moments later with an error. I would normally have to go to System Monitor to end the process, as it would be Zombied.

I have just uninstalled EVE so that I can try again with some assistance from anyone willing to provide. I have been on tons of forums and help sites in regards to getting EVE to work in ubuntu, but I must be missing something.

Thanks for reading

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 03:25:00 - [2]
 

I'm going to try Crossover Games to install EVE. Maybe it will make a difference.

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 04:07:00 - [3]
 

same thing happens. the error msg says something about a deficiency in wine. Anyone have an idea?

kakmonstret
Posted - 2011.05.05 08:06:00 - [4]
 

What graphics card do you have? What drivers are you using?

Can you say what things you have installed and configured?

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 16:57:00 - [5]
 

Originally by: kakmonstret
What graphics card do you have? What drivers are you using?

Can you say what things you have installed and configured?


Lets see, the GPU is a ATI Radeon X1200, i know crappy, its a laptop, but its all I have right now until I can get my Tower PC up and running again.
I am using the drivers that it automatically installed I suppose.

Right now, I have Wine and Crossover Games (trial) installed. I tried installed DX9c Redist. But I was having issues accessing dxconfig. I would click it, but it would never open.
In wine I followed the direction and added all the recommended overrides as well. Also, I have it set to Windows XP.

Anything else you might need to know?

kakmonstret
Posted - 2011.05.05 17:19:00 - [6]
 

As it is ATI and I have only used Nvidia it's harder to give a good answer for me, but here goes some points.

I would try to install the ATI proprietary drivers, in ubuntu you should be able to find them in "additional drivers". Either in the system menu or by searching for additional drivers in the app launcher. If this doesnít work I'm not sure I'm of much help sadly. Maybe someone else on the forum has more ATI experience.

For nvidia we have some registry keys not sure if they are needed with ati.

Vrea Astare
Minmatar
Posted - 2011.05.05 17:20:00 - [7]
 

If you haven't already done so, open up a terminal window and run the following:
winetricks vcrun2005
winetricks vcrun2008
winetricks corefonts

This will get a couple of the dll compatabilities that may be required to run EVE in wine. You may also want to try configuring wine to run in an "emulated a virtual desktop" in the graphics tab; set the window size to 800x600 or 1280x800.

No clue if you've already done this but it's worth mentioning.

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 17:37:00 - [8]
 

Originally by: kakmonstret
As it is ATI and I have only used Nvidia it's harder to give a good answer for me, but here goes some points.

I would try to install the ATI proprietary drivers, in ubuntu you should be able to find them in "additional drivers". Either in the system menu or by searching for additional drivers in the app launcher. If this doesnít work I'm not sure I'm of much help sadly. Maybe someone else on the forum has more ATI experience.

For nvidia we have some registry keys not sure if they are needed with ati.


It says no proprietary drivers are used on this system. :\

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 17:39:00 - [9]
 

Edited by: K''plar on 05/05/2011 17:41:38
Originally by: Vrea Astare
If you haven't already done so, open up a terminal window and run the following:
winetricks vcrun2005
winetricks vcrun2008
winetricks corefonts

This will get a couple of the dll compatabilities that may be required to run EVE in wine. You may also want to try configuring wine to run in an "emulated a virtual desktop" in the graphics tab; set the window size to 800x600 or 1280x800.

No clue if you've already done this but it's worth mentioning.


Ok, tried that. It says "Winetricks: Command not found"

Is there something I need to install for that to work?

EDIT: Yup nevermind, installing now :)

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.05 18:42:00 - [10]
 

Still no luck even after winetricks. I get a splash screen for Incursion, then nothing.

rycr
Posted - 2011.05.06 01:18:00 - [11]
 

Originally by: K'plar
Still no luck even after winetricks. I get a splash screen for Incursion, then nothing.

Can you give us the output wine is giving you? What is the actual error being displayed in terminal?

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.06 05:16:00 - [12]
 

I'm not seeing any error codes. I just get nothing at all after the splash screen. :-\

kakmonstret
Posted - 2011.05.06 08:55:00 - [13]
 

Originally by: K'plar
I'm not seeing any error codes. I just get nothing at all after the splash screen. :-\


To get the error codes start eve from a terminal, use the same start command that you use in your launcher.

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.06 16:24:00 - [14]
 

I can't get it to open from the terminal, I assume I am entering the wrong command string.


open -n /.wine/C:/Program Files\CCP\EVE\eve.exe

what am I missing/doing wrong?


Sin Golem
Posted - 2011.05.06 23:18:00 - [15]
 

If you are running Ubuntu 10.04 your command line to start eve should look like this

wine explorer /desktop=3,800x600 "C:\Program Files\CCP\EVE\eve.exe"

try that in your terminal

Sin

K'plar
Gallente
United Federation of Planetary Exploration
Posted - 2011.05.07 03:04:00 - [16]
 

Thanks! ok here is what happened

astaheli@astaheli-Satellite-A215:~$ wine explorer /desktop=3,800x600 "C:\Program Files\CCP\EVE\eve.exe"
fixme:system:SetProcessDPIAware stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33cfdc
fixme:iphlpapi:NotifyAddrChange (Handle 0xa4ce8d8, overlapped 0xa4ce8e0): stub
wine: configuration in '/home/astaheli/.wine' has been updated.
err:ole:CoGetClassObject class {9a5ea990-3034-4d6f-9128-01f3c61022bc} not registered
err:ole:CoGetClassObject no class object {9a5ea990-3034-4d6f-9128-01f3c61022bc} could be created for context 0x1
fixme:heap:HeapSetInformation 0x47e000 0 0x33f858 4
EVE Client version 6.43 build 247655 starting 22:02:45
Network layer using: StacklessIO
Multi-Language System: Client using language [EN]
fixme:win:EnumDisplayDevicesW ((null),0,0x338344,0x00000000), stub!
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
An exception has occurred. It has been logged in the log server as exception #1

rycr
Posted - 2011.05.07 13:08:00 - [17]
 

Originally by: K'plar
Thanks! ok here is what happened

astaheli@astaheli-Satellite-A215:~$ wine explorer /desktop=3,800x600 "C:\Program Files\CCP\EVE\eve.exe"
fixme:system:SetProcessDPIAware stub!
fixme:dwmapi:DwmIsCompositionEnabled 0x33cfdc
fixme:iphlpapi:NotifyAddrChange (Handle 0xa4ce8d8, overlapped 0xa4ce8e0): stub
wine: configuration in '/home/astaheli/.wine' has been updated.
err:ole:CoGetClassObject class {9a5ea990-3034-4d6f-9128-01f3c61022bc} not registered
err:ole:CoGetClassObject no class object {9a5ea990-3034-4d6f-9128-01f3c61022bc} could be created for context 0x1
fixme:heap:HeapSetInformation 0x47e000 0 0x33f858 4
EVE Client version 6.43 build 247655 starting 22:02:45
Network layer using: StacklessIO
Multi-Language System: Client using language [EN]
fixme:win:EnumDisplayDevicesW ((null),0,0x338344,0x00000000), stub!
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
err:module:import_dll Library DNSAPI.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\vivoxsdk.dll") not found
err:module:import_dll Library vivoxsdk.dll (which is needed by L"C:\\Program Files\\CCP\\EVE\\bin\\_vivox.dll") not found
An exception has occurred. It has been logged in the log server as exception #1


http://www.eveonline.com/ingameboard.asp?a=topic&threadID=811936 Top google result for "err:module:import_dll Library DNSAPI.dll"


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only