open All Channels
seplocked Macintosh
blankseplocked old Macbook and shader model 3.0
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

tpwh21
Posted - 2011.04.06 18:36:00 - [1]
 

I am playing on a macbook pro - a pretty old one - but i like it.
It has ATI X1600 card - which is supposedly shader model 3.0.
connecting to test server - get message that card is not sm 3.0 compliant.
anyone know what is going on here.
Am i soon about to be forced to use bootcamp - or going to have to buy a new laptop....
anyone got any clue what is going one here?

Malakai Draevyn
Caldari
Knights Of Anarchy
Shadow of xXDEATHXx
Posted - 2011.04.07 01:19:00 - [2]
 

Edited by: Malakai Draevyn on 07/04/2011 01:20:27
I am running on the 2008 'BlackBook' (Black Macbook) which has the Intel X3100 chipset running graphics - apparently this is supposed to be SM3.0 compliant as well, but again, the eve client decides that it's not and gives me the same 'Your graphics card doesn't support Shader Model 3.0 so facial customisation such as piercings scars etc will be removed' message.

When running the character customization process - I get this :

Character Creation Screenshot

Deep joy. Any clues, anyone ?

It's not as if the 2008 blackbook is an OLD machine....

CCP Gangleri


Minmatar
Posted - 2011.04.07 07:18:00 - [3]
 

The OS X driver for the x1600 doesn't fully support SM3 unfortunately, it's also the bare minimum supported currently and as such it is likely to become unsupported as we update our minimum requirements for future releases.

Intel X3100 isn't supported, it may well run the client but we do not develop with it in mind. See minimum system requirements here:
http://wiki.eveonline.com/en/wiki/System_Requirements

tpwh21
Posted - 2011.04.07 07:36:00 - [4]
 

great thanks for that.
obviously forgot that when i checked when the blog came out in october - is my laptop going to continue to work.
er yes - has a card that is SM 3.0 compliant.
Oh wait. It has a SM 3.0 card that isn't actually a sm 3.0 card, of course.
slightly irritated by this... (obviously)

CCP Gangleri


Minmatar
Posted - 2011.04.07 08:00:00 - [5]
 

Originally by: tpwh21
great thanks for that.
obviously forgot that when i checked when the blog came out in october - is my laptop going to continue to work.
er yes - has a card that is SM 3.0 compliant.
Oh wait. It has a SM 3.0 card that isn't actually a sm 3.0 card, of course.
slightly irritated by this... (obviously)


I understand your frustration, but there is very little I can do to convince Apple or ATi to spend time and resources supporting old hardware.

Rakshasa Taisab
Caldari
Sane Industries Inc.
Posted - 2011.04.07 11:11:00 - [6]
 

Uhm... This would have been nice to know a little sooner... ;/

/me wonders how he's supposed to get the money together for a new MBP in 2-3 months.

LiYuan
Posted - 2011.06.21 22:57:00 - [7]
 

So Incarna has ended (potentially) my ability to play eve..
Since the graphics requirements have gone up my macbook is no longer supported. So Dilemma. Do I somehow find $2000 for a new laptop so I can play a $20 a month game? or to I cut my losses and say adios? Crying or Very sad

Jass Sunrunner
Caldari
Posted - 2011.06.21 23:03:00 - [8]
 

Originally by: Rakshasa Taisab
Uhm... This would have been nice to know a little sooner... ;/

/me wonders how he's supposed to get the money together for a new MBP in 2-3 months.


simple answer, don't and download steam games instead, it'll be cheeper, you can also get sims3 for the mac, that's like CQ but more rounded ;)

Erksine
TH3 INF3CT3D
TH3 INF3CTION
Posted - 2011.06.22 05:16:00 - [9]
 

So... CCP loses $60 a month.

Thats my fix.

Karr Matt
Posted - 2011.06.22 05:22:00 - [10]
 

Did it really need to come to this?

Swiftshader - http://transgaming.com/business/swiftshader/faq/

Quote:

1) What is SwiftShader and how can I use it in my application?
The SwiftShader software GPU toolkit is a modular system capable of supporting 3D rendering through a variety of possible APIs and on several different hardware and operating system configurations. For example, the SwiftShader demo build includes support for DirectX® 9 Shader Model 3.0 on 32 and 64 bit Windows®. In other cases, SwiftShader might use a custom API specifically built to your specifications, and be deployed on several different operating systems and CPUs.

5) Will SwiftShader run on Linux® or Mac OS® X systems?
SwiftShader based renderers can run on Linux® and Mac OS® X systems directly or through TransGaming’s Cedega or Cider technologies. When running directly on these systems, an API front end other than Direct3D® is required.



Transgaming -- you know, the company that made this press release...
Quote:

EVE Online Available to Mac and Linux Users
Reykjavík, Iceland and Toronto, Canada - November 7, 2007 - CCP, one of the world's largest independent game developers, and TransGaming Inc, (TSX-V: TNG), a leading developer of software portability products for the electronic entertainment industry, today announced the availability of EVE Online, a leading massively multiplayer online game (MMOG), on the Macintosh and Linux platforms. With this release, EVE Online is now available on the most widely used operating systems - Microsoft Windows, Macintosh and Linux.

Dekiri
Gallente
Useless Inc.
Posted - 2011.06.22 08:36:00 - [11]
 

they should really get a fix in for this. It can't be that hard to let us run it without the shaders on older macbooks. As long as we don't enter CQ I can't see a problem really.

T3RMi3
Posted - 2011.06.22 09:11:00 - [12]
 

Edited by: T3RMi3 on 22/06/2011 09:14:24
I'm using a macbook pro with an ATI X1600 too. I'm also unable to run eve client after the Incarna update. My graphics card supports Shader model 3 but eve client refuse to launch. Please provide i fix for that before the end of the month were i have to renew my 3 accounts subscriptions.

Regards,

Rob Swanson
Posted - 2011.06.22 18:34:00 - [13]
 

Originally by: CCP Gangleri
The OS X driver for the x1600 doesn't fully support SM3 unfortunately, it's also the bare minimum supported currently and as such it is likely to become unsupported as we update our minimum requirements for future releases.

Intel X3100 isn't supported, it may well run the client but we do not develop with it in mind. See minimum system requirements here:
http://wiki.eveonline.com/en/wiki/System_Requirements



Any idea if bootcamping Windows XP or 7 with the X3100 chipset would make EVE run?

Kenny Sin
Posted - 2011.06.22 18:36:00 - [14]
 

Originally by: CCP Gangleri
Originally by: tpwh21
great thanks for that.
obviously forgot that when i checked when the blog came out in october - is my laptop going to continue to work.
er yes - has a card that is SM 3.0 compliant.
Oh wait. It has a SM 3.0 card that isn't actually a sm 3.0 card, of course.
slightly irritated by this... (obviously)


I understand your frustration, but there is very little I can do to convince Apple or ATi to spend time and resources supporting old hardware.

lolwut? you're the ones not spending time or resources to make your game run on old hardware. maybe just give us the option to turn all of this new crap off? or you could stop updating the graphics and start working on all of the other in game problems because this game is a big enough lagfest as it is? Rolling Eyes

Mad Hops
Caldari
Posted - 2011.06.22 19:04:00 - [15]
 

I don't see how slightly nicer looking guns and a seriously overpriced, unrelated CQ is worth losing the huge Mac market share. I mean honestly, who overlooked such a blatantly obvious issue?

Chase Mesara
Minmatar
Celestite Shepherd Industries
Posted - 2011.06.23 04:49:00 - [16]
 

Originally by: Mad Hops
I don't see how slightly nicer looking guns and a seriously overpriced, unrelated CQ is worth losing the huge Mac market share. I mean honestly, who overlooked such a blatantly obvious issue?


I have said it once and I will say it again... CCP doesn't really care about Mac users and its really sad. Blizzard does a much better job at catering to Mac customers and maybe that's why WoW is the #1 MMO :/

Devilldog
Posted - 2011.06.25 03:43:00 - [17]
 

well, i guess ill be selling everything and letting my three subscriptions end. Your company may not think my $45 a month is much (or $540.00 a year) but when you start loosing hundreds of accounts you will. This isnt a threat, its a promise.
ugh

Devilldog
Posted - 2011.06.25 03:50:00 - [18]
 



 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only