open All Channels
seplocked Market Discussions
blankseplocked Eve Trader for iPhone app looking for beta testers
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

Reana
Posted - 2011.03.30 19:53:00 - [1]
 

Edited by: Reana on 30/03/2011 19:53:26
Hello fellow players,

I have developed an iPhone app to keep track of my sales in EVE Online. It works fine for me, but I'd like to hear a second opinion. If you would like to test drive the app before it's released on the app store, just send an email to evetrader (at) gmx.de and tell me what makes you the perfect tester.

If more than 15 people reply, I'll totally randomly select 15 as the chosen ones.

You'll need an iOS device with at least iOS 4.1 and the willingness to enter your full API key into the app, and I'll need your device ID, but we come to that once the choosing has been done.

A quick sketch for a website should be online at http://www.evetrader.de within the next 48 hours or so.

Best regards
Reana and the EVE Trader for iPhone app dev team

Hexxx
Minmatar
Posted - 2011.03.30 20:12:00 - [2]
 

Just wanted to say good luck, and that you should probably keep an eye on a future dev blog. Very Happy

Moto Akimoto
Posted - 2011.04.04 22:13:00 - [3]
 

Hello Reana,

How is this app coming along?

Umbriele
Gallente
Natural Inventions
Solyaris Chtonium
Posted - 2011.04.07 13:22:00 - [4]
 

Awasome, I already use two eve related apps on my iphone4, it would be nice to do something for the ipad also

Reana
Posted - 2011.05.31 07:57:00 - [5]
 

*Note to self*: keep checking the forum for replies.

Well, the app is online now. Search the App store for EVE Trader, it's free. Of course.

Rule18
Capsuleer Races And Violent Events Inc.
Posted - 2011.05.31 09:41:00 - [6]
 

/me droid

...

/me ;-(

ep0c x
Posted - 2011.05.31 10:50:00 - [7]
 

This is really handy- thanks a lot :)

Caleb Ayrania
Gallente
TarNec
Posted - 2011.05.31 10:56:00 - [8]
 

Droid version?

Or is this a "drones" hostile app ?Wink


Siri Buelle
Gallente
regener8ted inc
Posted - 2011.05.31 14:56:00 - [9]
 

im liking the reports

Emma d'Acques
Gallente
Ortog Promethium Industries
Posted - 2011.06.01 15:20:00 - [10]
 

I downloaded the app to my iPhone (version 4.2.1), but I can't seem to get my characters to show in it.

I've tried by importing an existing contact from my addressbook, once with the corporation set to iClone, once to EVETrader.
I also tried to add characters by manually entering my Account ID and Full API, but it keeps getting stuck on "Loading data. Please wait..."
Turning the iPhone off and on again didn't help either :(

Has anyone encountered this same problem yet, and if so, how have you solved it?
I would really like to try out this app, as I think that it offers a bit more functionality in regards to trading over iClone.
Should I perhaps try re-installing the application?

CLONE 637A
Posted - 2011.06.03 19:58:00 - [11]
 

Fantastic app ! It has turned into my most used app on my iPhone :)
Good job. Razz

Reana
Posted - 2011.06.06 14:56:00 - [12]
 

Thanks for the positive feedback! If you have anything you would like to see added to the app, let me know.

Unfortunately there won't be an Android app, simply for the reason that I lack the time and an Android phone ;-(

@Emma: funny, now that you mention it, when entering the API data manually I have the same problem. Will look into that. Importing from the address book however should be working fine, just make sure you have made an address book entry like this:

Name: My Account <- this will be the account name in EVE Trader
Corp: iClone <- (not really necessary ATM)
Notes:
24680,8723495872340958234c5n234vn902387390248503958xs2349085n

Then tap 'Accounts settings' -> 'Import from address book' and select the above entry from the address list.

Let me know if that works out for you. I'll have a look at the manual import part.

BR/Reana

Ibn Faldan
Posted - 2011.06.07 01:43:00 - [13]
 

Be cool, my babies,

Native apps are great n' all, but they're a transient solution. In the right hands, a good stylesheet and web page can do the job. Those hands belong to me... I'm currently developing TradeHub (tentative name) and will include mobile support to adjust interface to fit any mobile browser user agent, be it iPhone or Droid.

Emma d'Acques
Gallente
Ortog Promethium Industries
Posted - 2011.06.07 09:44:00 - [14]
 

Reana,

I have tried via the manual and Addressbook way, but both would not work.
As I also used iClone, I used the existing contacts, that do work with iClone.

However, I went over all the address details again, and it seems my iPhone somehow snuck an extra unwanted space after the comma.
Deleted the space, and lo and behold, I'm not enjoying Eve Trader :)

Thx for the app, it has been an eye opener.

I do have one question though:
In my Buy Orders listing, I see some items as Unknown (itemid), any thoughts on what the cause is?
Is this API or perhaps app related?

Namira Incendie
Minmatar
Valor Enterprises
Posted - 2011.06.08 02:04:00 - [15]
 

I have been using Eve Trader on my iPad recently and love the interface. Do you have any plans for extending it to manage corp market orders?

Reana
Posted - 2011.06.09 06:57:00 - [16]
 

@Emma:
that's good to hear. I have fixed the flaws that caused you being stuck with the "Loading..." message when the credentials are faulty, but it's not submitted to the App store yet. But I seriously hope that you are "_now_ enjoying" it instead of "_not_ enjoying"...

The 'Unknown' market orders are for items that you have not bought or sold yet. Unfortunately the EVE API gives item names only for buy and sell transactions, for orders there's only a number. In order to translate that number to a name, Eve Trader must look it up in the transactions list. Hence: no transaction -> no name. I might include an item database in the future, but for now I wanted to keep the memory footprint of the app small.

@Namira, I'd like to include corp transactions as well, but at the moment I don't have access to the needed data for development and testing. If you know a PvE-oriented corp in low-sec that gives Junior Accountant roles to new members, let me know!

@Ibn Faldan: if you prefer web applications, what's wrong with eve-commander.com?

Emma d'Acques
Gallente
Ortog Promethium Industries
Posted - 2011.06.09 07:49:00 - [17]
 

Reana, thanks for the answers.
This is what I thought, and also noticed, but a reply from the appcreator is always the most correct imho.

And yes, that should read "NOW"... I don't know how I was able to make that kind of typo... n and w aren't exactly next to each other.

Bir'mata
Posted - 2011.06.10 08:18:00 - [18]
 

Hi there!

I really like this handy little tool, but i have one issue:

The "item statistics" is empty. It shows nothing at all, but all other menus seem to work properly.

Any tips?

Cheers
Bir

Daigunzen
Posted - 2011.06.13 05:22:00 - [19]
 

"shopping cart" and "Item Statistics" are empty. I'm specifically interested in this app just for items statistics. Transactions, reports, and market orders are all working fine. Any suggestions?

Reana
Posted - 2011.06.13 10:41:00 - [20]
 

Hmm, I've never encountered empty Item Statistics before, that's strange.

The shopping cart is empty by default, it is filled when you go to Item Statistics and use the "+" button to add items to the cart. Hence 'No statistics' -> 'Empty cart'.

I'll have a look into that stats thingy.

Reana
Posted - 2011.06.13 10:49:00 - [21]
 

One more thing about the item statistics: Bir'mata and Daigunzen, can you export your transactions and then use iTunes to download the file from your iPhone and have a look inside? It's plain text and should be a comma-separated list with one line per transaction, with non-empty and non-zero values in each column (except for the private column, which may be 0). If the file contains empty columns, I'd like to know.

Bir'mata
Posted - 2011.06.13 23:24:00 - [22]
 

Hmm, when i push those buttons (import and export) nothing happens. Im using an ipad, maybe thats the reason for trouble...?

Reana
Posted - 2011.06.14 12:31:00 - [23]
 

Bil'mata, nothing happening is not a problem. Once the button is deselected (you'll notice it turn's blue when you press it and then white again when you release?), the import or export is completed, there is no further feedback (irritating, I know, I'll address that in a later issue).

Nevertheless, when you connect the iPad to iTunes, click on the iPad in the left column of iTunes, select the 'Apps' tab and scroll down, you should be able to see a list of applications and the files they have available for download. For the Eve Trader app, there should be a file with an ".evetrader" ending, that you can download from the iPad and open in a text editor of your choice.

Daigunzen
Posted - 2011.06.15 22:00:00 - [24]
 

I opened the transactions file with notepad and to me its just a huge ball of text. Can't exactly tell what I'm looking for. Here are the top few lines

CHARACTERID;NAME;DATUM;TRANSID;QUANTITY;TYPE;PRICE;CLIENTNAME;STATIONNAME;STATIONID;TRANSACTIONTYPE;TRANSACTIONFOR;PRIVATE;CLIENTID;TYPEID
90589758;Daigunzen;2011-06-09 23:20:00;1842781142;925;Nocxium;465.07;CookieCake;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;1677154865;38
90589758;Daigunzen;2011-06-09 23:21:00;1842781925;10000;Nocxium;488.97;TheSeraph Crendraven;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;sell;personal;0;90558164;38
90589758;Daigunzen;2011-06-09 23:22:00;1842782609;100;Iron Charge M;13.51;Siggason Shi;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90606677;223
90589758;Daigunzen;2011-06-09 23:22:00;1842782905;400;Lead Charge M;35.31;Siggason Shi;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90606677;226
90589758;Daigunzen;2011-06-09 23:22:00;1842782940;200;Lead Charge S;4.57;Siggason Shi;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90606677;218
90589758;Daigunzen;2011-06-09 23:22:00;1842782517;200;Iridium Charge M;13.01;Siggason Shi;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90606677;225
90589758;Daigunzen;2011-06-09 23:23:00;1842783382;200;Uranium Charge M;15.35;Siggason Shi;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90606677;228
90589758;Daigunzen;2011-06-09 23:23:00;1842783862;500;Iridium Charge M;13.01;Bear aviator;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90670694;225
90589758;Daigunzen;2011-06-09 23:23:00;1842784074;100;Iron Charge M;13.51;Bear aviator;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90670694;223
90589758;Daigunzen;2011-06-09 23:24:00;1842784311;300;Lead Charge S;4.57;Bear aviator;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90670694;218
90589758;Daigunzen;2011-06-09 23:24:00;1842784220;300;Lead Charge M;35.31;Bear aviator;Dodixie IX - Moon 20 - Federation Navy Assembly Plant;60011866;buy;personal;0;90670694;226
90589758;Daigunzen;2011-06-09 23:25:00;1842784926;100;Uranium Charge M;15.35;Bear aviator;Dodixie IX - Moon 20 - Federation Navy Assembly

It goes on like that for another 100+ lines

Rob Paladon
Posted - 2011.06.15 22:05:00 - [25]
 

Looks good! Buy i dont know how the export function works. Besides that.. i once had a incorrect cash showed.

Baron vonSteubing
Posted - 2011.06.23 02:43:00 - [26]
 

Reana,

I'm seeing a bunch of duplicates. For instance, it says I have 600 of one item in stock but when I log in I only have 100. The numbers are oddly exact. Any idea what this is about?

Zaky Zee
Posted - 2011.06.25 09:22:00 - [27]
 

I've been using your app for a couple of days now. There are a few issues.

It is very hard to get the account to be recognized as some have previously said. Whether you do the address book route or putting it in directly. I tried both and could not get it to work. Eventually I went into iClone and copied the information directly from iClone and pasted it in to get it working. A suggestion would be to set it up like EVEUniverse does where you can log in, copy all of the API info (including user id and such just like the website gives you, then hit a button to put the account into your app automatically from that data.

Even though you put in your buy and sale rates, when looking at your transactions and profit, it does not take into account any broker's fees and such. Therefore it is showing a larger profit than you actually made.

The item statistics is blank.

And I don't think it is ignoring previously cached data as it should be because each time I update I get a duplicate of previous transactions. Therefore when I updated the first time it showed all the transactions I did just fine. Then I updated again and now it shows two of every transaction. Then again and it shows three of every transaction.

Hope this helps you debug it for the next updated version.

Aurora Sweetness
Posted - 2011.06.27 06:42:00 - [28]
 

Hey Reana.

First of all, GREAT app!
I love the reports and the net profit :)
Like zaky, ive also had some duplicate items showing up in my reports.
Must be an affect from the incarna patch i guess.?

Tnx again. Very Happy



Reana
Posted - 2011.06.29 09:46:00 - [29]
 

Hi all,

again, thanks for the feedback.

The duplicates are are known (and new) feature, seems that the app doesn't like the new larger transaction IDs. I'm looking into that. The duplicated transactions will be removed in the next update.

The costs for buying, selling and transportation (which are entered on in the preferences) are indeed only calculated for the reports. I'll add that to the transaction details later.

Fly safe everyone,
Reana

Reana
Posted - 2011.06.30 12:48:00 - [30]
 

Hi all,

Eve Trader Version 1.0.1 has been submitted to the App Store. It fixes the duplicates (they will clear up when you refresh your data) and the manual account adding.

Next stop: Visual feedback during import and export.

Fly safe,
Reana


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only