open All Channels
seplocked EVE Information Portal
blankseplocked New Dev Blog: Shader Model 2.0 support discontinued April 5th
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2 3 4 5 6 7

Author Topic

CCP Fallout

Posted - 2011.03.21 10:49:00 - [1]
 

CCP Zulu's newest dev blog provides more detail about Shader Model 2.0 support. Read all about it here.

Jamaican Herbsman
I Love You Mary Jane
Posted - 2011.03.21 10:52:00 - [2]
 

Edited by: Jamaican Herbsman on 21/03/2011 10:52:02
first

edit: oops

mechtech
SRS Industries
SRS.
Posted - 2011.03.21 10:55:00 - [3]
 

9,000 people use SM2? Not over 9000?

Yea, everything's fine then.

(I fully support this move, eve's superb graphics are a big hook for getting new players)

Hachi Ironfist
Gallente
Rubbish and Garbage Removal
Atlas.
Posted - 2011.03.21 10:56:00 - [4]
 

IBTC!

Maybe we can expect DX10/11 in the near future :O ? That would be awesome :D

Chribba
Otherworld Enterprises
Otherworld Empire
Posted - 2011.03.21 11:15:00 - [5]
 

Noooo what will my poor 286 do now!?!

/c

Thomas Gallant
Gallente
St Andrews
Posted - 2011.03.21 11:23:00 - [6]
 

Hmm does this mean that a big upgrade to graphics will be coming soon? Here's hoping for shinier internet spaceships

Daneel Trevize
Gallente
Posted - 2011.03.21 11:24:00 - [7]
 

But why is there a need for a grace period if we can recustomize whenever??

DTson Gauur
Caldari
Blend.
Nulli Tertius
Posted - 2011.03.21 11:27:00 - [8]
 

I hope this means that there will also be an external way coming (read: EveGate) to change the skill queue, your decision just killed about all netbooks which quite happily run the current client enough to chat and manage skills etc.


Maul555
Amarr
Reliables Inc
BricK sQuAD.
Posted - 2011.03.21 11:28:00 - [9]
 

Awesome... I had no idea you guys where supporting video cards that are 8+ years old. Don't worry, these people already knew they needed an upgrade long before this.

Illwill Bill
Svea Crusaders
Posted - 2011.03.21 11:32:00 - [10]
 

Edited by: Illwill Bill on 21/03/2011 11:32:38
Meh, can't blame you guys.

So, can anyone recommend a netbook with decent battery life and SM3? I "need" my Eve fix when traveling.

Edit: This better be needed for the new AWESOME cyno effect you promised! Wink

Captian Conrad
Minmatar
Empyrean Warriors
Posted - 2011.03.21 11:43:00 - [11]
 

Wont need upgrading, but BIG KUDOS TO CCP for trying to partnership with a GPU vender for those 9k souls, 1st company i know that has tryed to Very Happyugh

ArchenTheGreat
Caldari
Pulsar Nebulah
Army of Lovers.
Posted - 2011.03.21 11:49:00 - [12]
 

Originally by: DTson Gauur
I hope this means that there will also be an external way coming (read: EveGate) to change the skill queue, your decision just killed about all netbooks which quite happily run the current client enough to chat and manage skills etc.



Unlikely. It will allow to create bot farms automatically growing new characters. HTTP is too easy to automate. CCP wants people to log into the game.

You can chat using EVE Gate. Changing skills is off limits.

Ti Chi
Minmatar
Duct Tape Mechanics
Posted - 2011.03.21 12:04:00 - [13]
 

Originally by: Illwill Bill
Edited by: Illwill Bill on 21/03/2011 11:32:38
Meh, can't blame you guys.

So, can anyone recommend a netbook with decent battery life and SM3? I "need" my Eve fix when traveling.

Edit: This better be needed for the new AWESOME cyno effect you promised! Wink


I use an Asus, with Nvidia ION graphics, supports SM4, gets a good 5 hours battery life when doing normal work. There should be a whole range of new devices what will handle it fine, with all the SoC ships coming out.

Patient 2428190
DEGRREE'Fo'FREE Internet Business School
Posted - 2011.03.21 12:10:00 - [14]
 

Is the Shader 3.0 requirement going to be for EVE Online (the spaceships) or is going to be for Carbon/Incarna/Beta for WoD?

Karbowiak
Sniggerdly
Posted - 2011.03.21 12:10:00 - [15]
 

Originally by: Illwill Bill
Edited by: Illwill Bill on 21/03/2011 11:32:38
Meh, can't blame you guys.

So, can anyone recommend a netbook with decent battery life and SM3? I "need" my Eve fix when traveling.

Edit: This better be needed for the new AWESOME cyno effect you promised! Wink


This might sound biased and whatnot..
But a 13" MBP will run EVE nicely, the 2010 model - not the 2011 model..
The SandyBridges graphics card is just not powerfull enough - and its all there is in the 2011 model :(

But the 13" 2010 MBP is quite cheap now, and has a 10h battery life - even when running Windows as primary OS, incase you dont like OSX :)
Oh and they are cheap now the 2011 model is out aswell Wink

Shandir
Minmatar
Brutor Tribe
Posted - 2011.03.21 12:14:00 - [16]
 

Edited by: Shandir on 21/03/2011 12:15:19
Wow, actually going as far as getting a discount for those users. Nice one, though I don't need it.
I have to admit, '8 year old technology' is a bit disingenuous if there are a lot of netbooks currently employing it, although the technology may be 8yo, the systems which are built upon it are not always.
I suggest you edit your blog to clarify this before a netbook user gets an unhappy surprise.

Edit: Grammar fail.

Dariously Primrose Penken
Posted - 2011.03.21 12:29:00 - [17]
 

It just really goes to show how far out of touch CCP is with its player base. Yes we like eve, and we can all agree its pretty shiny now, why don't you fix whats wrong with it, instead of covering it up with eye candy in the hopes that the players will be lulled into joygasmic bliss.

If I gave you a nice shiny sports car, with all the latest tech inside of it, but no place for a motor, batteries or any such other means of propulsion or power, and no way of installing such things, would you still want it? Yet we the player base see this happening on a continuing basis, and we still see ccp glossing things over with making things shiny.

Jason Edwards
Internet Tough Guy
Spreadsheets Online
Posted - 2011.03.21 12:30:00 - [18]
 

sse2 req... shader 2 drop. Jeese how long until I need to upgrade my comp?

Amd 1090t
16 gigs ram
2x HD 5770
intel x25m v2 ssd
6tb hds

I bet AES instructions become mandatory soon and makes my comp obsolete.

Dierdra Vaal
Caldari
Veto.
Veto Corp
Posted - 2011.03.21 12:44:00 - [19]
 

Quote:
we are working on securing a discount deal with a graphics card vendor


let me guess: nvidia? :P

Considering SM3 cards are dirt cheap, it shouldnt be a burden for people.

drinking12many
Minmatar
Nine Inch Ninja Corp
Posted - 2011.03.21 12:46:00 - [20]
 

Originally by: Jason Edwards
sse2 req... shader 2 drop. Jeese how long until I need to upgrade my comp?

Amd 1090t
16 gigs ram
2x HD 5770
intel x25m v2 ssd
6tb hds

I bet AES instructions become mandatory soon and makes my comp obsolete.



Hmm im guessing somewhere around 2018 Laughing

Patient 2428190
DEGRREE'Fo'FREE Internet Business School
Posted - 2011.03.21 12:49:00 - [21]
 

Originally by: Dariously Primrose Penken
It just really goes to show how far out of touch CCP is with its player base. Yes we like eve, and we can all agree its pretty shiny now, why don't you fix whats wrong with it, instead of covering it up with eye candy in the hopes that the players will be lulled into joygasmic bliss.

If I gave you a nice shiny sports car, with all the latest tech inside of it, but no place for a motor, batteries or any such other means of propulsion or power, and no way of installing such things, would you still want it? Yet we the player base see this happening on a continuing basis, and we still see ccp glossing things over with making things shiny.


Fixing/balancing EVE Online <<<<< Making the graphics engine for the new game(s) coming out with the Carbon framework.

Shalune Regyri
Minmatar
Posted - 2011.03.21 13:03:00 - [22]
 

ITT whiners who have sm3 anyway. And people who dont care. No people without sm3 whining.

Gavjack Bunk
Gallente
Genos Occidere
HYDRA RELOADED
Posted - 2011.03.21 13:07:00 - [23]
 

If only you were banning 9000 bot accounts rather than 9000 genuine accounts I wouldn't have to hold you in massive contempt.

Minsc
Gallente
Alpha Empire
Posted - 2011.03.21 13:07:00 - [24]
 

Originally by: Dariously Primrose Penken
It just really goes to show how far out of touch CCP is with its player base. Yes we like eve, and we can all agree its pretty shiny now, why don't you fix whats wrong with it, instead of covering it up with eye candy in the hopes that the players will be lulled into joygasmic bliss.

If I gave you a nice shiny sports car, with all the latest tech inside of it, but no place for a motor, batteries or any such other means of propulsion or power, and no way of installing such things, would you still want it? Yet we the player base see this happening on a continuing basis, and we still see ccp glossing things over with making things shiny.


Where have you been the past few months. CCP has been releasing dozens of little fixes that many people have been clamoring for since the game launched and continue to do so. If you're little troll was just supposed to be a thinly veiled *fix lag* rant then seriously, get new argument. Lag will never fully be solved. Even when they manage to redesign the server code to support dynamic load balancing it will likely STILL pop up from time to time. If you can't accept that then find another game genre cause lag is inevitable in MMO's.

Also your whole second paragraph just shows how clueless you are. FYI the graphics ENGINE is the second most important component of the game behind the server code and has a huge impact on game performance.

Yuda Mann
Posted - 2011.03.21 13:23:00 - [25]
 

Shader 3 was first supported on the ATI Radeon R520 (x1300) and GeForce 6xxx series. Unbelievable that people are actually whining that a game in 2011 won't support those cards.
It's also well and commonly known that you don't buy a netbook if you want to play current, modern games. Too bad if your non-gaming netbook won't be able to play a game. Whining about it just makes you look stupid.

LarpingBard
Posted - 2011.03.21 13:33:00 - [26]
 

Edited by: LarpingBard on 21/03/2011 13:55:30
Actually, my shiny new 2010 computer only supports the SM 2.0. My ancient P4 that barely runs eve has a SM 3.0 card. Go figure.

Well. It's time to stop whining and stop playing eve. And I think the numbers are higher than what they are saying.

I petition each of the CSMs to make their position known on this issue. And we demand the right to attempt to recall our representatives if they do not support us.

Katrina Bekers
Gallente
Fighters Squadron
Posted - 2011.03.21 13:36:00 - [27]
 

Eight years old graphic cards, huh?

Ok, CCP, nice move and all, but AT VERY LEAST try and be honest with this.

You're shoving down our throat this change. You do it to cut costs, to improve the product, to get rid of legacy, whatever. But at least don't pretend we're dumb or idiot.

The very machine I'm writing this stuff on is a run-of-the-mill office rig (HP DC7800P) with a low-spec graphic card integrated in the Intel Q35 chipset servicing the Core2Duo E8400 CPU.

- It supports SM2.0
- It doesn't support SM3.0 (checked with the app linked in the devblog)
- It is still perfectly adequate for running low intensity tasks ingame like trading, POS caring, PI, hi-sec logistics and social stuff (chat, .
- Probably won't be able to do that once you "discontinue" SM2.0.
- It cannot be upgraded, as it's a work asset I'm allowed to use only after my daytime job is over and I relax a bit before going home.
- Most important, it's a chipset released in June 2007 (reference). That's less than FOUR years ago. Not eight.

Thank you for reducing my play options.

Razin
The xDEATHx Squadron
Legion of xXDEATHXx
Posted - 2011.03.21 13:36:00 - [28]
 

Does this mean we're getting engine trails and a better cyno effect in the 'summer expansion'?

Gallell
Gallente
Posted - 2011.03.21 13:44:00 - [29]
 

Edited by: Gallell on 21/03/2011 13:51:05
Sounds good, but computer manufacturers seem to go for the "cheep" graphic cards (sm 2.0, not sm3.0: in other words: Intel crap) which is a bit sad.

So just port the game to OpenGL (and make a native mac client ;) ), no problems :P


In any case, sounds like a good plan.


EDIT: a quick look on Google and it seems like sandy bridge do have support for SM4, but only "data sheets" text and no tech tests.

Celgar Thurn
Minmatar
Department 10
Posted - 2011.03.21 13:48:00 - [30]
 

Edited by: Celgar Thurn on 21/03/2011 13:48:49
It's a bit of a pain for luddites like me. I will use the 'handy little app' link to see If my graphics card has Shader 3.0 or not. Personally I would rather CCP fix non-lag related problems such as making the Corporation Management system more user friendly than do things like this. *bashes head against a brick wall* Embarassed


Pages: [1] 2 3 4 5 6 7

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only