open All Channels
seplocked Linux
blankseplocked Ubuntu 10.04 wine 1.3 ATI HD4800 lock up
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Zeminy
Minmatar
The Knights Templar
R.A.G.E
Posted - 2011.03.01 23:50:00 - [1]
 

Eve loads up and then the system seems to lock up any suggestions?

:~$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4830
OpenGL version string: 3.3.10524 Compatibility Profile Context

Wine output:
A traceback has been generated. It has been logged in the log server as stacktrace #1
A traceback has been generated. It has been logged in the log server as stacktrace #2
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #46:
fixme:d3d_shader:print_glsl_info_log Vertex shader(s) linked, fragment shader(s) linked.
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #49:
fixme:d3d_shader:print_glsl_info_log Vertex shader(s) linked, fragment shader(s) linked.
Service sov: 0.001s
Service channels: 0.000s
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #52:
fixme:d3d_shader:print_glsl_info_log Vertex shader(s) linked, fragment shader(s) linked.
fixme:d3d_shader:print_glsl_info_log Error received from GLSL shader #56:
fixme:d3d_shader:print_glsl_info_log Vertex shader(s) linked, fragment shader(s) linked.
Service onlineStatus: 0.000s
Service neocom: 6.130s
fixme:mixer:ALSA_MixerInit No master control found on HDA ATI HDMI, disabling mixer
err:alsa:ALSA_CheckSetVolume Could not find 'PCM Playback Volume' element
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
err:ntdll:RtlpWaitForCriticalSection section 0x7e6f4d00 "x11drv_main.c: X11DRV_CritSection" wait timed out in thread 0037, blocked by 0023, retrying (60 sec)



Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.03.02 18:04:00 - [2]
 

The crash occur when you load EVE or when you load your char and entering the game?

Zeminy
Minmatar
The Knights Templar
R.A.G.E
Posted - 2011.03.02 23:20:00 - [3]
 

Originally by: Ravow
The crash occur when you load EVE or when you load your char and entering the game?


After my character selection.

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.03.03 17:53:00 - [4]
 

You have 1 work around and 1 solution

WORKAROUNG:
1>Get another PC (a old laptop maybe) to ssh to your computer
2>Load EVE on your computer but don't log-in
3>with the other computer, log into ssh in root and type "ps -A | grep ExeFile"
4>write "kill <the pid of ExeFile.exe you just loaded>" in the same terminal as #3 but don't press enter now
5>Log in EVE, click on your char
6>if the loading line stop for more than 3-4 secondes or if eve hanged, go to the terminal and press Enter... And return to #2. Failure to do so for more than about 10 seconds will lockup the whole system

SOLUTION:
If you don't plan to play another big/high-tech game:
Remplace the ATI Catalyst blob by the open source drivers. You will need the libtxc-dxtn lib for S3TC and GIT version of the kernel (with a patch), libdrm, mesa and DDX X drivers..
In other term, you can fix this crash bug but you need to compile stuff :D

What is your Linux distribution?

Zeminy
Minmatar
The Knights Templar
R.A.G.E
Posted - 2011.03.15 15:12:00 - [5]
 

Originally by: Ravow


What is your Linux distribution?


Sorry for the late reply been a little preoccupied.
I was originally running the open source driver but I figured that was the problem and installed the ATI driver. Guessing that was not the solution.
I am running Ubuntu 10.04.
I have no problem with compiling a better driver. My interest is only really EVE.



 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only