open All Channels
seplocked Linux
blankseplocked Ubuntu 10.10 + HD4800 -> locks up
This thread is older than 90 days and has been locked due to inactivity.

Author Topic

Mnengli Noiliffe
Posted - 2011.02.28 08:04:00 - [1]

Edited by: Mnengli Noiliffe on 01/03/2011 06:25:53
Almost didn't work with default drivers (no texture, icons missing, LOCKUP) but when I installed proprietary drivers it looks fine.

However it still locks up completely after a few seconds after successful launch. So I have to kill the process.

Does not matter - in station, in space - all the same, locks up shortly after start.

I even disabled station environment - still locks up, so perhaps it's not graphics related.

There is no apparent trigger, apart from the time passed.

wine version is 1.2.2 from Ubuntu repository

P.S. sorry, I noticed similar post below, installed wine 1.3.14 and it works.

Mnengli Noiliffe
Posted - 2011.03.01 06:29:00 - [2]

Edited by: Mnengli Noiliffe on 01/03/2011 06:32:10
ok it's not really solved.

it still locks up after the start, but now not always (maybe like 1/3 chance or about that). Generally if a few minutes passed from the character login it's ok and it won't lock up in this session.

So during character login, and sometimes a few seconds after successful character login, it still locks up sometimes. But this time it's not only the Eve client that can be killed, it's the whole computer. I can still move the mouse cursor, but nothing else responds at all so the only way is to power down the machine.

Sevarus James
Meridian Dynamics
Posted - 2011.03.01 10:29:00 - [3]

Edited by: Sevarus James on 01/03/2011 10:29:57
You need to run the logserver and post the last bits it shows when the client locks up.

BUT, something sounds fishy with the lockups. If you only have mouse cursor, but nothing else...possibly corrupted video driver install?

Cosmic Encounter
Posted - 2011.03.01 16:02:00 - [4]

Edited by: Ravow on 01/03/2011 16:02:55
I have the same problem on FGLRX.
I used to have a rs232 terminal ready with the killall ExeFile.exe ready just in case. You need a terminal or another computer with SSH and you need to kill EVE in less than 5 to 10 seconds if you don't want the computer crash.

This bug is gone since I switched to the Gallium r600g driver so it's Catalyst related or a Wine->Catalyst issue.

Mnengli Noiliffe
Posted - 2011.03.02 10:09:00 - [5]

yes, killing through ssh helps.

oh well i will have to retry until its stable then

Inner Fire Inc.
Posted - 2011.03.02 17:08:00 - [6]

Did you rename the Jukebox directory? I see that you're not using a recent wine 1.3 beta but 1.2.2, and I don't think the Jukebox lockup has been fixed in 1.2.2.

cd ~/.wine/drive_c/Program\ Files/CCP/EVE/res/audio/
mv Jukebox Jukebox.HIDE

Then try running EVE. If this fixes it then the Jukebox was causing the lockups.

Cosmic Encounter
Posted - 2011.03.02 17:55:00 - [7]

He tried Wine 1.3.14 and his problem is still there. I still have it to.

The only way to fix it that I know, is to use Open source ATI drivers GIT{kernel,drm,mesa,ddx} instead of the binary blob{fglrx}.

In prime, you get 100% tear free video so you can enjoy watching show during you wait in you belt... ;)

Mnengli Noiliffe
Posted - 2011.03.05 06:35:00 - [8]

with those drivers I get missing icons and textures :(

Cosmic Encounter
Posted - 2011.03.06 16:46:00 - [9]

The texture and icons *was* missing because S3TC texture compression *was* not supported.

But now, it's implemented with an external lib to protect again stupId Patent.

You need to have libtxc_dxtn installed
And you need latest GIT {kernel,libdrm,mesa,DDX}.

I can help if you want... I need to check for Ubuntu...

You have 32 or 64BIT distribution? If you have the 64bit, we will need to compile in double to have 32 and 64 libs.


This thread is older than 90 days and has been locked due to inactivity.


The new forums are live

Please adjust your bookmarks to

These forums are archived and read-only