open All Channels
seplocked Linux
blankseplocked Textures with intel graphics chip...
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

SamhainSigh
Posted - 2011.02.26 23:26:00 - [1]
 

is there a fix?

My issue is with compressed textures on my laptop (lenovo t410 with a core.i5 with the intel graphics)... almost half the textures bork while rendering. PI is utterly unusable and several buttons on the neocom are blank as well as many (most?) ship textures.

Is there a better intel driver that I just havent found? I usually install the one that can be found in ubuntu repos...

Anyone have a core i5 using the intel hd graphics that doesn't have a a textures problem?

I'd love to get back to linux... but eve is my crack and I use win7 in the interim.

Aerryn Sural
Posted - 2011.02.27 05:43:00 - [2]
 

I am having exactly the same issue with my own Lenovo (X201, Intel i5 64bit, 4gb RAM) and again same issues, ship textures, station textures, hanger, & various random buttons (modules, left hand menus) all show up as black.

I have not found a solution for this problem yet but would really like to find a solution other than using my work laptop with Win7 for my Eve needs

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.03.01 13:34:00 - [3]
 

Edited by: Ravow on 01/03/2011 13:37:16
You need S3TC texture support.

radeon opensource driver got it on February 10th and LLVM/Softpipe have it too.

You can add them to your drivers but you will probably need to guess the DXT1/3/5 ID because patent infected so Intel will not implement or document them.

The other way would be to ask CCP if they can add a "no texture compression" checkbox in EVE options...

GL_S3_s3tc
GL_EXT_texture_compression_dxt1
GL_EXT_texture_compression_s3tc


EDIT: If you fake s3tc support in .driconf, you will get rid of the black squares on some module/thing but what is white... will stay white... That is "OK" for gatecamping.

SanguineSkye
Posted - 2011.03.10 22:11:00 - [4]
 

Originally by: Ravow
You need S3TC texture support.

You can add them to your drivers but you will probably need to guess the DXT1/3/5 ID because patent infected so Intel will not implement or document them.

The other way would be to ask CCP if they can add a "no texture compression" checkbox in EVE options...

GL_S3_s3tc
GL_EXT_texture_compression_dxt1
GL_EXT_texture_compression_s3tc


EDIT: If you fake s3tc support in .driconf, you will get rid of the black squares on some module/thing but what is white... will stay white... That is "OK" for gatecamping.


Thanks for this. By faking the s3tc support and eliminating the "black squares" will it just replace them with blank spots :) or will it actually display the texture correctly? Or is this the type of thing I have to try to find out? :D

SamhainSigh
Posted - 2011.03.10 22:12:00 - [5]
 

^alt :)

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.03.10 23:37:00 - [6]
 

You will see the interface normally but with missing icons.

Like, actually you have modules that display correctly and black squares. by faking s3tc, you will see those module button correctly but no icon on them. the same for station and side bar buttons.

Kerith Sural
Posted - 2011.03.15 19:10:00 - [7]
 

THanks for the info, so for the people that don't know how to do this (like myself) how would one go about getting those drivers and setting them up correctly?

Originally by: Ravow
Edited by: Ravow on 01/03/2011 13:37:16
You need S3TC texture support.

radeon opensource driver got it on February 10th and LLVM/Softpipe have it too.

You can add them to your drivers but you will probably need to guess the DXT1/3/5 ID because patent infected so Intel will not implement or document them.

The other way would be to ask CCP if they can add a "no texture compression" checkbox in EVE options...

GL_S3_s3tc
GL_EXT_texture_compression_dxt1
GL_EXT_texture_compression_s3tc


EDIT: If you fake s3tc support in .driconf, you will get rid of the black squares on some module/thing but what is white... will stay white... That is "OK" for gatecamping.

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.03.16 18:03:00 - [8]
 

You can use "driconf" and see if you have this option :

[ ] Enable S3TC texture compression even if software support is not available

If you have it, enable it.
Else I don't know as I don't use Intel card.

Aerryn Sural
Posted - 2011.03.20 10:09:00 - [9]
 

Originally by: Ravow
You can use "driconf" and see if you have this option :

[ ] Enable S3TC texture compression even if software support is not available

If you have it, enable it.
Else I don't know as I don't use Intel card.



DUDE! it works! I want your babies!

seriously, thanks man!

BlackSparrowHawk
Posted - 2011.03.21 18:45:00 - [10]
 

Originally by: Aerryn Sural
Originally by: Ravow
You can use "driconf" and see if you have this option :

[ ] Enable S3TC texture compression even if software support is not available

If you have it, enable it.
Else I don't know as I don't use Intel card.



DUDE! it works! I want your babies!

seriously, thanks man!


^ This

Finally! I can see textures again :D My Beautiful ship!

Seriously this little piece of advice should have its own thread :p

Thanks!

Lu'ay al Din
Amarr
1st Praetorian Guard
Posted - 2011.04.22 00:39:00 - [11]
 

This worked very well indeed! Thanks!

Slozhenitsyn
Caldari
Posted - 2011.05.10 05:49:00 - [12]
 

All lights are ugly white-to-green-gradient sprites here.
Shaders set to high fix the issue, yet i get 2fps.
Had someone ever tried to workaround that?
May be erasing some resources will do the job?
No idea where to lurk, tbh.

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.05.10 17:57:00 - [13]
 

Don't have that problem on my laptop. Intel X4500.

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2011.05.13 03:53:00 - [14]
 

The graphics are perfect if you install lib libtxc-dxtn. no more gray ships/black stuff...

You need git mesa, of course. And don't use Gallium driver.


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only