open All Channels
seplocked Linux
blankseplocked Upgrade to 1.2 and wine
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Badmoons
Posted - 2011.02.15 14:26:00 - [1]
 

Edited by: Badmoons on 15/02/2011 14:26:30
wow, what a mess. I had to install vcrun2005 and vcrun2008 using winetricks. I then had to create a dir c:\builds\chaos

After this, I was able to do the upgrade and get into game. Hope this helps others.

BlackSparrowHawk
Posted - 2011.02.15 14:33:00 - [2]
 

Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:26:30
I had to install vcrun2005 and vcrun2008 using winetricks.


Can you explain exactly how you do this - i'm kinda new to ubuntu with eve Embarassed What exactly do i type in terminal?

Kuric Khall
Posted - 2011.02.15 14:39:00 - [3]
 

For some reason my winetricks fails without error when trying to install vcrun2008. (Running on 32bit fedora 14)

Badmoons
Posted - 2011.02.15 14:43:00 - [4]
 

Edited by: Badmoons on 15/02/2011 14:44:39
You will want to run winetricks to install vcrun2005 and vcrun2008. I personally use Ubuntu 64bit. I have the repository for the latest and greatest wine and winetricks. I'm currently running wine 1.3.13.

http://wiki.winehq.org/winetricks

BlackSparrowHawk
Posted - 2011.02.15 14:48:00 - [5]
 

Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:44:39
You will want to run winetricks to install vcrun2005 and vcrun2008. I personally use Ubuntu 64bit. I have the repository for the latest and greatest wine and winetricks. I'm currently running wine 1.3.13.

http://wiki.winehq.org/winetricks


i already have winetricks installed (if my memory serves me well) when i first installed eve. What exactly do i type in terminal to install vcrun2005 and vcrun2008?

Miraqu
Caldari
Posted - 2011.02.15 15:24:00 - [6]
 

Well, simplest would be because ubuntu installs into path

"winetricks corefonts vcrun2005 vcrun2008" without >"<

if you downloaded it as a file, then

"sh winetricks corefonts vcrun2005 vcrun2008"

BlackSparrowHawk
Posted - 2011.02.15 15:32:00 - [7]
 

Originally by: Miraqu
Well, simplest would be because ubuntu installs into path

"winetricks corefonts vcrun2005 vcrun2008" without >"<

if you downloaded it as a file, then

"sh winetricks corefonts vcrun2005 vcrun2008"


thanks, i'm currently redownloading the client. I was having problems with the eve repair tool thing, which kept halting and not completing. I though i was the only one since no one had posted anything on forums. Oh well, only 50 mins left :)

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2011.02.15 15:34:00 - [8]
 

Seen this before (the repair splat.) This WAS working just fine last patch, and has boogered up again. Guessing CCP changed vcrun again? But just like last time it magically started working about 5-8 hours later. -shrugs. If winetricks will do the deal then hey. Personally gonna sleep and try patching again later.

BlackSparrowHawk
Posted - 2011.02.15 15:39:00 - [9]
 

Originally by: Sevarus James
Seen this before (the repair splat.) This WAS working just fine last patch, and has boogered up again. Guessing CCP changed vcrun again? But just like last time it magically started working about 5-8 hours later. -shrugs. If winetricks will do the deal then hey. Personally gonna sleep and try patching again later.



I just hope it's an easy work-around like before.

Maquis196
4S Corporation
Morsus Mihi
Posted - 2011.02.15 15:48:00 - [10]
 

Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:26:30
wow, what a mess. I had to install vcrun2005 and vcrun2008 using winetricks. I then had to create a dir c:\builds\chaos

After this, I was able to do the upgrade and get into game. Hope this helps others.


Can confirm this works unless the patch got magically fixed in the last few minutes! Cheers dude

BlackSparrowHawk
Posted - 2011.02.15 16:51:00 - [11]
 

Edited by: BlackSparrowHawk on 15/02/2011 16:53:27
Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:26:30
wow, what a mess. I had to install vcrun2005 and vcrun2008 using winetricks. I then had to create a dir c:\builds\chaos

After this, I was able to do the upgrade and get into game. Hope this helps others.


ok so i reinstalled the client and same problem occured with the repair tool. So i tried your method - vcrun2005 and 2008 both installed fine.

when it came to updating client it went to the repair tool thing. It passed to the repair tool window and it did its thing. After it completed it said "Failed to repair Eve online client" with this error:

Restoring file: "C:\users\Public\Application Data\CCP\EVE\Downloads\EVEPREMIUM.6.40.221279-6.41.229669.7z"
Repair data url: "http://content.eveonline.com/EVEPREMIUM.6.40.221279-6.41.229669.7z"
Traceback (most recent call last):
File "progressPanel.pyc", line 97, in _TaskRun
File "repairUI.pyc", line 63, in Start
File "repairLogic.pyc", line 129, in Repair
File "repairLogic.pyc", line 165, in Restore
File "zsync\zsync.pyc", line 56, in RestoreFile
File "urllib2.pyc", line 126, in urlopen
File "urllib2.pyc", line 397, in open
File "urllib2.pyc", line 510, in http_response
File "urllib2.pyc", line 429, in error
File "urllib2.pyc", line 369, in _call_chain
File "urllib2.pyc", line 605, in http_error_302
File "urllib2.pyc", line 397, in open
File "urllib2.pyc", line 510, in http_response
File "urllib2.pyc", line 435, in error
File "urllib2.pyc", line 369, in _call_chain
File "urllib2.pyc", line 518, in http_error_default
HTTPError: HTTP Error 503: Service Unavailable
Total Runtime: 0h00m23s

i was getting excited there for a second :(

Edit: after the error i ran update again and its working!!! You are a legend amongst men dude :D

third deep
Posted - 2011.02.15 19:39:00 - [12]
 

I had the same problem, could not patch. Installed vcrun2005 vcrun2008, it made a difference, but still failed. Downloaded the patch manually, that worked.

Thd.

Peri Simone
Steel Dawn Inc.
Posted - 2011.02.15 20:47:00 - [13]
 

Hi all,

Still having problems with this one. Have installed vcrun2005 and 2008 as suggested, but still seeing errors in the repair tool when installing patch - same problem when attempting to install manually.

Any thoughts?

cyber T3xHuK
Posted - 2011.02.15 21:45:00 - [14]
 

Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:26:30
wow, what a mess. I had to install vcrun2005 and vcrun2008 using winetricks. I then had to create a dir c:\builds\chaos

After this, I was able to do the upgrade and get into game. Hope this helps others.


thanks ! this helped me as well ! =) without the chaos folder doesn't work...

Scorpyn
Caldari
Infinitus Odium
Posted - 2011.02.15 22:50:00 - [15]
 

Edited by: Scorpyn on 15/02/2011 22:50:42
I downloaded the patch and installed it manually. Didn't try the other stuff in this thread first, so that may also help.

http://www.eveonline.com/patches/patches.asp

http://content.eveonline.com/evepremiumpatch224393-229669_m.exe

Edit : Added direct link to patch

Sunukai
Posted - 2011.02.15 22:52:00 - [16]
 

Originally by: cyber T3xHuK
Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:26:30
wow, what a mess. I had to install vcrun2005 and vcrun2008 using winetricks. I then had to create a dir c:\builds\chaos

After this, I was able to do the upgrade and get into game. Hope this helps others.


thanks ! this helped me as well ! =) without the chaos folder doesn't work...


I had to add that folder as well. Thanks!

Aamrr
Posted - 2011.02.16 00:40:00 - [17]
 

Originally by: Sunukai
Originally by: cyber T3xHuK
Originally by: Badmoons
Edited by: Badmoons on 15/02/2011 14:26:30
wow, what a mess. I had to install vcrun2005 and vcrun2008 using winetricks. I then had to create a dir c:\builds\chaos

After this, I was able to do the upgrade and get into game. Hope this helps others.


thanks ! this helped me as well ! =) without the chaos folder doesn't work...


I had to add that folder as well. Thanks!


Likewise. It seems that the new patches (both Sisi and Tranquility) attempt to store files there when patching, but do not properly attempt to create the directories if they're not present. Manually adding them before running the patch solves the problem.

I hope this problem isn't recurring. Ugh. Annoying.

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2011.02.16 01:00:00 - [18]
 

Full patcher works just fine. Seems some of our windows friends have the SAME problem with the patcher, and in the 'issues' thread, CCP might be having problems with those putting the patches together.

On my connection, the full patch downloads just as quickly as the autopatcher tries to and just works, so no workarounds or vcrun this or that needed.



 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only