open All Channels
seplocked EVE Information Portal
blankseplocked New Dev Blog: An update on the SSE compatibility issue
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

CCP Fallout

Posted - 2011.01.27 17:01:00 - [1]
 

CCP Zulu's newest dev blog gives us an update on the SSE compatibility issue. Read all about it here.

RaTTuS
BIG
Gentlemen's Agreement
Posted - 2011.01.27 17:05:00 - [2]
 

Edited by: RaTTuS on 27/01/2011 17:08:58
Edit 1st Cool

Ok ,
so I now have to get rid of one machine that I can use :-(
and this does affect at least 1 person I know [he's got another PC en-route though]

no real worries...

lets move to the 21st centuryWink

Steve Thomas
Minmatar
Sebiestor Tribe
Posted - 2011.01.27 17:20:00 - [3]
 

And I would like to take this time to remind you that, yet again, you dont have the Shader detector ap linked in that blog anymore.

Nikolai Kondratiev
Sphere Design Inc.
Posted - 2011.01.27 17:21:00 - [4]
 

inb4 Chribba!

And good decision I guess, I've never really been into software development, but maintaining a second client for non-SSE2 CPUs would be too complicated ?

CCP Explorer

Posted - 2011.01.27 17:34:00 - [5]
 

Originally by: Nikolai Kondratiev
And good decision I guess, I've never really been into software development, but maintaining a second client for non-SSE2 CPUs would be too complicated ?
We currently maintain 3 clients; a Windows client and a Mac client for Tranquility and a Windows client for Serenity. Each new client/configuration carries overhead and some of the middleware we now use requires SSE2.

DmitryEKT
Clandestine.
Posted - 2011.01.27 17:36:00 - [6]
 

Originally by: CCP Explorer
We currently maintain 3 clients; a Windows client and a Mac client for Tranquility and a Windows client for Serenity. Each new client/configuration carries overhead and some of the middleware we now use requires SSE2.
What ever happened to SiSi? ...and on that thought, why has Multiplicity not been available since october?

Rhok Relztem
Caldari
CGMA Synergist Syndicate
Posted - 2011.01.27 17:58:00 - [7]
 

The SSE2 move is needed, but the comment at the end...
Quote:
P.S. I would like to remind everyone that we will also be updating the minimum specification for graphics cards in the coming months as detailed in my October blog.
is a load of crap. Why not announce it now since the Character Creator is apparently SM3 (as well as some other requirement since some with SM3 and even SM4 are having issues too) and there are going to be a LOT of player casualties when the grace period expires due to not being able to access it. Why was this not announced before this expansion? Mad

C'mon CCP. Grow some gonads and tell us what the minimum graphics requirements are NOW so that we at least know what to look for to upgrade or buy new/used systems before we get locked out of the game.

Zerakix
Minmatar
The White Mantle
Posted - 2011.01.27 18:09:00 - [8]
 

Originally by: Rhok Relztem
The SSE2 move is needed, but the comment at the end...
Quote:
P.S. I would like to remind everyone that we will also be updating the minimum specification for graphics cards in the coming months as detailed in my October blog.
is a load of crap. Why not announce it now since the Character Creator is apparently SM3 (as well as some other requirement since some with SM3 and even SM4 are having issues too) and there are going to be a LOT of player casualties when the grace period expires due to not being able to access it. Why was this not announced before this expansion? Mad

C'mon CCP. Grow some gonads and tell us what the minimum graphics requirements are NOW so that we at least know what to look for to upgrade or buy new/used systems before we get locked out of the game.


I'd assume it would be best for anyone using an SM2.0 card to upgrade to an SM4/DX10 card so they don't have to worry about it when CCP drops SM3 support in a couple of year

Tagana Shavar
Posted - 2011.01.27 18:21:00 - [9]
 

Originally by: Rhok Relztem
C'mon CCP. Grow some gonads and tell us what the minimum graphics requirements are NOW so that we at least know what to look for to upgrade or buy new/used systems before we get locked out of the game.


If you'd have bothered to actually read the linked blog about the graphics card, you'd see it's already been announced in October. The only thing that's unclear is the exact moment this will become a minimum requirement. Reading is cool. It makes you learn stuff. Wink

Modescond
Minmatar
Twilight Military Industrial Complex Alliance
Posted - 2011.01.27 18:29:00 - [10]
 

if requiring SSE2 makes eve run faster, what would be the benfit/cost of having say, a SSE3 or x64 build that shipped along with EVE and allowing eve.exe to automagically load the appropriate one?

I realize that QA would hate you, but it would make those that have capable machines to run eve that much better.

Chribba
Otherworld Enterprises
Otherworld Empire
Posted - 2011.01.27 18:35:00 - [11]
 

I want my 386 back!

Tagana Shavar
Posted - 2011.01.27 18:41:00 - [12]
 

Originally by: Chribba
I want my 386 back!


So you can use it to upgrade the machine that EVE Files is running on? Very Happy

(Sorry, low blow, I know, but I honestly couldn't resist. Embarassed I'll ah... donate some veldspar somewhere in your name. ugh)

Chribba
Otherworld Enterprises
Otherworld Empire
Posted - 2011.01.27 19:01:00 - [13]
 

Originally by: Tagana Shavar
Originally by: Chribba
I want my 386 back!


So you can use it to upgrade the machine that EVE Files is running on? Very Happy

(Sorry, low blow, I know, but I honestly couldn't resist. Embarassed I'll ah... donate some veldspar somewhere in your name. ugh)
It damn sure would help!! Surprised

(but yeah that box is indeed pretty crappy I know, and it is due for upgrade)

Ifly Uwalk
Caldari
Concentrated Evil
Posted - 2011.01.27 19:08:00 - [14]
 

Originally by: Steve Thomas
you dont have the Shader detector ap linked in that blog anymore.

Works for me.

Karia Sur
Posted - 2011.01.27 19:41:00 - [15]
 

Edited by: Karia Sur on 27/01/2011 19:41:19
What sort of time-frame are we talking about before Shader 3 comes into effect? 'In the coming months' leaves a very wide range to the imagination. Are we talking 1-2 months? 3-4? in under 6 months? etc??

Rivqua
Caldari
Omega Wing
Snatch Victory
Posted - 2011.01.27 19:54:00 - [16]
 

Originally by: Karia Sur
Edited by: Karia Sur on 27/01/2011 19:41:19
What sort of time-frame are we talking about before Shader 3 comes into effect? 'In the coming months' leaves a very wide range to the imagination. Are we talking 1-2 months? 3-4? in under 6 months? etc??


Likely next expansion, so probably early summer.

VonKolroth
Gallente
Dreddit
Test Alliance Please Ignore
Posted - 2011.01.27 21:02:00 - [17]
 

Reimbursement of game time... Do you mean time spent playing the game and training skills,.. with money? I hope you guys are removing the accounts of people who accept these reimbursements. Otherwise you might as well have a hardware replacement program.

Personally, I don't mind seeing the hardware requirements go up if it means less botters in space.

Ranka Mei
Caldari
Posted - 2011.01.27 21:06:00 - [18]
 

Originally by: Karia Sur
What sort of time-frame are we talking about before Shader 3 comes into effect? 'In the coming months' leaves a very wide range to the imagination. Are we talking 1-2 months? 3-4? in under 6 months? etc??

This is your wake-up call! It's already in-effect. You need 3.0 shaders for the character creator. Because of the grace period you can postpone the inevitable for a while; buy you're essentially already humped...

Unless, of course, you did something radical like upgrading your 10-year-old hardware.

Destination SkillQueue
Are We There Yet
Posted - 2011.01.27 21:49:00 - [19]
 

Originally by: Ranka Mei
Originally by: Karia Sur
What sort of time-frame are we talking about before Shader 3 comes into effect? 'In the coming months' leaves a very wide range to the imagination. Are we talking 1-2 months? 3-4? in under 6 months? etc??

This is your wake-up call! It's already in-effect. You need 3.0 shaders for the character creator. Because of the grace period you can postpone the inevitable for a while; buy you're essentially already humped...

Unless, of course, you did something radical like upgrading your 10-year-old hardware.


Well you don't really need 3.0 shaders yet, but the CC will look like ass and some features in it won't work at all. You are basicly blindly guessing what some things will end up looking in the server rendered portrait. To fully enjoy EVE now you do need the 3.0 shader. Basicly be prepared to upgrade before the next expansion at the latest.

Aion Amarra
Minmatar
Real Nice And Laidback Corporation
Black Core Alliance
Posted - 2011.01.27 23:00:00 - [20]
 

Originally by: VonKolroth
Reimbursement of game time... Do you mean time spent playing the game and training skills,.. with money? I hope you guys are removing the accounts of people who accept these reimbursements. Otherwise you might as well have a hardware replacement program.

Personally, I don't mind seeing the hardware requirements go up if it means less botters in space.


They mean already-paid gametime that users find themselves unable to use. Like having paid a 12 month sub only to get clipped out of the game 3 months later.

Rhok Relztem
Caldari
CGMA Synergist Syndicate
Posted - 2011.01.28 04:44:00 - [21]
 

Originally by: Tagana Shavar
Originally by: Rhok Relztem
C'mon CCP. Grow some gonads and tell us what the minimum graphics requirements are NOW so that we at least know what to look for to upgrade or buy new/used systems before we get locked out of the game.


If you'd have bothered to actually read the linked blog about the graphics card, you'd see it's already been announced in October. The only thing that's unclear is the exact moment this will become a minimum requirement. Reading is cool. It makes you learn stuff. Wink

There's always one smartass. As a matter of fact I did read the linked blog and probably read more in a month than you do in a year. Yeah, reading is cool, but reading without comprehension makes us say stupid things (especially in forums).

If you'd have bothered reading my post with any comprehension, you'd have noticed that I mentioned there are other players in the forums who also can't access the CC even though they have SM3 or SM4 capable cards so there is something else changed too. Besides that, the October blog simply states that the change will be sometime in the future. Well SURPRISE!!! The CC already requires it and when the grace period is up, that means anyone without SM3 and whatever else has changed is not going to be able to play EVE even though their systems have been able to handle EVE up to this point with no issues. The CC is non-gameplay related currently (until Incarna launches) but people are going to be locked out of the game anyway. THAT is my point. Why say the graphics announcements will come at a later date when they are ALREADY required?! ANNOUNCE IT ALREADY! It should have been announced before the expansion was launched.

I'm on a limited budget right now (as I'm sure many others are in these times) and will probably purchase a used system or build one with less than top-of-the-line hardware, but I don't want to buy something without knowing it will run EVE (or, more accurately, the CC).

Rhok Relztem
Caldari
CGMA Synergist Syndicate
Posted - 2011.01.28 04:49:00 - [22]
 

Edited by: Rhok Relztem on 28/01/2011 04:54:26
Edited by: Rhok Relztem on 28/01/2011 04:53:10
Originally by: Destination SkillQueue
Originally by: Ranka Mei
Originally by: Karia Sur
What sort of time-frame are we talking about before Shader 3 comes into effect? 'In the coming months' leaves a very wide range to the imagination. Are we talking 1-2 months? 3-4? in under 6 months? etc??

This is your wake-up call! It's already in-effect. You need 3.0 shaders for the character creator. Because of the grace period you can postpone the inevitable for a while; buy you're essentially already humped...

Unless, of course, you did something radical like upgrading your 10-year-old hardware.


Well you don't really need 3.0 shaders yet, but the CC will look like ass and some features in it won't work at all. You are basicly blindly guessing what some things will end up looking in the server rendered portrait. To fully enjoy EVE now you do need the 3.0 shader. Basicly be prepared to upgrade before the next expansion at the latest.

Yes you do. Without SM3, the CC does not load so unless you know someone who will let you use their system to create your portrait, you are going to be sh*t-out-of-luck when the grace period expires.

And I have been fully enjoying EVE with SM2 for the past two years (and still am but without a portrait). SM3 is only required for the CC at this point.

Xituqtra
Posted - 2011.01.28 08:35:00 - [23]
 

Originally by: Rhok Relztem
Edited by: Rhok Relztem on 28/01/2011 04:54:26
Edited by: Rhok Relztem on 28/01/2011 04:53:10
Originally by: Destination SkillQueue
Originally by: Ranka Mei
Originally by: Karia Sur
What sort of time-frame are we talking about before Shader 3 comes into effect? 'In the coming months' leaves a very wide range to the imagination. Are we talking 1-2 months? 3-4? in under 6 months? etc??

This is your wake-up call! It's already in-effect. You need 3.0 shaders for the character creator. Because of the grace period you can postpone the inevitable for a while; buy you're essentially already humped...

Unless, of course, you did something radical like upgrading your 10-year-old hardware.


Well you don't really need 3.0 shaders yet, but the CC will look like ass and some features in it won't work at all. You are basicly blindly guessing what some things will end up looking in the server rendered portrait. To fully enjoy EVE now you do need the 3.0 shader. Basicly be prepared to upgrade before the next expansion at the latest.

Yes you do. Without SM3, the CC does not load so unless you know someone who will let you use their system to create your portrait, you are going to be sh*t-out-of-luck when the grace period expires.

And I have been fully enjoying EVE with SM2 for the past two years (and still am but without a portrait). SM3 is only required for the CC at this point.


it might help to petition and let them make a random ava for you?

Falkrich Swifthand
Caldari
eNinjas Incorporated
Posted - 2011.01.28 08:45:00 - [24]
 

Edited by: Falkrich Swifthand on 28/01/2011 08:46:32
Originally by: Chribba
I want my 386 back!


I have a working (!!) 086, can that run EVE?
(8MHz, 16-bit, 640kB of ram, Windows 3.0, B&W graphics...)
EDIT: Wait, no modem

CCP Explorer

Posted - 2011.01.28 08:54:00 - [25]
 

Originally by: DmitryEKT
Originally by: CCP Explorer
We currently maintain 3 clients; a Windows client and a Mac client for Tranquility and a Windows client for Serenity. Each new client/configuration carries overhead and some of the middleware we now use requires SSE2.
What ever happened to SiSi? ...and on that thought, why has Multiplicity not been available since october?
We maintain 3 production clients. We then maintain multiple test servers (and corresponding clients) for various projects.

The Informant
Posted - 2011.01.28 08:54:00 - [26]
 

Originally by: Rhok Relztem
Originally by: Tagana Shavar
Originally by: Rhok Relztem
C'mon CCP. Grow some gonads and tell us what the minimum graphics requirements are NOW so that we at least know what to look for to upgrade or buy new/used systems before we get locked out of the game.


If you'd have bothered to actually read the linked blog about the graphics card, you'd see it's already been announced in October. The only thing that's unclear is the exact moment this will become a minimum requirement. Reading is cool. It makes you learn stuff. Wink

There's always one smartass. As a matter of fact I did read the linked blog and probably read more in a month than you do in a year. Yeah, reading is cool, but reading without comprehension makes us say stupid things (especially in forums).

If you'd have bothered reading my post with any comprehension, you'd have noticed that I mentioned there are other players in the forums who also can't access the CC even though they have SM3 or SM4 capable cards so there is something else changed too. Besides that, the October blog simply states that the change will be sometime in the future. Well SURPRISE!!! The CC already requires it and when the grace period is up, that means anyone without SM3 and whatever else has changed is not going to be able to play EVE even though their systems have been able to handle EVE up to this point with no issues. The CC is non-gameplay related currently (until Incarna launches) but people are going to be locked out of the game anyway. THAT is my point. Why say the graphics announcements will come at a later date when they are ALREADY required?! ANNOUNCE IT ALREADY! It should have been announced before the expansion was launched.

I'm on a limited budget right now (as I'm sure many others are in these times) and will probably purchase a used system or build one with less than top-of-the-line hardware, but I don't want to buy something without knowing it will run EVE (or, more accurately, the CC).





You clearly haven't fiddled around with the graphic settings then. You can customize a character using low shaders, which works just fine on my x1400 Ati Radeon Mobility graphics card with 2.0 shaders. So it is still possible to make a character without the top-notch looking graphics. Granted it won't look anything like what you see, but it works and gives you an idea of what it will look like.

CCP Explorer

Posted - 2011.01.28 09:02:00 - [27]
 

Originally by: Rhok Relztem
Yes you do. Without SM3, the CC does not load so unless you know someone who will let you use their system to create your portrait, you are going to be sh*t-out-of-luck when the grace period expires.

And I have been fully enjoying EVE with SM2 for the past two years (and still am but without a portrait). SM3 is only required for the CC at this point.
The New Character Creator works with Shader Model 2 (SM2), but it will not look as nice.

The current minimum hardware requirement for EVE is SM2 but recommended is SM3 or higher.

If the New Character Creator doesn't work for you using an SM2 card, have you tried updating your video drivers to the latest version? Have you filed a technical petition? The GMs have a few tricks up their sleeve for updates from the graphic cards manufactures and Microsoft.

As detailed in CCP Zulu's earlier dev blog then the minimum will become SM3 and I would urge everyone to upgrade soon.

JcJet
Caldari
Pretenders Inc
W-Space
Posted - 2011.01.28 10:47:00 - [28]
 

Pffft. Why bother. My old computer, which was bought somwhere in 2003 and which i've give away to my friend 3 years ago, it's was with SSE3, and with SM 3.0 btw, it's was a cheap one even for those days...

The Snowman
Gallente
Aliastra
Posted - 2011.01.28 11:21:00 - [29]
 

If you want to know what I think about "players" who still poses SS1 or non-SS compatible processors in their computer then look at my portrait!

Hawk TT
Caldari
Bulgarian Experienced Crackers
Posted - 2011.01.28 14:15:00 - [30]
 

Dear CCP,

You should update the Minimum Hardware Requirements more precisely:
1) Minimum HDD space 6GB? My current EVE folder is 14.5GB + 0.5GB for my user profile CCP/EVE folder...Put 16GB
2) 56K Modem? While technically EVE will work, the network lag will be terrible, because of the latency. Try it on 3G - while the bandwidth is much
greater than 56K, the latency is comparable to 56K Modem...
3) Why the hell one should need DVD-ROM?

You should also update the Recommended Requirements:
1) Again HDD Free Space - put 20GB
2) Video 256MB SM 3.0 - while it could run, this is definately not "Recommended" - more of a 1GB SM 4.0 card
3) Why the hell one should need DVD-ROM?

If you don't want to raise the bar for "Recommended", just put a 3rd category "Out-of-station-playable" Twisted Evil


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only