open All Channels
seplocked Linux
blankseplocked [Solved] EVE crashes accessing the Jukebox
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

DaQuark Mortiferus
Amarr
Posted - 2011.01.26 22:30:00 - [1]
 

Edited by: DaQuark Mortiferus on 27/01/2011 09:16:07
Scientist of the Amarr Empire brings music to ALL capsuleers operating on Wine/Linux !

Please see http://bugs.winehq.org/show_bug.cgi?id=21373 for details.
Already applied to upstream so it will be in wine-1.3.13 soon...

Update:

If you still experience crashes after applying the patch make sure you have at
least version 1.12.3 of mpg123 as all version before that one have a memory
access violation bug due to bugged alignment.

On my Gentoo box libmpg123.so.0.25.5 solved the crashes.

If you cannot upgrade your libmpg123 32bit libraries,
another workaround is to enable the malloc checks in glibc prior to start
EVE, e.g:

export malloc_check_=1


Fly Safe

Miraqu
Caldari
Posted - 2011.01.27 11:17:00 - [2]
 

confirmed.

Grabbed from current git, Jukebox works like a charm for me, without l3codeca.acm or wmp.

Nora Smith
Gallente
Space Frontier Foundation
Posted - 2011.01.28 15:20:00 - [3]
 

Also confirming. Updating libmpg in emul-linux to libmpg123.so.0.29.1 solved the last hassle for me.
As even the current testing app-emulation/emul-linux-x86-soundlibs still contains a buggy version, I needed to crosscompile it from the current 1.13.1 version from portage. Here's how I did it on Gentoo (unclean install, if the next soundlibs update hits portage, remove the manually updated files prior to the update):

# ebuild /usr/portage/media-sound/mpg123/mpg123-1.13.1.ebuild unpack
# cd /var/tmp/portage/media-sound/mpg123-1.13.1/work/mpg123-1.13.1/
# CFLAGS=-m32 ./configure --with-audio=alsa --with-default-audio=alsa --with-cpu=sse
# CFLAGS=-m32 make
# rm /usr/lib32/libmpg123.so*
# cp src/libmpg123/.libs/libmpg123.so* /usr/lib32/

kakmonstret
Posted - 2011.02.11 23:25:00 - [4]
 

Works for me too, even with default libmpg123 from ubuntu repos.

Is this crasch random or does it work if it works?

Anyway awesome and thanks for the work! One more winebug down! One more step on the road to perfection! Cool


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only