open All Channels
seplocked Linux
blankseplocked [SOLVED] Flashing/Tearing and missing images
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Malakai Tanaki
Posted - 2011.01.18 02:10:00 - [1]
 

Edited by: Malakai Tanaki on 26/01/2011 16:18:43
Hi,

I want to come back to EVE after a break for university and in thatPlease visit your user settings to re-enable images. time I have moved over to ubuntu and I'm having issues with it.

I have installed the game and it runs but on the login screen there is flashing almost tearing white streaks across the screen moving constantly, then when I get to the character select screen and in the actual game screen there is images missing that display as black squares and my avatar doesn't seem to be rendering properly.

If anyone has any solutions that would be great.

Thanks in advance,
Bugsy

Whitehound
The Whitehound Corporation
Frontline Assembly Point
Posted - 2011.01.18 12:50:00 - [2]
 

Edited by: Whitehound on 18/01/2011 12:51:28
You should wait after the Incursion expansion has been released, which is today.

Then wait a little longer and check here on the forum if the new expansion brings problems for Linux/WINE or if EVE keeps working together with it.

What you can do in the meantime is to post your hardware and software specs. I.e. the type of graphics card, which driver version and release you are using, perhaps the Mesa and X11 release, too.

You then need at least 2GB of RAM and you should use the latest WINE versions - 1.2.2 for stable or 1.3.11 for develop, both will work.

Also try to run other 3D applications on your Linux box. Try to start "3D Blender" and see if this works. If it does then try to install some other Windows 3D application under WINE and see if this works, too.

This will help you to narrow down the problem.

Malakai Tanaki
Posted - 2011.01.18 18:08:00 - [3]
 

Ok, so I changed UseGLSL to disabled in my user.reg file and I have stopped the flashing/tearing stuff now I just have missing images?

Malakai Tanaki
Posted - 2011.01.20 01:08:00 - [4]
 

Im still having trouble with missing images, though I have been playing with it it would be nicer if i could see everything lol.

Eve error pics

Heres a picture to demo whats happening. Also if someone could tell me what info might help with someone solving this issue.

Malakai Tanaki
Posted - 2011.01.24 23:02:00 - [5]
 

Ok,

So just to help anyone else thats had my issue out. I have got all the textures to show now, I managed this by changing user.reg.

I added "StrictDrawOrdering"="enabled" in the Direct3D section.

Now all I have left is the lines of black flying out of my ship and funny orbs of light around my ship. Well back to the drawing board.

Bugsy

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2011.01.25 11:03:00 - [6]
 

First. Video card? Video driver?

If this was nvidia, I could sort you in about a minute, but without hardware/software+ versions its like spitting in the wind.

Malakai Tanaki
Posted - 2011.01.25 15:53:00 - [7]
 

Hey thanks for the reply,

lspci gives me:
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller

glxinfo | grep render gives me:
Mesa DRI Mobile Intel® GM45 Express Chipset

not sure about drivers my xorg.conf says "Intel"

Hope you can help
thanks
Bugsy

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2011.01.26 00:00:00 - [8]
 

Sorry, not I, but bettin' someone here could. If it doesn't say "nvidia" somewhere on the box I won't touch it, and thus am not an expert at fixin' said hardware. Sad

Malakai Tanaki
Posted - 2011.01.26 12:44:00 - [9]
 

Ok no worries just for interest what were you goin to suggest or is it nvidia specific?

Bugsy

Sevarus James
Minmatar
Meridian Dynamics
Posted - 2011.01.26 13:31:00 - [10]
 

Tearing and flashing are indicative of vsync issues normally. In EVE's escape key menu under graphics there is a section listed as "interval". 'default' indicates vsync on and immediate is "off". Under your video settings (I'm guessing here) you should also have the ability to turn on or off vsync (in your case turn it on).

My suggestion would be to play with those settings and see if it alleviates the tearing/oddness going on.

Again, I've never dealt with intel for gaming, so if anyone has ideas/suggestions, weigh in here.

Malakai Tanaki
Posted - 2011.01.26 14:24:00 - [11]
 

Ok thanks a bunch i will look into those settings

Bugsy

Malakai Tanaki
Posted - 2011.01.26 15:54:00 - [12]
 

Sadly the vsync stuff didnt change anything i actually already had it on any other ideas?

Bugsy

Malakai Tanaki
Posted - 2011.01.26 16:18:00 - [13]
 

Woo problem solved!!

I looked into any new updates for Intel and x server stuff for Ubuntu 10.10 and managed to find the x-updates repository from launchpad website for xorg, then I also found the more recent repository xorg-edgers with up to date packages for intel and x server etc.

Heres the address for those repositories:
https://launchpad.net/~xorg-edgers/+archive/ppa

and the ppa address:
ppa:xorg-edgers/ppa

With these newer packages installed the tearing has gone and EVE is playing beautifully thanks for all the help.

Bugsy


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only