open All Channels
seplocked EVE Technology Lab
blankseplocked Out of Eve 1.8-Inc - Character and Corporation info web app
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2

Author Topic

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.01.15 07:55:00 - [1]
 

Edited by: Azazel Mordred on 16/06/2011 12:31:13
Sup

Out of Eve is back in action. The original thread about the application is available here. The even older application introduction thread is here.

For it's first new release, OOE has been made fully Incursion compatible. There are not really any new features yet, the goal with this release was to ensure everything works with Incursion's DB structure and current API methods.

OOE has also been set up as a Google Code project, so you can track changes better, and it doesn't rely on my weedy and currently unavailable SVN server.

The project page and all source code and releases can be found here: http://code.google.com/p/ooe/

In addition to the released code, feel free to check out the branchs which will be home to additional features beyond the currently released version as they're added. Please make use of the issue tracker to report problems or suggest new features. Additional plugins and code contributions will be welcome.


If you're simply interested in using the application without hosting it yourself, you can register on http://www.outofeve.com/ and have full access to all OOE features. There are NO ISK/licensing charges for access to the website or source code, and there never will be.

For concerns about your full API key's security, please refer to discussions in the old threads linked in the first paragraph of this post.

If you encounter any problems on the OutOfEve.com site, please use the project's issue tracker to report them. The website is currently running the released code (tags/1.8-incursion).

Desmont McCallock
Posted - 2011.01.15 11:11:00 - [2]
 

Good to see that you are back. Wink

And quess what? My account is still there... Very Happy

VampireDeluxeVWB
Caldari
R.H. Umbrella Corporation
Ewoks
Posted - 2011.01.15 15:57:00 - [3]
 

hi,

i uploaded all files to my fileserver, filled one db with the dump and insert the two sql files also in the database...


but now i get this error... :

Fatal error: Uncaught exception 'PDOException' with message 'invalid data source name' in /www/htdocs/w00ab6c5/eveinfo/includes/database.php:12 Stack trace: #0

login and the passwort are insert correct into the config file

c00lina
Posted - 2011.01.16 02:26:00 - [4]
 

I am so glad to see this is back up. Many thanks.

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.01.17 05:51:00 - [5]
 

Originally by: VampireDeluxeVWB
hi,

i uploaded all files to my fileserver, filled one db with the dump and insert the two sql files also in the database...


but now i get this error... :

Fatal error: Uncaught exception 'PDOException' with message 'invalid data source name' in /www/htdocs/w00ab6c5/eveinfo/includes/database.php:12 Stack trace: #0

login and the passwort are insert correct into the config file


Hi,

By the sounds of it, you might have put both scripts into the same DB. That's fine, but make sure that both "$config['database']['dsn']" and "$config['evedatabase']['dsn']" both point to exactly the same thing and both have the same usernames and passwords.

If you are using separate databases, just make sure that both of the above config options are configured correctly.

Midge Mo'yb
Bat Country
Goonswarm Federation
Posted - 2011.01.17 10:26:00 - [6]
 

Been trying to get ahold of this code for a LONG time, used it religiously in the past but i broke it and needed a fresh install but couldnt find it anywhere

VampireDeluxeVWB
Caldari
R.H. Umbrella Corporation
Ewoks
Posted - 2011.01.18 12:28:00 - [7]
 

sweet

it works now with 2 different mysql dbs.

an question: its possible to geht the min prizes from eve central ???

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.01.18 13:43:00 - [8]
 

Yes, we do read that information from Eve-Central. Where would you want that information displayed?

It's currently only used in the production profitability plugin I think.

VampireDeluxeVWB
Caldari
R.H. Umbrella Corporation
Ewoks
Posted - 2011.01.18 18:01:00 - [9]
 

maybe in an simple iten search... ???

also idea: saving avatars into an cachefolder? to save eve server traffic ?

btw i love this tool... best method für mac user *G*

Per Bastet
Amarr
B.O.O.M
Obsidian Mining Coalition
Posted - 2011.01.28 16:14:00 - [10]
 

Question for you...

Is there some way to add some Forum Integration? Our Corp uses a SMF Forum code base and we require API keys to Register on it - Would there be a way you could look into Creating a mod for SMF that would allow an OOE Install to attach to the Forums for Registration purposes?

Kilabie
Earth Inc
Posted - 2011.01.28 17:17:00 - [11]
 

Originally by: Per Bastet
Question for you...

Is there some way to add some Forum Integration? Our Corp uses a SMF Forum code base and we require API keys to Register on it - Would there be a way you could look into Creating a mod for SMF that would allow an OOE Install to attach to the Forums for Registration purposes?


+1

Maxx Overseer
Gallente
Royal Advanced Industries
Imperial Crimson Legion
Posted - 2011.01.31 18:35:00 - [12]
 

Out of Eve is great, where have you been?

I can now keep up with my corp

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.02.01 05:47:00 - [13]
 

Around and about, away from EVE for ever a year :). Getting back into it, quite enjoying the PI stuff.

Regarding SMF or other integration, I'm not going to do that kind of integration with other systems myself, but if anyone's willing to contribute code, I'll be happy to review it and potentially include it in a future release.

Montague Summers
Posted - 2011.02.13 23:52:00 - [14]
 

Hi, just thought I should note that during install I was delayed for some time because I was getting blank pages. Eventually I figured out that the problem was that /templates/compiled needed write permissions. This wasn't noted in the docs.

Many thanks for the great work you've done on this, it's awesome!

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.02.14 05:29:00 - [15]
 

Hmm, sorry about that omission, and thanks for the note about it, I'll remember to include it in future installation notes.

Princess Corrino
Amarr
Hinata Inn
Posted - 2011.02.20 12:15:00 - [16]
 

Edited by: Princess Corrino on 20/02/2011 12:16:16
I've made a new plugin for this. So far it only works for Characters and not Corporations but I am working on that. I had to alter several files though throughout.

For characters, you can now see their Standings, I made it in a similar fashion to the existing assets area (collapse/expandable).

Agents don't have icons, hence the generic blank square.

Please visit your user settings to re-enable images.

Edit: I need to make it work with Corporations next, and then once that is complete, I will make a popup information window with some basic information.

Eugene Spencer
Rodents of Unusual Size
Posted - 2011.02.21 19:46:00 - [17]
 

Excellent tool. My corpies are trying it out just now. Thanks for the hard work!

Carazeith
Posted - 2011.02.21 21:03:00 - [18]
 

Edited by: Carazeith on 21/02/2011 23:52:03
Originally by: Montague Summers
Hi, just thought I should note that during install I was delayed for some time because I was getting blank pages. Eventually I figured out that the problem was that /templates/compiled needed write permissions. This wasn't noted in the docs.

Many thanks for the great work you've done on this, it's awesome!


Thankyou sooooo much, this helped me fix my problem. I can now enjoy the wonder that is Out Of Eve.

**Edit**

Has anyone else noticed that this takes quite a while to get the queries from the database? or is it my server being really lame?

Eugene Spencer
Rodents of Unusual Size
Posted - 2011.02.22 02:48:00 - [19]
 

Originally by: Carazeith
Has anyone else noticed that this takes quite a while to get the queries from the database? or is it my server being really lame?


The API Servers were being really slow earlier. That's probably what you're experiencing :)

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.02.22 08:42:00 - [20]
 

Originally by: Princess Corrino
Edited by: Princess Corrino on 20/02/2011 12:16:16
I've made a new plugin for this. So far it only works for Characters and not Corporations but I am working on that. I had to alter several files though throughout.

For characters, you can now see their Standings, I made it in a similar fashion to the existing assets area (collapse/expandable).

Agents don't have icons, hence the generic blank square.

Edit: I need to make it work with Corporations next, and then once that is complete, I will make a popup information window with some basic information.


This looks great. I guess a bunch of stuff had to be added to the base DB and API classes/files. Sorry you had to be exposed to that Embarassed.

Once done, would you like to distribute it yourself, or would you mind if it were integrated into OOE (this would make the API calls and stuff part of OOE base, so you don't have to hack those each time you want to upgrade).

Princess Corrino
Amarr
Hinata Inn
Posted - 2011.02.22 09:21:00 - [21]
 

It's okay, I learnt a few new pieces of PHP from it.

How can I request access to the google code to upload changes?

Carazeith
Posted - 2011.02.22 17:09:00 - [22]
 

Well in my case it seemed that it wasn't caching at all, i bet a slow API server wouldnt help but it wouldnt create 142 second processing times.

A small thing i have noticed now that i have got it all working quickly (other then the starbases page which still takes about 40 seconds to load) is that the utilities, once clicked, take an enormously long time to load. Im hoping this is another case with my server and not with the programming, but just incase anyone has had any issues with this can anyone think of anything that might help this?


Overall though this is a brilliant piece of coding, and will be sending you some ISKies once my head stop hurting from all the MySQL work (i am in no way, shape or form a DBA and i think ive proved that myself today)

Princess Corrino
Amarr
Hinata Inn
Posted - 2011.02.22 21:42:00 - [23]
 

It can be slow sometimes when the API servers are being slow. On my site I set all users to use http://api.evsco.net as a proxy, which helps with speed as the results are cached nicely. But there are periods when it is slow, but that's during busy periods (and even EVE Mon is slow during those times too).

Ikki Phoenix
Gallente
United Imperial Fleet
Posted - 2011.03.01 04:05:00 - [24]
 

welcome back

I definitely like the program. I have been generally an Eve Commander user, but I have to say that I love what I am seeing. And what is more important is that it is completely free to use.
Great job.

I would love to see a way for corp members to access corp data.
Is something like this possible?

Thanks

Azazel Mordred
Minmatar
Cloak of Shadows
Posted - 2011.03.01 10:59:00 - [25]
 

It's definitely possible to grant access to the corporation data to corp members, however it would require that the CEO or something with equivalent access rights be registered on the OOE instance, and we'll have to give them a profile option to allow members to access the data. Actually sharing specific corp pages would be very useful I guess.

Sorry progress has been a bit slow the last month or so, been busy with some other stuff. Haven't abandoned OOE again yet Wink.

Ikki Phoenix
Gallente
United Imperial Fleet
Posted - 2011.03.01 13:39:00 - [26]
 

If you could add that feature, I would definitely use it and have my corp use it as well.

VampireDeluxeVWB
Caldari
R.H. Umbrella Corporation
Ewoks
Posted - 2011.03.16 10:40:00 - [27]
 

it would be also very sweet, if its possible to add limited api keys...



Saxxon Baru
Gallente
Menelaus Corp
Posted - 2011.03.18 13:58:00 - [28]
 

Hi Azazel Mordred,

Look your ooe awesome! but have still problem on my test localhost.
And also was not very good info about MySQL edit on readme.txt..
I has create two db (ooe and evedump), default db user as root.

Get error message:
Quote:
Fatal error: Uncaught exception 'PDOException' with message 'could not find driver' in D:\EasyPHP\www\outofeve\includes\database.php:12 Stack trace: #0 D:\EasyPHP\www\outofeve\includes\database.php(12): PDO->__construct('mysql:host=loca...', 'root', '') #1 D:\EasyPHP\www\outofeve\includes\database.php(8): DBManager->Connect(Array) #2 D:\EasyPHP\www\outofeve\includes\site.php(18): DBManager->DBManager(Array) #3 D:\EasyPHP\www\outofeve\index.php(8): Site->Site() #4 {main} thrown in D:\EasyPHP\www\outofeve\includes\database.php on line 12


I did edit of config.php:

Quote:
/*************************************************************************
Database for OOE (users, API details, etc)
*************************************************************************/
$config['database']['dsn'] = 'mysql:host=localhost;dbname=ooe';
$config['database']['user'] = 'root';
$config['database']['pass'] = '';

/*************************************************************************
Database generated from Eve database dump
*************************************************************************/
$config['evedatabase']['dsn'] = 'mysql:host=localhost;dbname=evedump';
$config['evedatabase']['user'] = 'root';
$config['evedatabase']['pass'] = '';


Hope get insolved soon if you can figure bug or my wrong?

thanks

Saxxon Baru
Gallente
Menelaus Corp
Posted - 2011.03.19 18:10:00 - [29]
 

nobody can help? Sad

Das Orakel
Posted - 2011.03.19 20:01:00 - [30]
 

Fatal error: Uncaught exception 'PDOException'with message 'could not find driver'

This is because the corresponding PDO extension in the php.ini is not enabled. One should say after the line:

extension = php_pdo.dll

or under Linux

extension = php_pdo.so

. Search If this extension is'mode and it still the error message: could not find driver, will have to see addressed is what database via PDO. If this is such as SQLite, it should activate this extension further.

extension = php_pdo_sqlite.dll

or Linux

extension = php_pdo_sqlite.so

Then the Web server must be restarted and it should be.


Pages: [1] 2

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only