open All Channels
seplocked Linux
blankseplocked Client startup issues
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Moriiko
Nakama
Gemini Federation
Posted - 2010.12.31 18:41:00 - [1]
 

Hello,

I have had this issue for a while with eve these days and its becoming more of a problem for me. Since incursion when i launch eve i get the splash screen which then dissapears after a few seconds and nothing else happens. I have to kill the process to get rid of it.

My current wine version


Quote:
$ wine --version
wine-1.3.9


My current launching script:
Quote:
#!/bin/sh
i=1
while [ 1 ];do
YES=`ps aux | grep EVE | grep explorer.exe | awk '{print $12}' | awk -F= '{print $2}' | awk -F, '{print $1}' | grep EVE${i}`
if [ "${YES}" = "" ]; then
sed -i -e 's/bitsCancelled=1/bitsCancelled=0/' "/home/simon/.wine/drive_c/users/simon/Local Settings/Application Data/CCP/EVE/c_program_files_ccp_eve_tranquility/settings/prefs.ini"
wine explorer.exe /desktop=EVE${i},1024x768 "/home/simon/.wine/drive_c/Program Files/CCP/EVE/eve.exe"
exit 0;
fi;
i=`expr $i + 1`
done;



This allows me to have eve windowed in its own virtual desktop allowing them to play nice (1024x768 is just the intial size of the window. EVE runs fullscreen so it resizes the window to the size set in eve)

Any help with this would be much much appreciated




Kargyraa
Posted - 2010.12.31 22:06:00 - [2]
 

I have seen two issues that give me a splash screen plus a blank screen afterwards.

1) When it boots up to a blank screen can you still see your cursor and if you check the console are you getting some error including "GL_INVALID_OPERATION". In this case the game is running fine there is just a graphical glitch. To check this hit 'Ctrl-Q' then 'Enter', this should quit the game and it will close.

If this is the case you have to disable antialisaing and/or bloom, either though the EVE config or turn off forcing it on with your nvidia-settings (assuming you use a nvidia card). This is a bug many have with EVE and antialiasing (so far I've only seen it on nvidia cards).

2) I would see the eve splash screen and an almost bank screen -- there would be this light brownish/redish strip across the top of the blank screen (though sometimes it would just give me a full sized splash screen, in either case the game was unplayable). In this case it was a hard crash.

I have not figured out the exact reason of this (and I would be curious what caused it). I noticed it when I just came back to eve right before the first incursion patch. As far as I could figure out this has something to do with the files located in $WINEPREFIX ($HOME/.wine) dir. The reason I figured this out it is one of my accounts would get this effect, and my other wouldn't (they ran off the same eve binaries but had different $WINEPREFIX). Also if I tried to generate a new $WINEPREFIX but that wouldn't work either.

I never tracked down the settings that was causing this issue and I fixed it by doing a fresh install on a fresh $WINEPREFIX, then I copied the working $WINEPREFIX to my second account. Just for a test I decided to see if this was still the issue, and if I run eve using a fresh (or damaged) $WINEPREFIX, I get a splash screen, followed by a blank screen followed by a full screen splash screen with out the ability to see anything useful, but I still still hit Ctrl-Q + enter to quit the game.


Since your saying its a blank screen I'm thinking it could be an antialaising issue, if you haven't forced antialaising on you may want to make a new $WINEPREFIX dir along with doing a fresh install.

Moriiko
Nakama
Gemini Federation
Posted - 2011.01.01 01:09:00 - [3]
 

Sorry, let me clarify - I run my script and my explorer window appears with its nice blue windows background ^_^. I see the eve splash which is there for a few seconds then it dissapears. i am left with a blank explorer window (Colour of the background) which suggests eve has not even loaded

Kargyraa
Posted - 2011.01.01 01:55:00 - [4]
 

Well then try to run wine from a terminal with out the use of your script. Look at the output for errors and see why it is crashing.

Phantom Dominus
Posted - 2011.01.06 12:18:00 - [5]
 

Deleting cache+settings usually worked for me on wine 1.3.9 with this issue. I updated to 1.3.10 some days ago and did a clean eve install, which solved the issue altogether along with a nice performance increase. I use following lines for launch:
nice -n 19 wine explorer /desktop=Scout,1280x1023 "C:\Program Files\CCP\EVE\eve.exe"
nice -n 0 wine explorer /desktop=PvP,1280x1023 "C:\Program Files\CCP\EVE\eve.exe"

with wine 1.3.8 reinstalling videodrivers worked too sometimes, so you could try that too.


Vallek Arkonnis
Posted - 2011.01.09 20:58:00 - [6]
 

If you are using the ubuntu 9.10 kernel, it has a strange bug where if you were connected to the internet it would stall just as you said. Only way around that for me was to disable networking, load eve, then reenable networking, and click on "news" to get the connection to update. I noticed the "bits cancelled" in your script, that was suggested as a possible fix for this problem (which is why I ask if you're running 9.10) but it never worked for me. The later kernels worked fine.

Also try running the script from a terminal to try to catch any errors. You might even want to try simply:

wine explorer /desktop=0,1024x767 "C:\Program Files\CCP\EVE\eve.exe"


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only