open All Channels
seplocked Ships and Modules
blankseplocked The evefit project: Advanced Fitting Tools - Pyfa 1.0.3 for Incarna
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 3 4 5 6 [7] 8 9 10 11 ... : last (12)

Author Topic

Tornicks
Caldari
The Green Cross
Controlled Chaos
Posted - 2011.01.10 00:24:00 - [181]
 

This could have been posted already, but will mention still:
Introducing the possibility of applying the Command Ship Warfare Links' bonus effects to ship setups would be a good addition in the next release.

Chelso
Posted - 2011.01.10 03:55:00 - [182]
 

Program ran once, was super nice (much better than eft on a mac) but alas it now wont run.

"pyfa error"

[visit macpython website] or [terminate]

That is the message and two options i get. What the go, the macpython site seems out of date with the last update dated 2004.

Any help would be much appreciated!


Tornicks
Caldari
The Green Cross
Controlled Chaos
Posted - 2011.01.10 06:22:00 - [183]
 

Also, can't see any graph with tanked DPS info.

Kadesh Priestess
Scalding Chill
Posted - 2011.01.10 09:02:00 - [184]
 

Originally by: Xyfu
Edited by: Xyfu on 07/01/2011 07:01:30
Tripleeditawwwyeee: Eos, gamedata.py
    @property

"property"'s a keyword, isn't it? D':
It's method decorator.
Originally by: Ruareve
I'm not sure if I'm doing something wrong, but I'm unable to slot any implants for any of my characters. I go in to manually add them and while the implant trees all exist they are also all empty and contain none of the actual implants.
For now please add them to the fittings, that's another screen we forgot to cut from release.
Originally by: Xyfu
Ok, left clicking through the module states goes in the order Active -> Offline -> Online -> Active, which is kinda nonsensical, 'cause the only people I know who have offlined modules on their fits are Prowler pilots, and even then, they don't regularly switch things Online and Offline. I propose toggling between Online and Offline be done via middle click, toggling Online and Active be done via left click, and toggling FIYAH (doo doo doooo, I'll teach you to burn!) be done via right click.
Actually that's primarily habit from EFT, i had such 'suggestion' too, but got used to new behavior quickly - in 2 or 3 days. Toggling stuff online and offline is useful primarily for passive modules where you can compare ship stats w/o actual removal of module from fitting.
Originally by: Tornicks
This could have been posted already, but will mention still:
Introducing the possibility of applying the Command Ship Warfare Links' bonus effects to ship setups would be a good addition in the next release.
Yep, there'll be fleet simulator for that.
Originally by: Tornicks
Also, can't see any graph with tanked DPS info.
Tanked dps... what parameters would you suggest for its axis?
Originally by: Chelso
Any help would be much appreciated!
The only thing i can suggest is to navigate to your user folder, find .pyfa folder, backup it somewhere and delete, redownload pyfa itself and attempt to run again. Error itself isn't very descriptive, so can't help much with it.

Asurix
Caldari
StoneDogS
Posted - 2011.01.10 09:10:00 - [185]
 

Originally by: Chelso
Program ran once, was super nice (much better than eft on a mac) but alas it now wont run.

"pyfa error"

[visit macpython website] or [terminate]

That is the message and two options i get. What the go, the macpython site seems out of date with the last update dated 2004.

Any help would be much appreciated!




i had exactly the same error except mine didn't even run once

EFT i've never even been able to find on a mac, only .exe, been trying to find a fitting tool on the mac for ages

Chelso
Posted - 2011.01.10 10:53:00 - [186]
 

Originally by: Kadesh Priestess

Originally by: Chelso
Any help would be much appreciated!
The only thing i can suggest is to navigate to your user folder, find .pyfa folder, backup it somewhere and delete, redownload pyfa itself and attempt to run again. Error itself isn't very descriptive, so can't help much with it.


Here is the site it links to if you click visit macpython site - http://homepages.cwi.nl/~jack/macpython/index.html

And here is an image of the error pop up - http://www.boomboots.com/images/pyfa.png

Any chance you could be more specific as to the location of the .pyfa folder? I have checked my user directory and the preference directory and search does not reveal it.

Asurix
Caldari
StoneDogS
Posted - 2011.01.10 10:56:00 - [187]
 

Originally by: Chelso
Originally by: Kadesh Priestess

Originally by: Chelso
Any help would be much appreciated!
The only thing i can suggest is to navigate to your user folder, find .pyfa folder, backup it somewhere and delete, redownload pyfa itself and attempt to run again. Error itself isn't very descriptive, so can't help much with it.


Here is the site it links to if you click visit macpython site - http://homepages.cwi.nl/~jack/macpython/index.html

And here is an image of the error pop up - http://www.boomboots.com/images/pyfa.png

Any chance you could be more specific as to the location of the .pyfa folder? I have checked my user directory and the preference directory and search does not reveal it.


i had the same problem and there's no .pyfa folder in my entire mac computer

Lina Miaoke
Posted - 2011.01.10 12:14:00 - [188]
 

Edited by: Lina Miaoke on 10/01/2011 12:19:42
Never knew about this product until I read one of CCP's blog. I've been using EFT for as long as I can remember... Always had couple gripes about EFT. Then I tried out Pyfa... all my gripes been resolved!

A small suggestion I would like to see. The exact amount of resource remaining.

Currently it shows
CPU 617/635 tf
What I would like to see
CPU 617/635 tf (18 left) and CPU 687/635 tf (52 over)

Much thanks for developing Pyfa. Keep up the good work!

Sabevissia
Posted - 2011.01.10 12:14:00 - [189]
 

The .pyfa folder is a hidden folder (or considered hidden) on most systems including Macs. This means that your search (unless specified otherwise) will not reveal hidden files/folders by default though it has been a while since I used a Mac this may not be 100% accurate anymore and if so my apologies ahead of time.

As for a Windows user the "users" folder is referring to personal users folder but again the concept of a hidden folder applies. The reason for this is the dot in front of the folder name. Most systems by default treat this is a hidden folder and thus it won't show until you turn that option on under your folder/view options (which very based on your syste). But for an example lets say your username is SomeFunyPerson and your looking for this folder on a Windows system. The location would be c:\users\SomeFunyPerson, just replace SomeFunyPerson with your username instead. This is the standard format for this folder structure since Windows Vista, if your system is older then this I am not exactly sure on your folder structure though it should be close. Either case just remember it will normally be right inside of the folder based on your username or if not there then in the folder named 'default' representing the default user or the folder named 'administrator' representating the admin user.

Chelso
Posted - 2011.01.10 12:49:00 - [190]
 

Edited by: Chelso on 10/01/2011 12:53:07
Originally by: Sabevissia
The .pyfa folder is a hidden folder (or considered hidden) on most systems including Macs. This means that your search (unless specified otherwise) will not reveal hidden files/folders by default though it has been a while since I used a Mac this may not be 100% accurate anymore and if so my apologies ahead of time.

As for a Windows user the "users" folder is referring to personal users folder but again the concept of a hidden folder applies. The reason for this is the dot in front of the folder name. Most systems by default treat this is a hidden folder and thus it won't show until you turn that option on under your folder/view options (which very based on your syste). But for an example lets say your username is SomeFunyPerson and your looking for this folder on a Windows system. The location would be c:\users\SomeFunyPerson, just replace SomeFunyPerson with your username instead. This is the standard format for this folder structure since Windows Vista, if your system is older then this I am not exactly sure on your folder structure though it should be close. Either case just remember it will normally be right inside of the folder based on your username or if not there then in the folder named 'default' representing the default user or the folder named 'administrator' representating the admin user.


For the mac users - http://guides.macrumors.com/Viewing_hidden_files_on_a_Mac

Edit: But deleting this folder doesnt fix the issue.

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2011.01.10 14:18:00 - [191]
 

Originally by: Chelso
Edited by: Chelso on 10/01/2011 12:53:07
Originally by: Sabevissia
The .pyfa folder is a hidden folder (or considered hidden) on most systems including Macs. This means that your search (unless specified otherwise) will not reveal hidden files/folders by default though it has been a while since I used a Mac this may not be 100% accurate anymore and if so my apologies ahead of time.

As for a Windows user the "users" folder is referring to personal users folder but again the concept of a hidden folder applies. The reason for this is the dot in front of the folder name. Most systems by default treat this is a hidden folder and thus it won't show until you turn that option on under your folder/view options (which very based on your syste). But for an example lets say your username is SomeFunyPerson and your looking for this folder on a Windows system. The location would be c:\users\SomeFunyPerson, just replace SomeFunyPerson with your username instead. This is the standard format for this folder structure since Windows Vista, if your system is older then this I am not exactly sure on your folder structure though it should be close. Either case just remember it will normally be right inside of the folder based on your username or if not there then in the folder named 'default' representing the default user or the folder named 'administrator' representating the admin user.


For the mac users - http://guides.macrumors.com/Viewing_hidden_files_on_a_Mac

Edit: But deleting this folder doesnt fix the issue.


This looks a lot like it might be an issue with the binaries. Could you go through the from-source installation process (which is mostly just getting all dependencies) and see if pyfa runs that way ?

I'd also like to know what mac version you're on (the binary mac version is built with and was ment for 10.6

Chelso
Posted - 2011.01.10 14:25:00 - [192]
 

version 10.5.8

I will try the source method (already tried but the sql one is a pain to install) again.

Thanks you guys are doing a great job btw!

Xyfu
Minmatar
Love From Above
Posted - 2011.01.10 18:46:00 - [193]
 

Originally by: Kadesh Priestess
Originally by: Xyfu
Ok, left clicking through the module states goes in the order Active -> Offline -> Online -> Active, which is kinda nonsensical, 'cause the only people I know who have offlined modules on their fits are Prowler pilots, and even then, they don't regularly switch things Online and Offline. I propose toggling between Online and Offline be done via middle click, toggling Online and Active be done via left click, and toggling FIYAH (doo doo doooo, I'll teach you to burn!) be done via right click.
Actually that's primarily habit from EFT, i had such 'suggestion' too, but got used to new behavior quickly - in 2 or 3 days. Toggling stuff online and offline is useful primarily for passive modules where you can compare ship stats w/o actual removal of module from fitting.
I'm not denying it's useful, but it's drawn out, with not really any reason to not have stuff on middle click.

Especially when, occasionally, PyFA goes nuts, and has to refresh the whole interface whenever anything's online'd or offline'd.

Fraa Bjorn
Cell 317
Posted - 2011.01.10 20:16:00 - [194]
 

Originally by: Sakari Orisi
Originally by: darth siidiious
Originally by: crazygirly
I installed Pyfa and it renders the following log dump:

Traceback (most recent call last):
File "run.py", line 56, in <module>
File "sqlalchemy\schema.pyo", line 2119, in create_all
File "sqlalchemy\engine\base.pyo", line 1701, in create
File "sqlalchemy\engine\base.pyo", line 1738, in _run_visitor
File "sqlalchemy\engine\base.pyo", line 1832, in contextual_connect
File "sqlalchemy\pool.pyo", line 192, in connect
File "sqlalchemy\pool.pyo", line 370, in __init__
File "sqlalchemy\pool.pyo", line 214, in get
File "sqlalchemy\pool.pyo", line 600, in do_get
File "sqlalchemy\pool.pyo", line 148, in create_connection
File "sqlalchemy\pool.pyo", line 254, in __init__
File "sqlalchemy\pool.pyo", line 320, in __connect
File "sqlalchemy\engine\strategies.pyo", line 76, in connect
File "sqlalchemy\engine\default.pyo", line 249, in connect
sqlalchemy.exc.OperationalError: (OperationalError) unable to open database file None None

The program never starts...


I get the same error.... anyone here that can help with fixing this? I can't get the program to start :(


Please delete ~/.pyfa/ (~ is c:/users/<username>/ on windows 7)



I get the same problem (Swedish Windows 7 64bit), but it works on my English Vista machine. Deleting .pyfa on the Win7 machine does not help, neither does running as Administrator, nor Run in compatibility mode.

On my Win7 machine, my username contains unicode (ö), whereas the working Vista machine has a 7-bit ascii username. I just quickly browsed the source on your homepage and I assume that is the problem? (although config.py does seem to account for unicode, but maybe sqlalchemy does not? )

Let me know if you need help to reproduce the bug, I'll help you out best I can.

Kadesh Priestess
Scalding Chill
Posted - 2011.01.10 22:06:00 - [195]
 

Edited by: Kadesh Priestess on 10/01/2011 22:18:37
Originally by: Fraa Bjorn
On my Win7 machine, my username contains unicode (ö), whereas the working Vista machine has a 7-bit ascii username. I just quickly browsed the source on your homepage and I assume that is the problem? (although config.py does seem to account for unicode, but maybe sqlalchemy does not? )
You're absolutely correct, we have fixed it right after RC1 release. You can check out one of the development builds to make sure fix works for you.
Originally by: Lina Miaoke
A small suggestion I would like to see. The exact amount of resource remaining.

Currently it shows
CPU 617/635 tf
What I would like to see
CPU 617/635 tf (18 left) and CPU 687/635 tf (52 over)
May be good idea for a tooltip, but for some static text box we just don't have enough space (not for all, but for some fitttings, eg supercaps).
Originally by: Xyfu
I'm not denying it's useful, but it's drawn out, with not really any reason to not have stuff on middle click.
Let's clariffy this a bit. What you suggest to do is:
Active mods:
LMB: online - active - online
RMB - overheat
MMB - offline
Passive mods:
LMB: offline - online - offline
Rigs:
Offline (fyi - as pyfa relies on engine which simulates eve this state doesn't exist for rigs at all) - Online - offline

Correct?

Originally by: Xyfu
Especially when, occasionally, PyFA goes nuts, and has to refresh the whole interface whenever anything's online'd or offline'd.
I bet you're using Vista or 7 with Aero window decoration theme (transulcent glass stuff). This has been also fixed in development builds and will be included in RC2.

TimeDrawsNigh
Amarr
Posted - 2011.01.11 01:14:00 - [196]
 

Edited by: TimeDrawsNigh on 11/01/2011 01:14:14
Originally by: Chelso
Program ran once, was super nice (much better than eft on a mac) but alas it now wont run.

"pyfa error"

[visit macpython website] or [terminate]

That is the message and two options i get. What the go, the macpython site seems out of date with the last update dated 2004.

Any help would be much appreciated!




I'm also getting the same message after running the program once and quitting it. Deleting it and reinstalling the program fixes it.. for one more run, then after quitting it I'm back to square one. Neutral

I'm running Mac OS X 10.5.8 btw.

Xyfu
Minmatar
Love From Above
Posted - 2011.01.11 08:34:00 - [197]
 

Originally by: Kadesh Priestess
Originally by: Xyfu
I'm not denying it's useful, but it's drawn out, with not really any reason to not have stuff on middle click.
Let's clariffy this a bit. What you suggest to do is:
Active mods:
LMB: online - active - online
RMB - overheat
MMB - offline
Passive mods:
LMB: offline - online - offline
Rigs:
Offline (fyi - as pyfa relies on engine which simulates eve this state doesn't exist for rigs at all) - Online - offline

Correct?
Close enough, apart from:

Active mods:
LMB: online - active - online
RMB - overheat
MMB - offline - whatever state it was in before - offline
Passive mods:
MMB: offline - online - offline (Wasn't even aware you could do this, but MMB)
Rigs:
Offline (fyi - as pyfa relies on engine which simulates eve this state doesn't exist for rigs at all) - Online - offline

Originally by: Kadesh Priestss
Originally by: Xyfu
Especially when, occasionally, PyFA goes nuts, and has to refresh the whole interface whenever anything's online'd or offline'd.
I bet you're using Vista or 7 with Aero window decoration theme (transulcent glass stuff). This has been also fixed in development builds and will be included in RC2.
Nah, using XP, just does it anyway sometimes. (Bit of a slow rig, when running 3 EVEs and a firefox.)

Temporal Saint
Posted - 2011.01.11 16:38:00 - [198]
 

Hi,

I really like the program, its working on my laptop with XP but on my home pc it crashes with the following message when I open the Character Editor:
Quote:

Problem signature:
Problem Event Name: APPCRASH
Application Name: pyfa.exe
Application Version: 0.0.0.0
Application Timestamp: 49180193
Fault Module Name: StackHash_7c5e
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: 00000000
Exception Offset: 00000000
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 1043
Additional Information 1: 7c5e
Additional Information 2: 7c5eda3a2aa09c3a791c33848f5fbc26
Additional Information 3: ea75
Additional Information 4: ea75b4bbf0541d836056c69c97fe2c83


I am running Windows 7 Ult. x64 with 8GB memory and the RC of the program. I did try a nightly build but it gave the same issue.

Something I can do to get it to work?

Thanks.

Kadesh Priestess
Scalding Chill
Posted - 2011.01.11 21:07:00 - [199]
 

Edited by: Kadesh Priestess on 11/01/2011 21:09:49
Originally by: TimeDrawsNigh
I'm also getting the same message after running the program once and quitting it. Deleting it and reinstalling the program fixes it.. for one more run, then after quitting it I'm back to square one. Neutral
I'm running Mac OS X 10.5.8 btw.
Unfortunately, for now we can't help with this one. I have couple of Macs at work (including macbook 3.1 with 10.5 on-board), but won't have time to check the issue anytime soon. So if anyone familiar with Mac and Python (as well as access to machine with similar issue) can help us with tracking issue down - it'd be greatly appreciated.
Originally by: Temporal Saint
Something I can do to get it to work?
My primary workstation has almost the same setup, so, uh, i can't imagine what can cause it. Do you have DEP enabled for all programs or just system components (System Properties > Advanced System Settings > Advanced > Performance Settings > Data Execution Prevention)?
Originally by: Xyfu
Close enough, apart from:
Maybe later as an option, current behavior will be kept as default.
Originally by: Xyfu
Nah, using XP, just does it anyway sometimes. (Bit of a slow rig, when running 3 EVEs and a firefox.)
Hopefully we got rid of flickering on MSW platform at all, including XP platform :)

Rawnie
Posted - 2011.01.12 06:35:00 - [200]
 

Edited by: Rawnie on 12/01/2011 07:02:08
Nevermind, made a mistake Rolling Eyes

Gareth Ultari
Posted - 2011.01.12 16:29:00 - [201]
 

Originally by: Gareth Ultari
Edited by: Gareth Ultari on 30/12/2010 18:54:45
Edited by: Gareth Ultari on 30/12/2010 18:51:59
would be nice if all ammo types came loaded as possible damage patterns.

or as a compromise, when you open the damage pattern editor, you can still click and move through the menus to different damage types (and manually enter them).

Also, I tried exporting from Eve's fitting menu to a .xml file on a mac and it could not import to Pyfa on a mac until i made a fit and saved it. Then it was able to import. Not a big deal.

almost forgot, none of the implant functions work on my version on the mac. Can't add any.


Nice work otherwise, very good tool, especially for the mac.



any thoughts on the implant issue? i can't get to the actual list of implants. the drop down goes from skill hardwiring / attribute enhancers and then to the implant slots and then on the skill hardwiring it goes into the categories (armor/gunnery/industry/etc) but the actual implant items don't pop up.

Temporal Saint
Posted - 2011.01.12 20:47:00 - [202]
 

Originally by: Kadesh Priestess
Originally by: Temporal Saint
Something I can do to get it to work?
My primary workstation has almost the same setup, so, uh, i can't imagine what can cause it. Do you have DEP enabled for all programs or just system components (System Properties > Advanced System Settings > Advanced > Performance Settings > Data Execution Prevention)?


It's only enabled for windows stuff, not all programs.

I've disabled/unloaded anything that could play parts like Virus scanners and other background processes. Downloaded the latest nightly, everything works but as soon as I open the character editor, it crashes.

Is there a log or maybe a debug switch I can enable for extra logging?

Sphit Ker
Dreddit
Test Alliance Please Ignore
Posted - 2011.01.13 06:21:00 - [203]
 

Hey how am I supposed to use the projected effect function? I’d like to know how quick a given Curse setup can nuke a Drake’s capacitor, for one, or how much I can debuff a Dramiel’s range with tracking disruptors and so on.

How do I drag a module from a ship to another ships’ projected tab?

Xyfu
Minmatar
Love From Above
Posted - 2011.01.13 09:32:00 - [204]
 

Originally by: Sphit Ker
Hey how am I supposed to use the projected effect function? I’d like to know how quick a given Curse setup can nuke a Drake’s capacitor, for one, or how much I can debuff a Dramiel’s range with tracking disruptors and so on.

How do I drag a module from a ship to another ships’ projected tab?
Right click, project onto fit. Though, script changes in projected effects aren't implemented yet.

Click-dragging would be nice, devs.

Sphit Ker
Dreddit
Test Alliance Please Ignore
Posted - 2011.01.13 12:31:00 - [205]
 

Originally by: Xyfu
Originally by: Sphit Ker
Hey how am I supposed to use the projected effect function? I’d like to know how quick a given Curse setup can nuke a Drake’s capacitor, for one, or how much I can debuff a Dramiel’s range with tracking disruptors and so on.

How do I drag a module from a ship to another ships’ projected tab?
Right click, project onto fit. Though, script changes in projected effects aren't implemented yet.

Click-dragging would be nice, devs.


ah OK. Laughing
all I get is ship stats, module stats and jump to module market group in the right click menu.

Xyfu
Minmatar
Love From Above
Posted - 2011.01.13 22:26:00 - [206]
 

Originally by: Sphit Ker
Originally by: Xyfu
Originally by: Sphit Ker
Hey how am I supposed to use the projected effect function? I’d like to know how quick a given Curse setup can nuke a Drake’s capacitor, for one, or how much I can debuff a Dramiel’s range with tracking disruptors and so on.

How do I drag a module from a ship to another ships’ projected tab?
Right click, project onto fit. Though, script changes in projected effects aren't implemented yet.

Click-dragging would be nice, devs.


ah OK. Laughing
all I get is ship stats, module stats and jump to module market group in the right click menu.
You need a fit loaded, I think, and the projected effects window in focus. Something like that.

(I have an old version, though.)

yoo'hoo
Posted - 2011.01.14 21:26:00 - [207]
 

Looking cool so far. The only thing that bugged me after using eft so much is no sorting of the resistance types. Its one long list and a mess. A sub group of the resist type would help out greatly under the different platings and hardeners.

Zemog Osan
Posted - 2011.01.15 09:47:00 - [208]
 

Originally by: yoo'hoo
Looking cool so far. The only thing that bugged me after using eft so much is no sorting of the resistance types. Its one long list and a mess. A sub group of the resist type would help out greatly under the different platings and hardeners.

^
This

The main thing that is keeping me from using this more often I would want to see implemented is "check affecting skills" like EFT has.

Overall awesome software, thanks.

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2011.01.15 10:18:00 - [209]
 

Originally by: Zemog Osan
Originally by: yoo'hoo
Looking cool so far. The only thing that bugged me after using eft so much is no sorting of the resistance types. Its one long list and a mess. A sub group of the resist type would help out greatly under the different platings and hardeners.

^
This

The main thing that is keeping me from using this more often I would want to see implemented is "check affecting skills" like EFT has.

Overall awesome software, thanks.


This is actualy already implemented. Right click on a module and check the module stats (also works for ship stats, of course). You'll see the "Affected By" tab

Zemog Osan
Posted - 2011.01.16 01:22:00 - [210]
 

It's there to a certain extent I guess but It's not the same. If you don't have a skill trained that effects that ship or module it won't show it, it doesn't show you what level that skill is or give you a quick way to change it like ETF does.


Pages: first : previous : ... 3 4 5 6 [7] 8 9 10 11 ... : last (12)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only