open All Channels
seplocked Linux
blankseplocked issues at login on Arch
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

tel0seh
Posted - 2010.10.10 16:11:00 - [1]
 

Hi guys, I'm running Arch Linux, and having a strange issue that I cant find any information about after a few hours of searching, so I'm hoping someone else has seen + solved the problem.
After running eve, the splash comes up, and the game starts, however everything except the background is squished into the top right hand corner of the screen. See my attatched screenshot.

[URL=http://img403.imageshack.us/i/201010101711311680x1050.png/][/url]Please visit your user settings to enable images.

The errors I get when moving my (invisible) mouse are:




fixme:d3dx:D3DXGetImageInfoFromFileInMemory (0x8cac9d4, 640, 0x33b338): partially implemented
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:d3dx:D3DXGetImageInfoFromFileInMemory Invalid or unsupported image file
An exception has occurred. It has been logged in the log server as exception #2
fixme:d3dx:D3DXGetImageInfoFromFileInMemory (0x8d5f2cc, 1152, 0x33b338): partially implemented
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
fixme:d3dx:D3DXGetImageInfoFromFileInMemory Invalid or unsupported image file
An exception has occurred. It has been logged in the log server as exception #3
fixme:d3dx:D3DXGetImageInfoFromFileInMemory (0x8e4d8cc, 1152, 0x33b338): partially implemented







any ideas ladies and gentlemen?


ElfeGER
Deep Core Mining Inc.
Posted - 2010.10.10 16:18:00 - [2]
 

did you install or copy the client? try running the dxsetup included with Eve

what gfx card and driver + version do you use?

tel0seh
Posted - 2010.10.10 16:25:00 - [3]
 

Edited by: tel0seh on 10/10/2010 16:28:30
I copied the client, as I had issues with the download corrupting every time. I'm using a GEforce 7900GS and the latest proprietary Nvidia binary drivers. it's not a graphics issue as I'm playing WoW and counterstrike perfectly.

EDIT:

I went into the /bin directory and ran the DX installer, and now i can log in, However the framerate is absolutely diabolical.

Pivot P'tesh
Quantum Cats Syndicate
Posted - 2010.10.10 20:32:00 - [4]
 

I had the same issues till I installed the d3dx9 package with winetricks

velusip
Woopatang
Posted - 2010.11.27 14:43:00 - [5]
 

Originally by: ElfeGER
did you install or copy the client? try running the dxsetup included with Eve


Leaving this here for the fellow Arch users to chew on if they need it.


  • nvidia module (blacklist everything else)

  • Arch 64 + multi-libs

  • WINEARCH=wine32; winecfg

  • winetricks corefonts

  • Use Eve's "Repair" tool to install the game

  • Run included Direct X tool, CCP/EVE/bin/DirectX



Works 60% of the time -- everytime.

I still have severe problems with weird crashes where an error pops up, but eve continues to run. It's sketchy as **** and will randomly stop, so I don't do anything fun in Eve under Linux. It's just to tie me over until I feel the need to actually install Windows.

I don't even know what CCP was thinking revoking Linux support. Expecially now that everyone I know has just dropped Windows in favour of Linux and stopped playing. :/


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only