open All Channels
seplocked Linux
blankseplocked Ubuntu version 10.10
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Reaver Glitterstim
Legio Geminatus
Posted - 2010.09.18 02:54:00 - [1]
 

Does anyone here use Ubuntu 10.10? And if so what problems, if any, have you had?

I haven't seen anyone mention using version 10.10 yet anywhere on the forums, and solutions that have worked for others don't always seem to be working for me. Anyone think I have reason to believe that my version is one of the problems? Or is that probably not it?

More specifically, I don't know if renaming the jukebox directory made any difference because the game freezes when I try to turn sound on; updating the drivers and running that script for the drivers in wine did allow me to log into the station (there were minor graphical errors) but it failed to render any graphics at all outside of station (including previously rendered menu items); and I was unable to alter the screen size without the game crashing.

Now, I installed the latest driver from ATI directly (linux version of course) and it circumvented the previously existing driver but failed to activate the new one, and now the system runs as if it has no video driver and fails to start Eve completely. Please help!

Solbright
Advanced Security And Asset Protection
Posted - 2010.09.18 03:45:00 - [2]
 

http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1381872 and http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1379295

I can't tell from the comments but I presume you reenable sound after voice is disabled? That's certainly the way I've always played Eve.

As for graphics driver kernel mismatches, I've never succeeded in replacing the purpose built one. Which hasn't actually been an issue using nVidia cards.

Ubuntu now has a working revert back to failsafe driver, from whence I can de/reinstall the restricted driver and get the full speed OpenGL function back. :)


Satori Yakamura
Archaeopteryx Werften
Free Allied Traders
Posted - 2010.09.20 01:28:00 - [3]
 

Generally ATI (or now "AMD") Graphic Cards are no good Linux players.
It's a pain to get this working right.
My last test with a ATI Card was with Ubuntu Hardy. I got Eve Running but Space was displayed with "White" backgrounds.
So i dont get ATI running with EVE correctly.... :(


Now iam using ubuntu 10.04 as 10.10 is only beta release (I don't surf on bleeding edges) with an NVIDIA Card.
Which is easer to get working with the nvidia drivers. So EVE worked nearly out of the box after installing Nvidia drivers and renaming the jukebox.

The sound problem comes from Wine which not uses pulse-audio (the gnome sound drivers) but ALSA or OSS. Which results in "sound muting" after Starting EVE. Which can be fixed with alsamixer utility or in my case with just hitting volume up buttons on my keyboard a few times. vola sound is back ;-)

To make it short. If knowone else has a solution for ATI Cards i recommend you to get an nvidia card.

Alua Oresson
V I R I I
Posted - 2010.09.20 11:31:00 - [4]
 

I am running EVE with the 10.10 version of Ubuntu with an nVidia video card. I have no issues. It isn't the distro that is the problem.

Ravow
Minmatar
Cosmic Encounter
Mayhem.
Posted - 2010.09.21 13:44:00 - [5]
 

You have installed last fglrx ATI driver?

If it don't install correctly, you must check that first. You can past your error log somewhere in pastepin.

The best will be the dmesg log and the Xorg.0.log so I will be able to figure where is the problem.

For those having gray space and white object, it's caused by you using the OSS drivers instead of the binary blob driver. Those OSS drivers dont support the patents infected S3TC DXT* texture compression used by EVE. BUT Direct3D 10/11 is now implanted natively via a gallium state tracker soo it's a question of time (S3TCEvil or Very Mad) that we will get better than what we get with proprietary ATI/Nvidia drivers)

Douglas WildOak
The Executioners
Capital.Punishment
Posted - 2010.09.25 13:30:00 - [6]
 

Edited by: Douglas WildOak on 25/09/2010 14:07:07
Edited by: Douglas WildOak on 25/09/2010 13:34:20
Edited by: Douglas WildOak on 25/09/2010 13:33:05
Originally by: Satori Yakamura
Generally ATI (or now "AMD") Graphic Cards are no good Linux players.
It's a pain to get this working right.
My last test with a ATI Card was with Ubuntu Hardy. I got Eve Running but


I'm sorry, but that's bull****. I have had the chance to compare NVidia linux drivers to ATI in several scenarios and have come to the conclusion that ATI is superior, both in the current state of the drivers and the support for the community developers. Besides, the last time you looked at their drivers was for Hardy...

OP, you need to install fglrx "the right way". Completely uninstall all remnants of the current failed install and use the package build option of the ATI .run file to build the driver packages to install.

$ sh ati-driver-installer-10-9-x86.x86_64.run --listpkg
$ sh ati-driver-installer-10-9-x86.x86_64.run --buildpkg Ubuntu/lucid

This generates four deb files which you can then install using a package manager.

Apparently, the driver packaging scripts for xserver 1.9 have just made their way into the 10.10 repositories. See:
http://www.phoronix.com/forums/showthread.php?t=26164

EDIT: corrected filename
EDIT: corrected driver version in last para.

Reaver Glitterstim
Legio Geminatus
Posted - 2010.09.26 05:20:00 - [7]
 

Yeah I was worried I might have to do something like that, uninstall and do it over in the right order. I'll try what you said if I have trouble again. But for now I have windows working again, and I'm too lazy to work on Ubuntu at the moment.

Maybe I should say WHEN windows breaks again I'll try what you said.


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only