open All Channels
seplocked Linux
blankseplocked Install Fails
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Riley Anwar
Caldari
DARK HAT
4U Holdings Inc
Posted - 2010.08.06 18:48:00 - [1]
 

I'm trying to install EVE Tyrannis and I'm running into an issue where the installer claims its corrupted. I've downloaded the offline installer and bit torrent installer at least 3 times each. Every time is claims it's corrupt. The installer will reach the point where it begins to verify files and it will fail. In the terminal I see the following.
Quote:

[ knapcikm@fedora Downloads]$ wine EVE_Premium_Setup_167296_m\(2\).exe
fixme:shell:SHAutoComplete stub
fixme:exec:SHELL_execute flags ignored: 0x00000180
err:virtual:map_image failed to set 60000020 protection on section .text, noexec filesystem?


I'm running Wine 1.3 on Fedora 13.

Thanks!

ElfeGER
Deep Core Mining Inc.
Posted - 2010.08.07 10:25:00 - [2]
 

do you have a noexec filesystem or /tmp ?

"mount" should tell

Dristra
Amarr
Idle Haven
Posted - 2010.08.08 16:42:00 - [3]
 

Had the same problem myself, it refused to work until i moved the installer into the wine directory and tried running it from there.

Traykoff
Gallente
Obscure Ops
Posted - 2010.08.12 00:05:00 - [4]
 

Edited by: Traykoff on 12/08/2010 00:05:18
Not sure if this will help much but anyways;

1. Supporting the idea that Dristra suggested - put the installation file somewhere within your wine directory (in my case /home/user/.wine/drive_c/)
2. Start explorer:
$ wine explorer

3. Press the "c:\" button and double click on the installer

Surprisingly this is the only way it works for me on my Ubuntu 10.04.

Patches I run the same way. Not sure why, but they each time crash the first time so I do repair... but it works at the end so I can live with that :)

Sordeo Regius
Thunderwaffe
Goonswarm Federation
Posted - 2010.08.12 19:08:00 - [5]
 

Make sure the file has 2 things, execute bits set and .exe associated with wine. One of those two are what is causing your problem.

Kaliba Mort
Minmatar
Dark-Rising
Executive Outcomes
Posted - 2010.08.14 04:26:00 - [6]
 

From my experience, EVE patcher (no clue what installer does), always unpacks the compressed archive in the .EXE file into Local Settings subdirectory. There is no need to move it there, as long as the original patch is in one of the paths defined in winecfg.

Also, you do not need to "associate" .EXE with wine in GNOME or anywhere else.

HTTP download over IPv4 *can* result corrupted thanks to crappy checksuming in TCP, but bittorrent downloads should not.

As someone already wrote, the error seems to be "noexec filesystem". That is, no executable bit is set on the file system. Maybe you have /home mounted with noexec option.

What is the output of `mount` command?


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only