open All Channels
seplocked Linux
blankseplocked Out of Memory
 
This thread is older than 90 days and has been locked due to inactivity.


 
Author Topic

Aerieth
Posted - 2010.08.04 00:29:00 - [1]
 

So I am running Ubuntu 10.04, I have an nVidia Geforce 200 (not a gaming card I know) and I am using the current nVidia drivers from the launchpad PPA (needed for sound out of HDMI)

I can start up and play EVE for about 15 minutes and then textures stop loading and I then it dies. With these oodles of errors.

err:d3d_surface:surface_allocate_surface >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glTexImage2D @ surface.c / 857
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glTexSubImage2D @ surface.c / 768
err:d3d_surface:surface_allocate_surface >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glTexImage2D @ surface.c / 857
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glTexSubImage2D @ surface.c / 768
err:d3d_texture:basetexture_bind >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glBindTexture @ basetexture.c / 322
err:d3d_surface:surface_allocate_surface >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glTexImage2D @ surface.c / 857
err:d3d_texture:basetexture_bind >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glBindTexture @ basetexture.c / 322
err:d3d_surface:surface_upload_data >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glTexSubImage2D @ surface.c / 768
err:d3d_texture:basetexture_bind >>>>>>>>>>>>>>>>> GL_OUT_OF_MEMORY (0x505) from glBindTexture @ basetexture.c / 322
XIO: fatal IO error 12 (Cannot allocate memory) on X server ":0.1"
after 27669 requests (27667 known processed) with 0 events remaining.

The card has 1GB of VRAM and I play on all low settings, it shouldn't be running out of memory.

Any ideas how to deal with this?

Aerieth
Posted - 2010.08.05 11:20:00 - [2]
 

Nothing? No ideas? No requests for more information?

Kaliba Mort
Minmatar
Dark-Rising
Executive Outcomes
Posted - 2010.08.05 13:13:00 - [3]
 

http://www.nvidia.com/object/geforce_family.html
^^ Can't find your video card here Embarassed

Anyway, you may want to provide information like output of,

wine --version

The obvious is that X run out of memory. The reason is most likely a memory leak.

I've experienced severe leaks in X resources in wine 1.1.x series until almost 1.2. For me X bloated to 2+G over a period of few hours. I suggest you upgrade to wine stable (version 1.2).

PS. This is not a high traffic part of the forum, like COAD or similar. Responses can take days and that is if someone knows what's going on Laughing

Miraqu
Caldari
Posted - 2010.08.05 18:00:00 - [4]
 

There was such a problem once.

Some difficulties with storing textures above the 3GB (32bit) limit of wine.

http://www.nvnews.net/vbulletin/showthread.php?s=1e3dedf64625a7b246ead78dcab1d3f5&t=127984&page=7

But it should not happen with the current driver release.

Could you post your driver version?

Aerieth
Posted - 2010.08.05 23:32:00 - [5]
 

Oh damn, I think I found the problem. I realized I posted the nVidia chip not the actual video card. So when I went to look it up I discovered something. My card is this one http://www.msi.com/index.php?func=proddesc&maincat_no=130&prod_no=1923 and you'll notice it is only 512MB RAM.

See this is my media PC so I've never used it for gaming so I never actually looked at the VRAM. But when I go into nvidia-settings it reports back 1024MB RAM, which is I guess where this memory issue is coming from.

I should be heading over to the nvidia support for this one. Sorry about that guys.

Miraqu
Caldari
Posted - 2010.08.07 19:40:00 - [6]
 

Check your wine registry.

there is a key in HKEY_CURRENT_USER\Software\Wine\Direct3D

then add "VideoMemorySize" = 512


 

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only