open All Channels
seplocked EVE Technology Lab
blankseplocked POS Tracker - FGV - 5.1.5
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 2 3 4 5 6 7 8 [9]

Author Topic

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.08.25 04:41:00 - [241]
 

Originally by: Harry Bigshot
What would cause half of the towers to suddenly have no fuel at all and then on the next update the postracker reflecting the normal fuel levels again.

It seems to only have happened since i added another 5 towers. My postracker now has 12 towers in it, is it an issue of timeout waiting for the api to respond?


I could see a failed API pull(bad data perhaps) or maybe the SQL query failed on your server. Though the query failing can't really be the case because it just does an update so it would have had just old data. Same thing with a timeout, if a timeout happens and you get no data the POSes are just not updated. Which is why there's been a few requests that when it doesn't notice a tower on the API anymore to remove it from the tracker.

But 12 towers isn't a lot as I've seen the tracker handle 5x with no issues. I mean I don't even think there would be a problem with the tracker handling hundreds but I don't have any API keys to do such tests like that.

So really no idea on that one but just remembered something. Earlier today there was some downtime which maybe API was down or broken at the time also perhaps? Though that happened 12 hours ago so not sure what time you actually noticed this. Odd random fun you got there good sir.

-FG

Elesil Daelwon Taranogas
Posted - 2011.08.25 11:33:00 - [242]
 

Hi @all

I have a problem with the registry api key on the admin page

The message always appears when I enter the API key

Quote:
Error Code: 521::Invalid username and/or password passed to UserData.LoginWebUser().


I am director of my corp and the API key works with other programms

can someone help me with the problem ?

greeting


Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.08.25 13:59:00 - [243]
 

Originally by: Elesil Daelwon Taranogas
Hi @all

I have a problem with the registry api key on the admin page

The message always appears when I enter the API key

Quote:
Error Code: 521::Invalid username and/or password passed to UserData.LoginWebUser().


I am director of my corp and the API key works with other programms

can someone help me with the problem ?

greeting




Well if you know how to copy and paste it's usually this issue:

Your server has an interesting setup and you need to update your php.ini: http://www.eveonline.com/ingameboard.asp?a=topic&threadID=838892&page=10

Wait a second I just remembered something. You seem familiar. You asked this question on 6/7/11 and stated you couldn't touch your php.ini. Ummm well with no access to that it makes it a lot tougher to troubleshoot. In most cases you can override your php.ini you just don't know it. I can help troubleshoot this if you give me access to your webhost otherwise I would try and get another web host. If you want also I can also talk to your webhost(as I have done so in the past for others) about the issue but I'm going to need details about who you host with and where your installed files are actually located. Let me know via EVEMail if you don't want others to see.

-FG

Descention
Mega Global Compucon
Posted - 2011.08.25 17:44:00 - [244]
 

Edited by: Descention on 25/08/2011 17:45:08
I have made a few SQL queries to fix Pos Tracker for Wormhole folk. You may need to modify them to your own database if you changed the table prefix.

Quote:

-- fix region name in pos add list
update `pos3_moonsinstalled` set `regionName`=concat(regionName ,' R' , right(`regionID`,2)) WHERE `regionName` = 'Unknown'

-- fix region name in rest
update `pos3_mapregions` set `regionName`=concat(regionName ,' R' , right(`regionID`,2)) WHERE `regionName` = 'Unknown'

-- fix constellation name in pos add list
update `pos3_mapconstellations` set `contellationName`=concat(contellationName ,' C' , right(`contellationID`,3)) WHERE `contellationName` = 'Unknown'

-- fix dotloan link for pos location
update `pos3_evemoons` set moonName=REPLACE(moonName,"Uncharted Planet",`systemName`) WHERE `moonName` like 'Uncharted%'


Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2011.08.26 03:24:00 - [245]
 

Originally by: Descention
Edited by: Descention on 25/08/2011 17:45:08
I have made a few SQL queries to fix Pos Tracker for Wormhole folk. You may need to modify them to your own database if you changed the table prefix.

Quote:

-- fix region name in pos add list
update `pos3_moonsinstalled` set `regionName`=concat(regionName ,' R' , right(`regionID`,2)) WHERE `regionName` = 'Unknown'

-- fix region name in rest
update `pos3_mapregions` set `regionName`=concat(regionName ,' R' , right(`regionID`,2)) WHERE `regionName` = 'Unknown'

-- fix constellation name in pos add list
update `pos3_mapconstellations` set `contellationName`=concat(contellationName ,' C' , right(`contellationID`,3)) WHERE `contellationName` = 'Unknown'

-- fix dotloan link for pos location
update `pos3_evemoons` set moonName=REPLACE(moonName,"Uncharted Planet",`systemName`) WHERE `moonName` like 'Uncharted%'




What exactly do these do? I don't have an active install to test on atm.

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2011.08.26 03:33:00 - [246]
 

Originally by: Frozen Guardian
Originally by: Elesil Daelwon Taranogas
Hi @all

I have a problem with the registry api key on the admin page

The message always appears when I enter the API key

Quote:
Error Code: 521::Invalid username and/or password passed to UserData.LoginWebUser().


I am director of my corp and the API key works with other programms

can someone help me with the problem ?

greeting




Well if you know how to copy and paste it's usually this issue:

Your server has an interesting setup and you need to update your php.ini: http://www.eveonline.com/ingameboard.asp?a=topic&threadID=838892&page=10

Wait a second I just remembered something. You seem familiar. You asked this question on 6/7/11 and stated you couldn't touch your php.ini. Ummm well with no access to that it makes it a lot tougher to troubleshoot. In most cases you can override your php.ini you just don't know it. I can help troubleshoot this if you give me access to your webhost otherwise I would try and get another web host. If you want also I can also talk to your webhost(as I have done so in the past for others) about the issue but I'm going to need details about who you host with and where your installed files are actually located. Let me know via EVEMail if you don't want others to see.

-FG


Try
<php phpinfo() ?>
in a php file and see what arg_separator.output is set to. You may have to view source to make sure its not ∓

Depending on what that says, you can try [code]ini_set('arg_separator.output', '&'); in the api scripts. You may also be able to changed them with a .htaccess file.

Your best bet though is to change it in the php.ini or if you can't modify it, yell at your host because they suck. For a small monthly fee, I would be happy to host it for you :)

orphenshadow
Gallente
Easy Co.
Fatal Ascension
Posted - 2011.08.26 14:29:00 - [247]
 

I keep getting the error

ERROR API Cache timer too short ;

When trying to update my pos from API.

I googled and found that it was a bug that had been fixed in an earlier version. Yet I am still experiancing the issue. Anyone else know how to fix this? I've tried adding different API keys. No luck.

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.08.29 04:16:00 - [248]
 

Originally by: orphenshadow
I keep getting the error

ERROR API Cache timer too short ;

When trying to update my pos from API.

I googled and found that it was a bug that had been fixed in an earlier version. Yet I am still experiancing the issue. Anyone else know how to fix this? I've tried adding different API keys. No luck.


That problem was more towards jobs causing the API timer to be off. Not so much the POS timer. What version are you on currently and how often are you trying to update it? Are you also sure you replaced old files with new ones?

-FG

Descention
Mega Global Compucon
Posted - 2011.08.30 14:29:00 - [249]
 

Originally by: Johnathan Roark
Originally by: Descention
Edited by: Descention on 25/08/2011 17:45:08
I have made a few SQL queries to fix Pos Tracker for Wormhole folk. You may need to modify them to your own database if you changed the table prefix.

Quote:

-- fix region name in pos add list
update `pos3_moonsinstalled` set `regionName`=concat(regionName ,' R' , right(`regionID`,2)) WHERE `regionName` = 'Unknown'

-- fix region name in rest
update `pos3_mapregions` set `regionName`=concat(regionName ,' R' , right(`regionID`,2)) WHERE `regionName` = 'Unknown'

-- fix constellation name in pos add list
update `pos3_mapconstellations` set `contellationName`=concat(contellationName ,' C' , right(`contellationID`,3)) WHERE `contellationName` = 'Unknown'

-- fix dotloan link for pos location
update `pos3_evemoons` set moonName=REPLACE(moonName,"Uncharted Planet",`systemName`) WHERE `moonName` like 'Uncharted%'




What exactly do these do? I don't have an active install to test on atm.


It fixes unknown space region/constellation/planet names so that they don't all say "Unknown" or "Uncharted". This fix will allow the dotlan links beside the pos list to work for wormhole stations.

Mark Hampton
Posted - 2011.08.30 21:22:00 - [250]
 

Great work on this, it's hugely useful.

Two things:

1) I don't get how the 'Import Structures' is supposed to work. It wants some file, where is this supposed to be gotten from?

2) I'd really, REALLY love a feature that allows me to determine optimal fuel distribution with the fuel I have on hand. For example, if I have four towers, and I have X coolant, Y enriched uranium and Z isotopes, how much should I put in each to get the maximum times overall?


Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.08.30 22:41:00 - [251]
 

Originally by: Mark Hampton
Great work on this, it's hugely useful.

Two things:

1) I don't get how the 'Import Structures' is supposed to work. It wants some file, where is this supposed to be gotten from?

2) I'd really, REALLY love a feature that allows me to determine optimal fuel distribution with the fuel I have on hand. For example, if I have four towers, and I have X coolant, Y enriched uranium and Z isotopes, how much should I put in each to get the maximum times overall?




1. Import can only import 2 types of files. One from the POS tracker itself in which you exported earlier or from the program My POS(I'd link to it but the site seems to be down).

2. An interesting request but also a tuffy especially if we think about variables like if they don't have enough isotopes or coolant to do one cycle. Would have to make sure people understand that it can't work wonders unless someone has an idea on how to handle this request better. I mean would you care that you can only gain 3 hours in coolant and robotics but nothing else? I mean the tower wouldn't really gain anything in terms of time. I'll see what I can do with this though. We do have a partial fueling coming up in 5.1.6 that allows you to specify a partial fuelup based on space in cargo hold.

If you or anyone has any input on what they think about the request aka #2 idea please let me know. I'd be open for suggestions on this one on how you would specifically want it to work and where.

-FG

Mark Hampton
Posted - 2011.08.30 23:47:00 - [252]
 

A more typical use case for the feature request is this:

1) I use POS Tracker to figure out how much total fuel I need to buy
2) I transport the fuel to my target system
3) I have to go away / get DC'd / have some other reason I can't fuel right then
4) I come back the next day, and then I don't know how much fuel to put in each tower. If I use the 'optimal' value with today's data, I'll short one tower by a whole bunch.


Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2011.08.30 23:59:00 - [253]
 

Originally by: Mark Hampton
A more typical use case for the feature request is this:

1) I use POS Tracker to figure out how much total fuel I need to buy
2) I transport the fuel to my target system
3) I have to go away / get DC'd / have some other reason I can't fuel right then
4) I come back the next day, and then I don't know how much fuel to put in each tower. If I use the 'optimal' value with today's data, I'll short one tower by a whole bunch.




What your more looking for is how to evenly distribute the fuel so each tower will be on for the same amount of days?

Mark Hampton
Posted - 2011.08.31 00:23:00 - [254]
 

Yes, more or less.

Originally by: Johnathan Roark
Originally by: Mark Hampton
A more typical use case for the feature request is this:

1) I use POS Tracker to figure out how much total fuel I need to buy
2) I transport the fuel to my target system
3) I have to go away / get DC'd / have some other reason I can't fuel right then
4) I come back the next day, and then I don't know how much fuel to put in each tower. If I use the 'optimal' value with today's data, I'll short one tower by a whole bunch.




What your more looking for is how to evenly distribute the fuel so each tower will be on for the same amount of days?

Xathros
Inferno Technologies
Posted - 2011.09.02 13:52:00 - [255]
 

Edited by: Xathros on 02/09/2011 13:53:00
Hey I just wanted to try out the pos tracker and I have one main issue:
It's not possible to add a API key (Admin Panel).
Here is the error message:
Quote:
Error: String could not be parsed as XML

Any ideas?

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.09.02 15:37:00 - [256]
 

Originally by: Xathros
Edited by: Xathros on 02/09/2011 13:53:00
Hey I just wanted to try out the pos tracker and I have one main issue:
It's not possible to add a API key (Admin Panel).
Here is the error message:
Quote:
Error: String could not be parsed as XML

Any ideas?



Are you by chance trying to use the new API key system? The POS tracker doesn't support the new API version. However if not, I've been hearing issues of people using the API in all sorts of apps since the update with the old keys which is wonderful. If bad data comes back then you usually see that XML message. If possible try with someone else's key just to see what happens and make sure your install matches install requirements.

-FG

Xathros
Inferno Technologies
Posted - 2011.09.02 18:17:00 - [257]
 

Edited by: Xathros on 02/09/2011 18:18:32
Quote:

Are you by chance trying to use the new API key system? The POS tracker doesn't support the new API version. However if not, I've been hearing issues of people using the API in all sorts of apps since the update with the old keys which is wonderful. If bad data comes back then you usually see that XML message. If possible try with someone else's key just to see what happens and make sure your install matches install requirements.
-FG


No, I'm using the old API system. I've tried with another characters API and it's the same issue.
Install requirements are met, but I saw that CURL was version 0, and something like fopen was used as alternative. Might that be the cause of the problem? It did install fine though.

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.09.02 19:40:00 - [258]
 

Originally by: Xathros
Edited by: Xathros on 02/09/2011 18:18:32
Quote:

Are you by chance trying to use the new API key system? The POS tracker doesn't support the new API version. However if not, I've been hearing issues of people using the API in all sorts of apps since the update with the old keys which is wonderful. If bad data comes back then you usually see that XML message. If possible try with someone else's key just to see what happens and make sure your install matches install requirements.
-FG


No, I'm using the old API system. I've tried with another characters API and it's the same issue.
Install requirements are met, but I saw that CURL was version 0, and something like fopen was used as alternative. Might that be the cause of the problem? It did install fine though.


Yeah that would be the issue. CURL needs to work.

-FG

Xathros
Inferno Technologies
Posted - 2011.09.02 22:54:00 - [259]
 

Okay, thanks alot ;)
Is it really normal that it didn't cancel the installation then?


Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.09.03 00:47:00 - [260]
 

Originally by: Xathros
Okay, thanks alot ;)
Is it really normal that it didn't cancel the installation then?




At this time yes. The installer and the updater both need a bit of an update. Sorry for any inconvenience.

-FG

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2011.09.06 22:12:00 - [261]
 

New thread here on the new forums:

https://forums.eveonline.com/default.aspx?g=posts&t=6801

Please post any future stuff there.

Thank you,
-FG


Pages: 1 2 3 4 5 6 7 8 [9]

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only