open All Channels
seplocked EVE Technology Lab
blankseplocked POS Tracker - FGV - 5.1.5
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 [2] 3 4 5 6 7 8 9

Author Topic

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.09.08 17:24:00 - [31]
 

Originally by: Fizzle Fingers
Hi,

I uploaded some pics for you and mailed you the url.

The pics were done with same settings as what the pic of the fuel in the tower shows (18d 10h i think it was). There is a slight discrepancy with the numbers as a pos tick happened while taking them.




I see the issue. The problem is using structures to calculate the CPU/PG. Works on the POS View page because the information is there on what structures are available. Not so much for other pages because it was never made to do so. It never touches the database's information on the tower's CPU/PG. Sweet. Never seen it before because I know the structure information isn't the greatest and we just entered in the CPU/PG right from the tower.

Since I've never touched this area of the tracker it's probably going to need a bit of changes that may take a bit. Basically, a re-write of how it handles structure information.

So in the mean time if you want the correct information I would suggest removing all structures and putting in the CPU/PG manually based on what you actually see when you open up tower information in game. If you want to see what structures are on the tower, I guess you can put them in anchored mode instead of online because then it doesn't override your manual entry of the CPU/PG on the tower then.

-FG

Onyc Chick
Posted - 2010.09.12 21:09:00 - [32]
 

Really glad to see that youve decided to keep the project alive. Thanks !!! Just two suggestions for the next version:

- Production: Is it possible to fix the silo linking problem ? Whenever you link an output silo to another and the initial one gets full it shows all the other linked silos as being full too and the timers in brackets are completely off.

- Access: If i dont assign fuel techs to the towers I have a problem where people that have the fuel tech role still get to see the towers but the fuel calculator list as well as fuel bill are completely empty. Id like to be able to decide whether I want fuel techs to work on all towers. Maybe an option to "assign to all"

Thanks again for your efforts


Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.09.13 19:35:00 - [33]
 

Originally by: Onyc Chick
Really glad to see that youve decided to keep the project alive. Thanks !!! Just two suggestions for the next version:

- Production: Is it possible to fix the silo linking problem ? Whenever you link an output silo to another and the initial one gets full it shows all the other linked silos as being full too and the timers in brackets are completely off.

- Access: If i dont assign fuel techs to the towers I have a problem where people that have the fuel tech role still get to see the towers but the fuel calculator list as well as fuel bill are completely empty. Id like to be able to decide whether I want fuel techs to work on all towers. Maybe an option to "assign to all"

Thanks again for your efforts




Production Fix request added.

As for the access thing, this is a matter of preference unfortunately. I went back and forth on what to do here because some people have different ideas on how they should work. It does need a bit more tweaking.

There is a group though that can see everything like you want: "View-All Manager". They can basically see all towers no matter what unless they are put into secretive mode. However if you want them to see the secretive towers too, just make them a "View-All Manager" and "Highly Trusted".

-FG

Onyc Chick
Posted - 2010.09.20 08:17:00 - [34]
 

Originally by: Frozen Guardian

Production Fix request added.

As for the access thing, this is a matter of preference unfortunately. I went back and forth on what to do here because some people have different ideas on how they should work. It does need a bit more tweaking.

There is a group though that can see everything like you want: "View-All Manager". They can basically see all towers no matter what unless they are put into secretive mode. However if you want them to see the secretive towers too, just make them a "View-All Manager" and "Highly Trusted".

-FG


Cheers for the response and for adding the silo fix to the list.

As far as the access issue goes the current situation for the Fuel Tech role is this:

If you dont assign specific fuel techs to towers then they can see the full list of towers on the POS Track sheet (except the secretive ones until you make them trusted)

Now the problem is that whilst they can see all the towers, they cant use the Fuel Calculator or Fuel Bill to calculate how much fuel needs to go into the specific towers.

Basically the idea is that when a tower is not assigned then anyone with the fuel tech role should be able to use the Calculator or Bill for it.

Unfortunately, anything above Fuel Tech also gives access to Production which is something that you want an extra layer of security on.

Maybe a quick fix is the creation of a role for "View all POS Fueler" that gives the same access as the current "View All Manager" except for the production tab ?

Cheers

Donna Vecchi
Gallente
Vecchi Quantum Logistics
Posted - 2010.09.21 03:33:00 - [35]
 

Hi there

Any chance of you developing the MoonDB Addon for the moon materials,
A way of uploading some sort of file or grab from DotLan would be good..

Oh BTW i choose you version over the other one... LaughingLaughing

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.09.26 23:17:00 - [36]
 

Originally by: Donna Vecchi
Hi there

Any chance of you developing the MoonDB Addon for the moon materials,
A way of uploading some sort of file or grab from DotLan would be good..

Oh BTW i choose you version over the other one... LaughingLaughing


What are you looking for exactly to be doable in the MoonDB Addon. I haven't spent much time in there but I can take a gander if you tell me what you want to see or benefit.

Glad you like my version. You join the crowd of hundreds ^^

----

Onyc Chick: I see what you're saying. I'm going to be making some changes to how the rolls are handled or add more roles over the next month here. Sucky part with roles is it requires a LOT of testing. :(

Donna Vecchi
Gallente
Vecchi Quantum Logistics
Posted - 2010.10.01 18:22:00 - [37]
 

Edited by: Donna Vecchi on 01/10/2010 19:03:51
Found an Issue with Sov and changing allaince.

the Sov Status does not update when you join an Allaince

Only way i could find to update, is deleting the Tower and re-adding via API.

As for the MoonDB. Well just be able it import from a file or DotLan.....
i have no idea if it will be of any use though...

Edit
found a typo in viewpos.tpl , line 264
Missing <
<td class="mcolor">!--[$tower.required_strontium]--></td>
<td class="mcolor"><!--[$tower.required_strontium]--></td>

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.04 23:08:00 - [38]
 

Originally by: Donna Vecchi
Edited by: Donna Vecchi on 01/10/2010 19:03:51
Found an Issue with Sov and changing allaince.

the Sov Status does not update when you join an Allaince

Only way i could find to update, is deleting the Tower and re-adding via API.

As for the MoonDB. Well just be able it import from a file or DotLan.....
i have no idea if it will be of any use though...

Edit
found a typo in viewpos.tpl , line 264
Missing <
<td class="mcolor">!--[$tower.required_strontium]--></td>
<td class="mcolor"><!--[$tower.required_strontium]--></td>



Thanks for the heads up! < added lol. I'll look Sov thing, kinda hard to replicate since well kinda have to join and leave alliances and see what the API does lol but I'll check it out. Just got back into the groove of things from moving so I should have some more updates down the pipe here soon and some news(maybe).

No La
Greased Lightning Engineering
Posted - 2010.10.07 10:07:00 - [39]
 

I'm trying to do a fresh install, but i'm running into trouble.

I created a database called 'pos' and i have a usr that can do everything with it.

when i go to the /install.php page, it checks permissions and versions etc.
I can write the config, and the file does get updated, but then whin i het the button 'install tables' nothing happens. No tables are created in the database and the spinner in front of the button just keeps spinning, no error or anything is produced.

this is the output on the top of the page:

Quote:
Thank you for choosing POS-Tracker 5.0.2. FG Version! Please fill the form to set the database information.
Current PHP version: 5.2.14-pl0-gentoo (Needs to be greater than 5.1.2)
Your CURL Version: 7.20.0
Required Modules Installed
CURL: Yes
SimpleXML: Yes
Hash: Yes
Register_globals:
cache/template_c: OK
eveconfig/dbconfig.php: OK


There is nothing after 'Register_globals:', they are on.
Another thing is that i'm not using a local mysql server, but one on another host.

I hope anyone can help with this...
thnx
No La

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.08 00:54:00 - [40]
 

Originally by: No La
I'm trying to do a fresh install, but i'm running into trouble.

I created a database called 'pos' and i have a usr that can do everything with it.

when i go to the /install.php page, it checks permissions and versions etc.
I can write the config, and the file does get updated, but then whin i het the button 'install tables' nothing happens. No tables are created in the database and the spinner in front of the button just keeps spinning, no error or anything is produced.

this is the output on the top of the page:

Quote:
Thank you for choosing POS-Tracker 5.0.2. FG Version! Please fill the form to set the database information.
Current PHP version: 5.2.14-pl0-gentoo (Needs to be greater than 5.1.2)
Your CURL Version: 7.20.0
Required Modules Installed
CURL: Yes
SimpleXML: Yes
Hash: Yes
Register_globals:
cache/template_c: OK
eveconfig/dbconfig.php: OK


There is nothing after 'Register_globals:', they are on.
Another thing is that i'm not using a local mysql server, but one on another host.

I hope anyone can help with this...
thnx
No La



Hi,

Register_globals should be off as that's one of the requirements. If you can't get it to install that's probably the reason right there. The POS Tracker unfortunately is very very picky on its requirements. As for running off an external MySQL, that shouldn't be a problem as the tracker can connect perfectly fine to those sort of setups.

-FG

Onyc Chick
Posted - 2010.10.13 23:12:00 - [41]
 

Just one more thing...

Would it be possible to have a way to update all the fields in the production tab in one go ?

Maybe a Update All button that we can prez once weve inputed all the silo levels that we want changed ?

Its really tedious having to update each field one by one..

Cheers

Mad Bomber
Amarr
Fromage Frais Industries
Imajiaca
Posted - 2010.10.16 10:46:00 - [42]
 

Feature Request:

Not sure if this is within the scope, but I'll ask anyway.

Could there be a combined (POS + Hanger) fuel count?

You could see how long all the fuel at the POS would last.

Gladi
Caldari
Ganymede Solutions Inc.
Posted - 2010.10.17 01:02:00 - [43]
 

is this the actual version?

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.17 04:40:00 - [44]
 

5.0.4 Version Released.

Version 5.0.3 to 5.0.4 Changes:
* Updated access for mailer. Due to added security changes, the mailer program lost access to check towers correctly in some cases.
* posmail.sh file added to help people utilize the mailer program. Recommend cron job runs every 12 hours. (don't accidentally replace your version if you made something yourself)
* Fixed viewpos.tpl typo. - Thx Donna Vecchi
* Tyrannis change added. Removed charters requirement from 0.4 systems. Towers already within the program will have to removed and readded to reflect the change or manual DB update for charters_needed on the tower needs to be set to 0.
* Production page now has one update button to update all rows at once based on what's changed.
* Production page now has full on security. (e.g. If a fuel tech you can only see your tower's production.)

----------------------------------

Other info:

"is this the actual version?" <-- ?? Not sure what you're asking there but this is the POS-Tracker with my updates.

"Could there be a combined (POS + Hanger) fuel count?" <--Added to list of things to look at

"Maybe a Update All button that we can prez once weve inputed all the silo levels that we want changed ?" <--Completed for ya. Hehe I was doing my other changes today and saw that, was like sure lets do that now too. :)

"Unfortunately, anything above Fuel Tech also gives access to Production which is something that you want an extra layer of security on." <--Changed that too.

I've been seeing more things that could be fixed and I've been getting a lot of requests of stuff to look at and change so I'll keep working away here for ya. I'm only one person though so be patient and I'll reward your request eventually I hope ^^

<3
-FG


CCP Applebabe

Posted - 2010.10.17 06:33:00 - [45]
 

Moved from Science and Industry per OP's request.

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.17 23:55:00 - [46]
 

Edited by: Frozen Guardian on 17/10/2010 23:56:43
Want to note that issues and requests can come to me in three ways:

1. Posts on here
2. Message in game
3. Add a new issue here where the code is hosted: http://code.google.com/p/pos-tracker-eve/issues/list

I'll be adding more information to the issues list from the messages I've received. I also plan on adding to the wiki too for fixes to common problems in the future.

I don't mind the messages at all so don't feel like you're bothering me with requests/issues. ^^

Donna Vecchi
Gallente
Vecchi Quantum Logistics
Posted - 2010.10.23 23:36:00 - [47]
 

Originally by: Frozen Guardian
Edited by: Frozen Guardian on 17/10/2010 23:56:43
Want to note that issues and requests can come to me in three ways:

1. Posts on here
2. Message in game
3. Add a new issue here where the code is hosted: http://code.google.com/p/pos-tracker-eve/issues/list

I'll be adding more information to the issues list from the messages I've received. I also plan on adding to the wiki too for fixes to common problems in the future.

I don't mind the messages at all so don't feel like you're bothering me with requests/issues. ^^


Added an bug issues on the google code site, to do with linked silos
didnt see the one that was made 5 days ago.

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.24 14:36:00 - [48]
 

Originally by: Donna Vecchi
Originally by: Frozen Guardian
Edited by: Frozen Guardian on 17/10/2010 23:56:43
Want to note that issues and requests can come to me in three ways:

1. Posts on here
2. Message in game
3. Add a new issue here where the code is hosted: http://code.google.com/p/pos-tracker-eve/issues/list

I'll be adding more information to the issues list from the messages I've received. I also plan on adding to the wiki too for fixes to common problems in the future.

I don't mind the messages at all so don't feel like you're bothering me with requests/issues. ^^


Added an bug issues on the google code site, to do with linked silos
didnt see the one that was made 5 days ago.


Heheh it's okay. I've got a list to add still just haven't gotten around to it. I have some time today so I probably will add the rest but thx :)

LoneEcho
Gallente
Paragon Fury
Posted - 2010.10.26 02:51:00 - [49]
 

Edited by: LoneEcho on 26/10/2010 03:55:30
Hey, first thanks for this webapp but Im having 2 problems. I did a fresh install of the 0.2 then I updated to the 0.3 then 0.4.

1st with themes

Unknown column 'theme_id' in 'field list'UPDATE pos5_user SET theme_id = '1' WHERE id = '2'


and with View-all Manager and director, the POSes do not show at all. Only way for people to see POSes, I must add them as a fuel tech to that POS.

Also, i've noticed when you click "update corp/alliance" it does not update it. I've checked my database and those fields are still empty.

and I've also noticed you only need to enter 1 field to change the PW. Dont need to confirm it.

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.26 22:59:00 - [50]
 

Originally by: LoneEcho
Edited by: LoneEcho on 26/10/2010 03:55:30
Hey, first thanks for this webapp but Im having 2 problems. I did a fresh install of the 0.2 then I updated to the 0.3 then 0.4.

1st with themes

Unknown column 'theme_id' in 'field list'UPDATE pos5_user SET theme_id = '1' WHERE id = '2'


and with View-all Manager and director, the POSes do not show at all. Only way for people to see POSes, I must add them as a fuel tech to that POS.

Also, i've noticed when you click "update corp/alliance" it does not update it. I've checked my database and those fields are still empty.

and I've also noticed you only need to enter 1 field to change the PW. Dont need to confirm it.


A few things here.

1 Error. You need to run the actual updates for each:
Navigate to http://example.com/pos/upgrade.php but since you have a different location install ha, the update file never thought of that. Bah with updates.

That's why you're seeing the theme errors is because you have no theme field in your database. Edit the file here:

\install\upgrade\502.sql and change

ALTER TABLE `pos3_user` ADD `theme_id` TINYINT( 2 ) NOT NULL AFTER `highly_trusted` ;

To

ALTER TABLE `pos5_user` ADD `theme_id` TINYINT( 2 ) NOT NULL AFTER `highly_trusted` ;

.
Then run the 5.0.2 upgrade again.

2. Are you a member of the corp that controls the tower? The tracker was only meant to show you towers when you match the corp.

3. You should be able to click update corp/alliance and it works but make sure to be ingame. If you're not ingame it doesn't work.

4. Ahh passwords, yeah I can see about adding a confirmation, just no one's requested it before lol. Always been that way hehe.

-FG

LoneEcho
Gallente
Paragon Fury
Posted - 2010.10.27 00:12:00 - [51]
 

Edited by: LoneEcho on 27/10/2010 01:26:03
Thanks for the response!

1. I'll be sure to try those steps. I probably should have left it to pos3 but I thought what harm would it do to change it lol =P. I just deleted the tables and recreated as _pos3 =P

For themes to take effect, you must log off once you save it then log back in.

2. I do fuel the POS but the problem is when a Director or someone who needs to view all POSes registers for the site. I want to set their access to View-All Manager so they can see all the POSes but changing the access doesn't grant that to the user.

And for access, the user must log off then log back in for the new access to be granted. Same for when you set "highly trusted" on or off.

EDIT!: I've just noticed when you click "Update Corp/Alliance" it actually removes the corp information from inside the database and that's why I was unable to see the POSes even though I was set to View-All Manager or Director

3. Also for the poscron.sh
I get this error.

Fatal error: Call to undefined function: date_default_timezone_set() in /home/*hidden stuff*/includes/class.pos.php on line 4907

4. For the passwords I don't mind. I just saw that there were 2 fields to enter your password so I assumed 1 was a confirmation field =P

Again thanks for this postracker! xD

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.27 03:07:00 - [52]
 

Originally by: LoneEcho
Edited by: LoneEcho on 27/10/2010 01:26:03
Thanks for the response!

3. Also for the poscron.sh
I get this error.

Fatal error: Call to undefined function: date_default_timezone_set() in /home/*hidden stuff*/includes/class.pos.php on line 4907



What PHP version are you running? That error doesn't make much sense but it sounds like it can't get the default timezone from your PHP installation on the server. Odd thing to say but is date enabled on your PHP installation?

Create a test like file with .php extension and just put in

<?php

phpinfo();

?>

save and see if you can see something like:

date
date/time support enabled
"Olson" Timezone Database Version 2010.9
Timezone Database internal
Default timezone America/Los_Angeles

LoneEcho
Gallente
Paragon Fury
Posted - 2010.10.27 03:39:00 - [53]
 

PHP Version 5.2.9

date/time support enabled
"Olson" Timezone Database Version 2009.1
Timezone Database internal
Default timezone America/Chicago


This is my info.

Dragonaire
Caldari
Corax.
PURgE Alliance
Posted - 2010.10.27 03:55:00 - [54]
 

Frozen Guardian - Something they've started doing with PHP5.3 and even some of the 5.2 series is to require that you set time zone. You can simply add date_default_timezone_set('GMT'); to your init stuff and not worry about it anymore they are going away from have a default time zone in the default PHP config and you have to set it as needed. I added the above a few months back when it started being a problem in Yapeal.

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.10.27 17:28:00 - [55]
 

Originally by: Dragonaire
Frozen Guardian - Something they've started doing with PHP5.3 and even some of the 5.2 series is to require that you set time zone. You can simply add date_default_timezone_set('GMT'); to your init stuff and not worry about it anymore they are going away from have a default time zone in the default PHP config and you have to set it as needed. I added the above a few months back when it started being a problem in Yapeal.


Interesting thx for that information never knew that. However in POS Tracker's case, that information is already there. That's the error he's getting is setting the default timezone to GMT lol.

So why would his PHP version not like setting the default time zone? I've never seen that before.


LoneEcho
Gallente
Paragon Fury
Posted - 2010.10.27 19:07:00 - [56]
 

Also I've noticed with the posmail.sh script. I got this error.

Error Sending Alert :: Language string failed to load: connect_host<br>

I've done some researched and from what I read, it can't locate the file language. Unfornately I can't access my cpanel from work. Yay for firewalls =P

Thanks for the continues help! I hope with my problems, I have helped others including you with diagnosing the issues xD

Frozen Guardian
Registered Amateur Mathematicians
Posted - 2010.11.04 17:14:00 - [57]
 

Update here on the Silo issue that a few people reported. I've been unable to duplicate it in any sense. At first I thought I had the problem but actually I just didn't really know how to do silo linking(got a crash course in it from someone who does production stuff daily) but now I've run into no issues at all. It was a bit confusing at first because it wasn't really clear but as of right now it's working 100% correctly and I can't get it to break. I've tried different reactions, materials, silos full, silos not full, silos linking to one or the other, different towers, different times of emptying silos, different everything for over the past two weeks and I can't seem to get it to break.

I also know that there are others just like me having no issues at all so I'm really having a hard time trying to find out where the problem lies because if I can't make it happen there is nothing I need to fix. I'm not calling you all crazy yet so if you could send me a screenshot(post to imgur) on here or in PM of what's under "Silo Hanger Arrays" when viewing a POS I will duplicate your setup and see if I can get the problem to happen. Please make sure to crop the selection so I just see this, I really don't want to know where you have a POS up and running ^^

-FG

Agate Cailloux
Posted - 2010.11.04 17:59:00 - [58]
 

Hi,

I'm getting this error since 1 day now, while updating POS from API :

Error Code: 114::Invalid itemID provided

I only have this error on 1 corp in Pos Tracker( 3 registered in total ).

I have regenerate a new API, no changes.

Thx for this usefull product.

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2010.11.04 23:08:00 - [59]
 

Originally by: Agate Cailloux
Hi,

I'm getting this error since 1 day now, while updating POS from API :

Error Code: 114::Invalid itemID provided

I only have this error on 1 corp in Pos Tracker( 3 registered in total ).

I have regenerate a new API, no changes.

Thx for this usefull product.


probably related to this thread: http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1409612

Agate Cailloux
Posted - 2010.11.10 17:34:00 - [60]
 

Originally by: Johnathan Roark
Originally by: Agate Cailloux
Hi,

I'm getting this error since 1 day now, while updating POS from API :

Error Code: 114::Invalid itemID provided

I only have this error on 1 corp in Pos Tracker( 3 registered in total ).

I have regenerate a new API, no changes.

Thx for this usefull product.


probably related to this thread: http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1409612


Correct, the problem is now solved, thx.


Pages: 1 [2] 3 4 5 6 7 8 9

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only