open All Channels
seplocked EVE Technology Lab
blankseplocked phpBB3 API Registration Mod v3+
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 2 3 4 5 [6] 7 8 9 10 : last (10)

Author Topic

Norjia Blacksteel
Gallente
Blacksteel Mining and Manufacturing
Renaissance Federation
Posted - 2011.01.11 02:58:00 - [151]
 

Edited by: Norjia Blacksteel on 11/01/2011 03:14:15
My cron job doesn't seem to run at all. One of our members created his account, which worked, then invalidated his limited API to test the cron. Nothing has happened in 72 hours. He can still log in and see all the private boards.

ETA: Ok, I get it. I have to run the cron by hitting the page. Sorry about that!

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2011.01.11 06:39:00 - [152]
 

Edited by: Drake Draconis on 11/01/2011 06:40:48
Edited by: Drake Draconis on 11/01/2011 06:40:17
Originally by: Norjia Blacksteel
Edited by: Norjia Blacksteel on 11/01/2011 03:14:15
My cron job doesn't seem to run at all. One of our members created his account, which worked, then invalidated his limited API to test the cron. Nothing has happened in 72 hours. He can still log in and see all the private boards.

ETA: Ok, I get it. I have to run the cron by hitting the page. Sorry about that!


Check earlier posts *in this thread*... I think I posted a way to run the script automatically.

Requires SSH access however. Others have since improved it...

Norjia Blacksteel
Gallente
Blacksteel Mining and Manufacturing
Renaissance Federation
Posted - 2011.01.11 13:24:00 - [153]
 

Originally by: Drake Draconis
Edited by: Drake Draconis on 11/01/2011 06:40:48
Edited by: Drake Draconis on 11/01/2011 06:40:17

Check earlier posts *in this thread*... I think I posted a way to run the script automatically.

Requires SSH access however. Others have since improved it...


I don't mind running it by hand. Just didn't know I had to.

Also, should I expect the cron-job to reinstate people whose APIs changed? It was valid, he joined, it worked. He invalidated it, the cron kicked him. He did api_update.php and fixed his API key, and it re-activated his account. But it didn't put him into the Members group.

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2011.01.11 19:00:00 - [154]
 

The API Security System (AKA Script) should re-instate the member but only to the group you set originally in the system as far as I know.

Keep in mind the version I run is outdated... If you haven't noticed yet... I'm unable to update because the forums are out of date...and the forums can't update because of the API Mod.

And the authors gone MIA on us.

Your strongly encouraged to automate the script... that way the only thing you have to do is turn it off from the ACP and back on when CCP does their thing.

Steph Wing
Gallente
The Graduates
Morsus Mihi
Posted - 2011.01.12 05:43:00 - [155]
 

Is this mod not compatible with some themes? I can't get it to work with any except the default Prosilver.

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.01.12 19:25:00 - [156]
 

Edited by: Demitrios on 12/01/2011 19:27:55
Originally by: Drake Draconis
Still cannot update my forums DB or files or the Mod due to a paradox with the update itself.
I would appreciate help because this patch closes some security holes.
Reinstalling the DB would be unacceptable.
I got 170 Members + who would not like having to re-do the whole damn account business.


Go through with the update, telling it to trash all the modifications, then re-add them after its installed.

Was the only way i could make sure i was getting the new version of phpbb.

You can thank the lazy guys at phpbb for not making a propper modding system like EDK for this. (editing core core = pants on head ******ed)

Plus i spoke to him on Sunday, and he was busy at looking at the code to fix the bugs, so he hasnt gone mia, just afk :).

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.01.12 19:30:00 - [157]
 

Originally by: Steph Wing
Is this mod not compatible with some themes? I can't get it to work with any except the default Prosilver.


You need to read up (1st or 2nd page iirc), it tells you what theme files you need to edit, as the API text box's aren't in the theme you are trying to use (phpbb's modding system ftw...).

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.01.12 22:01:00 - [158]
 

Just to clarify;

I'm not MIA nor afk. I'm working on this mod in my spare time, basicly dividing time between school, work and EVE.

The problem with phpBB, as Demitrios has already pointed out, is that's it's not having any modding engine at all. You may ask, what's the difference? Let me try to explain.

Normally when you are talking about a moddable application, it's consists of 1 Core and 0 to infinite Modules.
The Core is basicly the inner workings of the program, like where/how the data is saved, connections, etc, basicly all the most important stuff that you shouldn't mess with.
On the other hand we have modules (MODs). These mods are made to add additional funtionality to the program (Core). Some people would like to have a most clean version and have enough functionality using the Core only, other people would like tons of more functionality and thus rely on a ton of MODs.

This explained, you should now know that phpBB is setup as a Core package without any engine to allow mods. This means that to add functionality, we need to change key parts in the Core with the possiblity of destroying the whole script.
While you may think that this isn't bad yet, imagine the person who wants 2+ mods on his phpBB, meaning he has to change the Core for each mod.When you've reached mod nr. 5, you wouldn't even know what you changed when you did nr. 2.

For instance, take the BBcodes in phpBB.
You can easily add a simple replacement piece of BBcode into phpBB, like adding a certain smilie or the simple code to make text underlined. What it can't do however, is do things more advanced then that. So let's say I want to check the database and return some text, it falls under scripting and you'll need to change about 8 different sections of code in the Core.

Basicly, the best outcome would be if phpBB would make an MOD engine where instead of having to change the Core files, I would only have to supply you with a certain mod package that automaticly installs in a seperate directory, that once enabled is being used to double check everything.

Would gives us;
- No more problems into updating our forums
- No more different versions for different updates of phpBB
- Far easier to manage

which will hopefully result into far more happy ppl.

~Cy

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2011.01.13 03:40:00 - [159]
 

Edited by: Drake Draconis on 13/01/2011 03:44:55
Edited by: Drake Draconis on 13/01/2011 03:43:42
Whoa buddy... we kinda figured your busy... but lack of response/timing is not helpful for us panic/stricken allaince admins who can't update their forums due to a paradox.

Help? Please?

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2011.01.13 03:43:00 - [160]
 

Edited by: Drake Draconis on 13/01/2011 03:45:48
Originally by: Demitrios
Edited by: Demitrios on 12/01/2011 19:27:55
Originally by: Drake Draconis
Still cannot update my forums DB or files or the Mod due to a paradox with the update itself.
I would appreciate help because this patch closes some security holes.
Reinstalling the DB would be unacceptable.
I got 170 Members + who would not like having to re-do the whole damn account business.


Go through with the update, telling it to trash all the modifications, then re-add them after its installed.

Was the only way i could make sure i was getting the new version of phpbb.

You can thank the lazy guys at phpbb for not making a propper modding system like EDK for this. (editing core core = pants on head ******ed)

Plus i spoke to him on Sunday, and he was busy at looking at the code to fix the bugs, so he hasnt gone mia, just afk :).


The update CRASHES at the DB.

I can't exactly "skip that". Nor does it offer such things.
Walk-through please?

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.01.15 05:58:00 - [161]
 

Edited by: Demitrios on 15/01/2011 05:58:52
I'm sorry, i have re-read my post 5 times, and at no point do the words "skip that" come up, not even by them selves scattered around the place.

What i said was, when you are given the option to merge, scrap/overwrite or ignore/dont update, you tell it to scrap the changes, ie, delete your edited files and put the new ones in.

THEN, you have to re-add all the mods. it might moan about the fact there are 2 extra things in the user db (api data), but you deal with that the best way you see fit.

Thats the way i updated the forum while keeping all the data intact without having a "db crash".

Also, if you want help with updating phpbb, i suggest going to their support forum, and while you are there, join what ever threadnaughts you can find about the lack of a modding engine :)

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.01.15 18:09:00 - [162]
 

Version 4.3 released with the following fixes:

- Fixed all the group settings for the api_cron script.
- Added a file to (hopefully) make it possible for users to have a "simple" mean of updating their board.
*NOTE!: Should be said the script is untested, but with good backups nothing can go unrepaired.

So, if you are still using 3.0.7-PL1 with the EVE API MOD, and want to update to 3.0.8; read on. Else, stop reading!

1. Backup your forum before even attempting to upload the "update307pl1to308.php" script.
2. Disable the board so no users are able to do anything while you are busy with the script.
3. Run the script (should only take seconds). Once it's finished, you'll read something like: "Step 1 completed".
4. Now update the forum using the normal phpBB update package.
5. Once your board is fully updated, install my 3.0.8 mod files by uploading the files in 'new_files' and 'pre_edit'. SQL is NOT NEEDED!
6. Now run the 'update307pl1to308.php' script again, after a few seconds it should say "Step 2 completed".
7. Delete 'update307pl1to308.php' from your forum and on you go.


If you have used this script, or are willing to risk using it, contact me by ingame evemail. I'll provide you with help with the script untill I'm statisfied it's working correctly.
Nonetheless, be sure by triplechecking that you do have a functioning backup before attempting anything.

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2011.01.15 18:35:00 - [163]
 

Edited by: Drake Draconis on 15/01/2011 18:35:23
Anyone successfully run the script and such yet?
(Just nervous about taking the plunge as of yet)

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.01.15 23:01:00 - [164]
 

Do a backup, and try the script.

Labrena
Posted - 2011.01.16 06:25:00 - [165]
 

Originally by: Cyerus
Version 4.3 released with the following fixes:

- Fixed all the group settings for the api_cron script.
- Added a file to (hopefully) make it possible for users to have a "simple" mean of updating their board.


I believe this is a bug:

User has account got deactivated due to bad API.
api_update.php corrected
User acct still disabled, api_cron.php does not correct it either, since it skips disabled accounts.

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.01.16 15:32:00 - [166]
 

Version 4.4 released.

-Updated and tested the 3.0.7-PL1 to 3.0.8 update script on my own forum, and now works like a charms. Follow the instructions I've posted few messages back, and you should be fine.
If not, evemail me.

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.01.16 17:12:00 - [167]
 

Originally by: Labrena
Originally by: Cyerus
Version 4.3 released with the following fixes:

- Fixed all the group settings for the api_cron script.
- Added a file to (hopefully) make it possible for users to have a "simple" mean of updating their board.


I believe this is a bug:

User has account got deactivated due to bad API.
api_update.php corrected
User acct still disabled, api_cron.php does not correct it either, since it skips disabled accounts.


I've tested this myself, seems to work correctly.

I've changed the API settings in the DB, basicly making them invalid. api_cron.php disabled the account.
Used api_update.php, and filled in the correct (working) API information, along with the charactername and the correct password. Account was made active again.
Ran api_cron.php again, account was in the list as being (and staying) active, like it should.

Are you sure that the character you've tested is suppose to be active by the settings you've set?

Demitrios
Di-Tron Heavy Industries
Atlas.
Posted - 2011.01.16 17:38:00 - [168]
 

Is anyone else having fun with the api server recently?

Just logged on after seeing the ts3 checker failed to run, checked the forum and it booted everyone to the non member group.

Its not a problem with the mod, but it looks like the api server is timing out on me.

Anyway, im taking the cron job off till after the patch :)

Labrena
Posted - 2011.01.16 17:43:00 - [169]
 

Originally by: Cyerus
Are you sure that the character you've tested is suppose to be active by the settings you've set?


Yes, this is what I did.

User with correct API / correct groups.
- Changed the API
- Ran api_cron.php
- Removed user from groups, and disabled account
- Ran api_update.php with correct API
- Account was left disabled, but had correct API

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.01.16 19:34:00 - [170]
 

Originally by: Labrena
Originally by: Cyerus
Are you sure that the character you've tested is suppose to be active by the settings you've set?


Yes, this is what I did.

User with correct API / correct groups.
- Changed the API
- Ran api_cron.php
- Removed user from groups, and disabled account
- Ran api_update.php with correct API
- Account was left disabled, but had correct API


You didn't understand my question correctly.
Is the character, according to the settings you have set, allowed to have an active account on the forum?
If he/she has, I need to know every single API setting you've set and also the name of the character you are trying to add.

Labrena
Posted - 2011.01.16 22:40:00 - [171]
 

Edited by: Labrena on 16/01/2011 23:24:04
Edited by: Labrena on 16/01/2011 23:17:15
Originally by: Cyerus
Originally by: Labrena
Originally by: Cyerus
Are you sure that the character you've tested is suppose to be active by the settings you've set?


Yes, this is what I did.

User with correct API / correct groups.
- Changed the API
- Ran api_cron.php
- Removed user from groups, and disabled account
- Ran api_update.php with correct API
- Account was left disabled, but had correct API


You didn't understand my question correctly.
Is the character, according to the settings you have set, allowed to have an active account on the forum?
If he/she has, I need to know every single API setting you've set and also the name of the character you are trying to add.


Sorry.

I have it set to allow non-members to register.

I've tried with both an in corp and out of corp characters, both with the same result.

The API does get updated, but the 1 is not changed to a 0 in user_type enabling the account.

Everything else is working fine. Same issue with 4.2/4.3/4.4.

I just noticed, that after putting in the correct API, it says "You have been successfully logged in." then goes back to the api_update.php page.

Also, if I try to send the re-activation email, I get this message:
"Your account has been manually deactivated and is only able to be reactivated by an administrator."

Shoot2kilI
Caldari
Unchained Potential
Test Alliance Please Ignore
Posted - 2011.01.19 19:43:00 - [172]
 

Did anything change as far as the API system with the recent patch? My board is now failing to retrieve player avatars, or really do anything that requires the API. Cyerus, appreciate all the work you've done.

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.01.20 21:46:00 - [173]
 

Originally by: Labrena

Sorry.

I have it set to allow non-members to register.

I've tried with both an in corp and out of corp characters, both with the same result.

The API does get updated, but the 1 is not changed to a 0 in user_type enabling the account.

Everything else is working fine. Same issue with 4.2/4.3/4.4.

I just noticed, that after putting in the correct API, it says "You have been successfully logged in." then goes back to the api_update.php page.

Also, if I try to send the re-activation email, I get this message:
"Your account has been manually deactivated and is only able to be reactivated by an administrator."



Open "include/auth.php", go to line 946.
Should say; $eve_api_row['user_type'] = 0;

Change that to; $eve_api_row['user_type'] = 5;

Let me know if that does the trick.


Originally by: Shoot2kilI
Did anything change as far as the API system with the recent patch? My board is now failing to retrieve player avatars, or really do anything that requires the API. Cyerus, appreciate all the work you've done.


Seems to work for me tho. Just tested the api_cron script, seems to correctly grab all the info from the EVE API.

Labrena
Posted - 2011.01.21 00:12:00 - [174]
 

Originally by: Cyerus
Open "include/auth.php", go to line 946.
Should say; $eve_api_row['user_type'] = 0;

Change that to; $eve_api_row['user_type'] = 5;

Let me know if that does the trick.


Yes, that seems to have worked.

It nows activates the user account and adds them to the member group if needed.

Thanks

Swanny231
FISKL GUARDS
RED.OverLord
Posted - 2011.01.21 05:52:00 - [175]
 

After the update
I did everything,ran the api_cron and the update_api which takes me to the index and it disabled all accounts ,I had to reactivate them manually so they can put in their api's again and it worked but the avatars aren't showing, even in the admin panel I try a download of the avatars and I get this message. The user CP does not even give the option and I have them enabled.

Warning

It was not possible to determine the dimensions of the image.
The submitted avatar is 0 pixels wide and 0 pixels high. Avatars must be at least 64 pixels wide and 64 pixels high, but no larger than 256 pixels wide and 256 pixels high.

Any help would rock.

WereWolfik
Posted - 2011.01.21 14:12:00 - [176]
 

Originally by: Swanny231

Warning

It was not possible to determine the dimensions of the image.
The submitted avatar is 0 pixels wide and 0 pixels high. Avatars must be at least 64 pixels wide and 64 pixels high, but no larger than 256 pixels wide and 256 pixels high.

Any help would rock.



There are old download link of eve avatars in the 4.4 version of mod. I fixed it with some changing of code. If you wanna you can look in the inludes/functions_user.php
code:
Quote:
function getAvatar($id, $user_id = false)
{
global $config, $user, $phpbb_root_path;
$user_id = ($user_id) ? $user_id : $user->data['user_id'];
$input = 'http://img.eve.is/serv.asp?s=256&c=' . $id;


and change last line to:
Quote:
$input = 'http://image.eveonline.com/Character/'.$id.'_128.jpg';


128 is avatar size. You can change it to 64, 128 or 256.

Good luck

Swanny231
FISKL GUARDS
RED.OverLord
Posted - 2011.01.21 16:34:00 - [177]
 

Originally by: WereWolfik
Originally by: Swanny231

Warning

It was not possible to determine the dimensions of the image.
The submitted avatar is 0 pixels wide and 0 pixels high. Avatars must be at least 64 pixels wide and 64 pixels high, but no larger than 256 pixels wide and 256 pixels high.

Any help would rock.



There are old download link of eve avatars in the 4.4 version of mod. I fixed it with some changing of code. If you wanna you can look in the inludes/functions_user.php
code:
Quote:
function getAvatar($id, $user_id = false)
{
global $config, $user, $phpbb_root_path;
$user_id = ($user_id) ? $user_id : $user->data['user_id'];
$input = 'http://img.eve.is/serv.asp?s=256&c=' . $id;


and change last line to:
Quote:
$input = 'http://image.eveonline.com/Character/'.$id.'_128.jpg';


128 is avatar size. You can change it to 64, 128 or 256.

Good luck



That fixed it Thanks.

Now 1 last problem, I have EvE avatars enabled in the acp, when I go to the user cp there is no option of editing the avatar or downloading it.

This is a fresh install with no mods, and I have copied all the files and updated the database. Am I missing something ?

WereWolfik
Posted - 2011.01.21 19:43:00 - [178]
 

Did you made changes in ucp_avatar_options.html when you installed mod?

Swanny231
FISKL GUARDS
RED.OverLord
Posted - 2011.01.21 20:10:00 - [179]
 

Originally by: WereWolfik
Did you made changes in ucp_avatar_options.html when you installed mod?


No I just added the files like it was stated, the only time it shows an option is if I enable uploaded avatars, but when it is just EvE avatars active I get no avatar options in the ucp. This is for all themes including pro

WereWolfik
Posted - 2011.01.21 20:18:00 - [180]
 

Edited by: WereWolfik on 21/01/2011 21:01:44
Edited by: WereWolfik on 21/01/2011 20:29:18
So if you enabled uploaded avatars + eve its working good? And only eve avatars don't work?

I have only problem if disable all options and only enable eve avatars


Pages: first : previous : ... 2 3 4 5 [6] 7 8 9 10 : last (10)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only