open All Channels
seplocked EVE Technology Lab
blankseplocked phpBB3 API Registration Mod v3+
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : 1 2 [3] 4 5 6 7 8 9 ... : last (10)

Author Topic

DiLantius
Caldari
Quam Singulari
Session Changes
Posted - 2010.07.16 01:31:00 - [61]
 

I'm sorry if this has been answered before, but I can't seem to find out how to do this. I've installed this mod on my test phpbb server, but from what I can tell I can only use it for bbcode stuff, like entering a system name and linking it in game.

Is there more to it than that? How can I take advantage of more functionality without knowing php/js and the api system intimately?

1.) I've seen on a few phpbb powered alliance boards where the profile has a dedicated Eve Online section of the profile settings. Under that, there are spaces to enter the User ID/limited-api, along with the TS3 uniq Id for teamspeak registration. Then under that are lines that list which characters are associated with the userid/api. In addition, you can have those link back to the alliance/corp killboard.

Not only that, but it gives you the option to pull the avatar from eve and replace your uploaded avatar in phpbb. Under your avatar it also shows your total kills/losses and k/d ratio. Also your kills per month.ugh

So what I'm curious about is if the info to do that is out there already, or if that's a custom job. Also, how difficult would that be to do?

Thanks very much to anyone who can answer that. I hope it stems from the use of this API mod.

Carl Rannseier
Caldari
Trust Foundation
Liberi Fatales
Posted - 2010.07.17 03:02:00 - [62]
 

Edited by: Carl Rannseier on 17/07/2010 03:13:30
Edited by: Carl Rannseier on 17/07/2010 03:02:08
@ Gerin Tell: I can't help ya here, i think for this you have to ask Cyerus. I actually think that you have to do all the work again cos he has rewritten pretty much all of the code so it might be easier setting it up from scratch again.

@DiLantius: You have to update your board template if you want those functions to work properly. The mod ships with the prosilver template only so this is the only one that actually works when you initially install it. The files that need to be modified are:
  • prosilver based templates
    • posting_buttons.html
    • ucp_avatar_options.html
    • ucp_profile_reg_details.html
    • ucp_register.html
  • subsilver2 based templates
    • posting_buttons.html
    • ucp_profile_avatar.html
    • ucp_profile_reg_details.html
    • ucp_register.html

You can tell what style was used to create the one you are using by looking up those files in the "phpbb/styles/<your_style>/template" folder. check if there is either ucp_avatar_options.html (prosilver) or ucp_profile_avatar.html (subsilver2). To check this you can simply use the acp, go to the styles tab -> templates -> edit the style you are using. there you get a dropdown box that offers you all files within that template. you can also modify it there althouh a proper editor would perform better.

If it is prosilver based then simply follow the steps that can be found in the install_api_registration_4.0.xml file. it's well structured and easy to read. For a subsilver based style i don't have any instructions ready but you can contact me ingame and we can figure out how to get your board running correctly with this mod.

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2010.07.17 08:36:00 - [63]
 

Edited by: Drake Draconis on 17/07/2010 08:37:32
OK.

One of the things that didn't get mentioned or looked over was how to kick the module in do automatically check for valid members of ______ according to the API Mod's settings.

Cyerus included a "api_cron.php" file that can be triggered if you surf manually to it... but that's such a pain to do if you forget to do it enough.

CRON is a cronological "egg timer" that basically triggers various tasks on the server/computer in question.
The "api_cron.php" file is a script that can be triggered by CRON... but only if you know how to set it up.

Most servers are linux based... and the majority of them (not all) grant SSH access on request to allow you to walk around the jailed_root portion of your web server.

Let me be very clear... this type of thing is not to be taken lightly... you must follow instructions clearly and carefully.

There's a few unknowns that I have yet to figure out answer but they won't break anything.

Step1: You must log into your server's SSH portal. Typically that information is made available on request if your able to do so.

ssh username@webserver.com

It then asks for password... and may require a signature approval or encryption key addition.

Step2: Make sure your aware of the exact literal location of your files

For example:

~/web/forums/directory/api_mod.php

(~ is relative to your home account/default directory)

Typically PHP is stored in ~/usr/bin/php5
(Cyerus says it requires PHP5 but it MAY run PHP4 (Which is just php)


Step 3: Now that you know where your files are... it's time to test that the script runs.
#WARNING - If it finds any accounts on your forums that do not check out... it will deactivate the account. Requiring reactivation by Admin#

/usr/bin/php5 -q web/forums/directory/api_mod.php

you should see some text scroll by with HTML code... that means it works.
If it says "no input file found" it means you've not triggered the file correctly.
Technically the api_mod.php is NOT an executable script in the eyes of the server... its a script.
You have to pass it to PHP to handle and then it will run the commands in that file.

You may have to learn a little more about how your server is configured... can't help you there as all are potentially configured differently but typically its the same... so hopefully you'll be fine.

#If it doesn't work... you can stop here and log out by typing
exit
And it will leave your server unharmed#

Step 4: time to get the command into CRON. CRON uses a "crontab" to allow you to add your own "cron jobs". Provided the server provider allows access to said feature. Usually they do... they just restrict what it can do.

type this
crontab -e

You'll be dumped into a VI Text editor...

type
i
Use the arrow keys to type the following:
00 00 * * * /usr/bin/php5 -q web/forums/directory/api_mod.php
00 12 * * * /usr/bin/php5 -q web/forums/directory/api_mod.php

hit the ESC Key then SHIFT : (colon).
Then type
x
Hit Enter
Your done.

What this does is tell the CRON "daemon" to run that script every 12 hours at 00:00 and 12:00 (your Servers Time Zone not EVE Time)

Google CRON and CRONTAB to learn more how to mess with it.
If you think you've messed up you can back up to crontab -e and add a
#
in front of each line to disable it... or you can erase it.

So yeah... little bit of command line but it should work.

My server emailed me each time it ran the script. So it works.

So if you want to automate it without the fuss... there you go.

Maybe Cyerus will find a way for it to automate that process by installation script? Not sure how you'd do that.

but there you go for you Linux Nerds.

type exit on the command line to close out.

PS: Set the crontab to go off at a time closer to your own to test it... you'll have to figure out which time zone its in to do that! Feel free to come up with quicker "hands free" solutions. Unless you want to manually surf to the page on your own.

Carl Rannseier
Caldari
Trust Foundation
Liberi Fatales
Posted - 2010.07.17 11:34:00 - [64]
 

I recommend creating a backup of your database before creating the cron job as it's always a good idea to have one.

Quote:
Step1: You must log into your server's SSH portal. Typically that information is made available on request if your able to do so. ssh username@webserver.com It then asks for password... and may require a signature approval or encryption key addition.


Windows users should actually google for "putty" and download it, as it is the most used ssh client for windows users. the ssh command itself only runs on unix based operating systems.

Quote:
type this
crontab -e

You'll be dumped into a VI Text editor...

type
i
Use the arrow keys to type the following:
00 00 * * * /usr/bin/php5 -q web/forums/directory/api_mod.php
00 12 * * * /usr/bin/php5 -q web/forums/directory/api_mod.php

hit the ESC Key then SHIFT : (colon).
Then type
x
Hit Enter
Your done.


As some installations of php don't change the working directory you should go a more failsafe way. use the editor of your choice to create a new file and simply name it api_cron without any endings. Copy and paste the following into the file:
Quote:

#!/bin/sh
cd path/to/phpbb
/usr/bin/php5 api_cron.php



make sure to change the "path/to/phpbb" part according to the location where phpbb is located on the webserver and upload the file. Make the uploaded file executable for the user(owner) and group by either using the FTP client or type "chmod ug+x path/to/api_cron" in the console.

now go ahead creating the crontab as described by Drake Draconis. Depending on the linux installation it might ask you what editor to use, i would recommend pico or nano if available rather than vi as vi is pretty hard to use for newbies.
Once you edit the file one line is sufficient to run the script every 12 hours:

Quote:
0 */12 * * * path/to/api_cron


this kicks the job into action every 12 hours too and there's no need for a second line.

DiLantius
Caldari
Quam Singulari
Session Changes
Posted - 2010.07.17 21:29:00 - [65]
 

Originally by: Carl Rannseier
Edited by: Carl Rannseier on 17/07/2010 03:13:30
Edited by: Carl Rannseier on 17/07/2010 03:02:08
@ Gerin Tell: I can't help ya here, i think for this you have to ask Cyerus. I actually think that you have to do all the work again cos he has rewritten pretty much all of the code so it might be easier setting it up from scratch again.

@DiLantius: You have to update your board template if you want those functions to work properly. The mod ships with the prosilver template only so this is the only one that actually works when you initially install it. The files that need to be modified are:
  • prosilver based templates
    • posting_buttons.html
    • ucp_avatar_options.html
    • ucp_profile_reg_details.html
    • ucp_register.html
  • subsilver2 based templates
    • posting_buttons.html
    • ucp_profile_avatar.html
    • ucp_profile_reg_details.html
    • ucp_register.html

You can tell what style was used to create the one you are using by looking up those files in the "phpbb/styles/<your_style>/template" folder. check if there is either ucp_avatar_options.html (prosilver) or ucp_profile_avatar.html (subsilver2). To check this you can simply use the acp, go to the styles tab -> templates -> edit the style you are using. there you get a dropdown box that offers you all files within that template. you can also modify it there althouh a proper editor would perform better.

If it is prosilver based then simply follow the steps that can be found in the install_api_registration_4.0.xml file. it's well structured and easy to read. For a subsilver based style i don't have any instructions ready but you can contact me ingame and we can figure out how to get your board running correctly with this mod.


Thanks for the reponse, very detailed and helpful. However, I just want to double check to make sure I'm on the right track. I currently use prosilver as that's the default template with phpbb3. When I installed this mod, I went through each directory, and overwrote all the files from the prosilver template, with the ones from this mod.

I thought that did what the install_api_registration_4.0.xml install guideline did? I'm going to check through the code again and make sure I did this right. As of now, the profile page has the userid/api fields, you can enter, it validates. It also allows bbcode references to eve to be made in a post. However, avatar pulls don't seem to be an option, automatic or manual, so they're not working atm. And no other options as far as putting kill information under the avatar are available.

But thank you very much for pointing out the specific files I need to edit to add functionality manually. I stalled on this to work on some other things, and that list is going to make it much easier to find/edit those specific things.

Thanks Very Happy

Carl Rannseier
Caldari
Trust Foundation
Liberi Fatales
Posted - 2010.07.18 01:00:00 - [66]
 

Have you checked the ACP -> General -> Avatar settings? You have to enable EVE avatars there.

About Kill information i don't know anything. That might be another mod as this one only uses the API to validate whether the user is allowed or not.

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2010.07.18 01:43:00 - [67]
 

Let me take some time and answer some of your questions.

Originally by: Carl Rannseier
Nice work u did there, although u might want to change the lines 588 and 628 of "includes/bbcode.php" to this:

Quote:

582 function bbcode_second_pass_eveitem($itemname)
583 {
584 global $db, $phpbb_root_path;
585
586 $sql = 'SELECT *
587 FROM eve_items
588 WHERE itemName = "' . $db->sql_escape($itemname) . '"';
589 $result = $db->sql_query($sql);
590 $row = $db->sql_fetchrow($result);
591 $db->sql_freeresult($result);
592
593 $preview_array = array(2,6,18,23,40);
594 $return_string = $itemname;
...


line 628 is the same for the system name. that way it is using phpbb's built in database methods and u don't have to bother what db driver actually is used. i came across this since i'm using mysqli.

keep up the great work m8, really appreciate it.


Thanks for that bit of info, will be change din the future.
Do note that currently it is relatively safe, considering 'regex' weeds out most of the damage.


Originally by: Drake Draconis
Edited by: Drake Draconis on 11/07/2010 08:43:51
Excellent job... I love this package.

Comments:
1: Instructions would be deathly/dangerous to any noob who didn't know enough about PHPBB systems to be dangerous... strongly urged to find a way to automate the SQL insertion commands via PHP or some such.

2: Might want to set a trap/error code for when you tell the API checker to use "Pre-set" User Groups... triggered an SQL Error... managed to find out that you have to use a pre-set group to make it happy again. Minor but a little annoying if your not the tinker'er type.

3: I got a suggestion for your "why allow more than one corporation/alliance" bit...

Standings... some alliances may want guests or some such... or there may be some corporations with +10 standings... would be nice to have extra sets of permissions set aside for them. Push them to different groups perhaps?


Conclusion - Fantastic addition to any EVE Online PHPBB... I love it. Hope it works when I throw a a crapload of users at it. :)

Question - If you leave API fields blank... does it "assume" your just a guest and not error out? Havn't tried this yet as no one that doesn't play eve will be seeing this board but I'd like to put it on a couple others for just corporations.


1. Some kind of database change/update PHP script will be created and released in the next update. (will take some time, to do proper testing).

2. I'm not sure what you are asking here?

3. I will add standings support to the forum in a later version (not scheduled for v5). A simple list of corps/alliance to get access will however not be created, I'm thinking more of an on/off function with a numeric value of the standings a corp/alliance should at least have.

..and thanks for the kind words. Very Happy


Originally by: Agent Unknown
Link is broken. Please host it again...I need it. Crying or Very sad


Link works, hasn't changed since I uploaded it a while ago. You are probably trying to use an outdated version of the mod. Be sure to check the topic startpost to get updated information, including links.




Cyerus
Galactic Dominion
Eternal Strife
Posted - 2010.07.18 02:13:00 - [68]
 

Originally by: Gerin Tell
Edited by: Gerin Tell on 15/07/2010 18:33:41
Edited by: Gerin Tell on 15/07/2010 18:32:22
I apologize if this question has already been answered, but as I have not seen an adequate response so far i'll ask away:

I have the old API mod running on my forum (version 2.1.1) and I am looking to update to this version. Can I simply update the files, and if so how would I go about doing this? I, of course, know how to do it as it's working and installed on my board currently, but I was wondering if there was an alternative to manually installing everything again, or if that is even possible without creating errors.

The current mod version I'm running has a lot of issues and limitations, so I'd love to update!



Hhhmm, where to start.
I suggest you download a 'clean' phpBB 3.0.7-PL1 pack from phpbb.com and read the instructions I've posted to mod the files.

The database on the other hand doesn't need much work. You should compare my DB-edits witht he ones from 2.1.1, and remove what is already done.
I'm pretty sure I didn't change anything in the way 2.1.1 was editing the phpbb_users table, so you can ignore those. Besides that just add the ones that weren't in 2.1.1, and you should be fine.

This is a very very very short 'guide', can provide live-help if needed.


Originally by: DiLantius
I'm sorry if this has been answered before, but I can't seem to find out how to do this. I've installed this mod on my test phpbb server, but from what I can tell I can only use it for bbcode stuff, like entering a system name and linking it in game.

Is there more to it than that? How can I take advantage of more functionality without knowing php/js and the api system intimately?

1.) I've seen on a few phpbb powered alliance boards where the profile has a dedicated Eve Online section of the profile settings. Under that, there are spaces to enter the User ID/limited-api, along with the TS3 uniq Id for teamspeak registration. Then under that are lines that list which characters are associated with the userid/api. In addition, you can have those link back to the alliance/corp killboard.

Not only that, but it gives you the option to pull the avatar from eve and replace your uploaded avatar in phpbb. Under your avatar it also shows your total kills/losses and k/d ratio. Also your kills per month.ugh

So what I'm curious about is if the info to do that is out there already, or if that's a custom job. Also, how difficult would that be to do?

Thanks very much to anyone who can answer that. I hope it stems from the use of this API mod.


This mod is intended to add API verification to phpBB forums. Besides that, I added extra features specially made for either the ingame browser, or automated adminitration processes.
Besides that, I'm aiming for a stable, easy-installable mod that is carefully tested before released.

I'm sure the other items you named are a custom job. Some of those features will be integrated in the mod, and others won't.
Can't release more information on this subject at this point.

I would rather not spend development/testing time on custom jobs while releasing it to the public a month later. However, if you feel/need it ASAP, feel free to contact me.

Originally by: Carl Rannseier
Edited by: Carl Rannseier on 17/07/2010 03:13:30
Edited by: Carl Rannseier on 17/07/2010 03:02:08
@ Gerin Tell: I can't help ya here, i think for this you have to ask Cyerus. I actually think that you have to do all the work again cos he has rewritten pretty much all of the code so it might be easier setting it up from scratch again.



Wrong, no need to rewrite it again. The way 2.1.1 and older were setup wasn't supporting major use. I just converted (read: rewritten) the functions to support phpBB internal functions and/or high usage.
It's setup to relativly easy add new features.

Ghorth
Posted - 2010.07.23 13:32:00 - [69]
 

Hi,

I've seen this mod on several corp forums and thought of installing it on mine.
Now The only part that changed before actually installing the script (by just copy pasting most files) was I added a theme.

So i just copied the files which had to be uploaded in the prosilver skin, to the new skin.

Afterwards I've set every option (corps name, "Allow non-member registration" to yes, ...) And tried to register my self (as the API for my admin account wasnt entered), didn't work. So I used my admin account (which had the characters name) and tried to enter the API code from within the admin panel... Still I get the same error message that the API key is invalid.


Any ideas?
Kind Regards

Carl Rannseier
Caldari
Trust Foundation
Liberi Fatales
Posted - 2010.07.28 12:14:00 - [70]
 

Try using the UCP for your admin account. I also have troubles using the acp to modify api information.

Miste Warren
Posted - 2010.08.05 04:54:00 - [71]
 

Although my forum does not upload eve avatars automatically for some reason, and furthermore the ucp upload avatar feature is broken, everything else works perfectly! (I suspect the issues are stemming from my forum and it alone, not the mod... though if anyone has any solutions I'd love to hear them!)

I am extremely impressed at the upgrades Cyerus has made to this mod! The in-game stuff is especially fun to use as we can link ships, items and systems with a click of a button prior to posting!

Thanks for all your hard work!

Kaomond
Posted - 2010.08.05 16:39:00 - [72]
 

I'm currently using the evestyle theme for my forum, will this work on that theme? If not is there a way to get it to work?

Link to the eveStyle theme site ... http://www.agabel.ch/cat_phpBB/theme_phpBB.html

Ramos Cornelious
Caldari
Lonestar Distribution Inc.
Posted - 2010.08.08 15:49:00 - [73]
 

I've tried using the API mod for my board,
but whenerver somebody tries to register is just takes them back to the register page and does utterly nothing.

Pressing submit seems to submit the data but doesn't do anything but bring them pack to the register page again.

I followed to readme file to the letter, any suggestions?

Agent Known
Posted - 2010.08.13 00:40:00 - [74]
 

Now I have a "major" issue. Whenever a non-alliance member registers the registration fails with "the API was invalid". I have it set up so non-alliance members can register but are placed in a different group. What's happening? Sad

Rubke
The 8th Order
Posted - 2010.08.19 16:11:00 - [75]
 

I just tried installing this mod (upload and copy all the files, run the mysql scripts).

But I cant fint anything that's related to the API mod. ACP, UCP and registration form are still the same.

I have another skinn installed, but this is disabled and thus we are using the default skin.

I think its a problem with the template files, but i dont know where to look.

Haden Ranch
Posted - 2010.08.20 21:57:00 - [76]
 

Hi,

I've got the latest mod and im getting "Invaild API key" every time i try and input the ID and key.
Also when you try and register on the forum and you enter the API key, nothing shows up.

Could you post a link to the latest version incase im behind.

Haden.

Zeers
Posted - 2010.08.22 12:26:00 - [77]
 

it was a fresh install i followed the readme file

but i'm getting this error

Quote:
General Error
SQL ERROR [ mysqli ]

Unknown column 'api_userid' in 'field list' [1054]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.



Any ideas?



Carl Rannseier
Caldari
Trust Foundation
Liberi Fatales
Posted - 2010.08.23 16:51:00 - [78]
 

Edited by: Carl Rannseier on 23/08/2010 17:10:32
@Miste Warren: some more info on what goes wrong (error messages i.e.) would help here. i don't have any problems with the avatars on my board.

@Kaomond: This theme is subsilver2 based, you would have to make the adjustments to the style yourself. my corp is currently changing the provider but i'll upload a zip with the subsilver2 changes then.

@Ramos Cornelious: Have you refreshed the templates with the ACP?

@Agent Known: Can't help ya with that yet, i gonna try to reproduce the error. maybe i can find a fix.

@Rubke: Same as to Ramos, looks like you forgot to refresh the template on the ACP.

@Haden Ranch: This can have quite a few reasons but to me it looks like the username on the forum isn't the same as the ingame name then.

@Zeers: looks like you forgot to insert the new database tables located in the sql directory.

Rubke
The 8th Order
Posted - 2010.08.23 17:15:00 - [79]
 

Tnx for the respondse!

It's indeed working now. I'm going to try to get the mod working in another skin.

Tnx

Haden Ranch
Posted - 2010.08.23 18:35:00 - [80]
 

Edited by: Haden Ranch on 23/08/2010 18:36:03
Ahh Right, ok.

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2010.09.06 00:33:00 - [81]
 

Vacation is over, school started.
Next weeks I'll release a new version.

If you have any issue that is still unresolved (or unanswered), please let me know and I'll get back to you as soon as I can.
Ingame mail preferred.

~Cyerus

vale storm
Shadows Of The Federation
Posted - 2010.09.14 14:47:00 - [82]
 

Hey there,

Some great work on this mod I cannot wait to get it working. I have installed it on my forum which has around 120 users currently registered. Everything seems to be running fine and I have setup all the settings in the acp the way I want them. I ran the api_cron.php file which has checked and disabled all accounts with out api details in the account details.

I am not running the standard theme but I followed the xml file to change all the code specified in the theme files that I have currently running on the forum. The issue I am having is when trying to add the api details to my own admin account on the forum I am getting "The API information you entered is invalid.". I am not sure what this means, the details are definitely correct. I have also made sure that my forum account has my characters in game name of "vale storm" all lower case. I have also tried entering the key via the acp and ucp but still no luck.

Is there anything else I could try to fix this issue?

Cheers, Vale.

Tevoda
Unrealized Reality
AAA Citizens
Posted - 2010.09.21 14:55:00 - [83]
 

Edited by: Tevoda on 21/09/2010 21:33:02
Install everything fine. Went through all the backend settings.
When trying to register a user, it will accept all the information then proceed to http://nowwhat.mmocafe.net/ucp.php?mode=register and a blank page will appear.

If I check in the admin panel no request or registration of a new user is made.

[Tue Sep 21 21:31:20 2010] [error] [client 88.27.75.218] PHP Fatal error: Call to undefined function curl_init() in /var/www/nowwhat.mmocafe.net/includes/functions.php on line 27, referer: http://nowwhat.mmocafe.net/ucp.php?mode=register

curl is installed.


Any ideas?


Cyerus
Galactic Dominion
Eternal Strife
Posted - 2010.09.21 22:39:00 - [84]
 

It appears cURL is not installed properly, or not configured properly in the php.ini file.
Either way, PHP doesn't recognize the function curl_init(), which suggest you need to doublecheck your settings.

Would you mind, just to be sure, to give me a link to a page showing phpinfo()?

Tevoda
Unrealized Reality
AAA Citizens
Posted - 2010.09.21 23:10:00 - [85]
 

Edited by: Tevoda on 21/09/2010 23:11:17
Doh never mind. Too tired, forget to reload apache.


FreakOfNature666
Posted - 2010.09.22 04:14:00 - [86]
 

Originally by: Tevoda
Edited by: Tevoda on 21/09/2010 23:11:17
Doh never mind. Too tired, forget to reload apache.




lol, been there done that. On the bright side, at least you didn't restart sshd on a remote system over 1k miles away only to have sshd crash and never load back up. Crying or Very sad Second time that happened, I decided sshd was set up just fine the way it was.

Anyway, is there an ETA on the next version of this lovely mod?Very Happy

Tevoda
Unrealized Reality
AAA Citizens
Posted - 2010.09.27 09:33:00 - [87]
 

I got a question about admin/member changing member/user info.
There seems to be no way to change the email or password unless I do it directly via sql. The message I get is "API key is too short" when I try to change the user email.

There is no field to change API/userid so how would the user/member do this themselves?

Any ideas thx.

Cyberslog
Posted - 2010.09.28 19:41:00 - [88]
 

Is there a current download link? I'm getting 404 page when i try to download the mod.

Rasta Rocketman
Sniggerdly
Pandemic Legion
Posted - 2010.09.28 21:26:00 - [89]
 

I emailed you about this as well, but not sure if you check the email you provided so I'll post here too.

Anyway, can this mod be installed on a style called black pearl?
http://www.phpbb.com/community/viewtopic.php?f=74&t=574818

In your mod, there are 4 files to edit in the prosilver style directory...however my Black Pearl style directory doesn't have the ucp_avatar_options.html file at all. Also, in my ucp_register.html file, I cannot find the code that needs to be replaced. My block of code regarding password confirmation looks much different.

I can post relevant code if necessary.

Is it still possible to install this mod on my board?

Tevoda
Unrealized Reality
AAA Citizens
Posted - 2010.09.30 10:38:00 - [90]
 

Originally by: FreakOfNature666
Originally by: Tevoda
Edited by: Tevoda on 21/09/2010 23:11:17
Doh never mind. Too tired, forget to reload apache.




lol, been there done that. On the bright side, at least you didn't restart sshd on a remote system over 1k miles away only to have sshd crash and never load back up. Crying or Very sad Second time that happened, I decided sshd was set up just fine the way it was.

Anyway, is there an ETA on the next version of this lovely mod?Very Happy


LOL I done worst I think, killed serial console located in another country while doing a kernel update. Not fun I can tell you :P


Pages: first : previous : 1 2 [3] 4 5 6 7 8 9 ... : last (10)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only